Provide VPN Connection plugins

Bug #37110 reported by Darryl Clarke on 2006-03-29
64
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Baltix
Medium
Unassigned
network-manager (Ubuntu)
Wishlist
Unassigned

Bug Description

When I attempt to run nm-vpn-properties I get nowhere.

This error message is fine, but it yeilds no help on what to install to connect to one.

There are no recommended packages, or clues in the man pages/documents as to what is required to get rolling with VPNs.

Joel Stanley (shenki) wrote :

to use nm to configure a vpn, the vpn 'plugins'/extensions need to be installed.

They can be found under vpn-daemons in networkmanager cvs. Plugins exist for vpnc, openvpn and pptp.

The directory contains a README describing the plugins http://cvs.gnome.org/viewcvs/NetworkManager/vpn-daemons/README?rev=1.2&view=markup

Also, there was a discussion on the NetworkManager mailing list about vpn plugin tarballs, or the lack of.
http://mail.gnome.org/archives/networkmanager-list/2006-March/msg00105.html

Johannes Hessellund (osos) wrote :

I can confirm this. I have vpnc installed, but I'm not able to connect using NM.
NM doesn't detect the vpnc utilities.
Please include VPN capability.

Changed in network-manager:
status: Unconfirmed → Confirmed
Mantas Kriaučiūnas (mantas) wrote :

I think network-manager-gnome should suggest/recommend vpnc package, because there are no way to know what package to install for vpn connection.

Btw, I also think, that there should be menu launcher (/usr/share/applications/nm-vpn-properties.desktop) for nm-vpn-properties program. Maybe I should report another bug about missing menu launcher?

Michael R. Head (burner) wrote :

Does vpnc actually make nm-vpn-properties work? I don't think so. You still need to download, compile, and install the vpn-daemons yourself.

Perhaps they could be packaged in ubuntu regardless of the fact that the GNOME guys haven't figure a way around the technical problem of how to make an official release.

I confirm this bug. I hope, the fix will get into dapper before release.

neoflight (srnvas) wrote :

yes...we need a vpnc plugin for NM.... i can connect using vpnc cia command line...but good to have all the networking options with NM....i second this wish....

Dmitry Petrov (demon-krasno) wrote :

Well, I go via pptp, but I need graphical interface too, because I'm only one in family, who know how to handle with CLI :)

Christian Doczkal (thyrus) wrote :

I have the same problem. Looking on the web I found a
network-manager-vpnc package for Breezy. Its provided on

http://bootlab.org/~j/NetworkManager-breezy/

unfortunately the package does not install on Dapper dry-run reports unmet (not installable) dependencies for

libdbus-1-1 (>= 0.36.2)
libdbus-glib-1-1 (>= 0.36.2)

Could it be possible to build this package for Dapper as well?

I got this from http://kubuntu.no-ip.org, which maintained this earlier. Seems like he deleted it from his repository.. ??

Works for me. So yes it is indeed posible.

I didn't find this bug in the first place, so another one created, which was found to be a duplicate of this one. So here I'm coppying the message in this one. :
I used the pptp-config GUI. It is good. It does the job properly. But that's just abother piece of software which needs to be installed, ran with root privilages, as another application, with lots of options, staying in the taskbar all the time/not hiding in the tray on connection, not supporting GTK or whatever and thus standing out of the hole desktop picture. That's just not what people look for when you think of VPN connection!
NetworkManager seems to be just opposit. Just it! It stays in tray. It has wizards to setup connections. It has a single button for a connection once set up. Just perfect.

But!
It suports Cisco and Opne VPN only I believe. I use pptp VPN to connect to internet through my ISP server. There are over 400 PCs on our network. Mainly Windows PCs mainly for this very reason. It's getting just tooooo complicated when simply connecting to Internet!

Guys! There is a solution for pptp support in nm at http://www.students.ncl.ac.uk/a.j.mee/blog/index.php/2005/11/21/networkmanager-pptp-vpn-support

But I'm not a Ubuntu developer (yet ), I cannot compile the package.

PLEASE! Someone make a package for Ubuntu. So we could simply install it and enjoy this super Lunix distro. And we do need this functionality in Dapper! So very much!

Some update here:
Look here. Easy MS VPN support - Ubuntu Forums
http://ubuntuforums.org/showthread.php?t=112064&goto=newpost

Just wanted to share this package from kubuntu.no-ip.org too.

Don't know why he took it down from his site, but here it is.

Here is a package. Dont have a chance to try it out. Could some one please do?
http://www.linux2go.dk/ubuntu/pool/main/n/network-manager-pptp/
or deb http://www.linux2go.dk/ubuntu dapper main in sources

It seems just like it. Se how it goes.

Jan Mynarik (jan-mynarik) wrote :

Is there any progress on the account of VPN plugins? Any chance to get it in Edgy?

stefab (bluefuture) wrote :

For pptp plugin the status on revu changed to uploaded on 28 september:

http://revu.tauware.de/details.py?upid=2918

Michael R. Head (burner) wrote :

Since it hasn't been mentioned, network-manager-pptp was released with edgy: https://launchpad.net/ubuntu/+source/network-manager-pptp

I'm still hoping network-manager-vpnc and network-manager-openvpn can be included soon. linux2go does have packages of these for dapper and edgy, though, and they are in revu:
http://www.linux2go.dk/ubuntu/pool/main/n/network-manager-vpnc/
http://revu.tauware.de/details.py?upid=4139
http://www.linux2go.dk/ubuntu/pool/main/n/network-manager-openvpn/
http://revu.tauware.de/details.py?upid=4138

Timo Aaltonen (tjaalton) wrote :

-openvpn and -vpnc have been uploaded to feisty. When the binaries are available, this can be closed.

Changed in network-manager:
status: Confirmed → Fix Committed
Michael R. Head (burner) wrote :

Just got the vpnc and openvpn packages in synaptic in fiesty!

Changed in network-manager:
status: Fix Committed → Fix Released
Darryl Clarke (dclarke) wrote :

binaries are available in feisty.

Thanks Everybody!

Przemek K. (azrael) on 2009-11-13
Changed in baltix:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers