RFE: Last comment by <LP ID>

Bug #79136 reported by Henrik Nilsen Omma on 2007-01-13
4
Affects Status Importance Assigned to Milestone
Bug Helper
Wishlist
Markus Korn

Bug Description

I'd like to find the bugs where:

- I made the last comment -- If I combine this with a date I can find those bugs where I requested more info but got no reply
- The submitter made the last comment -- The sumbitter has provided more info but no one has replied to her
- The package maintainer -- May have said something very wise about abut that I want to read

Changed in bughelper:
importance: Undecided → Wishlist
Daniel Holbach (dholbach) wrote :

Thanks for your suggestion. Does "-lc <LP ID>" sound good?

Changed in bughelper:
status: Unconfirmed → Needs Info
Henrik Nilsen Omma (henrik) wrote :

Sure.

Changed in bughelper:
status: Needs Info → Confirmed
Emilio Pozuelo Monfort (pochu) wrote :

Shouldn't it be "--lc <LP ID>" ?
I read in any report that python doesn't support long chains with just one "-" (dash?).

Fernando Ribeiro (ipsec) on 2007-02-02
Changed in bughelper:
assignee: nobody → fernando
status: Confirmed → In Progress
Fernando Ribeiro (ipsec) wrote :

$ ./bughelper -p vino -C dholbach 2007-01-31
Bug 26827 dated (2006-12-22) need more info.

Need a good review.
Need time and timezone too?

Fernando Ribeiro (ipsec) wrote :

hummm

is to return with "Need Info" status?

Daniel Holbach (dholbach) wrote :

Fernando: awesome work! I have some ideas still though: It'd be great, if we could split this all up a bit:
 * we shouldn't change the Bug() initialisation, but store the comments (if we can parse them properly, if not, the commentators) in the Bug object.
 * That way we can build a diverse command line interface around dates, commenters (somebody had the idea to even parse team lists, so we can handle teams too) and statuses of bugs.

What do you think?

Fernando Ribeiro (ipsec) wrote :

Mr. Daniel,

     Is better to use a dictionary to store all bug data? Example:

bug {
    bug_id: {
        'reporter': 'fernando',
        'date': 'the_date',
        'assigned': 'name',
        'status': 'the_status',
        ...
        'comments': {
            comment_id: {
                'user': 'username',
                'date': 'date',
                'comment': 'comment',
            },
            comment_id2: {
                'user': 'username',
                'date': 'date',
                'comment': 'comment',
            }
            ...
        }
    }
}

     What do you think?

Daniel Holbach (dholbach) wrote :

Looks fine to me. But why have
bug {
    bug_id: {
?

I'd add a dictionary for the comments maybe. Or a list of BugComment objects.

Any other opinions?

Fernando Ribeiro (ipsec) wrote :

$ ./bughelper --lc -p vino
http://launchpad.net/bugs/43050 [Last Comment: (7) wendell at 2007-02-02 14:31:44 UTC][vino upstream: Fix Released/Unknown][vino Ubuntu: Fix Committed/Medium] - Vino crasher bugs

need review.

Markus Korn (thekorn) wrote :

Fernando, nice patch. But two remarks:
1) The subject of a comment can contain "~" (like in Bug #84489) your RegEx is not working for that.

2) Correct me if i'm wrong, but the intention of this bugreport is to have a list of bugs where either the reporter, the maintainer or an other user had made the last comment. Based on the changes in my current branch it shouldn't be difficult to have such a list. If you dont mind i can work on that.

Fernando Ribeiro (ipsec) wrote :

>> 1) The subject of a comment can contain "~" (like in Bug #84489) your RegEx is not working for that.

Fixed on new patch.

>> 2) Correct me if i'm wrong, but the intention of this bugreport is to have a list of bugs where either the reporter, the maintainer or an other user had made the last comment. Based on the changes in my current branch it shouldn't be difficult to have such a list. If you dont mind i can work on that.

On the comment number 4 i have created a patch to get all bugs the users have no news after there date.
I really don't know what's the real intention of this bug.
Somebody have any explication?

Fernando Ribeiro (ipsec) wrote :

If you need a list of all commenters, date and commentID you can to use the:

comments/(\d+)[^<]*<[^>]*>[^<]*</strong>[^~]*~([^"]*)">[^"]*at ([^<]*)<

Daniel Holbach (dholbach) wrote :

Thanks Fernando for your work!

I'd prefer it if we'd not change the Bug() API. apport uses it already - this will break stuff.

I think it's better if we store the comments in a Bug attribute and use that information in bughelper itself.

What do you think?

Markus Korn (thekorn) wrote :

Fernando, are you still working on that?

Since revision nr 110 of bughelper.main we have the functions "Comments()" and "Reporter()" in the Bug-class.
With the help of this functions it might be easy to add a option to show bugs
* where a LP-user made the last comment
* where the submitter made the last comment

If you dont't mind I can work on that.

Markus

Fernando Ribeiro (ipsec) wrote :

Hi Mr. Korn,

     You can to fix it without problem.

Fernando

Changed in bughelper:
assignee: fernando → thekorn
Markus Korn (thekorn) wrote :

This patch against bughelper.main r118 adds a "--lc"-option to bugnumbers. Arguments are "reporter" (looks for bugs where the submitter made the last comment) or <LP-ID>.
As always, if it works fine, this option can be easily added to bughelper.
Example usage:
$ ./bugnumbers -p bughelper --lc thekorn
87448 (Confirmed,Low) - cleaning bug helper cache

$ ./bugnumbers -p bughelper --lc reporter
88102 (Confirmed,Undecided) - sort report by issue type rather than bug number
88521
(Confirmed,Medium) - selectively pulling attachments by name

Needs to be reviewed and tested.

Markus

Changed in bughelper:
status: In Progress → Fix Committed
Daniel Holbach (dholbach) wrote :

Patch needs to be updated.

Markus Korn (thekorn) wrote :

This patch against bughelper.main r152 changes the RegEx in Bug.Comments() and Bug.Reporter() in respect to the new LP pages.

Markus

Daniel Holbach (dholbach) wrote :

------------------------------------------------------------
revno: 155
committer: Daniel Holbach <email address hidden>
branch nick: bughelper.main
timestamp: Mon 2007-04-23 08:28:09 +0200
message:
  commit Markus' patch to fix bug 79136 (filter on last commenter on the bug); include a small fix to also accept 'str' in Bug constructor
------------------------------------------------------------

Changed in bughelper:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers