Launchpad.net

CVE 2012-2126

RubyGems before 1.8.23 does not verify an SSL certificate, which allows remote attackers to modify a gem during installation via a man-in-the-middle attack.

See the CVE page on Mitre.org for more details.