Change log for ace package in Debian

127 of 27 results
Published in buster-release on 2017-10-12
Published in sid-release on 2017-10-04
ace (6.4.5+dfsg-1) unstable; urgency=medium

  [ Johnny Willemsen ]
  * New upstream version:
    - fixes FTBFS with GCC-7. Closes: #853299.
    - can use openssl 1.1. Closes: #851424.
    - fixes GNU/FreeBSD FTBFS. Closes: #823592.
  * Cleanup packaging:
    - re-enable PIE. Closes: #859350.
    - remove Marek from uploaders.

  [ Thomas Girard ]
  * Remove Pau from uploaders.
  * Fix repackaging process by removing bashism.
  * Remove QtReactor until it gets ported to Qt5. Closes: #874813.
  * Remove d/p/37-remove-google-tracking.diff, no longer needed.
  * Bump Standards-Version: to 4.1.0.

 -- Thomas Girard <email address hidden>  Sat, 16 Sep 2017 17:29:35 +0200

Available diffs

Superseded in buster-release on 2017-10-12
Published in stretch-release on 2017-01-25
Superseded in sid-release on 2017-10-12
ace (6.3.3+dfsg-1.2) unstable; urgency=medium

  * Non-maintainer upload.
  * Build against libssl1.0.2 (Closes: #828229).
  * Merge build-indep rules into build-arch rules so it builds with -A as it
    did before (Closes: #806602).

 -- Sebastian Andrzej Siewior <email address hidden>  Sat, 14 Jan 2017 13:47:41 +0000

Available diffs

Superseded in stretch-release on 2017-01-25
Superseded in sid-release on 2017-01-15
ace (6.3.3+dfsg-1.1) unstable; urgency=medium

  * Non-maintainer upload.
  * Fix FTBFS in kfreebsd.  Closes: #825709

 -- Mattia Rizzolo <email address hidden>  Fri, 01 Jul 2016 05:43:35 +0000

Available diffs

Superseded in stretch-release on 2016-07-06
Superseded in sid-release on 2016-07-04
ace (6.3.3+dfsg-1) unstable; urgency=medium

  [ Pau Garcia i Quiles ]
  * New upstream version

  [ Peter Michael Green ]
  * Add patch to remove use of sslv3 methods which are no longer provided by
    the Debian openssl package.

  [ Thomas Girard ]
  * Integrate fix from Kurt Roeckx <email address hidden> thru patch from
    Peter Michael Green <email address hidden> to remove use of sslv3.
    Thanks to both of them. Closes: #804326.

 -- Thomas Girard <email address hidden>  Sun, 15 Nov 2015 11:30:34 +0100
Superseded in stretch-release on 2015-11-22
Superseded in sid-release on 2015-11-18
ace (6.3.2+dfsg-1) unstable; urgency=medium

  * New upstream version
  * Use new ChangeLog filename and location instead of the old
    <root>/ChangeLog
  * Update get-orig-source.sh to remove .gitignore files (reported upstream)
  * Delete stale doxygen_sqlite3.db file left by recent versions of Doxygen
  * Update standards to 3.9.6.1 (no changes needed)

 -- Pau Garcia i Quiles <email address hidden>  Thu, 02 Jul 2015 21:53:49 +0200
Superseded in stretch-release on 2015-09-06
Published in jessie-release on 2014-11-01
Superseded in sid-release on 2016-07-09
ace (6.2.8+dfsg-1) unstable; urgency=medium


  * New upstream version
  * Drop patch 25-versioned_so.diff (applied upstream)
  * Drop patch 36-fix-typos.diff (applied upstream)
  * Drop patch 38-fix-predictable-filename-in-tmp.diff (applied upstream)
  * Drop patch largefile.diff (applied upstream)

 -- Pau Garcia i Quiles <email address hidden>  Wed, 01 Oct 2014 19:27:00 +0200

Available diffs

Superseded in sid-release on 2014-10-30
ace (6.2.7+dfsg-2) unstable; urgency=medium


  * Add patch 38-fix-predictable-filename-in-tmp (CVE-2014-6311). 
    Closes: #760709

 -- Pau Garcia i Quiles <email address hidden>  Sun, 07 Sep 2014 14:35:23 +0200
Superseded in sid-release on 2014-09-23
ace (6.2.7+dfsg-1) unstable; urgency=low


  [ Johnny Willemsen ]
  * New upstream release. Closes: #746825, #724774, #734393

  [ Pau Garcia i Quiles ]
  * Enable hardening
  * Add Large File Support
  * Add lintian overrides for safe-to-be-ignored issues
  * Add patch 36-fix-typos (submitted upstream)
  * Add patch 37-remove-google-tracking
  * Update standards to 3.9.5.0
  * Repack upstream source using get-orig-source.sh and add usage note to
    README.source
  * Remove all TAO-related stuff due to DFSG-incompatibility
  * Remove deprecated DM-Upload-Allowed field

 -- Pau Garcia i Quiles <email address hidden>  Sun, 29 Jun 2014 12:40:36 +0200
Deleted in jessie-release (Reason: None provided.)
Superseded in sid-release on 2014-10-30
ace (6.0.3+dfsg-0.2) unstable; urgency=low


  * NMU to rebuild with up-to-date tool chain (closes: #723856)

 -- Barak A. Pearlmutter <email address hidden>  Tue, 08 Oct 2013 10:24:20 +0100

Available diffs

Superseded in jessie-release on 2013-10-22
Published in wheezy-release on 2013-02-06
Superseded in sid-release on 2013-10-16
ace (6.0.3+dfsg-0.1) unstable; urgency=low


  * NMU with maintainers blessing.
  * Remove upstream files with nonfree licence (closes: #697848) or
    without source (closes: #697847):
    - repack the orig tarball by removing:
        bin/LabVIEW_RT/*.exe
        examples/{C++NPv2,C++NPv1,APG}/
        TAO/
    - debian/control: drop all packages named *tao*
    - debian/rules: drop everything related to tao
    - remove all hunks applying to TAO files in patch reduce-doxygen-doc.diff
    - drop patch 34-bts386713.diff since it applies only to TAO files.
    - debian/copyright: remove copyright entries of TAO/, and of the 
      directories under examples/ that have been removed.
  * Bump version in build-dependency on debhelper to >=9 since we are using
    debhelper compatibility level 9.

 -- Ralf Treinen <email address hidden>  Wed, 23 Jan 2013 21:27:40 +0100

Available diffs

Deleted in experimental-release (Reason: None provided.)
ace (6.1.2-1) experimental; urgency=low


  * New upstream release.
  * debian/patches/16-ace-inet-pkgconfig-files.diff: drop, integrated.
  * debian/patches/prevent_doxygen_ace_manpages.diff: ditto.
  * debian/patches/reduce-doxygen-doc.diff: reworked since HTMLHelp is
    no longer generated.
  * debian/patches/20-versioned_libs.diff: refreshed.
  * debian/patches/34-bts386713.diff: refreshed.
  * debian/patches/92-default-ACE_ROOT.diff: refreshed.

 -- Thomas Girard <email address hidden>  Sat, 16 Jun 2012 20:51:01 +0200
Superseded in wheezy-release on 2013-02-06
Superseded in sid-release on 2013-01-31
ace (6.0.3-5) unstable; urgency=low


  * debian/control:
    o define Build-Depends-Indep: for documentation generation.
    o Build-Depends on dpkg-dev >= 1.16.2 to have dpkg-buildpackage -B
      correctly invoke build-arch then binary-arch. Closes: #657844.
  * debian/libace-dev.README.Debian: mention how to make ACE Service
    Configuration work in Debian. Closes: #656040.

 -- Thomas Girard <email address hidden>  Fri, 30 Mar 2012 20:03:40 +0200

Available diffs

Superseded in sid-release on 2012-04-01
ace (6.0.3-4) unstable; urgency=low


  * Remove work-around for arm now that g++-4.6 ICE is fixed.
    Closes: #653642, #654743.
  * Really ensure doxygen is not being run when invoking build-arch.
    Closes: #657844.

 -- Thomas Girard <email address hidden>  Sat, 04 Feb 2012 17:24:25 +0100
Superseded in sid-release on 2012-03-31
ace (6.0.3-3) unstable; urgency=low


  * Build with g++-4.4 on armel to work-around #644722. Closes: #644826.
    Thanks to Peter Green for the report and work-around investigation.
  * debian/lib{ace,tao}-dev.install, debian/tao-utils.install: perform brace
    expansion instead of letting debhelper do it "due to an accident". Helped
    removing no longer needed expansions.
  * debian/control: move transitional packages to section oldlibs, priority
    extra, as per lintian warning recommendation.

 -- Thomas Girard <email address hidden>  Wed, 28 Dec 2011 10:46:18 +0100

Available diffs

Published in squeeze-release on 2011-10-08
ace (5.7.7+dfsg-1) stable; urgency=low


  * Repackage to remove non-distributable .pdf files. Closes: #630897.

 -- Thomas Girard <email address hidden>  Mon, 15 Aug 2011 08:06:07 +0200
Superseded in sid-release on 2012-01-29
ace (6.0.3-2) unstable; urgency=low


  * Upload to unstable.
  * Remove the build part in build %: make rule. GNU make 3.82 doesn't
    like it. Should fix the FTBFS seen on experimental/amd64 where make 3.82
    is installed.
  * debian/rules: prevent long generation of doxygen documentation in arch-dep
    build by defining binary-arch: and binary-indep: targets. This requires
    switching to debhelper level 9.
  * debian/rules: overriding dh_fixperm for needed packages only.
    Closes: #636028.
  * debian/*.examples: move examples here.
  * debian/ace-netsvcs.doc-base: remove extra space at end of document field.

 -- Thomas Girard <email address hidden>  Sat, 30 Jul 2011 21:38:07 +0200

Available diffs

Deleted in experimental-release (Reason: None provided.)
ace (6.0.3-1) experimental; urgency=low
  [ Thomas Girard ]  * Drop obsolete patch multiarch.dpatch.  * Really install NEWS file with libace-ssl.  * Convert to format 3.0 (quilt):    o Drop dpatch dependency    o Do not repackage upstream tarball    o rework patches 90 and 91 so that they can be applied before building  * Convert debian/rules to debhelper level 8.  * Convert patches to DEP3 format.  * debian/watch: use ACE+TAO-src-*.tar.bz2 since we don't package CIAO.  * Port to GNU/Hurd.  * Make tao-idl and tao-ifr depend on g++; we need cpp for preprocessing.  * Change descriptions to match new binary names.  * Replace Conflicts:/Replaces: with Breaks:/Replaces:, following lintian    recommendation.  * Register ace-netsvcs documentation with doc-base (again, thanks lintian).  [ Pau Garcia i Quiles ]  * New upstream patch release. Closes: #628572.  * Drop patch 11-promote-QtResource-to-qt4 -- Thomas Girard <email address hidden>  Wed, 27 Jul 2011 15:34:32 +0200
Superseded in sid-release on 2011-10-24
ace (6.0.1-3) unstable; urgency=low
  * debian/patches/multiarch.dpatch: change detection of librt.so to use    getconf so that it does not break with multiarch locations.    Closes: #629657.  * debian/NEWS.Debian: mention that SSL v2 was removed from Debian    packages.  * Enhance package descriptions. Thanks to Gerfried Fuchs for the    report, and to Justin B Rye from debian-l10n-english@ for    his changes. Closes: #599549. -- Thomas Girard <email address hidden>  Mon, 20 Jun 2011 21:05:52 +0200
Superseded in sid-release on 2011-09-21
ace (6.0.1-2) unstable; urgency=low
  [ Thomas Girard ]  * Import into git.  * debian/control: change Vcs-* accordingly.  * Restore lost changelog entries, thanks to git!  * Add DM-Upload-Allowed: yes to debian/control.  * Bump Standards-Version: to 3.9.2.  [ Pau Garcia i Quiles ]  * Disable SSLv2 by adding patch 35_disable_sslv2 (Closes: #622074) -- Thomas Girard <email address hidden>  Sun, 01 May 2011 13:02:17 +0200

Available diffs

Superseded in wheezy-release on 2012-04-04
Superseded in sid-release on 2012-04-02
ace (6.0.1-1) unstable; urgency=low
  [ Pau Garcia i Quiles ]  * New upstream release  * Drop patch 12-add-DESTDIR-to-MPC (applied upstream)  * Drop patch 13-add-QtReactor-export (applied upstream)  * Drop patch 14-fix-tcl-flags (applied upstream)  * Drop patch 16-fix-pidl-install (applied upstream)  * Update patch 11-promote-QtResource-to-qt4  * Update patch 15-fix-lzo-flags  * Update patch 34-bts386713  * Require debhelper >= 7 (it was already required, in practice)  * Register documentation with doc-base  * Explicitly set source format 1.0 until we move to 3.0  * Package ACE_INet and ACE_INet_SSL  [ Thomas Girard ]  * Build-depend on Tcl/Tk >= 8.5. -- Pau Garcia i Quiles <email address hidden>  Sun, 20 Feb 2011 16:33:13 +0100
Superseded in experimental-release on 2011-09-21
ace (6.0.0-1) experimental; urgency=low
  * New upstream release:    o use new make install target.    o remove generator_pkgconfig.sh, no longer needed.    o new binary renaming:      - LoadManager => tao_loadmanager      - LoadMonitor => tao_loadmonitor      - ImplRepo_Service => tao_imr_locator      - ImR_Activator => tao_imr_activator      - IFR_Service => tao_ifr_service      - Fault_Detector => tao_fault_detector      - Fault_Notifier => tao_fault_notifier      - Scheduling_Service => tao_cosscheduling      - Dump_Schedule => tao_dump_schedule    o remove libACE_gperf_lib.    o remove patches that were merged upstream:      - 11-create-ace_qt4reactor-mpb.dpatch      - 12-create-config_kfreebsd.dpatch      - 16-rename-tao-programs.dpatch      - 24-add-missing-headers.dpatch      - 25-remove-duplicate-files.dpatch      - 47-change-netsvcs.dpatch      - 48-fix-doxygen-cross-links.dpatch    o remove useless patches:      - 10-fix-prj-install.dpatch      - 19-gcc43.dpatch    o rework existing patches:      - 20-versioned_libs.dpatch, for versioned_so=2      - 34-bts386713.dpatch      - 90-patch-mpc-basedir.dpatch    o new patches or scripts:      - 12-add-DESTDIR-to-MPC.dpatch, to add and use DESTDIR in make install      - 13-add-QtReactor_export.h.dpatch, to add a missing header in        libace-qtreactor-dev package.      - 16-fix-pidl-install.dpatch, to add missing .pidl files.      - fix_doxygen.sh, to regenerate the patch for Doxygen reduction.  * Bump Standards-Version: to 3.9.1. -- Thomas Girard <email address hidden>  Thu, 06 Jan 2011 07:39:04 +0100
Superseded in wheezy-release on 2011-09-21
Superseded in squeeze-release on 2011-10-08
Superseded in sid-release on 2011-09-21
ace (5.7.7-4) unstable; urgency=high

  [ Marek Brudka ]
  * Synchronized *.pc with *.so and created transitional tags. Closes: #598169

 -- Marek Brudka <email address hidden>  Mon, 27 Sep 2010 20:36:00 +0200
Superseded in squeeze-release on 2011-09-13
Superseded in sid-release on 2011-09-21
ace (5.7.7-3) unstable; urgency=low

  [ Marek Brudka ]
  * Configuration file for KFreeBSD created. Closes: #591586.
  * Restored pkgconfig files. Closes: #591610.
  * Provided manpages for tao_catior, tao_nslist, tao_nsdel, tao_nsadd, ace_netsvcs.

  [ Thomas Girard ]
  * Disable -fvisibility=hidden on armel since it does not seem to work on
    that platform. Closes: #593225.

 -- Thomas Girard <email address hidden>  Tue, 07 Sep 2010 20:04:20 +0200
Superseded in sid-release on 2011-09-21
ace (5.7.7-2) unstable; urgency=low


  * Rebuild with sid tk-dev build-dependency. Closes: #590512.

 -- Thomas Girard <email address hidden>  Mon, 02 Aug 2010 23:49:01 +0200
Superseded in sid-release on 2011-09-21
ace (5.7.7-1) unstable; urgency=low


  [ Thomas Girard ]
  * Add Marek to Uploaders: field.
  * Remove dependencies on autotools; these are no longer needed now that we
    have agreed to move back to the traditional compilation method.
  * Add bzip2 and lzo ZIOP implementation.
  * New patch: 20-versioned_libs.dpatch, to generate libraries with names
    following libACE-5.7.7.so pattern instead of libACE.so.5.7.7.
  * Rename binaries and packages to follow what is used in RPMs.
  * Move $ACE_ROOT to /usr/lib/ace.

  [ Marek Brudka ]
  * New upstream release:
    o add libACE_gperf, libACE_ETCL and libACE_Monitor_Control to libace
    o add headers and libraries for Monitor, ZIOP, ETCL to libtao package
    o renamed gperf-ace to ace_gperf to follow the upstream convention
    o renamed utilities (ns{add,del,list} to tao_ns{add,del,list}) in tao-utils
      to follow the upstream changes
  * Change compilation back to traditional ACE+TAO build method:
    o adapt existing Debian build mechanism
    o remove patches no longer needed because of this switch
    o use MPC generated makefiles
    o install build result using MPC/prj_install.pl and .ins files
    o temporarily excluded logWalker from build
  * New patch: 10-fix-prj-install to work-around a problem installing files
  * Added PerlACE to mpc-ace. Closes: #522557
  * Created patch to reduce the size of doxygen doc. Closes: #562164
  * Created patch to fix cross references in doxygen tags
  * Created libnetsvcs packages. Closes: #466137. Addresses: LP#185285
  * Moved IDL fiels from /usr/include into /usr/share/idl

  [ Pau Garcia i Quiles ]
  * New upstream release
  * Add dependency on ${misc:Depends}
  * Add new libraries and update patch 34-bts386713 accordingly
  * Update patch 02-qt4 (partially fixed upstream)
  * Drop patch 05-autoconf-fox (fixed upstream)
  * Drop patch 06-fix-kokyu-mpc (fixed upstream)
  * Drop patch 07-autoconf-fix-gperf (fixed upstream)
  * Drop patch 08-fix-perl-shebang (fixed upstream)
  * Drop patch 10-fix-fox-resource-export (fixed upstream)
  * Drop patch 11-fix-fox-reactor.dpatch (fixed upstream)
  * Update patch 12-fix-fox-include
  * Drop patch 13-fix-fox-errors (fixed upstream except for the #include, which
    I have now merged in 12-fix-fox-include)
  * Drop patch 14-autoconf-tao (fixed upstream)
  * Drop patch 15-fix-fltk-include (fixed upstream)
  * Drop patch 17-protect-mpc-path (fixed upstream)
  * Drop patch 18-fix-bswap-detection (fixed upstream)
  * Update patch 19-gcc43
  * Drop patch 20-fix-iostream-detection (fixed upstream)
  * Drop patch 22-remove-Ge-doc (fixed upstream)
  * Drop patch 23-add-sh-shebang (fixed upstream)
  * Update patch 24-add-missing-headers (WORK IN PROGRESS)
  * Update patch 34-bts386713
  * Drop patch 49-missing-template (fixed upstream)
  * Update patch 90-patch-mpc-basedir
  * Update patch 91-patch-dg-basedir
  * Add patch 93-hack-to-fix-libtoolize
  * Add patch 94-build-crosscompile
  * Add patch 95-build-ace-for-tao
  * Add patch 96-build-athena3d
  * Remove DH_COMPAT definition from the debian/rules file, it's already in
    debian/compat
  * Fix fox-config location, detection method has changed since 5.6.3

 -- Thomas Girard <email address hidden>  Sun, 23 May 2010 16:58:42 +0200
Superseded in squeeze-release on 2011-09-13
Superseded in sid-release on 2011-09-21
ace (5.6.3-6) unstable; urgency=low


  [ Thomas Girard ]
  * Remove obsolete maintainers:
    - Konstantinos Margaritis <email address hidden>
    - Brian Nelson <email address hidden>
    Closes: #521487.
  * Bump Standards-Version: to 3.8.3.
  * Remove erroneous #define ACE_SCANDIR_CMP_USES_CONST_VOIDPTR in config.h;
    causing diagnostics to FTBFS. Closes: #552899.
  * Remove extra ACLOCAL_AMFLAGS from already existing Makefile.am; causing
    recent aclocal to abort. Thanks to Pau Garcia i Quiles for the patch.
    Closes: #518735.
  * Add README.source.
  * Add Pau Garcia i Quiles to the list of maintainers.
  * Fix many issues spotted by lintian.

  [ Pau Garcia i Quiles ]
  * Add new patches:
    - Remove duplicate files from .mpc files so that Makefile.am files do
      not have duplicates 
    - Run autoupdate and autoreconf in the ACE and TAO directories in order
      to update from libtool 1.5 (what upstream uses) to libtool 2.2

 -- Thomas Girard <email address hidden>  Sun, 13 Dec 2009 11:47:50 +0100
Superseded in squeeze-release on 2011-09-13
Superseded in sid-release on 2011-09-21
Published in lenny-release on 2008-10-29
ace (5.6.3-5) unstable; urgency=low


  * Do not ship MPC config files in both mpc-ace and libace-dev packages;
    they're meant to be only in mpc-ace. Make mpc-ace Replaces: the bogus
    previous upload. Closes: #484718.
  * Bump Standards-Version: to 3.8.0.

 -- Thomas Girard <email address hidden>  Fri, 13 Jun 2008 21:52:28 +0000
127 of 27 results