Change log for akonadi package in Debian

168 of 68 results
Published in buster-release on 2019-02-25
Published in sid-release on 2019-02-15
akonadi (4:18.08.3-4) unstable; urgency=medium

  * Team upload.

  [ Sandro Knauß ]
  * Update symbols from buildds for 4:18.08.3

 -- Sandro Knauß <email address hidden>  Thu, 14 Feb 2019 21:07:51 +0100
Superseded in sid-release on 2019-02-15
akonadi (4:18.08.3-3) unstable; urgency=medium

  * Team upload.

  [ Sandro Knauß ]
  * Add Build-Depends-package field in symbolfiles.
  * Add patch Call-QSqlQuery-finish-on-all-SELECT-queries-when-don
    (Closes: #921535).

 -- Sandro Knauß <email address hidden>  Fri, 08 Feb 2019 23:20:48 +0100
Superseded in sid-release on 2019-02-09
akonadi (4:18.08.3-2) unstable; urgency=medium

  * Team upload.

  [ Sandro Knauß ]
  * Rename {kubuntu_,}disable_secure_file_priv_check.diff.
  * Update symbols from buildds for 4:18.08.3

  [ Alf Gaida ]
  * Replaced wrapper mysqld-akonadi with link mysqld -> mysqld-akonadi
    (Closes: #921389)
  * Replaced dependency for akonadi-backend-mysql:
    - default-mysql-server-core -> default-mysql-server
    - virtual-mysql-server-core -> virtual-mysql-server

 -- Sandro Knauß <email address hidden>  Wed, 06 Feb 2019 12:56:58 +0100
Superseded in sid-release on 2019-02-06
akonadi (4:18.08.3-1) unstable; urgency=medium

  * Team upload.

  [ Sandro Knauß ]
  * New upstream release (18.08.3).
  * Bump Standards-Version to 4.3.0 (No changes needed).
  * Removed acc autopkgtest.

 -- Sandro Knauß <email address hidden>  Mon, 04 Feb 2019 15:56:47 +0100
Superseded in buster-release on 2019-02-25
Superseded in sid-release on 2019-02-12
akonadi (4:18.08.1-1) unstable; urgency=medium

  * Team upload.

  [ Sandro Knauß ]
  * Bump Standards-Version to 4.2.1 (No changes needed).
  * Update symbols from buildds for 4:18.07.90
  * Remove armel specific symbols, that are not exposed anymore.
  * Follow stable releases in KDE again..
  * New upstream release (18.08.1).

 -- Sandro Knauß <email address hidden>  Tue, 02 Oct 2018 23:16:04 +0200
Deleted in experimental-release (Reason: None provided.)
akonadi (4:18.07.90-1) experimental; urgency=medium

  * Team upload.

  [ Sandro Knauß ]
  * New upstream release (18.07.90).
  * Update build-deps and deps with the info from cmake
  * Update copyright file for new upstream.
  * Bump DebianAbi for libkf5akonadicore5 because of breakage to 2.
  * Bump DebianAbi for libkf5akonadiprivate5 because of breakage to 2.
  * Update symbols for libkf5akonadiagentbase5 for 18.07.90.
  * Remove patch that got upstream.
  * Update patch hunks.

 -- Sandro Knauß <email address hidden>  Thu, 16 Aug 2018 11:10:34 +0200
Superseded in buster-release on 2018-10-15
Superseded in sid-release on 2019-02-03
akonadi (4:17.12.3-3) unstable; urgency=medium

  * Team upload.
  * Backport upstream commit 310b6a26f58814568245c781c2136504d1a6f338 to fix
    build with Qt 5.11; patch
    upstream_Fix-build-with-Qt-5.11-missing-QAbstractItemView.patch.
  * Remove empty line at the end of changelog.
  * Bump Standards-Version to 4.1.5, no changes required.
  * Remove the 'testsuite' autopkgtest:
    - it runs the test suite from the build dir, not using the installed
      packages (hence misusing what autopkgtest is for)
    - it always failed (so it is not useful to even catch regressions), and
      nobody bothered to fix it
    - hence, pass -DBUILD_TESTING=OFF to cmake to disable the build of the
      tests, and pass -DBUILD_TOOLS=ON to explicitly request the test tools
      (which are installed)
  * Update symbols files for GCC 8, and the loss of test-only symbols.
  * Do not append -fvisibility=hidden -fvisibility-inlines-hidden to the
    CFLAGS, and CXXFLAGS anymore, since they are already there since at least
    the switch to KF5/ECM.

 -- Pino Toscano <email address hidden>  Tue, 31 Jul 2018 08:01:23 +0200
Superseded in buster-release on 2018-08-14
Superseded in sid-release on 2019-01-30
akonadi (4:17.12.3-2) unstable; urgency=medium

  * Team upload.

  [ Sandro Knauß ]
  * Adds Breaks/Replaces against kapptemplate (Closes: #894913)

 -- Sandro Knauß <email address hidden>  Thu, 05 Apr 2018 19:45:46 +0200
Superseded in sid-release on 2018-04-06
akonadi (4:17.12.3-1) unstable; urgency=medium

  * Team upload.

  [ Sandro Knauß ]
  * Add kdevelop templates to libkf5akonadi-dev.
  * New upstream release (17.12.3).
  * Update symbols from buildds for 4:17.12.2
  * bump epoch in symbolsfiles to match version of the package.
  * use secure copyright format uri.
  * small fixes in copyright file.
  * Update package descriptions.

 -- Sandro Knauß <email address hidden>  Sat, 31 Mar 2018 18:21:21 +0200
Deleted in experimental-release (Reason: None provided.)
akonadi (4:17.12.2-1) experimental; urgency=medium

  * Team upload.

  [ Sandro Knauß ]
  * Drop transitional package libkf5akonadicore-bin (Closes: #873932)
  * New upstream release (17.12.2).
  * Update build-deps and deps with the info from cmake
  * Remove unneded Build-Deps.
  * Use DebianABIManager to handle libkf5akonadi* properly
  * Update library from libkf5akonadicore5 -> libkf5akonadicore5abi1,
    because of ABI breakage.
  * Update library from libkf5akonadiprivate5 ->
    libkf5akonadiprivate5abi1, because of ABI breakage.
  * Update library from libkf5akonadiwidgets5 ->
    libkf5akonadiwidgets5abi1, because of ABI breakage.
  * Update copyright file.
  * Split arch independet data out of libkf5akonadicore5abi1 into new
    package libkf5akonadi-data.
  * Update Vcs links to salsa.
  * Bump debhelper build-dep and compat to 11.
  * add akonadi-backend-postgresql.lintian-overrides to ignore empty
    package.

 -- Sandro Knauß <email address hidden>  Fri, 09 Mar 2018 20:10:06 +0100
Superseded in buster-release on 2018-04-06
Superseded in sid-release on 2018-04-07
akonadi (4:17.08.3-2) unstable; urgency=medium

  * Team upload.

  [ Pino Toscano ]
  * Fix typo in NEWS file.
  * Remove the unused kio-dev build dependency.
  * Remove obsolete /etc/akonadi/mysql-global.conf, and
    /etc/akonadi/mysql-global-mobile.conf conffiles. (Closes: #868231)
  * Update symbols files from logs of buildds.
  * Bump Standards-Version to 4.1.3, no changes required.
  * Simplify watch file, and switch it to https.
  * Remove trailing whitespaces in changelog.

  [ Sandro Knauß ]
  * libkf5akonadiserver-dev incorrectly marked as Multi-Arch: same
    (Closes: #880385)
  * Fix "usr.sbin.mysqld-akonadi: denied access to
    /etc/mysql/mariadb.cnf" (Closes: #869865)
    - Added patch to allow files under mariadb.conf.d
      Thanks to Vincas Dargis <email address hidden> for the patch

 -- Pino Toscano <email address hidden>  Wed, 03 Jan 2018 17:38:15 +0100
Superseded in sid-release on 2018-01-03
akonadi (4:17.08.3-1) unstable; urgency=medium

  * Team upload.

  [ Maximiliano Curia ]
  * New revision
  * Update the apparmor file for mariadb, and report errors
  * Update uploaders list as requested by MIA team (Closes: #879284)

  [ Sandro Knauß ]
  * New upstream release (17.08.3).
  * Bump Standards-Version to 4.1.2 (No changes needed).
  * Add NEWS entry about the db migration
  * Bump debhelper build-dep and compat to 10.
  * Update symbols from buildds for 4:17.08.0
  * Update symbols from buildds for 4:17.08.3
  * Bump l10npkgs_firstversion_ok to 4:16.04.3-9~

 -- Sandro Knauß <email address hidden>  Thu, 21 Dec 2017 17:48:11 +0100
Deleted in experimental-release (Reason: None provided.)
akonadi (4:17.08.0-1) experimental; urgency=medium

  [ Maximiliano Curia ]
  * New upstream release (17.08.0). (Closes: 871147, 871246)
  * Drop Multi-Arch: foreign from the dev pkg.
    Thanks to Helmut Grohne <email address hidden> for the report (Closes: 872207)
  * Uscan no longer supports two main components urls
  * Update build-deps and deps with the info from cmake
  * Drop upstream patches
  * Bump Standards-Version to 4.0.1.
  * Update symbols files
  * Update install files
  * Set Priority to optional
  * Add breaks/replaces for the /mo files
  * Add breaks for libkolab1
  * Bump group breaks (17.08)
  * Drop kdepimlibs-data symbols injection
  * Release to experimental

  [ Jonathan Riddell ]
  * Sync debian/watch with neon

 -- Maximiliano Curia <email address hidden>  Fri, 01 Sep 2017 22:07:58 +0200
Superseded in buster-release on 2018-01-17
Published in sid-release on 2017-08-25
akonadi (4:16.04.3-6) unstable; urgency=medium

  * Team upload.
  * Backport upstream changes to not #include .cpp files in tests sources.
    (Closes: #871147)

 -- Dmitry Shachnev <email address hidden>  Fri, 25 Aug 2017 20:26:14 +0300
Superseded in buster-release on 2017-08-30
Superseded in sid-release on 2017-08-26
akonadi (4:16.04.3-5) unstable; urgency=medium

  * Team upload.

  [ Maximiliano Curia ]
  * Add new patch: Delete-the-properties-window-if-closed.patch.
    Thanks to Nancy Anthracite for reporting (Closes: 845553)

  [ Dmitry Shachnev ]
  * Add a patch from upstream to fix build with Qt 5.9.

 -- Dmitry Shachnev <email address hidden>  Fri, 07 Jul 2017 16:33:59 +0300
Published in jessie-release on 2017-01-14
akonadi (1.13.0-2+deb8u2) jessie-security; urgency=medium

  * Add patch from kubuntu: kubuntu_disable_secure_file_priv_check.diff
    - fix compatibility with stricter defaults in mysql security update.
      (Closes: 843534) Thanks to fld for the report and Marc Deslauriers
      for the patch.

 -- Maximiliano Curia <email address hidden>  Thu, 10 Nov 2016 15:17:27 +0100
Published in stretch-release on 2017-01-21
Superseded in sid-release on 2017-07-13
akonadi (4:16.04.3-4) unstable; urgency=medium

  * Team upload.

  [ Sandro Knauß ]
  * Add patch from kubuntu: kubuntu_disable_secure_file_priv_check.diff
    - fix compatibility with stricter defaults in mysql security update.
      (Closes: 843534) Thanks to fld for the report and Marc Deslauriers
      for the patch.
  * Fix known typos.
  * Update Build-Deps to use default-libmysqlclient-dev instead of
    libmysqlclient-dev.
  * Add Multi-Arch Hinters from tracker.
  * Remove unused source.lintian-overrides file.
  * Merge libkf5akonadicore-bin into akonadi-server package.

  [ Maximiliano Curia ]
  * Use mysql default metapackages
  * Replace dbus-launch with dbus-run-session in tests.
    Thanks to Simon McVittie for reporting (Closes: 835827)

 -- Sandro Knauß <email address hidden>  Tue, 22 Nov 2016 21:42:07 +0100
Superseded in stretch-release on 2017-01-21
Superseded in sid-release on 2017-01-20
akonadi (4:16.04.3-3) unstable; urgency=medium

  * Team upload.

  [ Sandro Knauß ]
  * Backport patch from upstream to build QSqlite3 backend with Qt5.7.1
    - QSqlite3-fix-build-with-Qt-5.7.patch
    - Closes: 842502
    - The original patch written by Daniel Vratil:
      068c0bd5f93232eea97e492354eff2b9b62c6643
    - Added qtbase5-private-dev to build deps
  * Update symbols files from buildds logs (4:16.04.3-2+b1).

 -- Sandro Knauß <email address hidden>  Wed, 02 Nov 2016 01:15:34 +0100
Superseded in stretch-release on 2016-11-18
Superseded in sid-release on 2017-06-26
akonadi (4:16.04.3-2) unstable; urgency=medium

  [ Automatic packaging ]
  * Update symbols files from buildds logs (4:16.04.3-1).

  [ Maximiliano Curia ]
  * Inject libkf5akonadicore-bin dependency through the akonadiwidgets symbols file.
    Thanks to Bill Allombert for the report (Closes: 834099)

 -- Maximiliano Curia <email address hidden>  Sun, 14 Aug 2016 12:07:49 +0200
Superseded in stretch-release on 2016-08-20
Superseded in sid-release on 2016-08-15
akonadi (4:16.04.3-1) unstable; urgency=medium

  [ Automatic packaging ]
  * Update symbols files from buildds logs (4:16.04.2-3).

  [ Maximiliano Curia ]
  * Add Breaks from kmail, korganizer and akonadiconsole, to avoid invalid installations
  * Add conflicts for akonadi2xml against kdepimlibs5-dev.
    Thanks to Andreas Beckmann for the report (Closes: 831226)

 -- Maximiliano Curia <email address hidden>  Tue, 19 Jul 2016 16:24:06 +0200
Superseded in sid-release on 2016-07-20
akonadi (4:16.04.2-3) unstable; urgency=medium

  * Avoid depending on a reverse dependency.

 -- Maximiliano Curia <email address hidden>  Tue, 05 Jul 2016 11:08:48 +0200
Superseded in sid-release on 2016-07-05
akonadi (4:16.04.2-2) unstable; urgency=low

  [ Maximiliano Curia ]
  * Drop libakonadi-kde4 breaks/replaces to allow installing knode and ktimetracker
  * Release to unstable.

  [ Automatic packaging ]
  * Update symbols files from buildds logs (4:16.04.2-1).

 -- Maximiliano Curia <email address hidden>  Mon, 04 Jul 2016 15:09:18 +0200
Deleted in experimental-release (Reason: None provided.)
akonadi (4:16.04.2-1) experimental; urgency=medium

  [ Maximiliano Curia ]
  * Update copyright information
  * Drop automoc build dependency
  * testsuite: Set the akonaditest path
  * Inject kdepimlibs-data dependency through the symbols files

  [ Automatic packaging ]
  * Update symbols files from buildds logs (4:16.04.1-1).
  * Update symbols files.
  * Refresh patches

 -- Maximiliano Curia <email address hidden>  Thu, 23 Jun 2016 23:02:40 +0200
Superseded in experimental-release on 2016-06-24
akonadi (4:16.04.1-1) experimental; urgency=medium

  [ Automatic packaging ]
  * Bump Standards-Version to 3.9.8
  * Refresh patches
  * Add a .gitattributes file to use dpkg-mergechangelogs
  * Update build-deps and deps with the info from cmake
  * Update symbols files.

  [ Maximiliano Curia ]
  * Add missing dependency on mysql server core.
  * New upstream release (15.12.2).
  * Replace the "Historical name" ddeb-migration by its "Modern, clearer" replacement dbgsym-migration.
  * Add upstream metadata (DEP-12)
  * debian/control: Update Vcs-Browser and Vcs-Git fields
  * Add kgendesignerplugin as a build dep
  * Add missing breaks/replaces, knutresource was in in kdepimlibs5-dev
  * Set the dev-bin as m-a: foreign
  * Add new patch: set_dependency_order.diff

 -- Maximiliano Curia <email address hidden>  Fri, 27 May 2016 18:08:49 +0200
Superseded in experimental-release on 2016-06-10
akonadi (15.12.1-1) experimental; urgency=medium

  * New upstream release (15.12.0).
  * New upstream release (15.12.1).

 -- Maximiliano Curia <email address hidden>  Mon, 01 Feb 2016 10:23:57 +0100
Superseded in experimental-release on 2016-02-07
akonadi (15.08.3-1) experimental; urgency=medium

  * New upstream release (15.08.3).

 -- Maximiliano Curia <email address hidden>  Wed, 02 Dec 2015 12:39:44 +0100
Superseded in experimental-release on 2016-02-18
akonadi (15.08.2-1) experimental; urgency=medium

  * New upstream release (15.08.2).

 -- Maximiliano Curia <email address hidden>  Fri, 16 Oct 2015 08:06:30 +0200
Superseded in experimental-release on 2015-10-27
akonadi (15.08.1-1) experimental; urgency=medium

  * New upstream release (15.08.1).

 -- Maximiliano Curia <email address hidden>  Sat, 19 Sep 2015 03:16:13 +0200
Superseded in jessie-release on 2017-01-14
akonadi (1.13.0-2+deb8u1) stable-proposed-updates; urgency=medium

  * Team upload.
  * Apply upstream_dont_leak_old_external_payload_files.patch which fixes a bug
    that let old files be kept when they should be removed.

 -- Lisandro Damián Nicanor Pérez Meyer <email address hidden>  Mon, 24 Aug 2015 19:15:25 -0300
Superseded in stretch-release on 2016-08-06
Superseded in sid-release on 2016-07-14
akonadi (1.13.0-8) unstable; urgency=medium

  * Team upload.
  * Update symbols files.

 -- Maximiliano Curia <email address hidden>  Sat, 29 Aug 2015 00:41:28 +0200
Superseded in stretch-release on 2015-09-06
Superseded in sid-release on 2015-08-31
akonadi (1.13.0-7) unstable; urgency=medium

  * Team upload.
  * Removed some patches introduced in previous upload due to regressions
    causing invalid SQL commands.

 -- Dmitry Smirnov <email address hidden>  Mon, 20 Jul 2015 12:30:32 +1000
Superseded in sid-release on 2015-07-20
akonadi (1.13.0-6) unstable; urgency=medium

  * Team upload.
  * New "upstream-MOVEcomplete.patch" (fixes deadlock).
  * Bunch of optimisation patches from upstream 1.13 branch.
  * Install "akonadictl.1" man page.
  * copyright: reviewed, converted to copyright-format-1.0 and updated.

 -- Dmitry Smirnov <email address hidden>  Mon, 20 Jul 2015 03:26:42 +1000
Superseded in sid-release on 2015-07-28
akonadi (1.13.0-5) unstable; urgency=medium

  * Team upload.
  * New upstream patches:
    + upstream-use-QAtomicInt.patch
    + upstream-prevent-QTimer-negative-interval.patch
  * Initialise PSQL database with "--data-checksums" (Closes: #791807).
  * Build-Depends: removed "mysql-server-core" (not needed on build time).

 -- Dmitry Smirnov <email address hidden>  Sun, 19 Jul 2015 20:31:33 +1000
Superseded in stretch-release on 2015-07-25
Superseded in sid-release on 2015-07-19
akonadi (1.13.0-4) unstable; urgency=medium

  * Team upload.
  * backend-mysql: depend on MySQL-5.6 or any MySQL flavour (Closes: #746651)
    Depends:
    - mysql-server-core-5.5 | mysql-server-core
    + mysql-server-core-5.6 | virtual-mysql-server-core
  * Standards-Version: 3.9.6.
  * xs-testsuite-header-in-debian-control: removed "XS-Testsuite" header.
  * Updated Vcs-Browser URL.
  * Patches renamed to consistently end with ".patch".
  * New patch to add PostgreSQL 9.4 search path (Closes: #791805).

 -- Dmitry Smirnov <email address hidden>  Mon, 13 Jul 2015 23:56:38 +1000
Superseded in stretch-release on 2015-07-19
Superseded in sid-release on 2015-07-16
akonadi (1.13.0-3) unstable; urgency=medium

  * Team upload.
  * Apply upstream_dont_leak_old_external_payload_files.patch which fixes a bug
    that let old files be kept when they should be removed.

 -- Lisandro Damián Nicanor Pérez Meyer <email address hidden>  Tue, 30 Jun 2015 12:03:32 -0300
Superseded in stretch-release on 2015-07-06
Superseded in jessie-release on 2015-09-05
Superseded in sid-release on 2015-07-27
akonadi (1.13.0-2) unstable; urgency=medium


  [ Pino Toscano ]
  * Bump the priority of all the binaries, except akonadi-dbg, to optional
    (as other packages depend on them).

  [ Maximiliano Curia ]
  * New upstream patch: upstream-fix_typo_in_if_condition
  * New upstream patch: upstream-
    fix_buffer_overflow_in_AKTEST_FAKESERVER_MAIN
  * New upstream patch: upstream-
    do_not_crash_when_setmntent_returns_NULL
  * Update symbols files from buildds logs (1.13.0-1).
  * New upstream patch: upstream_dont_call_insert_from_Q_ASSERT
  * libakonadi-dev: Add libqt4-dev Dependency.

 -- Maximiliano Curia <email address hidden>  Fri, 19 Sep 2014 11:04:57 +0200
Superseded in jessie-release on 2014-09-25
Superseded in sid-release on 2014-09-19
akonadi (1.13.0-1) unstable; urgency=medium


  * New upstream release.
  * Remove upstream patches.
  * Update symbols file.
  * Add missing breaks for kdepim-runtime << 4:4.13. (Closes: #749776)

 -- Maximiliano Curia <email address hidden>  Tue, 19 Aug 2014 21:01:28 +0200
Superseded in jessie-release on 2014-08-25
Superseded in sid-release on 2014-08-20
akonadi (1.12.1-1) unstable; urgency=medium


  * New upstream release.
  * Update symbols for 1.12.0 version.
  * New upstream patch: upstream_1.12-Use-per-thread-
    QDBusConnections.patch
  * New upstream patch: upstream_1.12-Remove-the-invalid-GID-part-from-
    PartTable-before-st.patch
  * New upstream patch: upstream_1.12-Fix-retrieving-of-GID-from-SQL-
    query-result-in-Fetch.patch

 -- Maximiliano Curia <email address hidden>  Tue, 06 May 2014 17:19:48 +0200
Deleted in experimental-release (Reason: None provided.)
akonadi (1.12.0-1) experimental; urgency=medium


  * 
  * New upstream release.
  * Remove patch: dont_do_redundant_flag_changes.diff
  * Remove patch: always_verify_writing_data_to_external_file.diff
  * Remove patch: correctly_detect_inter-resource_moves.diff
  * Update install files.
  * Remove old abi information, update acc file.
  * Update symbols from 1.11.0.
  * Update symbols.

 -- Maximiliano Curia <email address hidden>  Tue, 01 Apr 2014 15:37:32 +0200
Superseded in jessie-release on 2014-05-13
Superseded in sid-release on 2014-05-09
akonadi (1.11.0-1) unstable; urgency=low


  * New upstream release.
  * Update build dependencies.
  * Update subst var for akonadi-backend-mysql.
  * Bump Standards-Version to 3.9.5, no changes needed.
  * New upstream patch: dont_do_redundant_flag_changes.diff
  * New upstream patch: always_verify_writing_data_to_external_file.diff
  * Update symbols file.
  * Update install files.
  * New upstream patch: correctly_detect_inter-resource_moves.diff.

 -- Maximiliano Curia <email address hidden>  Wed, 08 Jan 2014 15:40:35 -0300
Superseded in jessie-release on 2014-01-19
Superseded in sid-release on 2014-01-09
akonadi (1.10.3-1) unstable; urgency=medium


  * New upstream release. (Closes: #729615, #716922)
  * Update build dependencies.

 -- Maximiliano Curia <email address hidden>  Wed, 20 Nov 2013 14:53:11 +0100
Superseded in sid-release on 2013-11-20
akonadi (1.10.2-2) unstable; urgency=low


  * Rebuild for unstable release.

 -- Maximiliano Curia <email address hidden>  Tue, 05 Nov 2013 12:54:23 +0100
Deleted in experimental-release (Reason: None provided.)
akonadi (1.10.2-1) experimental; urgency=low


  * Update vcs-fields.
  * Refresh patch disable_dbus_requiring_tests.
  * Update installed files.
  * Update libakonadiprotocolinternals1 symbols file.
  * Add empty dir in -dev package, to make AkonadiConfig.cmake happy.

 -- Maximiliano Curia <email address hidden>  Fri, 30 Aug 2013 12:42:10 +0200
Superseded in jessie-release on 2013-11-26
Superseded in sid-release on 2013-11-05
akonadi (1.9.2-2) unstable; urgency=low


  * Team upload.
  * Force the installation of the Qt plugins (such as qsqlite3) within Qt's
    plugin directory: (Closes: #708007)
    - pass -DINSTALL_QSQLITE_IN_QT_PREFIX=ON to cmake
    - adjust akonadi-backend-sqlite.install
    - add ${misc:Pre-Depends} in akonadi-backend-sqlite

 -- Pino Toscano <email address hidden>  Fri, 17 May 2013 15:39:30 +0200
Superseded in sid-release on 2013-05-17
akonadi (1.9.2-1) unstable; urgency=low


  * New upstream release.
  * Bump debhelper build-dep and compat to 9.
  * Add myself to the Uploaders field.
  * Bump Standards-Version to 3.9.4.

 -- Maximiliano Curia <email address hidden>  Sat, 11 May 2013 00:57:28 +0200
Deleted in experimental-release (Reason: None provided.)
akonadi (1.9.1-2) experimental; urgency=low


  * Merge in the uploads to unstable.

 -- Sune Vuorela <email address hidden>  Tue, 02 Apr 2013 22:52:29 +0200
Superseded in jessie-release on 2013-05-28
Published in wheezy-release on 2013-04-01
Superseded in sid-release on 2013-05-12
akonadi (1.7.2-3) unstable; urgency=low


  * Team upload.
  * akonadi-backend-mysql: depend on a real mysql-server-core-5.5 before the
    virtual mysql-server-core. This should help apt in really choosing -mysql
    when upgrading from squeeze. (Closes: #686147, #702919)

 -- Pino Toscano <email address hidden>  Tue, 26 Mar 2013 20:02:38 +0100
Superseded in experimental-release on 2013-04-03
akonadi (1.9.1-1) experimental; urgency=low


  * New upstream release.

  [ José Manuel Santamaría Lema ]
  * Update disable_dbus_requiring_tests.diff; some tests were added and
    some of them need D-Bus.
  * Update installed files.

  [ Sune Vuorela ]
  * Add mysql-server-core to Build-Depends so it can be used by the test suite

 -- Sune Vuorela <email address hidden>  Mon, 25 Mar 2013 17:00:16 +0100
Superseded in wheezy-release on 2013-04-01
Superseded in sid-release on 2013-03-27
akonadi (1.7.2-2) unstable; urgency=low


  * Team upload.

  [ Lisandro Damián Nicanor Pérez Meyer ]
  * Change [General] to [%General] in README.Debian (Closes: #688236).
    Thanks Alexander Wuerstlein for noticing.

 -- Pino Toscano <email address hidden>  Wed, 05 Dec 2012 11:07:57 +0100
Superseded in wheezy-release on 2012-12-31
Superseded in sid-release on 2012-12-07
akonadi (1.7.2-1) unstable; urgency=low


  * New upstream release.
  * Drop x11_not_required.diff, no longer needed as internal FindQt4 was
    dropped.
  * Disable tests which require an active DBus daemon. It is not available on
    buildds (patch disable_dbus_requiring_tests.diff).
  * Bump Standards-Version to 3.9.3: no changes needed.

 -- Modestas Vainius <email address hidden>  Sat, 12 May 2012 23:41:01 +0300
Superseded in wheezy-release on 2012-05-23
Superseded in sid-release on 2012-05-14
akonadi (1.6.2-2) unstable; urgency=low


  * Team upload. Upload to unstable.

  [ Sune Vuorela ]
  * Kill the odbc package. It won't currently work.

 -- Ana Beatriz Guerrero Lopez <email address hidden>  Mon, 05 Mar 2012 10:09:22 +0100
Deleted in experimental-release (Reason: None provided.)
akonadi (1.6.2-1) experimental; urgency=low


  * New upstream release.

  [ Felix Geyer ]
  * Add a watch file.
  * Use DEB_*_MAINT_APPEND instead of setting CFLAGS/CXXFLAGS.

 -- Debian Qt/KDE Maintainers <email address hidden>  Thu, 01 Dec 2011 17:18:06 +0100
Published in squeeze-release on 2011-10-08
akonadi (1.3.1-3+squeeze1) stable-proposed-updates; urgency=low


  * Add patch 04_socket_location.diff to allow akonadi-server to run when HOME
    is mounted to the network filesystem (Closes: #545139). Thanks to Ansgar
    Burchardt for the patch.

 -- Modestas Vainius <email address hidden>  Sat, 30 Apr 2011 12:50:31 +0300
Superseded in wheezy-release on 2012-03-16
Superseded in sid-release on 2012-03-07
akonadi (1.5.3-2) unstable; urgency=low
  [ Pino Toscano ]  * Fix typo in README.Debian. (Closes: #627826) -- Debian Qt/KDE Maintainers <email address hidden>  Thu, 26 May 2011 00:22:36 +0300
Deleted in experimental-release (Reason: None provided.)
akonadi (1.5.3-1) experimental; urgency=low
  * New upstream release. -- Modestas Vainius <email address hidden>  Mon, 09 May 2011 00:50:11 +0300
Superseded in experimental-release on 2011-09-21
akonadi (1.5.1-2) experimental; urgency=low
  * Replace $(overriden_command) with $(overridden_command) in debian/rules.    Requires pkg-kde-tools 0.12.  * Bump Standards-Version to 3.9.2: no changes needed.  * Merge 1.3.1-4 changes:    - Drop 04_socket_location.diff patch, merged upstream.  * Build with -fvisibility=hidden -fvisibility-inlines-hidden.  * Update symbol file: private symbols disappeared after building with hidden    visibility. -- Modestas Vainius <email address hidden>  Mon, 02 May 2011 01:40:34 +0300
Superseded in wheezy-release on 2011-09-21
Superseded in sid-release on 2011-09-20
akonadi (1.3.1-4) unstable; urgency=low
  * Add patch 04_socket_location.diff to allow akonadi-server to run when HOME    is mounted to the network filesystem (Closes: #545139). Thanks to Ansgar    Burchardt for the patch. -- Modestas Vainius <email address hidden>  Sat, 30 Apr 2011 12:31:46 +0300
Superseded in experimental-release on 2011-09-21
akonadi (1.5.1-1) experimental; urgency=low
  * New upstream release.  [ Modestas Vainius ]  * Point debian/control Vcs fields to the new Git repository.  * Add libsqlite3-dev to build depends. This build has support for SQLite    backend.  * Drop 03_disable_usr_lib_install_rpath.diff patch, no longer needed as    the problem was fixed upstream differently.  * Add new packages for multiple backend split:    - akonadi-backend-mysql - a package which depends on the stuff needed for      MySQL backend (server and Qt module) and installs a configuration file      previously present in akonadi-server;    - akonadi-backend-postgresql - a package which depends on the stuff needed      for PostgreSQL backend. Even if default configuration starts an internal      PostgreSQL server instance, add postgresql package to Recommends because      the latter package enables the daemon system-wide. PostgreSQL needs to be      split to the -core part as MySQL was;    - akonadi-backend-odbc - a package which depends on the stuff needed to      enable Akonadi ODBC backend. It's primarily intended to be used with a      local Virtuoso instance that's started by Nepomuk;    - akonadi-backend-sqlite - a package with improved SQLite driver that is      needed for Akonadi SQLite backend;  * Make akonadi-server on both backends with | relation preferring MySQL for    now. Also suggest both backends.  * Move akonadi-dbg to the end of debian/control.  * Update install files.  * Add README.Debian with extensive information about Akonadi configuration    files and storage backends.  * Bump build dependency to libqt4-dev 4:4.6.0. SQLite backend needs it.  * Drop Replaces from libakonadi-dev for very old pre-4.1 KDE versions.  * Switch to quilt 3.0 format:    - add appropriate debian/source/format;    - remove quilt from Build-Depends;    - remove debian/README.source, no longer necessary.  * Bump Standards-Version to 3.9.1: add Breaks next to Replaces where needed    or replace Conflicts with Breaks respectively,  * Improve passing of MYSQLD_EXECUTABLE flag to cmake.  * Drop 02_hardcode_debian_mysqld_path.diff, not needed any more.  * Drop obsolete (pre-KDE 4.1) Breaks.  * Switch debian/rules engine to qt-kde-team/2/*. Fix FTBFS in the process.    (Closes: #618200)  * Strip sequence numbers from debian/patches/*.  * Install README.Debian to akonadi-server and all backend packages.  * Install README.sqlite to akonadi-backend-sqlite.  * Drop ${shlibs:Depends} from libakonadi-dev Depends.  * Update debian/copyright.  [ José Manuel Santamaría Lema ]  * Rename libakonadiprivate1 as libakonadiprotocolinternals1     (libakonadiprivate.so.1* doesn't exist anymore) and create symbols file. -- Modestas Vainius <email address hidden>  Sun, 13 Mar 2011 22:25:05 +0200
Superseded in wheezy-release on 2011-09-21
Superseded in squeeze-release on 2011-10-08
Superseded in sid-release on 2011-09-20
akonadi (1.3.1-3) unstable; urgency=low


  [ Didier Raboud ]
  * Make akonadi-mysql depend on mysql-server-core instead of mysql-server,
    thanks to the split made in mysql-5.1. (Closes: #513382) 

 -- Debian Qt/KDE Maintainers <email address hidden>  Sun, 11 Apr 2010 01:46:38 +0300
Superseded in squeeze-release on 2011-09-13
Superseded in sid-release on 2011-09-20
akonadi (1.3.1-2) unstable; urgency=low


  [ Modestas Vainius ]
  * Bump libakonadiprivate1 shlibs with each new upstream release.
  * Generate strict local shlibs for libakonadiprivate1: use
    library-packages.mk from pkg-kde-tools 0.6.4.
  * Add ${misc:Depends} to akonadi-dbg Depends.
  * Add 03_disable_usr_lib_install_rpath.diff patch in order to get rid of
    /usr/lib RPATH.

 -- Debian Qt/KDE Maintainers <email address hidden>  Sat, 06 Mar 2010 01:51:56 +0200
Superseded in sid-release on 2011-09-20
akonadi (1.3.1-1) unstable; urgency=low


  * New upstream release.

  [ Lisandro Damián Nicanor Pérez Meyer ]
  * New upstream release.
  * Refresh patches to apply cleanly:
    - 01_x11_not_required.diff
    - 02_hardcode_debian_mysqld_path.diff
  * Fix the list of dbus interfaces files installed by libakonadi-dev.

  [ Martin Alfke ]
  * Make libakonadiprivate1 depend on akonadi-server
    binary version (Closes: #544431)

  [ Ana Beatriz Guerrero Lopez ]
  * Remove myself from Uploaders.
  * Update year on packaging copyright.

  [ Modestas Vainius ]
  * Change my email address to <email address hidden> in Uploaders field.
  * Fix Vcs-Browser URL.

  [ Fathi Boudra ]
  * Bump Standards-Version to 3.8.4 (no changes needed).

 -- Debian Qt/KDE Maintainers <email address hidden>  Sat, 30 Jan 2010 22:09:48 -0300
Superseded in sid-release on 2011-09-20
Superseded in squeeze-release on 2011-09-13
akonadi (1.2.1-1) unstable; urgency=low


  * New upstream release.
  * Bump Standards-Version to 3.8.3 (no changes needed).

 -- Fathi Boudra <email address hidden>  Sat, 29 Aug 2009 12:00:51 +0200
Superseded in squeeze-release on 2011-09-13
Superseded in sid-release on 2011-09-20
akonadi (1.2.0-2) unstable; urgency=low


  +++ Changes by Modestas Vainius:

  * Build depend on libmysqlclient-dev rather than libmysqlclient15-dev.
    Backports friendly as libmysqlclient-dev is a virtual package in lenny.
    (Closes: #541024).

 -- Debian Qt/KDE Maintainers <email address hidden>  Tue, 11 Aug 2009 12:58:10 +0300
Superseded in sid-release on 2011-09-20
akonadi (1.2.0-1) unstable; urgency=low


  * New upstream release.

 -- Ana Beatriz Guerrero Lopez <email address hidden>  Tue, 04 Aug 2009 09:07:49 +0200
Superseded in experimental-release on 2011-09-21
akonadi (1.1.95-2) experimental; urgency=low


  * Make akonadi-dev depend on boost-dev, as several akonadi headers includes
    boost headers.

 -- Sune Vuorela <email address hidden>  Sat, 11 Jul 2009 23:51:48 +0200
Superseded in squeeze-release on 2011-09-13
Superseded in sid-release on 2011-09-20
akonadi (1.1.2-1) unstable; urgency=low


  * New upstream release.

  +++ Changes by Modestas Vainius:

  * Point Debian Vcs URLs to pkg-kde/trunk (new location).

  +++ Changes by Fathi Boudra:

  * Bump Standards-Version to 3.8.1. No changes needed.
  * Update akonadi-dbg package section: debug.

 -- Debian Qt/KDE Maintainers <email address hidden>  Fri, 01 May 2009 14:00:31 +0200
Superseded in squeeze-release on 2011-09-13
Superseded in sid-release on 2011-09-20
akonadi (1.1.1-2) unstable; urgency=low


  +++ Changes by Modestas Vainius:

  * Switch from internal debian/cdbs/kde.mk to pkg-kde-tools:
    - build depend on pkg-kde-tools 0.4;
    - remove debian/cdbs directory;
    - replace debian/cdbs/kde.mk with
      /usr/share/pkg-kde-tools/qt-kde-team/1/debian-qt-kde.mk in debian/rules.
  * Remove THIS_SHOULD_GO_TO_UNSTABLE from debian/rules.

 -- Debian Qt/KDE Maintainers <email address hidden>  Wed, 18 Feb 2009 23:19:08 +0100
Superseded in sid-release on 2011-09-20
Published in lenny-release on 2008-10-29
akonadi (1.0.0-2) unstable; urgency=low


  +++ Changes by Ana Beatriz Guerrero Lopez:

  * Make libakonadi-dev depend on libakonadiprivate1 instead of
    libakonadiprivate0.

  +++ Changes by Sune Vuorela:

  * Copyright file. Thanks Thomas.

 -- Debian Qt/KDE Maintainers <email address hidden>  Thu, 24 Jul 2008 16:35:45 +0200
168 of 68 results