Debian GNU/Linux

Change log for “base-files” package in Debian

154 of 54 results
Published in squeeze-release on 2014-02-15
base-files (6.0squeeze9) oldstable; urgency=low


  * Changed /etc/debian_version to 6.0.9, for Debian 6.0.9 point release.

 -- Santiago Vila <email address hidden>  Tue, 28 Jan 2014 11:46:34 +0100
Published in wheezy-release on 2014-02-08
base-files (7.1wheezy4) stable; urgency=low


  * Changed /etc/debian_version to 7.4, for Debian 7.4 point release.

 -- Santiago Vila <email address hidden>  Tue, 28 Jan 2014 11:49:40 +0100
Superseded in wheezy-release on 2014-02-08
base-files (7.1wheezy3) stable; urgency=low


  * Changed /etc/debian_version to 7.3, for Debian 7.3 point release.

 -- Santiago Vila <email address hidden>  Wed, 04 Dec 2013 12:30:04 +0100

Available diffs

Superseded in squeeze-release on 2014-02-15
base-files (6.0squeeze8) oldstable; urgency=low


  * Changed /etc/debian_version to 6.0.8, for Debian 6.0.8 point release.

 -- Santiago Vila <email address hidden>  Mon, 23 Sep 2013 00:26:36 +0200
Superseded in wheezy-release on 2013-12-14
base-files (7.1wheezy2) stable; urgency=low


  * Changed /etc/debian_version to 7.2, for Debian 7.2 point release.

 -- Santiago Vila <email address hidden>  Mon, 23 Sep 2013 00:28:46 +0200
Superseded in wheezy-release on 2013-10-18
base-files (7.1wheezy1) stable; urgency=low


  * Changed /etc/debian_version to 7.1, for Debian 7.1 point release.
  * Dropped ".0" part from "7.0" in issue, issue.net and os-release,
    as wheezy is Debian 7, the point releases are 7.x, and we
    don't want to modify those files at every point release.

 -- Santiago Vila <email address hidden>  Sun, 02 Jun 2013 22:27:00 +0200

Available diffs

7.2
Published in jessie-release on 2013-05-12
Published in sid-release on 2013-05-06
base-files (7.2) unstable; urgency=medium


  * Changed issue, issue.net, debian_version and os-release to read "jessie/sid",
    and dropped VERSION and VERSION_ID from os-release.

 -- Santiago Vila <email address hidden>  Sun, 05 May 2013 18:19:00 +0200
Superseded in squeeze-release on 2013-10-19
base-files (6.0squeeze7) stable; urgency=low


  * Changed /etc/debian_version to 6.0.7, for Debian 6.0.7 point release.

 -- Santiago Vila <email address hidden>  Thu, 14 Feb 2013 11:14:00 +0100
7.1
Superseded in jessie-release on 2013-05-12
Superseded in wheezy-release on 2013-06-15
Superseded in sid-release on 2013-05-07
base-files (7.1) unstable; urgency=low


  * Added Multi-Arch: foreign. This is needed even if base-files is
    "Essential: yes" because there are quite a number of packages
    having versioned dependencies on it. Closes: #695863.

 -- Santiago Vila <email address hidden>  Fri, 14 Dec 2012 13:55:36 +0100
7.0
Superseded in sid-release on 2012-12-14
base-files (7.0) unstable; urgency=low


  * Oops. Even if the Breaks on sendfile does not help APT to decide about
    the configuration order, removing the breaks is wrong, because then it is
    possible to upgrade base-files and not sendfile, which would effectively
    break sendfile. Readded Breaks on sendfile.

 -- Santiago Vila <email address hidden>  Wed, 12 Dec 2012 13:05:12 +0100
Superseded in sid-release on 2012-12-18
base-files (6.12) unstable; urgency=low


  * Added HOME_URL, SUPPORT_URL and BUG_REPORT_URL to /etc/os-release.
    Reported by Raphaël Hertzog. Closes: #681480.
  * Added Breaks: sendfile (<< version in squeeze) to help sendfile bug
    regarding improper modification of /etc/profile to be fixed faster.
    Reported by Andreas Beckmann. Closes: #689835.
  * Make /var/run and /var/lock absolute again.
    Reported by Roger Leigh. Closes: #690345.

 -- Santiago Vila <email address hidden>  Sat, 27 Oct 2012 17:41:00 +0200
Superseded in squeeze-release on 2013-02-23
base-files (6.0squeeze6) stable; urgency=low


  * Changed /etc/debian_version to 6.0.6, for Debian 6.0.6 point release.

 -- Santiago Vila <email address hidden>  Fri, 21 Sep 2012 22:51:06 +0200
Superseded in wheezy-release on 2012-12-26
Superseded in sid-release on 2012-10-28
base-files (6.11) unstable; urgency=medium


  * Create /etc/motd instead of /etc/motd.tail, with same default contents,
    as initscripts is now using /etc/motd again as a real file.

 -- Santiago Vila <email address hidden>  Sun, 17 Jun 2012 14:14:44 +0200
Superseded in sid-release on 2012-06-18
base-files (6.10) unstable; urgency=low


  * Record md5sums of unmodified /etc/profile versions so that we can
    upgrade it automatically, as it's done in Ubuntu.
  * In the initial install, create /etc/motd.tail instead of /etc/motd,
    as /etc/motd is converted to a symlink by initscripts and /etc/motd.tail
    is since a long time the master copy to which the output of uname is added.
    Remove postinst code which tries to update /etc/motd, as it does no longer
    work and the file has not changed in a lot of time. Will add code to
    update /etc/motd.tail based on md5sum if it ever changes in a future.
  * Implement proposed transition plan for group staff in /usr/local.
    The file /etc/staff-group-for-usr-local is now created on upgrades
    from releases before 6.10 and (for now) also on initial install.
  * Removed reference to /etc/nsswitch.conf in extended description, as
    the file is being moved to libc-bin.

 -- Santiago Vila <email address hidden>  Sat, 09 Jun 2012 17:41:30 +0200
6.9
Superseded in wheezy-release on 2012-09-01
Superseded in sid-release on 2012-06-10
base-files (6.9) unstable; urgency=low


  * We can't make /etc/profile a conffile without triggering a piuparts
    check which is considered to be serious. Sorry, /etc/profile
    will be handled as before for now. Closes: #673767.

 -- Santiago Vila <email address hidden>  Mon, 21 May 2012 15:12:06 +0200

Available diffs

6.8
Superseded in sid-release on 2012-05-22
base-files (6.8) unstable; urgency=low


  * Added /etc/os-release. Closes: #659853. Note: for stable releases
    this file will look like it's suggested in the bug report above.
    Also, like /etc/debian_version, this file should only be considered
    meaningful for stable releases, which testing and unstable are not.
  * By popular demand, make /etc/profile a conffile. Closes: #668871.
  * Added /sys for all systems but the Hurd. Closes: #670091.
  * Added /proc for the Hurd, as it's already being used.
  * Added a lintian override for /root being 700.

 -- Santiago Vila <email address hidden>  Thu, 17 May 2012 00:08:42 +0200
Superseded in squeeze-release on 2012-09-29
base-files (6.0squeeze5) stable; urgency=low


  * Changed /etc/debian_version to 6.0.5, for Debian 6.0.5 point release.

 -- Santiago Vila <email address hidden>  Tue, 01 May 2012 13:10:42 +0200
Published in lenny-release on 2012-03-10
base-files (5lenny11) oldstable; urgency=low


  * Bump version in /etc/debian_version to "5.0.10".

 -- Santiago Vila <email address hidden>  Thu, 16 Feb 2012 20:49:38 +0100
6.7
Superseded in wheezy-release on 2012-06-01
Superseded in sid-release on 2012-05-17
base-files (6.7) unstable; urgency=low


  * Switch to "compat" again in default /etc/nsswitch.conf. It is not
    obsolete and it should not go away. Closes: #651356.
    Thanks a lot to Petter Reinholdtsen.

 -- Santiago Vila <email address hidden>  Sun, 04 Mar 2012 01:02:00 +0100
6.6
Superseded in sid-release on 2012-03-05
base-files (6.6) unstable; urgency=low


  * Switch to "files" instead of "compat" in default /etc/nsswitch.conf.
    That was only useful for libc5. The new default will only take
    effect for new installs. Thanks to Roger Leigh. Closes: #651356.
  * Reword the very first question in base-files FAQ. Closes: #622200.
  * When migrating /var/run and /var/lock, create relative symlinks
    instead of absolute ones. Useful for chroots. Closes: #652301.

 -- Santiago Vila <email address hidden>  Sat, 03 Mar 2012 16:35:22 +0100
Superseded in squeeze-release on 2012-05-12
base-files (6.0squeeze4) stable; urgency=low


  * Changed /etc/debian_version to 6.0.4, for Debian 6.0.4 point release.

 -- Santiago Vila <email address hidden>  Thu, 12 Jan 2012 19:42:24 +0100
Superseded in squeeze-release on 2012-01-28
base-files (6.0squeeze3) stable; urgency=low


  * Changed /etc/debian_version to 6.0.3, for Debian 6.0.3 point release.

 -- Santiago Vila <email address hidden>  Thu, 08 Sep 2011 12:28:34 +0200
Superseded in lenny-release on 2012-03-10
base-files (5lenny10) oldstable; urgency=low


  * Bump version in /etc/debian_version to "5.0.9".
  * Target distribution changed to "oldstable", as stable is now squeeze.

 -- Santiago Vila <email address hidden>  Thu, 08 Sep 2011 12:22:38 +0200
6.5
Superseded in wheezy-release on 2012-03-14
Superseded in sid-release on 2012-03-04
base-files (6.5) unstable; urgency=low
  * Modified default /etc/profile to not read /etc/bash.bashrc if bash    is invoked as /bin/sh. Closes: #632887. -- Santiago Vila <email address hidden>  Fri, 29 Jul 2011 21:03:02 +0200
Superseded in squeeze-release on 2011-10-08
base-files (6.0squeeze2) stable; urgency=low
  * Changed /etc/debian_version to 6.0.2, for Debian 6.0.2 point release. -- Santiago Vila <email address hidden>  Sat, 28 May 2011 14:04:08 +0200
6.4
Superseded in wheezy-release on 2011-09-21
Superseded in sid-release on 2011-09-20
base-files (6.4) unstable; urgency=low
  * Added /run. Closes: #620157.  * On new installs:    - Create /run/lock (debian-installer will remove it but this will    ensure that it exists even on chroot environments).    - Symlink /var/run to /run.    - Symlink /var/lock to /run/lock.  * On upgraded systems, initscripts will handle the transition to /run.  * Added "Breaks: initscripts << (2.88dsf-13.3)" to ensure that initscripts    is upgraded first, as otherwise udev would break.  * Thanks a lot to Roger Leigh. -- Santiago Vila <email address hidden>  Fri, 27 May 2011 14:25:42 +0200
6.3
Superseded in wheezy-release on 2011-09-21
Superseded in sid-release on 2011-09-20
base-files (6.3) unstable; urgency=low
  * Dropped /run until everything else is ready for it. In particular,    udev should not blindly assume that it works just because it exists. -- Santiago Vila <email address hidden>  Wed, 06 Apr 2011 20:33:02 +0200
6.2
Superseded in sid-release on 2011-09-20
base-files (6.2) unstable; urgency=low
  * Added /run. Requested by Roger Leigh. Closes: #620157. -- Santiago Vila <email address hidden>  Tue, 05 Apr 2011 18:03:36 +0200
Superseded in squeeze-release on 2011-09-13
base-files (6.0squeeze1) stable; urgency=low
  * Changed /etc/debian_version to 6.0.1, for Debian 6.0.1 point release. -- Santiago Vila <email address hidden>  Sat, 12 Mar 2011 14:05:20 +0100
6.1
Superseded in wheezy-release on 2011-09-21
Superseded in sid-release on 2011-09-20
base-files (6.1) unstable; urgency=medium
  * Changed issue, issue.net and debian_version to read "wheezy/sid". -- Santiago Vila <email address hidden>  Mon, 07 Feb 2011 19:24:00 +0100
Superseded in lenny-release on 2011-10-01
base-files (5lenny9) stable; urgency=low
  * Bump version in /etc/debian_version to "5.0.8". -- Santiago Vila <email address hidden>  Sun, 16 Jan 2011 13:02:04 +0100
6.0
Superseded in wheezy-release on 2011-09-21
Superseded in squeeze-release on 2011-09-13
Superseded in sid-release on 2011-09-20
base-files (6.0) unstable; urgency=low
  * Changed issue, issue.net and debian_version to read "6.0".  * Updated README accordingly. -- Santiago Vila <email address hidden>  Tue, 14 Dec 2010 22:20:38 +0100
Superseded in lenny-release on 2011-09-13
base-files (5lenny8) stable; urgency=low
  * Bump version in /etc/debian_version to "5.0.7". -- Santiago Vila <email address hidden>  Fri, 26 Nov 2010 13:58:08 +0100
Superseded in squeeze-release on 2011-09-13
Superseded in sid-release on 2011-09-20
base-files (5.10) unstable; urgency=medium


  * Changed postinst to not reset /var/run/utmp permissions on every upgrade.
    It is definitely not base-files business to change the permissions of
    an already existing /var/run/utmp, as the system admin might have
    changed them on purpose after the file was created. Closes: #601746.

 -- Santiago Vila <email address hidden>  Sat, 13 Nov 2010 13:01:12 +0100
Superseded in lenny-release on 2011-09-13
base-files (5lenny7) stable; urgency=low


  * Bump version in /etc/debian_version to "5.0.6".

 -- Santiago Vila <email address hidden>  Mon, 30 Aug 2010 03:32:00 +0200
5.9
Superseded in squeeze-release on 2011-09-13
Superseded in sid-release on 2011-09-20
base-files (5.9) unstable; urgency=medium


  * Changed /etc/profile so that it defines PATH again. Closes: #571086.
    We will have plenty of time to discuss about this after the release
    of squeeze, but for now, this is the safe thing to do.

 -- Santiago Vila <email address hidden>  Fri, 06 Aug 2010 19:37:40 +0200
5.8
Superseded in squeeze-release on 2011-09-13
Superseded in sid-release on 2011-09-20
base-files (5.8) unstable; urgency=low


  * Added GPL version 1 from http://ftp.gnu.org/gnu/Licenses/ as there
    are a lot of packages still using it. Bug #436105.

 -- Santiago Vila <email address hidden>  Mon, 05 Jul 2010 19:10:54 +0200
Superseded in lenny-release on 2011-09-13
base-files (5lenny6) stable; urgency=low


  * Bump version in /etc/debian_version to "5.0.5".

 -- Santiago Vila <email address hidden>  Fri, 18 Jun 2010 17:12:38 +0200
5.7
Superseded in squeeze-release on 2011-09-13
Superseded in sid-release on 2011-09-20
base-files (5.7) unstable; urgency=low


  * Drop umask setting from /etc/profile, will be handled by pam_umask.
    Closes: #583967.

 -- Santiago Vila <email address hidden>  Tue, 01 Jun 2010 23:57:52 +0200
5.6
Superseded in squeeze-release on 2011-09-13
Superseded in sid-release on 2011-09-20
base-files (5.6) unstable; urgency=low


  * Ordinary user accounts start at UID 1000 by default, but they also
    end at 29999 by default. Modified default /etc/profile accordingly.

 -- Santiago Vila <email address hidden>  Thu, 20 May 2010 11:34:34 +0200
5.5
Superseded in sid-release on 2011-09-20
base-files (5.5) unstable; urgency=low


  * Changed default /etc/profile so that the new umask of 002 is only
    used for ordinary user accounts, which, according to policy, start
    at uid 1000 by default.

 -- Santiago Vila <email address hidden>  Wed, 19 May 2010 18:57:10 +0200
5.4
Superseded in sid-release on 2011-09-20
base-files (5.4) unstable; urgency=low


  * Changed umask in default /etc/profile to 002, which has a little bit
    more sense than 022 on systems like Debian having User Private Groups.
    As usual for /etc/profile, only new installs will have the new default,
    so nobody will be surprised by this on upgrades. Hopefully, this change
    will be documented in the release notes for squeeze as well, for users
    who install squeeze from scratch. Closes: #248140, #581434.
  * Refresh GNU licenses from http://ftp.gnu.org/gnu/Licenses/, as they
    have expanded the embedded tabs. Closes: #572245.
  * Switch to "3.0 (native)" format.

 -- Santiago Vila <email address hidden>  Thu, 13 May 2010 18:35:42 +0200
5.3
Superseded in squeeze-release on 2011-09-13
Superseded in sid-release on 2011-09-20
base-files (5.3) unstable; urgency=low


  * Changed default /etc/profile so that it sources /etc/profile.d/*.sh
    as mandated by the LSB section 16.2. Closes: #545756.
    Package maintainers: Please don't use profile.d if you can avoid it,
    as policy says "A program must not depend on environment variables
    to get reasonable defaults".
  * Removed questions about profile.d from FAQ.

 -- Santiago Vila <email address hidden>  Fri, 09 Apr 2010 18:07:20 +0200
5.2
Superseded in sid-release on 2011-09-20
base-files (5.2) unstable; urgency=low


  * Added question in FAQ to document the fact that some configuration
    files in /etc are never updated on upgrades. Closes: #571083.
  * Changed default /usr/src to be root:root and 755. Closes: #573701.
    The old permissions were of little benefit, and the user can still
    change this after installing a new system anyway.
  * Renamed FAQ to README and added a compatibility symlink.
  * Removed obsolete Depends on base-passwd, as version 2.0.3.4 is more
    than 10 years old and we don't support upgrades which skip releases.
  * Dropped preinst completely, as it was there just to support upgrades
    from very old releases (that we don't support anymore).
  * Removed postinst code that supports upgrades from very old releases.

 -- Santiago Vila <email address hidden>  Sun, 04 Apr 2010 13:22:04 +0200
5.1
Superseded in squeeze-release on 2011-09-13
Superseded in sid-release on 2011-09-20
base-files (5.1) unstable; urgency=low


  * Changed default permissions for /root to 700, as many admins consider
    it should be more private than other home directories. Closes: #514794.
  * Changed default permissions for /var/log/btmp to 660, to be in sync
    with permissions set by logrotate. Closes: #547407.
  * Do not export PS1 in /root/.bashrc, as it has bash escapes and it's
    inherited to subshells that do not have to be bash. Closes: #567733.
  * Added debian_chroot variable to default PS1 in /root/.bashrc.
  * Comment out PS1 in /root/.bashrc anyway, as /etc/profile and
    /etc/bash.bashrc already care about it. Closes: #443245.
  * Comment out umask as well, as it's already in /etc/profile.
  * Added /usr/local/games to default PATH in /etc/profile. Closes: #487105.
  * While we are at it, comment out everything about PATH, as /etc/login.defs
    should already care about this.
  * Changed default /etc/profile so that it sources /etc/bash.bashrc
    if the shell is bash. Closes: #275622.
  * Drop \u part from default PS1 in /etc/profile, as it's only useful
    for people with several non-root accounts. Most people are either root
    or an ordinary user, so $ and # are enough to differentiate between them.
  * Comment out PS1 setting in /etc/profile anyway, as we have bash.bashrc.

 -- Santiago Vila <email address hidden>  Sun, 31 Jan 2010 13:16:14 +0100
Superseded in lenny-release on 2011-09-13
base-files (5lenny5) stable; urgency=low


  * Bump version in /etc/debian_version to "5.0.4".

 -- Santiago Vila <email address hidden>  Tue, 19 Jan 2010 23:45:44 +0100
Superseded in lenny-release on 2011-09-13
base-files (5lenny4) stable; urgency=low


  * Bump version in /etc/debian_version to "5.0.3".

 -- Santiago Vila <email address hidden>  Sun, 30 Aug 2009 22:00:54 +0200
Superseded in lenny-release on 2011-09-13
base-files (5lenny3) stable; urgency=low


  * Bump the version in debian_version to "5.0.2".

 -- Santiago Vila <email address hidden>  Fri, 12 Jun 2009 11:31:32 +0200
Superseded in squeeze-release on 2011-09-13
Superseded in sid-release on 2011-09-20
base-files (5.0.0) unstable; urgency=low


  * Drop README.base, remove-base, and the lines in postinst which checked
    for the old base package being present.
  * Do not fiddle with /etc/adjtime anymore, as it does not belong here.
  * Added file /etc/dpkg/origins/debian from dpkg package, for the benefit
    of Debian-derived distributions, as base-files is trivial to fork.
    Hopefully, this will be one less reason to fork dpkg. Closes: #487437.
  * Added dpkg (<= 1.15.0) to Replaces, because of the above.
  * On initial install and also on upgrades, create /etc/dpkg/origins/default
    as a symlink to /etc/dpkg/origins/debian, if it does not exist.
  * Updated copyright year in copyright file.

 -- Santiago Vila <email address hidden>  Fri, 24 Apr 2009 21:02:42 +0200
Superseded in lenny-release on 2011-09-13
base-files (5lenny2) stable; urgency=low


  * Fixed typo in /usr/share/doc/base-files/remove-base so that
    it actually does what it is supposed to do. Closes: #519719.
    This code will be removed in squeeze, but hopefully, it will
    be part of some future lenny point release.

 -- Santiago Vila <email address hidden>  Sat, 11 Apr 2009 14:30:50 +0200
5.0
Superseded in squeeze-release on 2011-09-13
Superseded in sid-release on 2011-09-20
base-files (5.0) unstable; urgency=medium


  * Changed issue, issue.net and debian_version to read "squeeze/sid".
  * Added GFDL-1.3 from http://www.gnu.org/licenses/fdl-1.3.txt as new
    packages in unstable are starting to use it. Closes: #517196.
  * Updated generic GFDL symlink accordingly, as it is always supposed
    to point to the latest version.

 -- Santiago Vila <email address hidden>  Thu, 26 Feb 2009 17:09:38 +0100
5
Superseded in lenny-release on 2011-09-13
Superseded in sid-release on 2011-09-20
base-files (5) unstable; urgency=low


  * Changed issue, issue.net and debian_version to read "5.0".
  * Changed FAQ so that users of lenny as stable will know what happens
    when they upgrade to the new testing.

 -- Santiago Vila <email address hidden>  Thu, 04 Dec 2008 10:04:04 +0100
Superseded in lenny-release on 2011-09-13
Superseded in sid-release on 2011-09-20
base-files (4.0.6) unstable; urgency=low


  * Changed the way wtmp, btmp and lastlog are handled. They are no longer
    recreated at every base-files upgrade. Instead, they are only created
    once, when base-files is installed by debootstrap. It is really not
    base-files business to fiddle with those files, as it is documented
    that removing them is the standard way to disable logging to them.
    Closes: #488376.

 -- Santiago Vila <email address hidden>  Tue, 04 Nov 2008 20:34:12 +0100
Superseded in sid-release on 2011-09-20
Superseded in lenny-release on 2011-09-13
base-files (4.0.5) unstable; urgency=low


  * Changed awk from Depends to Pre-Depends. Closes: #314571, #469552.
    This is required to make the awk virtual package to be truly essential,
    as only essential packages, their predependencies, and the dependencies
    of their predependencies are guaranteed to be "working at all times".
    Previously, the packaging system was allowed to remove an awk flavour
    and install another one in the middle of an upgrade, which may break
    packages using awk in their preinsts (and in fact, it happened).
    Tkanks a lot to Steve Langasek for clarifying this issue.
  * It's still soon to change /etc/debian_version. Please be patient.

 -- Santiago Vila <email address hidden>  Tue,  5 Aug 2008 18:06:06 +0200
154 of 54 results