Debian GNU/Linux

Change log for “ca-certificates-java” package in Debian

121 of 21 results
Published in jessie-release on 2014-03-30
Published in sid-release on 2014-03-25
ca-certificates-java (20140324) unstable; urgency=medium


  * Team upload.
  * Fixed a test failure caused by the removal of the CAcert.org root
    certificate from the ca-certificates package (Closes: #741755)
  * Limit the memory used by java to 64M when updating the certificates
    (Closes: #576453)
  * Mavenized the project
  * Code refactoring
  * d/control: Standards-Version updated to 3.9.5 (no changes)
  * Switch to debhelper level 9

 -- Emmanuel Bourg <email address hidden>  Mon, 24 Mar 2014 09:42:08 +0100
Superseded in jessie-release on 2014-03-30
Superseded in sid-release on 2014-03-25
ca-certificates-java (20130815) unstable; urgency=low


  * Acknowledge NMU done by Don Armstrong and Andreas Beckmann.
  * Fix tests to works with new cacert certificates names (Closes:
    #713138).
  * d/control: Use canonical value for Vcs-* fields.
  * d/control: Remove deprecated DMUA flag.
  * d/control: Bump Standards-Version to 3.9.4 (no changes needed).

 -- Damien Raude-Morvan <email address hidden>  Thu, 15 Aug 2013 13:52:46 +0200

Available diffs

Superseded in jessie-release on 2013-08-26
Published in wheezy-release on 2013-02-04
Superseded in sid-release on 2013-08-15
ca-certificates-java (20121112+nmu2) unstable; urgency=medium


  * Non-maintainer upload.
  * postinst, jks-keystore.hook: Do not fail if nss.cfg does not (yet) exist,
    i.e. if openjdk-?-jre-headless is unpacked but not yet configured.
    (Closes: #694888)
  * Set urgency to medium for RC bugfix.

 -- Andreas Beckmann <email address hidden>  Sun, 27 Jan 2013 14:19:41 +0100

Available diffs

Superseded in sid-release on 2013-01-29
ca-certificates-java (20121112+nmu1) unstable; urgency=low


  * Non-maintainer upload
  * Fix test for dpkg-query in postinst; there was an extraneous --version
    here. [Probably don't even need to bother to check for dpkg-query, but
    why not.] (Closes: #690204)
  * Library path for softokn3pkg and nsspkg is potentially wrong if there
    are multiple different paths; fix it.
  * Do not run the hook if ca-certificates-java has been removed but not
    purged.
  * Use the new trigger support provided by ca-certificates (>=20121114).

 -- Don Armstrong <email address hidden>  Mon, 12 Nov 2012 15:45:50 -0800

Available diffs

Superseded in wheezy-release on 2013-02-04
Superseded in sid-release on 2012-11-29
ca-certificates-java (20120721) unstable; urgency=low


  * Fix jks-keystore and postinst to work on multi-arch system.
    Use dpkg-query -L package:arch. (Closes: #680618).
  * As libnss3-1d is a transitional package on both Debian and Ubuntu,
    upgrade Depends to use libnss3.

 -- Damien Raude-Morvan <email address hidden>  Sat, 21 Jul 2012 01:06:32 +0200

Available diffs

Superseded in wheezy-release on 2012-08-13
Superseded in sid-release on 2012-07-21
ca-certificates-java (20120608) unstable; urgency=low


  [ James Page ]
  * Switch primary JRE dependency from openjdk-6 to openjdk-7 to support
    demotion of openjdk-6 to universe in Ubuntu:
    - d/control, rules: Generate primary JRE dependency at build time to
      allow differentiation between Ubuntu and Debian.
  * Added myself to uploaders.

  [ Damien Raude-Morvan ]
  * Update to unstable.
  * Set DMUA flag for James Page.

 -- James Page <email address hidden>  Fri, 08 Jun 2012 09:44:58 +0100
Superseded in sid-release on 2012-06-09
ca-certificates-java (20120603) unstable; urgency=low


  * Use javahelper as buildsystem:
    - d/control: Add Build-Depends on javahelper.
    - d/rules: Use jh_build to call javac.
  * Create a testsuite for this package:
    - Refactor UpdateCertificates code to send exceptions instead of
      System.exit(1).
    - New testsuite: UpdateCertificatesTest.
    - d/control: Build-Depends on junit4.
    - d/rules: Launch junit after build and handle "nocheck" option in
      DEB_BUILD_OPTIONS.

 -- Damien Raude-Morvan <email address hidden>  Sun, 03 Jun 2012 12:10:26 +0200

Available diffs

Superseded in sid-release on 2012-06-03
ca-certificates-java (20120524) unstable; urgency=low


  [ Marc Deslauriers ]
  * debian/preinst, debian/postinst: remove the 20110912ubuntu1 work-around
    since it is no longer needed.
  * debian/postinst: don't put a symlink in / if jvm doesn't contain nss
    configuration. (Closes: #665754, #665749).
  * debian/postinst: force migration to new alias names again. The
    migration was supposed to occur on upgrades to Oneiric, but failed
    because of an NSS error.
  * debian/postinst: forcibly remove diginotar cert. It could be left
    behind under certain circumstances. (LP: #920758)
  * debian/postinst: also look for jvm in multiarch locations (LP: #962378)
  * debian/postinst: retrigger first_install to properly get cert store.

  [ James Page ]
  * d/rules: Ensure java is built with source/target == 1.6 for backwards
    compatibility with openjdk-6. 

  [ Damien Raude-Morvan ]
  * Sync handling of nss.cfg between debian/jks-keystore.hook.in and
    debian/postinst.in.
  * Merge changes from Ubuntu (Thanks to James Page and Marc Deslauriers).
  * Improve handling of certificate with UTF-8 filenames:
    - UpdateCertificates: Force read System.in with UTF-8
    - debian/postinst: Set LC_CTYPE to C.UTF-8

 -- Damien Raude-Morvan <email address hidden>  Tue, 22 May 2012 23:41:41 +0200
Superseded in wheezy-release on 2012-06-19
Superseded in sid-release on 2012-05-25
ca-certificates-java (20120225) unstable; urgency=low


  [ Steve Langasek ]
  * debian/jks-keystore.hook: If we *don't* find libnss3 / libnss3-1d,
    don't remove files from the filesystem in do_cleanup(),
    since this has a nasty tendency of nuking system libraries.
    LP: #855171.
  * debian/preinst, debian/postinst: when upgrading from version
    20110912ubuntu1, disable the buggy hook script early to prevent it from
    being run before our new version is configured; and re-enable the script
    in the postinst.  LP: #855246.

  [ Matthias Klose ]
  * Mark as Multi-Arch: foreign.
  * Adjust the libnss3-1d versioned dependency.

  [ Damien Raude-Morvan ]
  * Add myself to Uploaders.
  * Use dh_gencontrol and dpkg-vendor to allow:
    - New substvar ${nss:Depends} for libnss3-1d versionning.
    - New @NSS_LIB@ parameter for debian/*.in files.
  * Bump Standards-Version to 3.9.3:
    - Add recommended build-arch / build-indep targets.

 -- Damien Raude-Morvan <email address hidden>  Sat, 25 Feb 2012 15:06:32 +0100
Superseded in wheezy-release on 2012-03-07
Superseded in sid-release on 2012-02-26
ca-certificates-java (20111223) unstable; urgency=low


  * Support new multiarch JRE packages in postinst.

 -- Torsten Werner <email address hidden>  Fri, 23 Dec 2011 13:46:15 +0100
Superseded in wheezy-release on 2012-01-03
Superseded in sid-release on 2011-12-23
ca-certificates-java (20110912) unstable; urgency=low


  * Support new multiarch JRE packages in jks-keystore. (Closes: #641306)
  * Support OpenJDK 7. (Closes: #641305)

 -- Torsten Werner <email address hidden>  Mon, 12 Sep 2011 21:23:22 +0200
Superseded in wheezy-release on 2011-09-24
Superseded in sid-release on 2011-09-20
ca-certificates-java (20110816) unstable; urgency=low


  * Upgrade Recommends: libnss3-1d to a versioned Depends due to multiarch
    changes. (Closes: #635571)
  * Use the locale C.UTF-8 for the hook script to be more robust.

 -- Torsten Werner <email address hidden>  Tue, 16 Aug 2011 11:00:33 +0200
Superseded in wheezy-release on 2011-09-21
Superseded in sid-release on 2011-09-20
ca-certificates-java (20110531) unstable; urgency=low
  * Prepare for multiarch libnss3 update. -- Matthias Klose <email address hidden>  Tue, 31 May 2011 15:20:52 +0200
Superseded in wheezy-release on 2011-09-21
Superseded in sid-release on 2011-09-20
ca-certificates-java (20110426) unstable; urgency=low
  * Test for existing file in postinst before copying it. (Closes: #624152)  * Add Vcs headers to debian/control. -- Torsten Werner <email address hidden>  Tue, 26 Apr 2011 09:23:03 +0200
Superseded in sid-release on 2011-09-20
ca-certificates-java (20110425) unstable; urgency=low
  * Add Java code to update the keystore and support UTF-8 encoded filenames.    (Closes: #607245, #623671)  * Change Maintainer to Debian Java Maintainers and add myself to Uploaders.  * Update Build-Depends.  * Replace old inconsistent keystore aliases. (Closes: #623888)  * Add support for openjdk-7 and remove support for old cacao VM.  * Add a NEWS file explaining the update.  * Update README.Debian. -- Torsten Werner <email address hidden>  Mon, 25 Apr 2011 15:28:55 +0200
Superseded in sid-release on 2011-09-20
ca-certificates-java (20110421~nmu1) unstable; urgency=low
  * Non-maintainer Upload.  * Depend on locales-all and use en_US.UTF-8 locale (Closes: #623672) -- Ondřej Surý <email address hidden>  Sun, 24 Apr 2011 10:13:48 +0200
Superseded in wheezy-release on 2011-09-21
Superseded in sid-release on 2011-09-20
Published in squeeze-release on 2010-05-19
ca-certificates-java (20100412) unstable; urgency=low


  * Upload to unstable.

 -- Matthias Klose <email address hidden>  Mon, 12 Apr 2010 03:15:47 +0200
Superseded in sid-release on 2011-09-20
ca-certificates-java (20100406) unstable; urgency=low


  * Explicitely fail the installation, if /proc is not mounted.
    Currently required by the java tools, changed in OpenJDK7.
    Closes: #576453. LP: #556044.
  * Print name of JVM in case of errors.
  * Set priority to optional, set section to java. Closes: #566855.
  * Remove /etc/ssl/certs on package purge, if empty. Closes: #566853.

 -- Matthias Klose <email address hidden>  Tue, 06 Apr 2010 21:41:39 +0200
Superseded in squeeze-release on 2011-09-13
Superseded in sid-release on 2011-09-20
ca-certificates-java (20091021) unstable; urgency=low


  * Clarify output for keytool errors (although it shouldnn't be
    necessary anymore). Closes: #540490.

 -- Matthias Klose <email address hidden>  Wed, 21 Oct 2009 22:00:53 +0200
Superseded in sid-release on 2011-09-20
Superseded in squeeze-release on 2011-09-13
ca-certificates-java (20090629) unstable; urgency=low


  * debian/rules, debian/postinst, debian/jks-keystore.hook: Filter out
    SHA384withECDSA certificates since keytool won't support them.
    LP: #392104, closes: #534520.
  * Fix typo in hook. Closes: #534533.
  * Use java6-runtime-headless as alternative dependency. Closes: #512293.

 -- Matthias Klose <email address hidden>  Mon, 29 Jun 2009 11:27:59 +0200
Superseded in sid-release on 2011-09-20
Superseded in squeeze-release on 2011-09-13
Superseded in squeeze-release on 2011-09-13
Superseded in sid-release on 2011-09-20
ca-certificates-java (20081028) unstable; urgency=low


  * Ignore LANG and LC_ALL setting when running keytool. LP: #289934.

 -- Matthias Klose <email address hidden>  Tue, 28 Oct 2008 07:20:16 +0100
121 of 21 results