curl 7.52.1-1 source package in Debian

Changelog

curl (7.52.1-1) unstable; urgency=medium

  * New upstream release
    - Fix printf floating point buffer overflow as per CVE-2016-9586
      (Closes: #848958)
  * B-D on "libssl1.0-dev | libssl-dev (<< 1.1)" (Closes: #850880, #844018)
  * Another attempt at making -dev packages multi-arch.
    Thanks to Benjamin Moody for the patches. (Closes: #731998, #846360)
  * Enable support for PSL (Closes: #847958)
  * Re-enable support for IDN (Closes: #849539)
  * Drop 10_disable-network-tests.patch.
    It didn't really work, and the issue is not urgent.
  * Switch curl binary back to libcurl3/OpenSSL.
    While the GnuTLS flavour mostly worked fine, there are a bunch of features
    that are not implemented.

 -- Alessandro Ghedini <email address hidden>  Thu, 12 Jan 2017 22:02:44 +0000

Upload details

Uploaded by:
Alessandro Ghedini on 2017-01-13
Uploaded to:
Sid
Original maintainer:
Alessandro Ghedini
Architectures:
any all
Section:
libs
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Builds

Downloads

File Size SHA-256 Checksum
curl_7.52.1-1.dsc 2.7 KiB bc82de7b02127add254a39b767b9fd378add339b62e0c79d16d9d2f273fad378
curl_7.52.1.orig.tar.gz 3.3 MiB a8984e8b20880b621f61a62d95ff3c0763a3152093a9f9ce4287cfd614add6ae
curl_7.52.1-1.debian.tar.xz 27.3 KiB c2d962814c274e1ec5c962a3346631ec93a18fcb2da9438fdd44b7e8deda4e1a

No changes file available.

Binary packages built by this source