curl 7.60.0-2 source package in Debian

Changelog

curl (7.60.0-2) unstable; urgency=medium

  [ Steve Langasek ]
  * Build-depend on libssl-dev instead of libssl1.0-dev.
  * Rename libcurl3 to libcurl4, because libcurl exposes an SSL_CTX via
    CURLOPT_SSL_CTX_FUNCTION, and this object changes incompatibly between
    openssl 1.0 and openssl 1.1.
  * debian/patches/03_keep_symbols_compat.patch: drop, since we are no longer
    claiming compatibility.
  * debian/patches/90_gnutls.patch: Retain symbol versioning compatibility for
    non-OpenSSL builds.  Closes: #858398.
  * Adjust libssl1.1 vs libssl1.0 Suggests/Conflicts; thanks, Adrian Bunk

 -- Alessandro Ghedini <email address hidden>  Wed, 23 May 2018 20:25:39 +0100

Upload details

Uploaded by:
Alessandro Ghedini on 2018-05-28
Uploaded to:
Sid
Original maintainer:
Alessandro Ghedini
Architectures:
any all
Section:
libs
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Builds

Downloads

File Size SHA-256 Checksum
curl_7.60.0-2.dsc 2.6 KiB 171c3e2879b4ee61138b9d2225644caf5517ddb2a415ed1ffccb363650da057e
curl_7.60.0.orig.tar.gz 3.8 MiB e9c37986337743f37fd14fe8737f246e97aec94b39d1b71e8a5973f72a9fc4f5
curl_7.60.0-2.debian.tar.xz 27.5 KiB 903732d54e8edefbac2688b95110f16ae0e304dbf92a10864c4dd7e7bb410443

No changes file available.

Binary packages built by this source