Incorrect Bengali rendering of ra+japhala

Bug #35085 reported by Baishampayan Ghose on 2006-03-15
16
Affects Status Importance Assigned to Milestone
icu (Debian)
Fix Released
Unknown
icu (Ubuntu)
Medium
Unassigned

Bug Description

In OOo [all versions] when we type ra (U+09B0)+ halant (U+09CD)+ ya (U+09AF), the rendering is incorrect. Instead of a japhala after ra, the formation becomes garbled, the ra forms a conjunct with the ya.
I am supplying reference renderings.

Correct rendering of ra+japhala

Garbled rendering in OOo

Soumyadip Modak (soumyadip) wrote :

Well I've seen this issue too. A patch exists, but it is a temporary workaround. The developers of the patch have promised to produce a better working version by Monday 20th March

Changed in openoffice.org:
status: Unconfirmed → Confirmed
Baishampayan Ghose (b.ghose) wrote :

Changing the status to confirmed.

This patch is temporary workaround, and contains code from a person who has not signed the OpenOffice code submission agreement. So including this patch may not be possible in upstream. The other developer of this patch has however signed the agreement and wants some time ( a couple of days) to work around the potentially unacceptable code.

Soumyadip Modak (soumyadip) wrote :

Screenshot of Openoffice with the patch applied. Screenshot taken on a Fedora Core 4 machine with Openoffice 2.0.0 downloaded from openoffice.org (not FC4 OpenOffice.org2):

http://www.flickr.com/photos/soumyadip/112472713/

Soumyadip Modak schrieb:
> - Changed attachments:
> Added: Temporary workaround
> http://librarian.launchpad.net/1739193/icu_sdg_patches.diff

the patch doesn't apply to the icu package, please attach a patch
against the icu source package found in dapper.

I have attached a fixed patch. Kindly test it as it's experimental.

Matthias Klose (doko) on 2006-03-15
Changed in openoffice.org:
assignee: nobody → doko
status: Confirmed → In Progress
Matthias Klose (doko) wrote :

fixed in 3.4-4ubuntu1

Changed in icu:
status: In Progress → Fix Released
Soumyadip Modak (soumyadip) wrote :

[Request] Please attach screenshots of Openoffice working with ICU patched. Or please indicate where we can download the binaries of the patched ICU so that we can put them in and validate that the patch is working correctly.

  • Test Case Edit (7.5 KiB, application/vnd.oasis.opendocument.text)

I am attaching a test document. The rendering should be identical to the reference rendering posted earlier for the bug to be fixed.

Baishampayan Ghose (b.ghose) wrote :

The fix released doesn't fix the bug. So I am reopening it.

Changed in icu:
status: Fix Released → Confirmed
Sayamindu Dasgupta (sayamindu) wrote :

Umm.., I think a major goof up has occured somewhere. Firstly, the Unicode recommended sequence for ra-japhala is ra (U+09B0)+ Zero Width Non Joiner (U+200C) + halant (U+09CD)+ ya (U+09AF). The sequence, ra (U+09B0)+ halant (U+09CD)+ ya (U+09AF), on the other hand, is supposed to render as ja+reph (which it does, with ICU).
AFAIK, at present, the only rendering engine to implement ra (U+09B0)+ Zero Width Non Joiner (U+200C) + halant (U+09CD)+ ya (U+09AF) correctly is Microsoft's Uniscribe engine.
I also looked at the attached patches. They are for completely different issues. The patch attached by Soumyadip fixes a rendering issue for a-jafala and for ba-fala, while Baishampayan's patch is a subset of the previous patch, addressing the a-jafala issue.

Jay Berkenbilt (ejb) wrote :

Is anything happening with this? Applying the patch to the icu in debian doesn't impact the rendering of test-case.odt. Debian bug 357137 has been open for some time, and I probably can't resolve it until this problem is resolved. Alternatively, if someone would like to post a proper patch to bug 357137 in debian by sending to <email address hidden>, I will fix the problem there and the change will eventually make it back into the Ubuntu package when Ubuntu resyncs with debian.

Jay Berkenbilt (ejb) wrote :

The automatically generated links above do not point to the debian bug. They point to a bug in this system with the same number should any such bug eventually exist...

Jay Berkenbilt (ejb) wrote :

ICU 3.6 d02 (beta) is in debian experimental. I am going to see if I can determine whether this bug is there in 3.6. Whoever is interested in this may want to take advantage of this beta period of ICU to see if they can get a patch upstream.

Jay Berkenbilt (ejb) wrote :

ICU 3.6 is in debian unstable now. Hopefully openoffice.org built against it will follow soon. Then we can see if this bug is still present in 3.6.

Matt Zimmerman (mdz) on 2006-09-27
Changed in icu:
importance: High → Medium
Changed in icu:
status: Unknown → Unconfirmed
Harshula Jayasuriya (harshula) wrote :

Hi,

I'm not familiar with Unicode Bengali but if the character sequence in question requires ZWJ or ZWNJ, as suggested by Sayamindu Dasgupta, I might be able to point to the potential problem.

OOo has been filtering out (i.e. not allowing ZWJ and ZWNJ to reach ICU) since Nov 2005. This has been a major problem for Unicode Sinhala which requires ZWJ to reach the renderer.

You can find the details here:
http://qa.openoffice.org/issues/show_bug.cgi?id=68047

Regards,
Harshula

Jay Berkenbilt (ejb) wrote :

For what it's worth, after ICU 3.6 went into debian, openoffice reverted to its internal ICU because of other apparent incompatibilities. I'm not running Ubuntu right now, so I don't know whether Ubuntu has followed. In any case, it's quite likely that this problem is no longer reproducible in ICU with openoffice in Ubuntu. During the fleeting moment during which there was an openoffice in debian that built against ICU 3.6, I tried to open the sample file. I got something that looked neither like the incorrect nor like the correct renderings that were posted here. I don't know Bengali and can't really help further with diagnosis.

In any case, just be aware when testing this that openoffice may not be using the ICU package anymore.

Jay Berkenbilt schrieb:
> In any case, just be aware when testing this that openoffice may not be
> using the ICU package anymore.

OOo in Ubuntu edgy uses the system icu-3.4 packages.

Harshula Jayasuriya (harshula) wrote :

Hi,

re: "For what it's worth, after ICU 3.6 went into debian, openoffice reverted to its internal ICU because of other apparent incompatibilities."

OOo only reverted back to the internal ICU for a moment. It is using ICU 3.6 again.

# dpkg -l openoffice.org
<snip>
ii openoffice.org 2.0.4-5 OpenOffice.org Office suite version 2.0

# ldd /usr/lib/openoffice/program/soffice.bin | grep icu
        libicuuc.so.36 => /usr/lib/libicuuc.so.36 (0xa693a000)
        libicule.so.36 => /usr/lib/libicule.so.36 (0xa68fa000)
        libicudata.so.36 => /usr/lib/libicudata.so.36 (0xa5d6b000)

Regards,
Harshula

Jay Berkenbilt (ejb) wrote :

Okay, I confirm that the bug is still present with icu 3.6 in debian sid.

Matthias Klose (doko) on 2007-09-07
Changed in icu:
assignee: doko → nobody
Changed in icu:
status: New → Fix Released

Can anyone confirm this on 3.8 on hardy?

Changed in icu:
status: Confirmed → Incomplete

It seems my OOo on Hardy still produces the wrong thing
(i don't read Bengali, so please check the attachment - looks like Incorrect rendering to me).

j@j-laptop:~$ dpkg -l openoffice.org
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-===========================-===========================-======================================================================
ii openoffice.org 1:2.4.0-3ubuntu6 OpenOffice.org Office suite

j@j-laptop:~$ ldd /usr/lib/openoffice/program/soffice.bin | grep icu
 libicuuc.so.38 => /usr/lib/libicuuc.so.38 (0xb6315000)
 libicule.so.38 => /usr/lib/libicule.so.38 (0xb62e0000)
 libicudata.so.38 => /usr/lib/libicudata.so.38 (0xb5213000)

David Futcher (bobbo) on 2010-06-10
tags: added: patch-accepted-debian

Thank you for posting this bug.

Does this issue still occur in Lucid?

If this is still present in the latest ICU available (4.4) please submit a bug upstream or make a link to one if there's already one.

tags: added: patch-needswork
removed: patch-accepted-debian
Adolfo Jayme (fitojb) on 2013-12-25
Changed in icu (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.