Debian GNU/Linux

Change log for “jabberd14” package in Debian

17 of 7 results
Published in squeeze-release
jabberd14 (1.6.1.1-5+squeeze1) stable-security; urgency=high
  * Non-maintainer upload by the Security Team.  * Prevent entity expansion in order to prevent about    the billion laughs DoS attack (CVE-2011-1754.dpatch). -- Nico Golde <email address hidden>  Tue, 31 May 2011 00:12:20 +0200
Deleted in wheezy-release (Reason: None provided.)
Deleted in sid-release (Reason: None provided.)
jabberd14 (1.6.1.1-5.1) unstable; urgency=high
  * Non-maintainer upload by the Security Team.  * Prevent entity expansion in order to prevent about    the billion laughs DoS attack (CVE-2011-1754.dpatch). -- Nico Golde <email address hidden>  Tue, 31 May 2011 00:12:20 +0200
Superseded in wheezy-release on 2011-09-21
Superseded in squeeze-release on 2011-09-13
Superseded in sid-release on 2011-09-20
jabberd14 (1.6.1.1-5) unstable; urgency=low


  * Fixed connection breakage due to net.ipv6.bindv6only=1. (Closes: #561705).
  * Notified in NEWS.Debian the new way of configuring server hostname.
    (Closes: #561391).
  * Really removed obsolete conffiles on upgrade. (Closes: #561388).

 -- Miguel Landaeta <email address hidden>  Fri, 15 Jan 2010 14:34:30 -0430
Superseded in squeeze-release on 2011-09-13
Superseded in sid-release on 2011-09-20
jabberd14 (1.6.1.1-4) unstable; urgency=low


  * Fixed reading of settings from /etc/default/jabberd. (Closes: #552281).
  * Fixed detecting of IPv6 support. (Closes: #546545).
  * Fixed crashing on old ssl protocol. (Closes: #546544).
  * Added support to easy configuration using /etc/default/jabberd14
    to allow setting of basic options without editing jabber.xml.
  * Removed obsolete conffiles on upgrade. (Closes: #546814).
  * Fixed patch-system-but-no-source-readme lintian warning and bumped 
    Standards-Version to 3.8.3.
  * Fixed FTBFS with g++-4.4. (Closes: #560342).
  * Fixed FTBFS with binutils-gold. (Closes: #554924).

 -- Miguel Landaeta <email address hidden>  Fri, 11 Dec 2009 19:40:55 -0430
Superseded in squeeze-release on 2011-09-13
Superseded in sid-release on 2011-09-20
jabberd14 (1.6.1.1-3) unstable; urgency=low


  * Replaced Build-Depends on libmysqlclient15-dev with libmysqlclient-dev
    and dropped its version restriction since it's already satisfied with
    stable. (Closes: #542131).

 -- Miguel Landaeta <email address hidden>  Mon, 17 Aug 2009 21:41:37 -0430
Superseded in sid-release on 2011-09-20
jabberd14 (1.6.1.1-2) unstable; urgency=low


  * Added Vcs-* fields.
  * Fixed a typo in init script that was causing startup errors.
    (Closes: #532419)
  * Fixed dir-or-file-in-var-run lintian error and bumped 
    Standards-Version to 3.8.2.
  * Fixed piuparts error regarding left files on system after purging.
  * Added NEWS.Debian for announce server-breaking incompatability
    warnings. (Closes: #528129)
  * Fixed bug with copy of user data files to the new spool directory
    on upgrades from 1.4.x to 1.6.x versions. (Closes: 523095)
  * Disabled logging via syslog. Now jabberd writes itself to its
    logfile in /var/log/jabberd.

 -- Miguel Landaeta <email address hidden>  Sat, 25 Jul 2009 01:07:05 -0430
Superseded in squeeze-release on 2011-09-13
Superseded in sid-release on 2011-09-20
jabberd14 (1.6.1.1-1) unstable; urgency=low


  [ Miguel Landaeta ]
  * New maintainer. (Closes: #471408)
  * New upstream release. (Closes: #329680, #430529)
  * debian/copyright:
    - Upstream now uses license GPL-2+. (Closes: #302417)
    - Implement a version of the copyright format proposal.
  * Bumped standards version to 3.8.0; no changes required.
  * Provided a new binary package libjabberd2 and renamed
    jabber-dev package to libjabberd2-dev.
  * Updated debian/jabberd14.postinst:
     - Copy spool data from /var/lib/jabber to /var/spool/jabberd.

  [ Paul van Tilburg ]
  * Renamed source and binary packages to jabberd14; conflict with
    and provide jabber. (Closes: #404816).
  * Updated debian/rules since jabberd14 now uses autotools; converted it
    to use CDBS. (Closes: #337542).
  * Added --enable-ipv6 flag for configure in debian/rules.
    (Closes: #334414, #386601).
  * Added debian/jabber.xml.xdb_file to install as default configuration;
    use file-based XDB for now.
  * Updated debian/control:
    - Changed build-depend from libssl-dev to libgnutls-dev.
    - Added build-depends on libpopt-dev, cdbs and pkg-config.
    - Removed the build-depend on procps.
    - Added depend on openssl to be able to generate dhparams.pem.
    - Changed ${jabber:Provides} into hardcoded jabber-1.4
    - Slight update to the description of the libjabber2-dev package.
      (Closes: #404816).
  * Added the Homepage field.
  * Updated and created more files for debhelper to be used with
    jabberd14, libjabberd2 and libjabberd2-dev packages.
  * Added a watch file.
  * Added depend on lsb-base (>= 3.0-6) and updated init script to use
    LSB functions. (Closes: #350337, #489071, #407166).
  * Added a man page for xdbfiletool: debian/xdbfiletool.8.
  * Dropped depend on jabber-common.
  * Removed debian/jabberd14.preinst, it wasn't doing anything anymore.
  * Updated debian/jabberd.14.post{inst,rm}:
     - Create/remove jabberd system user and group. (Closes: #438871).
     - Generate/remove /etc/jabber/dhparams.pem.
     - Chown and chmod/clean the configuration and spool directory.

 -- Miguel Landaeta <email address hidden>  Tue, 17 Feb 2009 11:21:36 -0430
17 of 7 results