Debian GNU/Linux

“openssh” 1:5.2p1-2 source package in Debian

Changelog

openssh (1:5.2p1-2) unstable; urgency=low


  [ Colin Watson ]
  * Backport from upstream:
    - After sshd receives a SIGHUP, ignore subsequent HUPs while sshd
      re-execs itself.  Prevents two HUPs in quick succession from resulting
      in sshd dying (LP: #497781).
    - Output a debug if we can't open an existing keyfile (LP: #505301).
  * Use host compiler for ssh-askpass-gnome when cross-compiling.
  * Don't run tests when cross-compiling.
  * Drop change from 1:3.6.1p2-5 to disable cmsg_type check for file
    descriptor passing when running on Linux 2.0.  The previous stable
    release of Debian dropped support for Linux 2.4, let alone 2.0, so this
    very likely has no remaining users depending on it.

  [ Kees Cook ]
  * Implement DebianBanner server configuration flag that can be set to "no"
    to allow sshd to run without the Debian-specific extra version in the
    initial protocol handshake (closes: #562048).

 -- Colin Watson <email address hidden>  Sat, 16 Jan 2010 01:28:58 +0000

Upload details

Uploaded by:
Debian OpenSSH Maintainers on 2010-01-16
Uploaded to:
Sid
Original maintainer:
Debian OpenSSH Maintainers
Component:
main
Architectures:
any
Section:
net
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Builds

Downloads

File Size MD5 Checksum
openssh_5.2p1-2.dsc 1.6 KiB 16f778133fca11cad3b9555e0e762de3
openssh_5.2p1.orig.tar.gz 992.8 KiB ada79c7328a8551bdf55c95e631e7dad
openssh_5.2p1-2.diff.gz 226.4 KiB 3ee3a4c0d14a6108a9502d1ffdc807c1

Binary packages built by this source