pwgen 2.07-1 source package in Debian

Changelog

pwgen (2.07-1) unstable; urgency=high


  * New upstream version
  * Remove backwards compatibility for no-tty mode.  Addresses
    CVE-2013-4440 (Closes: #725507)
  * Fail hard if /dev/urandom and /dev/random are not available.
    Addresses CVE-2013-4442 and Launchpad #1183213 (Closes: #767008)
  * Fix pwgen -B so that it doesn't accidentally generate passwords with
    ambiguous characters after changing the case of some letters.
    Addresses Launchpad Bugs #638418 and #1349863
  * Fix potential portability bug on architectures where unsgined ints
    are not 4 bytes long
  * Update Debian policy compliance to 3.9.6.0
  * Build with Debian hardening using dpkg-buildflags

 -- Theodore Y. Ts'o <email address hidden>  Mon, 27 Oct 2014 23:30:52 -0400

Upload details

Uploaded by:
Theodore Ts'o on 2014-10-28
Uploaded to:
Sid
Original maintainer:
Theodore Ts'o
Architectures:
any
Section:
admin
Urgency:
Very Urgent

See full publishing history Publishing

Series Pocket Published Component Section
Jessie release on 2014-10-30 main admin

Builds

Downloads

File Size SHA-256 Checksum
pwgen_2.07-1.dsc 1.6 KiB 4994f1bd2d7165e8d4258fceec92e421765284909d3ec795673697d44278f2c0
pwgen_2.07.orig.tar.gz 52.3 KiB eb74593f58296c21c71cd07933e070492e9222b79cedf81d1a02ce09c0e11556
pwgen_2.07-1.debian.tar.xz 5.1 KiB 86226155068172fdbfb7d90a303f3eeeee94612c46a2d80521b1474dafeb7e46

No changes file available.

Binary packages built by this source