qemu 1:2.8+dfsg-3 source package in Debian

Changelog

qemu (1:2.8+dfsg-3) unstable; urgency=high

  * urgency high due to security fixes

  [ Michael Tokarev ]
  * serial-fix-memory-leak-in-serial-exit-CVE-2017-5579.patch
    Closes: #853002, CVE-2017-5579
  * cirrus-ignore-source-pitch-as-needed-in-blit_is_unsafe.patch
    (needed for the next patch, CVE-2017-2620 fix)
  * cirrus-add-blit_is_unsafe-to-cirrus_bitblt_cputovideo-CVE-2017-2620.patch
    Closes: #855791, CVE-2017-2620
  * nbd_client-fix-drop_sync-CVE-2017-2630.diff
    Closes: #855227, CVE-2017-2630
  * sd-sdhci-check-transfer-mode-register-in-multi-block-CVE-2017-5987.patch
    Closes: #855159, CVE-2017-5987
  * vmxnet3-fix-memory-corruption-on-vlan-header-stripping-CVE-2017-6058.patch
    Closes: #855616, CVE-2017-6058
  * 3 CVE fixes from upstream for #853996:
    sd-sdhci-check-data-length-during-dma_memory_read-CVE-2017-5667.patch
    megasas-fix-guest-triggered-memory-leak-CVE-2017-5856.patch
    virtio-gpu-fix-resource-leak-in-virgl_cmd_resource-CVE-2017-5857.patch
    Closes: #853996, CVE-2017-5667, CVE-2017-5856, CVE-2017-5857
  * usb-ccid-check-ccid-apdu-length-CVE-2017-5898.patch
    Closes: #854729, CVE-2017-5898
  * virtio-crypto-fix-possible-integer-and-heap-overflow-CVE-2017-5931.patch
    Closes: #854730, CVE-2017-5931
  * xhci-apply-limits-to-loops-CVE-2017-5973.patch
    Closes: #855611, CVE-2017-5973
  * net-imx-limit-buffer-descriptor-count-CVE-2016-7907.patch
    Closes: #839986, CVE-2016-7907
  * cirrus-fix-oob-access-issue-CVE-2017-2615.patch
    Closes: #854731, CVE-2017-2615
  * 9pfs-symlink-attack-fixes-CVE-2016-9602.patch
    Closes: #853006
  * vnc-do-not-disconnect-on-EAGAIN.patch
    Closes: #854032
  * xhci-fix-event-queue-IRQ-handling.patch (win7 xhci issue fix)
  * xhci-only-free-completed-transfers.patch
    Closes: #855659
  * char-fix-ctrl-a-b-not-working.patch
    Closes: https://bugs.launchpad.net/bugs/1654137
  * char-drop-data-written-to-a-disconnected-pty.patch
    Closes: https://bugs.launchpad.net/bugs/1667033
  * s390x-use-qemu-cpu-model-in-user-mode.patch
    Closes: #854893
  * d/control is autogenerated, add comment
  * check if debootstrap is available in qemu-debootstrap
    Closes: #846497

  [ Christian Ehrhardt ]
  * (ubuntu) no more skip enable libiscsi (now in main)
  * (ubuntu) Disable glusterfs (Universe dependency)
  * (ubuntu) have qemu-system-arm suggest: qemu-efi;
    this should be a stronger relationship, but qemu-efi is still
    in universe right now.
  * (ubuntu) change dependencies for fix of wrong acl for newly
    created device node on ubuntu

 -- Michael Tokarev <email address hidden>  Tue, 28 Feb 2017 11:40:18 +0300

Upload details

Uploaded by:
Debian QEMU Team on 2017-03-01
Uploaded to:
Sid
Original maintainer:
Debian QEMU Team
Architectures:
any
Section:
otherosfs
Urgency:
Very Urgent

See full publishing history Publishing

Series Pocket Published Component Section

Builds

Downloads

File Size SHA-256 Checksum
qemu_2.8+dfsg-3.dsc 5.4 KiB c59ce113cac6a8579d9c7c56b6ab47ae2412c3847262bee4a81804fff184c3b3
qemu_2.8+dfsg.orig.tar.xz 6.7 MiB 780abde8ee1f3847bf96b2ae2515ba68bda20734ece3d1017ca6128b3b2a97a6
qemu_2.8+dfsg-3.debian.tar.xz 90.4 KiB 3ac5b4bef0d983b319f3556ea3c5182956f7c99fb5cb4cacf30eca04063aeccd

No changes file available.

Binary packages built by this source