Change log for vlc package in Debian

175 of 180 results
Published in buster-release on 2019-01-13
Published in sid-release on 2019-01-10
vlc (3.0.6-1) unstable; urgency=medium

  * New upstream release.

 -- Sebastian Ramacher <email address hidden>  Thu, 10 Jan 2019 20:03:32 +0100
Superseded in sid-release on 2019-01-11
vlc (3.0.5-2) unstable; urgency=medium

  * debian/control: Bump libbluray-dev to >= 1.0.0.
  * debian/: Bump debhelper compat to 12.
  * debian/copyright: Remove paragraphs for no longer existing files.

 -- Sebastian Ramacher <email address hidden>  Fri, 04 Jan 2019 18:08:58 +0100

Available diffs

Superseded in buster-release on 2019-01-13
Superseded in sid-release on 2019-01-05
vlc (3.0.5-1) unstable; urgency=medium

  [ Mateusz Łukasik ]
  * New upstream release:
    - Remove patches included upstream.

  [ Sebastian Ramacher ]
  * debian/control: Bump Standards-Version.
  * debian/vlc-plugin-base.install: Install 10-bit x264 plugin.

 -- Sebastian Ramacher <email address hidden>  Thu, 27 Dec 2018 19:11:50 +0100

Available diffs

Superseded in buster-release on 2018-12-30
Superseded in sid-release on 2018-12-28
vlc (3.0.4-4) unstable; urgency=medium

  * debian/patches: Apply upstream patch to fix integer underflow
    (CVE-2018-19857). (Closes: #915760)

 -- Sebastian Ramacher <email address hidden>  Sun, 09 Dec 2018 21:02:57 +0100
Published in stretch-release on 2018-11-10
vlc (3.0.3-1-0+deb9u1) stretch-security; urgency=high

  * New upstream bug fix release.
    - mkv: Fix NULL pointer access. (CVE-2018-11529)
    - Fix buffer over-read in avcodec audio encoding with non-default layouts.
  * debian/control: Force libvlc5 to be upgraded. (Closes: #900979)

 -- Sebastian Ramacher <email address hidden>  Wed, 18 Jul 2018 13:55:20 +0200
Superseded in buster-release on 2018-12-16
Superseded in sid-release on 2018-12-10
vlc (3.0.4-3) unstable; urgency=medium

  * debian/patches: Add support for libplacebo 0.6.

 -- Sebastian Ramacher <email address hidden>  Thu, 11 Oct 2018 18:53:22 +0200
Superseded in buster-release on 2018-10-25
Superseded in sid-release on 2018-11-01
vlc (3.0.4-2) unstable; urgency=medium

  * debian/: Build AOM plugin.

 -- Sebastian Ramacher <email address hidden>  Thu, 20 Sep 2018 20:08:29 +0200

Available diffs

Superseded in buster-release on 2018-09-26
Superseded in sid-release on 2018-09-21
vlc (3.0.4-1) unstable; urgency=medium

  * New upstream release.
    - Fix OpenGL output for single plane devices. (LP: #1774119)
    - Decode AV1 streams. (LP: #1789715)
  * debian/patches: Drop patches merged upstream.

 -- Sebastian Ramacher <email address hidden>  Fri, 31 Aug 2018 19:35:02 +0200
Superseded in sid-release on 2018-09-01
vlc (3.0.3-1-4) unstable; urgency=medium

  * Bump Standards-Version
  * debian/patches: Apply upstream patch for x264 155 support.

 -- Sebastian Ramacher <email address hidden>  Thu, 30 Aug 2018 23:03:27 +0200
Superseded in buster-release on 2018-09-03
Superseded in sid-release on 2018-08-31
vlc (3.0.3-1-3) unstable; urgency=medium

  * debian/: Enable libspatialaudio.
  * debian/control: Bump Standards-Version.

 -- Sebastian Ramacher <email address hidden>  Sat, 04 Aug 2018 18:26:19 +0200

Available diffs

Superseded in buster-release on 2018-08-14
Superseded in sid-release on 2018-08-08
vlc (3.0.3-1-2) unstable; urgency=medium

  * debian/patches: Apply upstream patch to fix build with Qt 5.11.

 -- Sebastian Ramacher <email address hidden>  Thu, 19 Jul 2018 19:08:55 +0200

Available diffs

Superseded in sid-release on 2018-07-20
vlc (3.0.3-1-1) unstable; urgency=high

  * New upstream version.
    - mkv: Fix NULL pointer access. (CVE-2018-11529)
  * debian/bug-presubj: No longer include -f.
  * debian/bug-control: Remove Submit-As.
  * debian/patches: Backport upstream patch for fribidi 1.0.x.

 -- Sebastian Ramacher <email address hidden>  Wed, 18 Jul 2018 13:44:16 +0200

Available diffs

Superseded in stretch-release on 2018-11-10
vlc (3.0.2-0+deb9u1) stretch-security; urgency=high

  * New upstream release following the LTS release branch.
    - Install vlc_interface.h. (Closes: #768808)
    - Fix stuttering with ALSA output. (Closes: #734100)
    - Fix CRC errors in some FLAC files. (Closes: #772503)
    - Add support for Wayland. (Closes: #857769)
    - Better support for HLS. (Closes: #792647)
    - Update VLSub. (Closes: #868236)
    - Fix issues with green borders. (Closes: #765969)
  * Remove embedded copy of ffmpeg.
  * debian/: Adapt to vlc 3.0 packaging:
    - Drop ffmpeg build dependencies.
    - Remove unused build dependencies: libcdio-dev, libdirectfb-dev,
      libgles1-mesa-dev.
    - Add new build dependencies: bison, flex, libarchive-dev,
      libharfbuzz-dev, libmicrodns-dev, libmpg123-dev, libnfs-dev,
      libprotobuf-dev, libqt5svg5-dev, libsecret-1-dev, libsoxr-dev,
      libsystemd-dev, protobuf-compiler, wayland-protocols.
    - Drop vlc-plugin-sdl.
    - Turn vlc-plugin-zvbi into a transitional package.
    - Update Breaks+Replaces versions.
    - Remove patches integrated upstream.
    - Update copyright information.
    - Add new symbols.
    - Enable all hardening options.
    - Update configure flags for 3.0.
    - Update install files for new and removed plugins.

 -- Sebastian Ramacher <email address hidden>  Thu, 03 May 2018 20:55:01 +0200
Superseded in buster-release on 2018-07-24
Superseded in sid-release on 2018-07-20
vlc (3.0.3-2) unstable; urgency=medium

  * debian/patches: Fix build on riscv64 (Closes: #901577)

 -- Sebastian Ramacher <email address hidden>  Sat, 30 Jun 2018 10:01:23 +0200
Superseded in buster-release on 2018-07-05
Superseded in sid-release on 2018-07-08
vlc (3.0.3-1) unstable; urgency=medium

  * New upstream release.

 -- Sebastian Ramacher <email address hidden>  Mon, 28 May 2018 23:51:35 +0200
Superseded in buster-release on 2018-05-31
Superseded in sid-release on 2018-05-30
vlc (3.0.2-1) unstable; urgency=medium

  [ Felipe Sateler ]
  * Change maintainer address to <email address hidden>

  [ Sebastian Ramacher ]
  * New upstream version.
  * debian/rules: Install correct changelog.
  * debian/control: Bump Standards-Version.
  * debian/patches: Remove patched included upstream.

 -- Sebastian Ramacher <email address hidden>  Tue, 24 Apr 2018 16:52:12 +0200
Superseded in buster-release on 2018-05-04
Superseded in sid-release on 2018-04-25
vlc (3.0.1-3) unstable; urgency=medium

  * debian/control: Re-add some Breaks+Replaces to help Ubuntu reduce the diff
    and be able to handle upgrades from 16.04 to 18.04. (LP: #1753111,
    #1749916)
  * debian/rules:
    - Re-enable Chromecast plugin on Ubuntu. Apparently it works now.
    - Fix typo to really build with all hardening options enabled.

 -- Sebastian Ramacher <email address hidden>  Sun, 11 Mar 2018 21:52:05 +0100
Superseded in buster-release on 2018-03-17
Superseded in sid-release on 2018-03-12
vlc (3.0.1-2) unstable; urgency=medium

  * debian/patch: Add missing files for arm64.

 -- Sebastian Ramacher <email address hidden>  Fri, 02 Mar 2018 16:28:28 +0100
Superseded in sid-release on 2018-03-03
vlc (3.0.1-1) unstable; urgency=medium

  * New upstream release.
  * debian/control: Bump libplacebo-dev B-D to 0.2.1 (required by upstream).

 -- Sebastian Ramacher <email address hidden>  Thu, 01 Mar 2018 11:32:12 +0100
Superseded in buster-release on 2018-03-08
Superseded in sid-release on 2018-03-02
vlc (3.0.0-1) unstable; urgency=medium

  * New upstream release.
  * debian/*.symbols:
    - Bump all newly introduced symbols to version 3.0.0.
    - Add new symbols.

 -- Sebastian Ramacher <email address hidden>  Fri, 09 Feb 2018 16:40:34 +0100
Superseded in buster-release on 2018-02-15
Superseded in sid-release on 2018-02-10
vlc (3.0.0~rc8-1) unstable; urgency=medium

  * New upstream release candidate.

 -- Sebastian Ramacher <email address hidden>  Thu, 01 Feb 2018 20:00:43 +0100
Superseded in buster-release on 2018-02-07
Superseded in sid-release on 2018-02-02
vlc (3.0.0~rc7-2) unstable; urgency=medium

  * debian/: Disable freerdp plugin. freerdp2 is currently not supported.
    (Closes: #888323)

 -- Sebastian Ramacher <email address hidden>  Thu, 25 Jan 2018 00:15:17 +0100
Superseded in sid-release on 2018-01-25
vlc (3.0.0~rc7-1) unstable; urgency=medium

  * New upstream release candidate.

 -- Sebastian Ramacher <email address hidden>  Wed, 24 Jan 2018 22:34:33 +0100
Superseded in buster-release on 2018-01-30
Superseded in sid-release on 2018-01-26
vlc (3.0.0~rc6-1) unstable; urgency=medium

  [ Helmut Grohne ]
  * debian/control: Annotate Build-Depends: python3 with :native. (Closes:
    #887440)

  [ Sebastian Ramacher ]
  * New upstream release candidate.
  * debian/rules:
    - Handle vendor consistently.
    - Remove workaround for some resources.
  * debian/vlc-plugin-base.install: Install lua byte code.
  * debian/libvlc-bin.postinst.in: Exit early if plugins directory does not
    exist. (Closes: #887621)

 -- Sebastian Ramacher <email address hidden>  Thu, 18 Jan 2018 22:31:56 +0100
Superseded in buster-release on 2018-01-24
Superseded in sid-release on 2018-01-19
vlc (3.0.0~rc5-1) unstable; urgency=medium

  * New upstream release candidate.
    - Fix crash in full-screen mode. (LP: #1740078)
  * debian/copyright: Update copyright years.
  * debian/patches: Removed, included upstream.
  - debian/control: Demote vlc-l10n from Depends to Recommends.

 -- Sebastian Ramacher <email address hidden>  Thu, 11 Jan 2018 19:41:02 +0100
Superseded in buster-release on 2018-01-17
Superseded in sid-release on 2018-01-12
vlc (3.0.0~rc4-3) unstable; urgency=medium

  * debian/control:
    - Move to salsa.debian.org
    - Remove obsolete Pre-Depends.
  * debian/NEWS: Remove old NEWS from pre 2.x.
  * debian/:
    - Move documentation to /usr/share/doc/$mainpkg as recommended by policy.
    - Bump debhelper compat to 11.
  * debian/copyright: Bump copyright years.

 -- Sebastian Ramacher <email address hidden>  Sat, 06 Jan 2018 14:17:42 +0100
Superseded in sid-release on 2018-01-06
vlc (3.0.0~rc4-2) unstable; urgency=medium

  * debian/control: Add Breaks on phonon-backend-vlc to ensure proper
    upgrades.
  * debian/rules: Do not build chromecast plugin on Ubuntu. It fails due to
    issues involving Mir and protobuf.
  * debian/: Enable libplacebo.

 -- Sebastian Ramacher <email address hidden>  Fri, 05 Jan 2018 09:51:06 +0100
Superseded in sid-release on 2018-01-07
vlc (3.0.0~rc4-1) unstable; urgency=medium

  * New upstream release candidate.
  * debian/control: Bump Standards-Version.

 -- Sebastian Ramacher <email address hidden>  Sat, 30 Dec 2017 18:56:14 +0100
Superseded in buster-release on 2018-01-12
Superseded in sid-release on 2018-01-01
vlc (3.0.0~rc2-2) unstable; urgency=medium

  * debian/*.maintscript: Fix symlink to directory conversions.

 -- Sebastian Ramacher <email address hidden>  Wed, 20 Dec 2017 21:48:00 +0100
Superseded in sid-release on 2017-12-21
vlc (3.0.0~rc2-1) unstable; urgency=medium

  * Upload to unstable.
  * New upstream release candidate.
  * debian/tests/control: Update list of plugin packages.
  * debian/patches: Removed, no longer needed.
  * debian/vlc-plugin-access-extra.install: Drop no longer built plugin.
  * debian/*.symbols: Add new symbols and bump versions of new symbols to
    3.0.0~rc2.

 -- Sebastian Ramacher <email address hidden>  Tue, 19 Dec 2017 23:34:22 +0100
Deleted in experimental-release (Reason: None provided.)
vlc (3.0.0~rc1-1) experimental; urgency=medium

  * New upstream release candidate.
  * debian/control: Move Breaks+Replaces to correct package. (Closes: #884063)
  * debian/:
    - Mark more plugins only built on linux-any.
    - Switch libnotify plugin to GTK+ 3.

 -- Sebastian Ramacher <email address hidden>  Mon, 11 Dec 2017 21:46:02 +0100

Available diffs

Superseded in experimental-release on 2017-12-12
vlc (3.0.0~rc1~20171210-2) experimental; urgency=medium

  * debian/rules: Ensure tighter dependencies on libraries.
  * debian/: Build wayland plugins only on linux-any.

 -- Sebastian Ramacher <email address hidden>  Sun, 10 Dec 2017 19:17:48 +0100
Superseded in experimental-release on 2017-12-11
vlc (3.0.0~rc1~20171210-1) experimental; urgency=medium

  * New upstream snapshot.
  * debian/: Install nfs plugin only on linux-any.
  * debian/*.symbols: Add new symbols.

 -- Sebastian Ramacher <email address hidden>  Sun, 10 Dec 2017 13:11:23 +0100
Superseded in experimental-release on 2017-12-10
vlc (3.0.0~rc1~20171206-1) experimental; urgency=medium

  * New upstream snapshot.
    - Install vlc_interface.h. (Closes: #768808)
    - Fix stuttering with ALSA output. (Closes: #734100) (LP: #1639479)
    - Fix CRC errors in some FLAC files. (Closes: #772503)
    - Add support for Wayland. (Closes: #857769) (LP: #1720901)
    - Better support for HLS. (Closes: #792647)
    - Update VLSub. (Closes: #868236)
    - Re-write UPnP discovery. (LP: #977277, #1318262)
    - Complete porting to Qt 5. (LP: #1576175)
    - Fix issues with green borders. (Closes: #765969) (LP: #1405166)
  * Remove embedded ffmpeg copy. (LP: #1546078)
  * SONAME bump: libvlccore8 -> libvlccore9.
  * debian/patches: Drop all patches.
  * debian/libvlc-bin.postinst.in: Skip plugin cache generation if no plugins
    are installed. (Closes: #878026)
  * debian/:
    - Drop vlc-plugin-zvbi package and merge into vlc-plugin-base. ffmpeg
      already depends on libzvbi anyway.
    - Update installed plugins.
    - Track plugin ABI.
  * debian/copyright:
    - Convert to CF 1.0.
    - Update copyright information.
  * debian/control:
    - Bump Standards-Versios.
    - Set Rules-Requires-Root: no.
    - Remove vlc-plugin-sdl.
    - Turn vlc-plugin-zvbi into a transitional package.
    - New Build-Depends: bison, flex, libarchive-dev, libaribb24-dev,
      libharfbuzz-dev, libmicrodns-dev, libmpg123-dev, libnfs-dev,
      libprotobuf-dev, libqt5svg5-dev, libsecret-1-dev, libsoxr-dev,
      libsystemd-dev, protobuf-compiler, qtbase5-prive-dev, wayland-protocols.
    - Removed Build-Depends: libcdio-dev.
  * debian/*.symbols: Add new symbols.

 -- Sebastian Ramacher <email address hidden>  Thu, 07 Dec 2017 00:23:24 +0100
Published in jessie-release on 2017-12-09
vlc (2.2.7-1~deb8u1) jessie-security; urgency=high

  * New upstream release.
    - Fix crash in libavcodec module (heap write out-of band). (CVE-2017-10699)
    - Fix flac heap write overflow on format change. (CVE-2017-9300)
    - Fix AVI read/write overflow.

 -- Sebastian Ramacher <email address hidden>  Sun, 19 Nov 2017 16:28:34 +0100
Superseded in stretch-release on 2018-07-14
vlc (2.2.7-1~deb9u1) stretch-security; urgency=high

  * New upstream release.
    - Fix crash in libavcodec module (heap write out-of band). (CVE-2017-10699)
    - Fix flac heap write overflow on format change. (CVE-2017-9300)
    - Fix AVI read/write overflow.
  * Update ffmpeg to 2.8.13.
  * debian/{control,*.maintscript}: Bump versions to ensure proper upgrades
    from jessie.

 -- Sebastian Ramacher <email address hidden>  Sun, 19 Nov 2017 16:17:52 +0100
Superseded in buster-release on 2017-12-27
Superseded in sid-release on 2018-01-10
vlc (2.2.8-2) unstable; urgency=medium

  * debian/patches: Apply upstream patch to fix build with libupnp-dev
    1.6.24-1.

 -- Sebastian Ramacher <email address hidden>  Wed, 06 Dec 2017 21:42:58 +0100
Superseded in buster-release on 2017-12-12
Superseded in sid-release on 2017-12-07
vlc (2.2.8-1) unstable; urgency=medium

  * New upstream release.

 -- Mateusz Łukasik <email address hidden>  Thu, 23 Nov 2017 22:19:07 +0100

Available diffs

Superseded in buster-release on 2017-12-04
Superseded in sid-release on 2017-11-24
vlc (2.2.7-1) unstable; urgency=high

  * New upstream release.
    - Fix AVI read/write overflow.
  * debian/control: Bump Standards-Version.
  * debian/patches: Remove patches included upstream.

 -- Sebastian Ramacher <email address hidden>  Sun, 19 Nov 2017 14:05:04 +0100
Superseded in buster-release on 2017-11-21
Published in sid-release on 2017-09-05
vlc (2.2.6-6) unstable; urgency=medium

  * Update to ffmpeg 2.8.13.

 -- Sebastian Ramacher <email address hidden>  Tue, 05 Sep 2017 19:37:57 +0200
Superseded in buster-release on 2017-09-11
Superseded in sid-release on 2017-09-06
vlc (2.2.6-5) unstable; urgency=medium

  * debian/control: Bump Standards-Version.
  * debian/patches: Add support for libupnp 1.8. (Closes: #868936)

 -- Sebastian Ramacher <email address hidden>  Wed, 30 Aug 2017 20:57:06 +0200
Superseded in buster-release on 2017-09-05
Superseded in sid-release on 2017-09-01
vlc (2.2.6-4) unstable; urgency=medium

  * debian/upstream: Add DEP-12 metadata.
  * debian/control:
    - Restrict Recommends on vlc-plugin-samba to linux-any kfreebsd-any.
    - Switch to timgm6mb-soundfont. (Closes: #870790)
    - Bump Standards-Version.
  * debian/{rules,control,vlc-plugin-base}: No longer build directfb plugin.
    directfb upstream is inactive and the plugin got removed for vlc 3.0.
  * debian/vlc-plugin-base.lintian-overrides: Override
    shlibs-with-non-pic-code. See lintian overrides of ffmpeg for more
    details.

 -- Sebastian Ramacher <email address hidden>  Sat, 12 Aug 2017 12:56:58 +0200
Superseded in jessie-release on 2017-12-09
vlc (2.2.6-1~deb8u1) jessie-security; urgency=high

  * New upstream release.
    - subtitle: Fix heap buffer overflows (CVE-2017-8312).
    - subtitle: Fix invalid double increment (CVE-2017-8311).
    - flac: Fix potential out-of-band dereference.
    - mpeg: Fix potential out-of-band reads.
    - subtitle: Fix infinite loop.
    - ogg: Fix incorrect memory free.
    - subtitle: Fix potential out-of-band reads (CVE-2017-8310, CVE-2017-8313).

 -- Sebastian Ramacher <email address hidden>  Thu, 25 May 2017 11:57:56 +0200
Superseded in buster-release on 2017-08-30
Superseded in sid-release on 2017-08-15
vlc (2.2.6-3) unstable; urgency=medium

  [ Mateusz Łukasik ]
  * debian/patches: avcodec: Check visible sizes (CVE-2017-10699).

  [ Sebastian Ramacher ]
  * debian/patches: flac: Fix heap write overflow on frame format change.
    (CVE-2017-9300)

 -- Sebastian Ramacher <email address hidden>  Tue, 11 Jul 2017 21:35:32 +0200
Superseded in sid-release on 2017-07-14
vlc (2.2.6-2) unstable; urgency=medium

  * Upload to unstable.
  * Update to ffmpeg 2.8.12.
  * debian/control:
    - Remove Build-Conflicts.
    - Bump Standards-Version.
  * debian/rules: Build with hardening=+all.

 -- Sebastian Ramacher <email address hidden>  Sun, 18 Jun 2017 18:15:34 +0200

Available diffs

Superseded in stretch-release on 2017-12-09
Superseded in sid-release on 2017-06-22
vlc (2.2.6-1~deb9u1) unstable; urgency=high

  * New upstream release.
    - demux: Fix heap buffer overflows (CVE-2017-8312)
  * debian/*.maintscript: Bump all versions to 2.2.6-1~z. This is necessary to
    properly handle symlink to directory conversions once 2.2.6 is available
    in jessie.
  * debian/control: Bump Breaks + Replaces to 2.2.6-1~deb9u1 where necessary
    to ensure proper upgrades from jessie.

 -- Sebastian Ramacher <email address hidden>  Wed, 24 May 2017 18:00:59 +0200
Deleted in experimental-release (Reason: None provided.)
vlc (2.2.6-1) experimental; urgency=medium

  * New upstream release.
    - demuxer: Fix heap buffer overflows (CVE-2017-8312).

 -- Sebastian Ramacher <email address hidden>  Wed, 24 May 2017 17:35:55 +0200

Available diffs

Superseded in sid-release on 2017-05-25
vlc (2.2.5.1-1~deb9u2) unstable; urgency=medium

  * debian/control:
    - Bump Breaks + Replaces to 2.2.5.1-1~deb9u1 also in vlc-plugin-qt and
      vlc-plugin-skins2. Files moved from vlc to those two packages since
      jessie.
    - Remove Breaks + Replaces from libvlc-bin. While files moved from vlc-nox
      to libvlc-bin, they also changed their path.

 -- Sebastian Ramacher <email address hidden>  Sat, 20 May 2017 10:41:05 +0200
Superseded in stretch-release on 2017-05-27
Superseded in sid-release on 2017-05-20
vlc (2.2.5.1-1~deb9u1) unstable; urgency=medium

  * New upstream release.
  * debian/patches/fix-translation.patch: Refreshed.
  * debian/*.maintscript: Bump all versions to 2.2.5.1-1~z. This is necessary
    to properly handle symlink to directory conversions once 2.2.5.1 is
    available in jessie.
  * debian/control: Bump Breaks + Replaces to 2.2.5.1-1~deb9u1 where necessary
    to ensure proper upgrades from jessie. (Closes: #862474)

 -- Sebastian Ramacher <email address hidden>  Sat, 13 May 2017 15:24:45 +0200
Superseded in experimental-release on 2017-05-24
vlc (2.2.5.1-1) experimental; urgency=medium

  [ Mateusz Łukasik ]
  * New upstream release.

  [ Sebastian Ramacher ]
  * debian/patches: Refreshed.

 -- Sebastian Ramacher <email address hidden>  Sat, 13 May 2017 15:04:10 +0200
Superseded in jessie-release on 2017-07-22
vlc (2.2.5-1~deb8u1) jessie; urgency=medium

  * New upstream release.
    - adpcm: Fix heap corruption.
    - dvd: Fix heap corruption.
    - asf: Fix integer overflow.
    - mp4: Fix divide-by-zero error and heap buffer overflow.
    - flac: Fix integer overflow and NULL pointer dereference.
    - ftp: Fix scan string injection.
    - voc: Fix divide-by-zero error.
    - xa: Fix divide-by-zero error.
    - smf: Fix divide-by-zero error.
    - nsvf: Fix infinite loop.
    - aiff: Fix infinite loop.

 -- Sebastian Ramacher <email address hidden>  Fri, 07 Apr 2017 19:32:28 +0200
Superseded in experimental-release on 2017-05-15
vlc (2.2.5-4) experimental; urgency=medium

  * debian/rules: Revert "Also enable NEON on arm64". (LP: #1685444)

 -- Sebastian Ramacher <email address hidden>  Sun, 23 Apr 2017 15:52:57 +0200
Superseded in experimental-release on 2017-05-14
vlc (2.2.5-3) experimental; urgency=medium

  * Fix typos in changelog.
  * debian/rules: Also enable NEON on arm64.
  * debian/control: Build-Conflict with Qt in experimental to work around
    #858762.
  * debian/patches:
    - Use gbp-pq for patch management.
    - Apply upstream patch for WebVTT support. (Closes: #858963)

 -- Sebastian Ramacher <email address hidden>  Fri, 07 Apr 2017 19:01:02 +0200

Available diffs

Superseded in experimental-release on 2017-04-23
vlc (2.2.5-2) experimental; urgency=medium

  [ Mateusz Łukasik ]
  * debian/{control,rules,vlc-plugin-video-output.install}: Disable OpenGL
    ES 1 support, mesa has dropped it. (Closes: #855117)

  [ Sebastian Ramacher ]
  * debian/: Major package clean up.
    - Remove vlc-nox binary package.
    - Update tests to new package layout.
    - Remove obsolete Breaks+Replaces.
  * debian/rules: Be explicit about GLES 1
  * debian/{rules,libvlc-bin.*}: Fix warning from about non-empty directory
    (Closes: #854928)

 -- Sebastian Ramacher <email address hidden>  Thu, 23 Mar 2017 17:56:16 +0100
Superseded in stretch-release on 2017-05-19
Superseded in sid-release on 2017-05-15
vlc (2.2.5-1) unstable; urgency=medium

  * New upstream releases. (Closes: #850529)
  * debian/patches:
    - fix-translation.patch: Refreshed.
    - Removed patches taken from upstream included in 2.2.5.
  * debian/*.maintscript: Bump all versions to 2.2.5-1~z. This is necessary to
    properly handle symlink to directory conversions once 2.2.5 is available
    in stretch.

 -- Sebastian Ramacher <email address hidden>  Sun, 19 Mar 2017 21:50:23 +0100
Superseded in stretch-release on 2017-04-05
Superseded in sid-release on 2017-04-13
vlc (2.2.4-14) unstable; urgency=medium

  [ Mateusz Łukasik ]
  * Update to ffmpeg 2.8.11.

 -- Sebastian Ramacher <email address hidden>  Tue, 14 Feb 2017 20:17:50 +0100
Superseded in stretch-release on 2017-02-27
Superseded in sid-release on 2017-02-15
vlc (2.2.4-13) unstable; urgency=medium

  * debian/control: Switch to libopenmpt's libmodplug comat layer.

 -- Sebastian Ramacher <email address hidden>  Wed, 11 Jan 2017 19:50:54 +0100

Available diffs

Superseded in sid-release on 2017-01-12
vlc (2.2.4-12) unstable; urgency=medium

  * Update to ffmpeg 2.8.10.

 -- Sebastian Ramacher <email address hidden>  Tue, 03 Jan 2017 21:11:29 +0100

Available diffs

Superseded in stretch-release on 2017-01-23
Superseded in sid-release on 2017-01-04
vlc (2.2.4-11) unstable; urgency=medium

  * debian/patches: Apply upstream to fix VLSub incorrectly announcing HTTP
    1.1 support. (Closes: #847559)
  * debian/control: Make vlc-plugin-skins2 depend on vlc-plugin-qt.

 -- Sebastian Ramacher <email address hidden>  Sun, 18 Dec 2016 21:29:12 +0100

Available diffs

Superseded in stretch-release on 2016-12-29
Superseded in sid-release on 2016-12-19
vlc (2.2.4-10) unstable; urgency=medium

  * debian/{control,*.links,*.install}: Move qvlc and svlc binaries to
    vlc-plugin-qt and vlc-plugin-skins2. Also add vlc-bin to Recommends.
    (Closes: #841530)
  * Update to ffmpeg 2.8.9.

 -- Sebastian Ramacher <email address hidden>  Sun, 04 Dec 2016 15:12:16 +0100

Available diffs

Superseded in stretch-release on 2016-12-15
Superseded in sid-release on 2016-12-05
vlc (2.2.4-9) unstable; urgency=medium

  * debian/control: Drop dh_buildinfo. This is now automatically recorded by
    dpkg.
  * debian/bug-control: Update list of packages.
  * debian/{control,rules,vlc-plugin-base.install}: Remove libschroedinger
    plugin since the library is about to be removed. See #845037 for details.

 -- Sebastian Ramacher <email address hidden>  Tue, 22 Nov 2016 00:16:46 +0100

Available diffs

Superseded in stretch-release on 2016-11-27
Superseded in sid-release on 2016-11-22
vlc (2.2.4-8) unstable; urgency=medium

  * debian/NEWS: Remove NEWS entry on package split. On upgrade, new
    Recommends are installed by apt anyway.
  * debian/control:
    - Switch from liblircclient-dev to liblirc-dev.
    - Remove shlibs:Depends from vlc's Depends.
  * debian/rules: Add --disable-neon when building with noopt.
  * debian/patches:
    - drop-check-qt-check.patch: Remove obsolete patches.
    - multiple: Add upstream patches to generate default skins2 skin
      reproducibly. (Closes: #841525)

 -- Sebastian Ramacher <email address hidden>  Tue, 01 Nov 2016 13:34:46 +0100

Available diffs

Superseded in stretch-release on 2016-11-18
Superseded in sid-release on 2017-01-05
vlc (2.2.4-7) unstable; urgency=medium

  * Split plugins and binaries into different packages. (Closes: #513177)
    - libvlc-bin: constains vlc-cache-gen and triggers plugin cache
      generation.
    - vlc-bin: the VLC binaries.
    - vlc-plugin-base: "base" set of plugins.
    - vlc-plugin-qt: the Qt interface.
    - vlc-plugin-skins2: the Skins2 interface.
    - vlc-plugin-access-extra: extra access plugins.
    - vlc-plugin-visualization: visualization plugins.
    - vlc-plugin-video-splitter: video splitter plugins.
    - vlc-plugin-video-output: video output plugins.
    - vlc-l10n: translations.
    - vlc: contains desktop integration and pulls in most plugins as before.
    - vlc-nox: transitional dummy package
  * Move libraries and plugins to multi-arch locations.
    - debian/control:
      + Add M-A: same for library and plugin packages.
      + Remove most Breaks and Replaces as they are now obsolete.
    - debian/rules: Do not override libdir.
    - debian/*.{lintian-overrides,install}: Update paths for M-A locations.

 -- Sebastian Ramacher <email address hidden>  Wed, 19 Oct 2016 17:59:18 +0200
Superseded in stretch-release on 2016-10-26
Superseded in sid-release on 2016-10-21
vlc (2.2.4-6) unstable; urgency=medium

  * debian/*.maintscript: Bump all versions to fix symlink-to-directory
    conversions. (Closes: #814646)

 -- Sebastian Ramacher <email address hidden>  Fri, 23 Sep 2016 21:08:42 +0200
Superseded in sid-release on 2016-09-24
vlc (2.2.4-5) unstable; urgency=medium

  * Update ffmpeg to 2.8.8.

 -- Sebastian Ramacher <email address hidden>  Wed, 21 Sep 2016 20:29:03 +0200
Superseded in jessie-release on 2017-05-07
vlc (2.2.4-1~deb8u1) jessie-security; urgency=medium

  * New upstream release.
    - quicktime: Reject invalid IMA files (CVE-2016-5108). (Closes: #825728)
    - pulse: Compute latency correctly if negative, fixing missing audio on
      high network latency. (Closes: #784640)
    - alsa: Fix audio device selection. (Closes: #801448)
    - hls: Fix hang on stop, crashes and stack overflow.
    - mkv: Fix infinite loop.
    - vpx: Fix crash.
    - mxf: Fix crash on stop.
    - adpcm: Fix double-free.
    - zvbi: Fix crash.
    - skins2: Fix crash on malformed skin bitmaps.
    - swscale: Fix crashes in swscale resizing.
    - mp4: Fix divide-by-zero crash in mux.
    - rtsp: Fix off-by-one buffer overflow.
    - mms: Fix segmentation fault on large allocation, fix overflows.
    - lua: Fix use-after-free.
    - httplive: Fix stack overflow.
    - avformat: Fix heap overflow, NULL dereference and double-free.
    - avcodec: Fix invalid free.
    - sdp: Fix read overflow.
    - vcd: Fix double-free.
    - aout: Fix use-after-free.
    - vout: Fix use-after-free.
    - realrtsp: Fix off-by-one and various crashes.
    - Fix various memory leaks.
    - Fix links to French TV icons. (Closes: #782229)
  * debian/patches/CVE-2015-5949.patch: Removed, included upstream.
  * debian/copyright: Update copyright years.
  * debian/libvlc5.symbols: Bump version of libvlc_event_type_name for new
    event names.

 -- Sebastian Ramacher <email address hidden>  Sun, 05 Jun 2016 17:39:38 +0200
Superseded in stretch-release on 2016-09-29
Superseded in sid-release on 2016-09-22
vlc (2.2.4-4) unstable; urgency=medium

  [ Pino Toscano ]
  * Install solid actions in Frameworks location. (Closes: #834884)

  [ Sebastian Ramacher ]
  * Bump debhelper compat to 10.

 -- Sebastian Ramacher <email address hidden>  Tue, 13 Sep 2016 21:29:23 +0200
Superseded in stretch-release on 2016-09-19
Superseded in sid-release on 2017-05-21
vlc (2.2.4-3) unstable; urgency=medium

  [ Mateusz Łukasik ]
  * debian/control:
    - Remove Clément Stenac from Uploaders. Thanks for your job!

  [ Sebastian Ramacher ]
  * debian/patches/{vlc_atomic*,Fix-build-using-old-GCC-intrinsics}.patch: Fix
    FTBFS with GCC 6 (Closes: #831199)

 -- Sebastian Ramacher <email address hidden>  Fri, 29 Jul 2016 00:52:06 +0200

Available diffs

Superseded in stretch-release on 2016-08-09
Superseded in sid-release on 2016-08-20
vlc (2.2.4-2) unstable; urgency=medium

  * Build ffmpeg without libopenjpeg (Closes: #826827)
    - debian/control: Remove libopenjpeg-dev from B-D.
    - debian/rules: Build ffmpeg with --disable-libopenjpeg.
  * debian/rules: Revert workaround for zsh completion build failures on
    powerpc. The underlying issue seems to be fixed.

 -- Sebastian Ramacher <email address hidden>  Sat, 11 Jun 2016 11:44:37 +0200

Available diffs

Superseded in stretch-release on 2016-06-17
Superseded in sid-release on 2016-06-12
vlc (2.2.4-1) unstable; urgency=medium

  * New upstream release.
  * debian/patches:
    - g711-fix-dangling-pointer-fixes-16909.patch,
      adpcm-reject-invalid-QuickTime-IMA-files.patch, zsh-completion.patch,
      frenchtv-links.patch, fix-Hurd-build.patch,
      the-Hurd-also-uses-the-.so-extension-for-libraries.patch: Removed, all
      included upstream.
    - generated-mimetypes.patch: Upstream patch for auto-generated list of
      mime types. (Closes: #822245)
  * debian/{rules,vlc-nox.install}: No longer install old BluRay access
    plugin. (LP: #864933)
  * debian/rules: No longer disable i686 optimization on i386 architectures.

 -- Sebastian Ramacher <email address hidden>  Sun, 05 Jun 2016 16:08:54 +0200
Superseded in stretch-release on 2016-06-11
Deleted in sid-release (Reason: None provided.)
vlc (2.2.2-6) unstable; urgency=medium

  * Use embedded copy of ffmpeg 2.8.6. (Closes: #803868)
  * debian/rules:
    * Explicitly disable gst-decode.
    * Enable sndio plugin.
    * Drop unnecessary override.
    * Fix noopt handling.
  * debian/vlc{-nox}.install: Filter plugins with a helper script.
  * debian/control: Bump Standards-Version.
  * debian/watch: Update to version 4.

 -- Sebastian Ramacher <email address hidden>  Mon, 18 Apr 2016 01:00:56 +0200
Superseded in stretch-release on 2016-04-23
Superseded in sid-release on 2016-04-19
vlc (2.2.2-5) unstable; urgency=medium

  * debian/patches:
    - qt4-Fix-resume-where-you-left-off.patch,
      qt4-input_manager-Always-reset-lastURI-when-stopping.patch: Apply
      upstream patches to fix issues with "resume playback" feature.
    - avcodec-pass-consistent-dimensions-to-hardware-decod.patch: Apply
      upstream patch to fix hardware decoding with libvdpau-va-gl.
      (Closes: #813370)

 -- Sebastian Ramacher <email address hidden>  Sun, 13 Mar 2016 21:43:11 +0100

Available diffs

Superseded in stretch-release on 2016-03-22
Superseded in sid-release on 2016-04-05
vlc (2.2.2-4) unstable; urgency=medium

  * debian/patches/fix-translation.patch: Fix translation of Shortcuts.
    (Closes: #814258)
  * debian/*.maintscript: Switch from absolute to relative paths to better
    handle symlink chains. (Closes: #814646)

 -- Sebastian Ramacher <email address hidden>  Wed, 17 Feb 2016 20:21:32 +0100
Superseded in stretch-release on 2016-02-23
Superseded in sid-release on 2016-02-19
vlc (2.2.2-3) unstable; urgency=medium

  * debian/*.maintscript: Handle all cases.
  * debian/patches/zsh-completion.patch: Upstream patch to fix zsh completion
    generation.

 -- Sebastian Ramacher <email address hidden>  Thu, 04 Feb 2016 20:53:28 +0100

Available diffs

Superseded in sid-release on 2016-02-09
vlc (2.2.2-2) unstable; urgency=medium

  * debian/*.maintscript: Handle more symlink to directory conversions.
  * debian/rules: Do not fail to build if zsh completion fails to generate.
    This is a temporary workaround for a FTBFS on praetorius.

 -- Sebastian Ramacher <email address hidden>  Wed, 03 Feb 2016 18:37:02 +0100

Available diffs

175 of 180 results