wpa 1.1-1 source package in Debian

Changelog

wpa (1.1-1) unstable; urgency=medium


  * New upstream release:
    - drop 11_wpa_gui_ftbfs_gcc_4_7, applied upstream.
    - drop EAP-TLS-server_fix-TLS-Message-length-validation, applied upstream.
    - fixes:
      - EAP access point constantly roaming with proactive key caching
        (Closes: #711063).
  * enable IBSS RSN, thanks to Nicolas Cavallari <email address hidden>
    (Closes: #678147).
  * enable simple AP support for wpasupplicant, thanks to Patrik Flykt
    <email address hidden> (Closes: #690536).
  * use the readline6, wpa_cli doesn't link to openssl.
  * link with --as-needed.
  * compress binaries with xz.
  * debian/get-orig-source: switch to xz compressed upstream tarballs.
  * debian/get-orig-source: adapt for the post 1.x upstream branch.
  * debian/get-orig-source: support named snapshots, see debian/README.source
    for detailed syntax and semantics.
  * debian/README.source: explain fetching git snapshots by specifying their
    git hash.
  * debian/README.source: update to match current reality and apply grammar
    fixes.
  * debian/README.source: drop trailing whitespace.
  * fix hardening flags, thanks a lot to Florent Daigniere
    <email address hidden> (Closes: #725865).
  * debian/control: fold dependencies.
  * bump standards version to 3.9.5, no changes necessary.
  * reflect reality and adapt the maintainer mail address not to claim
    representing Ubuntu.
  * drop wheezy-specific comments in the configuration files.
  * glob 'wpa-password' as well and hide its debugging output, this hopefully
    closes: #728092.
  * enable EAP-FAST, openssl in Debian is now new enough (Closes: #685685).
  * update to new alioth URIs (vcs-field-not-canonical).
  * add Keywords entry for desktop files (desktop-entry-lacks-keywords-entry).
  * functions.sh: s/particuarly/particularly/, thanks to Vincent Lefevre
    <email address hidden> (Closes: #734422).
  * fix FTBS using gcc-4.8 by linking with -ldl on kfreebsd-any; the udeb
    packages don't provide EAP support and are therefore unaffected. This is
    already accounted for by the upstream Makefile, however wrongly depending
    on !CONFIG_DRIVER_BSD, while it is actually depending on the target libc
    rather than the kernel (Closes: #737465). Thanks to Cyril Brulebois
    <email address hidden> and Steven Chamberlain <email address hidden>.
  * import "hostapd: Fix WDS VLAN bridge handling" by Felix Fietkau
    <email address hidden> from upstream, thanks to Mark Hindley
    <email address hidden> (Closes: #737109).
  * drop build-conflicts with libqt3-dev as the package is no longer available
    >= lenny, thanks to Michael Biebl <email address hidden>.
  * drop pre-dependency on dpkg (>= 1.15.6~), data.tar.xz-member-without-dpkg-
    pre-depends is no longer a problem after Ubuntu lucid is EOL. Thanks to
    Michael Biebl for noticing.
  * drop build-dependency on libdbus-glib-1-dev, it is no longer required for
    dbus-binding-tool, thanks to Michael Biebl.
  * allow parallel building.
  * fix spelling s/algorith/algorithm/.
  * add lintian overrides for false positive spelling complaints.

 -- Stefan Lippers-Hollmann <email address hidden>  Fri, 21 Feb 2014 01:07:28 +0100

Upload details

Uploaded by:
Debian/Ubuntu wpasupplicant Maintainers on 2014-02-21
Uploaded to:
Sid
Original maintainer:
Debian/Ubuntu wpasupplicant Maintainers
Architectures:
linux-any kfreebsd-any
Section:
net
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Builds

Downloads

File Size SHA-256 Checksum
wpa_1.1-1.dsc 2.3 KiB e814e09174bbdc595818f2553928ab18a8a1e2c0d94b427ca70f6c8420a270d2
wpa_1.1.orig.tar.xz 1.3 MiB 01c842c26ec94aae45c26e0755a34d5bb629505610119f63ce971c8dc390ea09
wpa_1.1-1.debian.tar.xz 72.1 KiB df917c6ab87d8829f0d0c4683c6390508ac725bc19721de37357f1557bf65528

No changes file available.

Binary packages built by this source