wpa 2.5-2+v2.4-1 source package in Debian

Changelog

wpa (2.5-2+v2.4-1) unstable; urgency=medium

  [ Ricardo Salveti de Araujo ]
  * debian/patches/dbus-fix-operations-for-p2p-mgmt.patch: fix operations
    when P2P management interface is used (LP: #1482439)

  [ Stefan Lippers-Hollmann ]
  * wpasupplicant: install systemd unit (Closes: #766746).
  * wpasupplicant: configure driver fallback for networkd.
  * import changelogs from the security queues.
  * move previous patch for CVE-2015-1863 into a new subdirectory,
    debian/patches/2015-1/.
  * replace the Debian specific patch "wpasupplicant: fix systemd unit
    dependencies" with a backport of its official upstream change "systemd:
    Order wpa_supplicant before network.target".
  * fix dependency odering when invoked with DBus, by making sure that DBus
    isn't shut down before wpa_supplicant, as that would also bring down
    wireless links which are still holding open NFS shares. Thanks to Facundo
    Gaich <email address hidden> and Michael Biebl <email address hidden>
    (Closes: #785579).
  * import NMU changelogs and integrate NMU changes.
  * Add patches to address CVE-2016-4476 and CVE-2016-4477, thanks to Salvatore
    Bonaccorso <email address hidden> (Closes: #823411):
    - WPS: Reject a Credential with invalid passphrase
    - Reject psk parameter set with invalid passphrase character
    - Remove newlines from wpa_supplicant config network output
    - Reject SET_CRED commands with newline characters in the string values
    - Reject SET commands with newline characters in the string values
  * use --buildsystem=qmake_qt4 (available since dh 8.9.1) for debhelper
    (Closes: #823171).
  * fix clean target, by splitting the find call into individual searches.
  * building wpa in a current unstable chroot using debhelper >= 9.20151219
    will introduce automatic dbgsym packages, thereby indirectly providing
    the requested debug packages for stretch and upwards (Closes: #729934).
    Don't add a versioned build-dependency in order to avoid unnecessary
    complications with backports.
  * change Vcs-Browser location to prefer https, but keep the unsecure tag for
    Vcs-Svn, as there is no option allowing to pull from the svn+ssh:// 
    location without an alioth account, this only makes lintian partially happy
    in regards to vcs-field-uses-insecure-uri.
  * debian/*: fix spelling errors noticed by lintian.
  * drop the obsolete Debian menu entry for wpa_gui, according to the tech-ctte
    decision on #741573.
  * fix debian/get-orig-source for wpa 2.6~.
  * add debian/watch file for the custom tarball generation.

  [ Paul Donohue ]
  * debian/ifupdown/functions.sh: Fix handling for "wpa-roam". Call ifquery
    instead of directly parsing /run/*/ifstate files to work with current
    ifupdown. (Closes: #545766, LP: #1545363)

  [ Martin Pitt ]
  * Add debian/system-sleep/wpasupplicant: Call wpa_cli suspend/resume
    before/after suspend, like the pm-utils hook. In some cases this brings
    back missing Wifi connection after resuming. (LP: #1422143)

  [ Andrew Shadura ]
  * New upstream release (Closes: #806889).
  * Refresh patches, drop patches applied upstream.
  * Fix pkcs11 OpenSSL engine initialisation (Closes: #827253).
  * Update Vcs-* to point to Git.

 -- Andrew Shadura <email address hidden>  Fri, 05 Aug 2016 20:45:14 +0200

Upload details

Uploaded by:
Debian/Ubuntu wpasupplicant Maintainers on 2016-08-08
Uploaded to:
Sid
Original maintainer:
Debian/Ubuntu wpasupplicant Maintainers
Architectures:
linux-any kfreebsd-any
Section:
net
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Builds

Downloads

File Size SHA-256 Checksum
wpa_2.5-2+v2.4-1.dsc 2.1 KiB e41104260ddc75a7960ac5d0b68607a752c920ebc21439fab58412732dde52c4
wpa_2.5-2+v2.4.orig.tar.xz 1.7 MiB a1e4eda50796b2234a6cd2f00748bbe09f38f3f621919187289162faeb50b6b8
wpa_2.5-2+v2.4-1.debian.tar.xz 82.8 KiB f15158f99c77665dd7f6f6f50b35e535ea90772155ac23e9d0c26b2c1aa6d1b0

No changes file available.

Binary packages built by this source