Change logs for ansible source package in Stretch

  • ansible (2.2.1.0-2+deb9u1) stretch-security; urgency=high
    
      * Add patch to fix CVE 2018-10855.
      * Add patch to fix CVE 2018-16837.
      * Add patch to fix CVE 2018-10875.
      * Add patch to fix CVE 2018-16876.
      * Add patch to fix CVE 2019-3828.
    
     -- Lee Garrett <email address hidden>  Mon, 11 Feb 2019 00:11:51 +0100
  • ansible (2.2.1.0-2) unstable; urgency=medium
    
      * Add patch to fix CVE-2017-7466.
    
     -- Harlan Lieberman-Berg <email address hidden>  Wed, 12 Apr 2017 00:56:30 -0400
  • ansible (2.2.1.0-1) unstable; urgency=medium
    
      * New upstream release
      * Remove following patches, applied upstream:
        - fix_CVE-2016-8647.patch
        - fix_pip_venv.patch
        - fix_UnboundedLocalError.patch
        - fix-cve-2016-9587.patch
      * Add myself to uploaders.
    
     -- Lee Garrett <email address hidden>  Sat, 21 Jan 2017 21:27:15 +0100
  • ansible (2.2.0.0-4) unstable; urgency=high
    
      * Commit to git the changelog line I actually used.
      * Cherry-pick patch fixing git module error. (Closes: #850935)
      * Cherry-pick patch fixing python3 + virtualenv problems. (Closes: #847546)
      * Cherry-pick patch fixing CVE-2016-8647 (Closes: #844691)
    
     -- Harlan Lieberman-Berg <email address hidden>  Sat, 14 Jan 2017 15:30:48 -0500
  • ansible (2.2.0.0-2) unstable; urgency=high
    
      * Cherry-pick patch to fix CVE-2016-9587 (Closes: #850846)
    
     -- Harlan Lieberman-Berg <email address hidden>  Tue, 10 Jan 2017 20:14:07 -0500
  • ansible (2.2.0.0-1) unstable; urgency=medium
    
      * New upstream release: (Closes: #843763)
        - CVE-2016-8628 (Closes: #842985)
        - CVE-2016-8614 (Closes: #842984)
      * Add python-kerberos, python-winrm, python-xmltodict to Recommends, needed
        to manage Windows hosts. (Closes: #843995)
      * Suggest cowsay (Closes: #834056)
    
     -- Lee Garrett <email address hidden>  Fri, 25 Nov 2016 20:52:24 +0100
  • ansible (2.1.1.0-1) unstable; urgency=medium
    
      * New upstream release.
      * Update cme copyright helper files.
      * Drop ansible-*fireball, as it is no longer supported.
    
     -- Harlan Lieberman-Berg <email address hidden>  Sun, 31 Jul 2016 22:02:59 -0400
  • ansible (2.1.0.0-1) unstable; urgency=medium
    
      * New upstream release. (Closes: #826927, #814371)
      * Update d/copyright; add cme hinting files.
      * Bump S-V; no changes required
      * Add manpage for ansible-console.
    
     -- Harlan Lieberman-Berg <email address hidden>  Sun, 12 Jun 2016 21:12:05 -0400
  • ansible (2.0.2.0-1) unstable; urgency=medium
    
      * New upstream release
      * Remove patches applied upstream
      * Change maintainer from Janos to me
    
     -- Harlan Lieberman-Berg <email address hidden>  Tue, 19 Apr 2016 22:31:25 -0400
  • ansible (2.0.1.0-2) unstable; urgency=medium
    
      * Backport patches to fix vulns in lxc plugin (Closes: #819676)
      * Update my email address
    
     -- Harlan Lieberman-Berg <email address hidden>  Sun, 10 Apr 2016 18:37:37 -0400
  • ansible (2.0.1.0-1) unstable; urgency=medium
    
      * New upstream release.
      * Fix Vcs-git URI.
      * Bump standards version.
    
     -- Harlan Lieberman-Berg <email address hidden>  Thu, 25 Feb 2016 23:03:33 -0500
  • ansible (2.0.0.2-2) unstable; urgency=medium
    
      * Migrate to unstable.
      * Switch Vcs-git to https.
    
     -- Harlan Lieberman-Berg <email address hidden>  Mon, 08 Feb 2016 07:15:41 -0500
  • ansible (1.9.4-1) unstable; urgency=medium
    
      * New upstream version.
    
     -- Harlan Lieberman-Berg <email address hidden>  Sat, 10 Oct 2015 17:51:09 -0400
  • ansible (1.9.3-1) unstable; urgency=medium
    
      * New upstream version.
    
     -- Harlan Lieberman-Berg <email address hidden>  Thu, 03 Sep 2015 21:06:03 -0400
  • ansible (1.9.2+dfsg-2) unstable; urgency=low
    
      * Fix suggestion of no-longer-built ansible-doc. (Closes: #795532)
        .
        Ansible used to ship their website which contained the manual for using ansible
        and learning it.  They no longer ship this in released versions, thus ansible-doc
        was removed.
    
     -- Harlan Lieberman-Berg <email address hidden>  Sat, 15 Aug 2015 09:29:31 +0200
  • ansible (1.9.2+dfsg-1) unstable; urgency=medium
    
      * New upstream version. (Closes: #773526)
      * Add dependency on python-netaddr (Closes: #790234)
      * Heavy refactoring due to upstream release changes
      * New, comprehensive d/copyright.
    
     -- Harlan Lieberman-Berg <email address hidden>  Sat, 27 Jun 2015 23:12:55 -0400
  • ansible (1.7.2+dfsg-2) unstable; urgency=low
    
    
      * Add updated paths to d/copyright.
    
     -- Harlan Lieberman-Berg <email address hidden>  Thu, 02 Oct 2014 17:31:12 -0400