On-the-fly display switcher

Primary monitor not correctly exported

Reported by wvengen on 2010-09-30
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
disper
Wishlist
Unassigned

Bug Description

I just wanted to know if is there any way to set not only the resolution, but also the refresh rate.

i tried: disper -r "1366x768","1440x900_75" -e

and i got: invalid literal for int() with base 10: '900_75'

how do i tell disper to use an specific refresh rate?

PS: this is becouse my secondary screen is not been detected correctly with auto, this also happens from NVIDIA xserver settings, so I have always fixed the Hz manually, even before installing disper.

wvengen (wvengen) wrote :

Hi,

You're the first person I've encountered that needs to set the refresh rate ... to simplify things at first I didn't implemented this.

I'll think of adding support at some time, but now other things are higher on the list (like a gui, plugins, and cycle mode).

For now you can still use nvidia-settings to setup your layout and then use disper's export/import feature.

Another workaround would be to download the EDID of your monitor using nvidia-settings, patch it to contain the correct refresh rate, and specify in your X.org configuration to use that as EDID.

Changed in disper:
importance: Undecided → Wishlist
status: New → Confirmed
Jurel (cristobalatria) wrote :

How is export/import feature supposed to be used? Is there some some guide available?
well, it's just that... I first entered disper -p and got:

could not get scaling for screen CRT-0, reverting to "default"
backend: nvidia
associated displays: CRT-0, DFP-0
metamode: CRT-0: 1440x900_75 @1440x900 +1366+0, DFP-0: 1366x768 @1366x768 +0+0
scaling: default, stretched

I then entered "disper -i" and the terminal got stuck, as if it were doing some task, but it took too long and I gave up. Maybe i'm doing something wrong?

wvengen (wvengen) wrote :

the output of `disper -p` can be written to a file, which then can be used as input to `disper -i`:

  $ disper -p >~/.disper/mysetup.dat
  $ disper -i <~/.disper/mysetup.dat

it looks like disper is stuck, but it just waits for input until EOF (Ctrl-D).

Jurel (cristobalatria) wrote :

It worked perfectly good. Thank you a lot! :)

Jurel (cristobalatria) wrote :

HEY! It worked, but...
...my laptop's screen was the primary display when I exported configuration, and then when I imported it back, disper set my external monitor as the primary display.

For some reason, it was exported this way:

backend: nvidia
associated displays: CRT-0, DFP-0
metamode: CRT-0: 1440x900_75 @1440x900 +1366+0, DFP-0: 1366x768 @1366x768 +0+0
scaling: default, stretched

so tried changing the order manually on the .dat, in line 2, this way:

backend: nvidia
associated displays: DFP-0, CRT-0
metamode: CRT-0: 1440x900_75 @1440x900 +1366+0, DFP-0: 1366x768 @1366x768 +0+0
scaling: default, stretched

and it worked, now disper sets my laptop's screen as primary and external as secondary.
I just wanted to report that disper missed on determine wich one was the primary screen.

Thank you!

wvengen (wvengen) on 2011-04-27
summary: - Specifying refresh rate for monitor
+ Primary monitor not correctly exported
wvengen (wvengen) wrote :

Hi, could you test if the primary monitor issue is still a problem with current bzr trunk?

Jurel (cristobalatria) wrote :

It worked as expected this time =) I have been able to export two different .dat to choose to set laptop screen or external monitor as primary, both .dat were imported as expected and have this new line at the bottom...

xinerama info order: DFP-0, CRT-0

...this line depends on wich is my primary screen at the time of exporting.

--version
disper 0.3.0

wvengen (wvengen) wrote :

Thanks for testing. Export of monitor order should be correct in disper 0.3.0.

Changed in disper:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers