[kernel] CD-RW erasing fails on QSI drives

Bug #13729 reported by Rafał Próchniak on 2005-03-09
32
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nautilus-cd-burner
Unknown
Medium
brasero (Ubuntu)
Undecided
Unassigned
cdrtools (Debian)
Fix Released
Unknown
cdrtools (Fedora)
Won't Fix
Medium
cdrtools (Ubuntu)
Medium
Unassigned

Bug Description

I suppose it's a cdrecord problem, although it is also encountered in
nautilus-cd-burner.

Problem:
It is impossible to burn a cd-rw with nautilus. It opens druid if empty cd-rw is
inserted, but reports an error. However it is possible to burn a cd-rw with
cdrecord (with different frontends).
It is impossible to erase a cd-rw with cdrecord (CLI or with frontend like
xcdroast). However, it is possible to erase a cd-rw with cdrdao.

Note: Added [kernel] tag as the SCSI blank command is perfectly OK
and as this problem is only present on Linux. It seems that the Linux
kernel modifies the SCSI cdb before sending it ti the drive. This explains why
a perfectly correct SCSI command will get an error "Illegal Field in CDB".

Download full text (6.8 KiB)

forwarded 186099 Joerg Schilling <email address hidden>
thanks

Hi Monari,

this is something for the upstream author.

#include <hallo.h>
* Monari Emanuele [Mon, Mar 24 2003, 04:27:58PM]:
> Package: cdrecord
> Version: 4:2.0+a05-1
> Severity: important
>
> In /var/log/dmesg my cdrecorder is detected also "QSI CD-RW/DVD-ROM
> SBW-081, ATAPI CD/DVD-ROM drive". It seems to work properly, but in case
> of CDRW blanking (either fast and all) or writing it fails and says (see below for complete output)
>
> $cdrecord -blank=xxx -v
> [...]
> cdrecord: Input/output error. blank unit: scsi sendcmd: no error
> CDB: A1 01 00 00 00 00 00 00 00 00 00 00
> status: 0x2 (CHECK CONDITION)
> Sense Bytes: 70 00 05 00 00 00 00 0A 00 00 00 00 24 00 00 00
> Sense Key: 0x5 Illegal Request, Segment 0
> Sense Code: 0x24 Qual 0x00 (invalid field in cdb) Fru 0x0
> Sense flags: Blk 0 (not valid)
> cmd finished after 0.000s timeout 9600s
> cdrecord: Cannot blank disk, aborting.
>
> or in case of writing:
> $cdrecord -v --eject foo.iso
> cdrecord: Input/output error. read track info: scsi sendcmd: no error
> CDB: 52 01 00 00 00 FF 00 00 1C 00
> status: 0x2 (CHECK CONDITION)
> Sense Bytes: 70 00 05 00 00 00 00 0A 00 00 00 00 26 00 00 00
> Sense Key: 0x5 Illegal Request, Segment 0
> Sense Code: 0x26 Qual 0x00 (invalid field in parameter list) Fru 0x0
> Sense flags: Blk 0 (not valid)
> cmd finished after 0.000s timeout 240s
> Writing time: 0.013s
> Fixating...
> Fixating time: 0.190s
> cdrecord: fifo had 255 puts and 0 gets.
> cdrecord: fifo was 0 times empty and 0 times full, min fill was 100%.
>
> Cheers,
> Monari Emanuele
>
>
> -- System Information:
> Debian Release: testing/unstable
> Architecture: i386
> Kernel: Linux little 2.4.20-mona-swsusp #1 mar mar 11 11:17:18 CET 2003 i686
> Locale: LANG=it_IT@euro, LC_CTYPE=it_IT@euro
>
> Versions of packages cdrecord depends on:
> ii debconf 1.2.33 Debian configuration management sy
> ii libc6 2.3.1-16 GNU C Library: Shared libraries an
> ii makedev 2.3.1-62 Creates device files in /dev.
>
> -- debconf information:
> * cdrecord/SUID_bit: true
> cdrecord/MAKEDEV: true
> cdrecord/MAKEDEVNEW: true
> cdrecord/do_it_yourself:
>
>
> output of blank=all
> Cdrecord 2.01a05 (i686-pc-linux-gnu) Copyright (C) 1995-2002 J?rg
> Schilling
> TOC Type: 1 = CD-ROM
> scsidev: '0,0,0'
> scsibus: 0 target: 0 lun: 0
> Linux sg driver version: 3.1.24
> Using libscg version 'schily-0.7'
> Driveropts: 'burnfree'
> atapi: 1
> Device type : Removable CD-ROM
> Version : 0
> Response Format: 2
> Capabilities :
> Vendor_info : 'QSI '
> Identifikation : 'DVD/CDRW SBW-081'
> Revision : 'NXA5'
> Device seems to be: Generic mmc2 DVD-ROM.
> Using generic SCSI-3/mmc CD-R driver (mmc_cdr).
> Driver flags : MMC-2 SWABAUDIO BURNFREE
> Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R16 RAW/R96P
> RAW/R96R
> Drive buf size : 1605632 = 1568 KB
> Current Secsize: 2048
> ATIP info from disk:
> Indicated writing power: 6
> Reference speed: 2
> Is not unrestricted
> Is erasable
> ATIP start of lead in: -11078 (97:34/22)
> ...

Read more...

Hello,

referring to your problem report with cdrecord QSI CD-RW recorder:

Is the problem fixed in the recent releases of cdrecord?

If not, did you provide the additional info to the upstream author
(Joerg Schilling <email address hidden>)?

MfG,
Eduard.
--
<quitte> jef ich habe von dir gestern gehoert das du hylafax benutzt.
<jef> quitte: habe ich das öffentlich zugegeben?

Il mar, 2003-06-03 alle 23:37, Eduard Bloch ha scritto:
> Hello,
>
> referring to your problem report with cdrecord QSI CD-RW recorder:
>
> Is the problem fixed in the recent releases of cdrecord?

I think not, but I must try to ensure this fact. Joerg said me that's a
firmware leak....
Then I'll contact him...

> MfG,
> Eduard.
Bests
Emanuele.

--

Il mar, 2003-06-03 alle 23:37, Eduard Bloch ha scritto:
> Hello,
>
> referring to your problem report with cdrecord QSI CD-RW recorder:
>
> Is the problem fixed in the recent releases of cdrecord?

I think not, but I must try to ensure this fact.
Then I'll contact him...
Joerg said me that's a firmware leak....

> MfG,
> Eduard.
Bests
Emanuele.
--

Il mar, 2003-06-03 alle 23:37, Eduard Bloch ha scritto:
> Hello,
>
> referring to your problem report with cdrecord QSI CD-RW recorder:
>
> Is the problem fixed in the recent releases of cdrecord?
>
> If not, did you provide the additional info to the upstream author
> (Joerg Schilling <email address hidden>)?

I've tryed to blank, either fast or all , but the error's the same.
There is the output.

$ cdrecord -v blank=all
Cdrecord 2.01a15 (i686-pc-linux-gnu) Copyright (C) 1995-2003 Jörg
Schilling
TOC Type: 1 = CD-ROM
scsidev: '0,0,0'
scsibus: 0 target: 0 lun: 0
Linux sg driver version: 3.1.24
Using libscg version 'schily-0.7'
Driveropts: 'burnfree'
atapi: 1
Device type : Removable CD-ROM
Version : 0
Response Format: 2
Capabilities :
Vendor_info : 'QSI '
Identifikation : 'DVD/CDRW SBW-081'
Revision : 'NXA5'
Device seems to be: Generic mmc2 DVD-ROM.
Current: 0x000A
Profile: 0x0010
Profile: 0x0008
Profile: 0x0009
Profile: 0x000A (current)
Using generic SCSI-3/mmc CD-R/CD-RW driver (mmc_cdr).
Driver flags : MMC-2 SWABAUDIO BURNFREE
Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R16 RAW/R96P
RAW/R96R
Drive buf size : 1605632 = 1568 KB
Current Secsize: 2048
ATIP info from disk:
  Indicated writing power: 3
  Reference speed: 6
  Is not unrestricted
  Is erasable
  Disk sub type: High speed Rewritable (CAV) media (1)
  ATIP start of lead in: -11635 (97:26/65)
  ATIP start of lead out: 359849 (79:59/74)
  1T speed low: 4 1T speed high: 10
  2T speed low: 4 2T speed high: 0 (reserved val 6)
  power mult factor: 1 5
  recommended erase/write power: 3
  A1 values: 24 1A BC
  A2 values: 26 B2 26
Disk type: Phase change
Manuf. index: 3
Manufacturer: CMC Magnetics Corporation
Starting to write CD/DVD at speed 8 in real BLANK mode for single
session.
Last chance to quit, starting real write 0 seconds. Operation starts.
Performing OPC...
Blanking entire disk
cdrecord: Input/output error. blank unit: scsi sendcmd: no error
CDB: A1 00 00 00 00 00 00 00 00 00 00 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 05 00 00 00 00 0A 00 00 00 00 24 00 00 00
Sense Key: 0x5 Illegal Request, Segment 0
Sense Code: 0x24 Qual 0x00 (invalid field in cdb) Fru 0x0
Sense flags: Blk 0 (not valid)
cmd finished after 0.000s timeout 9600s
cdrecord: Cannot blank disk, aborting.

It's the newest version...
$ cdrecord --version
Cdrecord 2.01a15 (i686-pc-linux-gnu) Copyright (C) 1995-2003 Jörg
Schilling

Bye!
E.
--
Monari Emanuele <email address hidden>

>From <email address hidden> Mon Jun 9 18:52:05 2003

>Il mar, 2003-06-03 alle 23:37, Eduard Bloch ha scritto:
>> Hello,
>>=20
>> referring to your problem report with cdrecord QSI CD-RW recorder:
>>=20
>> Is the problem fixed in the recent releases of cdrecord?
>>=20
>> If not, did you provide the additional info to the upstream author
>> (Joerg Schilling <email address hidden>)?

>I've tryed to blank, either fast or all , but the error's the same.
>There is the output.

I already mentioned that this is either a Linux kernel bug or a bug in
the firmware of the writer.

To verify if it is a Linux kernel bug, install Solaris and test...

This is definitely not cdrecord related!

>$ cdrecord -v blank=3Dall
>Cdrecord 2.01a15 (i686-pc-linux-gnu) Copyright (C) 1995-2003 J=F6rg
>Schilling
>TOC Type: 1 =3D CD-ROM
>scsidev: '0,0,0'
>scsibus: 0 target: 0 lun: 0
>Linux sg driver version: 3.1.24
>Using libscg version 'schily-0.7'
>Driveropts: 'burnfree'
>atapi: 1
>Device type : Removable CD-ROM
>Version : 0
>Response Format: 2
>Capabilities :
>Vendor_info : 'QSI '
>Identifikation : 'DVD/CDRW SBW-081'
>Revision : 'NXA5'
>Device seems to be: Generic mmc2 DVD-ROM.
>Current: 0x000A
>Profile: 0x0010
>Profile: 0x0008
>Profile: 0x0009
>Profile: 0x000A (current)
>Using generic SCSI-3/mmc CD-R/CD-RW driver (mmc_cdr).
>Driver flags : MMC-2 SWABAUDIO BURNFREE
>Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R16 RAW/R96P
>RAW/R96R
>Drive buf size : 1605632 =3D 1568 KB
>Current Secsize: 2048
>ATIP info from disk:
> Indicated writing power: 3
> Reference speed: 6
> Is not unrestricted
> Is erasable
> Disk sub type: High speed Rewritable (CAV) media (1)
> ATIP start of lead in: -11635 (97:26/65)
> ATIP start of lead out: 359849 (79:59/74)
> 1T speed low: 4 1T speed high: 10
> 2T speed low: 4 2T speed high: 0 (reserved val 6)
> power mult factor: 1 5
> recommended erase/write power: 3
> A1 values: 24 1A BC
> A2 values: 26 B2 26
>Disk type: Phase change
>Manuf. index: 3
>Manufacturer: CMC Magnetics Corporation
>Starting to write CD/DVD at speed 8 in real BLANK mode for single
>session.
>Last chance to quit, starting real write 0 seconds. Operation starts.
>Performing OPC...
>Blanking entire disk
>cdrecord: Input/output error. blank unit: scsi sendcmd: no error
>CDB: A1 00 00 00 00 00 00 00 00 00 00 00
>status: 0x2 (CHECK CONDITION)
>Sense Bytes: 70 00 05 00 00 00 00 0A 00 00 00 00 24 00 00 00
>Sense Key: 0x5 Illegal Request, Segment 0
>Sense Code: 0x24 Qual 0x00 (invalid field in cdb) Fru 0x0
>Sense flags: Blk 0 (not valid)
>cmd finished after 0.000s timeout 9600s
>cdrecord: Cannot blank disk, aborting.

Jörg

 EMail:<email address hidden> (home) Jörg Schilling D-13353 Berlin
       <email address hidden> (uni) If you don't have iso-8859-1
       <email address hidden> (work) chars I am J"org Schilling
 URL: http://www.fokus.fraunhofer.de/usr/schilling ftp://ftp.berlios.de/pub/schily

Package: cdrecord
Version: 4:2.0+a19-2
Followup-For: Bug #186099

-- System Information:
Debian Release: testing/unstable
Architecture: i386
Kernel: Linux vegeta 2.6.0-test9-1-386 #1 Sun Oct 26 22:32:52 EST 2003 i686
Locale: LANG=it_IT, LC_CTYPE=it_IT

Versions of packages cdrecord depends on:
ii debconf 1.3.18 Debian configuration management sy
ii libc6 2.3.2-9 GNU C Library: Shared libraries an
ii makedev 2.3.1-63 Creates device files in /dev

-- debconf information excluded

On Sun, Nov 02, 2003 at 09:29:48PM +0100, Fabio Bonelli wrote:
> Followup-For: Bug #186099

> Subject: Bug#186099: cdrecord: Works with cdrdao

Could you be more verbose?

[ ] You also have got a QSI CD-RW/DVD-ROM SBW-081
[ ] Your cdwriter fails with cdrecord since at least 4:2.0+a05-1
[ ] You get identical error-messages as the bug-submitter
[ ] You tested with cdrdao version _______.
[ ] Even cdrecord in woody fails[1].

TIA, cu andreas
[1] You don't have to install the package if you cannot because of
dependencies, just download it to /tmp and unpack the executable with
dpkg --fsys-tarfile cdrecord....deb | tar xf - ./usr/bin/cdrecord*
                 cu andreas

On Mon, Nov 03, 2003 at 11:18:51AM +0100, Andreas Metzler wrote:

> > Subject: Bug#186099: cdrecord: Works with cdrdao
> Could you be more verbose?

Sure.
reportbug shouldn't have sent that message.

> [X] You also have got a QSI CD-RW/DVD-ROM SBW-081
> [X] Your cdwriter fails with cdrecord since at least 4:2.0+a05-1
> [X] You get identical error-messages as the bug-submitter

It writes and re-writes flawlessly, but blanking a disk is a forbidden
field, it seems.

> [X] You tested with cdrdao version _______.

Version 1.1.7, and I guess it works even with older versions.
(just with a $ cdrdao blank)

I tried with both Linux 2.4.x (ide-scsi emulation) and Linux 2.6.0-test
(ide-scsi and ATAPI), same results.

> [ ] Even cdrecord in woody fails[1].

I haven't access to the drive right now, I'll send additional
information as soon as I can test it.

--
Fabio Bonelli <email address hidden>
gpg fingerprint: 61E6 5442 3BDF EA0E 2D10 35A6 971B 77D1 DA7F 0F59

On Mon, Nov 03, 2003 at 11:18:51AM +0100, Andreas Metzler wrote:

> [X] Even cdrecord in woody fails[1].

I can confirm this, now.

--
Fabio Bonelli <email address hidden>
gpg fingerprint: 61E6 5442 3BDF EA0E 2D10 35A6 971B 77D1 DA7F 0F59

On 2003-03-24 Monari Emanuele <email address hidden> wrote:
> Package: cdrecord
> Version: 4:2.0+a05-1
> Severity: important

> In /var/log/dmesg my cdrecorder is detected also "QSI CD-RW/DVD-ROM
> SBW-081, ATAPI CD/DVD-ROM drive". It seems to work properly, but in case
> of CDRW blanking (either fast and all) or writing it fails and says (see below for complete output)
[...]

This seems to be a general problem with QSI-drives, see e.g.
http://lists.debian.org/debian-user-german/2004/debian-user-german-200402/msg05143.html
which shows testimonials about failed blanking of cd-rws for
QSI CD-RW/DVD-ROM SBW-241, cdrdao succeeds.
               cu andreas

I suppose it's a cdrecord problem, although it is also encountered in
nautilus-cd-burner.

Problem:
It is impossible to burn a cd-rw with nautilus. It opens druid if empty cd-rw is
inserted, but reports an error. However it is possible to burn a cd-rw with
cdrecord (with different frontends).
It is impossible to erase a cd-rw with cdrecord (CLI or with frontend like
xcdroast). However, it is possible to erase a cd-rw with cdrdao.

Matt Zimmerman (mdz) wrote :

I burn CD-RWs with Nautilus regularly, so it is possible. If it reported an
error for you, we need to know what that error was in order to diagnose the problem.

Rafał Próchniak (burlap) wrote :

Nautilus reports only "reload rewritable or empty media"

Cdrecord errors (command line) are attached in a text file.

Rafał Próchniak (burlap) wrote :

Created an attachment (id=1579)
cdrecord errors

Matt Zimmerman (mdz) wrote :

Are you able to write a CD-RW in nautilus if you have already blanked it using
cdrdao?

Rafał Próchniak (burlap) wrote :

No - blank cd-rws do not work with nautilus (neither blanked with cdrdao nor
never used ones)
BTW: I have filed this bug at GNOME, where I was told to check
nautilus-cd-burner 2.8.7. It did not help (now I am back to standard Ubuntu
package) and finally they advised me to report a bug here as it may concern
cdrecord.

Sebastien Bacher (seb128) wrote :

do you have the GNOME bug number ?

Sebastien Bacher (seb128) wrote :

I've looked on google, there is some messages about debian/redhat/mandrake users
having the same bug with cdrecord and this drive

Rafał Próchniak (burlap) wrote :

So I've looked around too. It seems that QSI drives are quite popular (and I
thought that it was just my low-end notebook)...

The only possible clue was the -immed option. Well, use it at your own risk it
says...

First try:

cdrecord -immed -blank=minimal -dev=/dev/hdd

Blank worked fine, but it was not possible to burn the cd at first, I blanked it
with cdrdao with no effect either and I somehow - when I almost already decided
to throw the cd away - xcdroast burned it with no problems. So I went to risk
further.

Second try:

cdrecord -immed -blank=all -dev=/dev/hdd

Blank worked fine, Gnomebaker worked fine also.

Third try:

cdrecord -immed -blank=minimal -dev=/dev/hdd

I thought I would reproduce problems I encountered with the first try, but no:
gnomebaker worked fine.

Fourth try:

cdrecord -immed -blank=minimal -dev=/dev/hdd

To make sure: gnomebaker worked fine.

Conclusion?

"cdrecord -immed" seems to work with my QSI drive. Of course, you can't call
four attempts real testing, but it's better than nothing.

And nautilus problem (should I report it again as a bug or maybe request feature?):
Nautilus always tries to blank first, which is impossible for my drive, so i
can't use it even if my cd is blank. Possible solution would be to ask if
blanking is necessary. Or something similar.

Sebastien Bacher (seb128) wrote :

(In reply to comment #9)

> And nautilus problem (should I report it again as a bug or maybe request
feature?):
> Nautilus always tries to blank first, which is impossible for my drive, so i
> can't use it even if my cd is blank. Possible solution would be to ask if
> blanking is necessary. Or something similar.

The hoary version only erase the media if it's not empty, no need to open a bug
on ncb

Rafał Próchniak (burlap) wrote :

(In reply to comment #10)
>
> The hoary version only erase the media if it's not empty, no need to open a bug
> on ncb

I am on Hoary (upgraded from Warty) now and this doesn't work either.

If I insert a recorded cd-rw, nautilus asks if I want to "blank a cd" and if I
choose "yes" *something* happens (and I guess this is still the same error of
cdrecord), the cd is not blanked... I tried only twice: once the cd was ejected
and nautilus asked for a new one, the other time the cd was ejected and nautilus
hanged.

And if I insert a blank cd-rw, nautilus opens the druid, again asks to "blank",
and the effects are the same as above - the cd is ejected (and it hangs
sometimes). So apparently nautilus always tries to blank a cd.

So - shall I file a bug for ncb at gnome (last one, 169040, was closed as
non-gnome)? Or shall I provide more information?

Jeff Vehrs (icemanv9) wrote :

(In reply to comment #9)
> So I've looked around too. It seems that QSI drives are quite popular (and I
> thought that it was just my low-end notebook)...
>
> The only possible clue was the -immed option. Well, use it at your own risk it
> says...
>
> First try:
>
> cdrecord -immed -blank=minimal -dev=/dev/hdd
>
> Blank worked fine, but it was not possible to burn the cd at first, I blanked it
> with cdrdao with no effect either and I somehow - when I almost already decided
> to throw the cd away - xcdroast burned it with no problems. So I went to risk
> further.
>
> Second try:
>
> cdrecord -immed -blank=all -dev=/dev/hdd
>
> Blank worked fine, Gnomebaker worked fine also.
>
> Third try:
>
> cdrecord -immed -blank=minimal -dev=/dev/hdd
>
> I thought I would reproduce problems I encountered with the first try, but no:
> gnomebaker worked fine.
>
> Fourth try:
>
> cdrecord -immed -blank=minimal -dev=/dev/hdd
>
> To make sure: gnomebaker worked fine.
>
> Conclusion?
>
> "cdrecord -immed" seems to work with my QSI drive. Of course, you can't call
> four attempts real testing, but it's better than nothing.
>
>
> And nautilus problem (should I report it again as a bug or maybe request
feature?):
> Nautilus always tries to blank first, which is impossible for my drive, so i
> can't use it even if my cd is blank. Possible solution would be to ask if
> blanking is necessary. Or something similar.
>

I second his finding on "cdrecord -immed"!! It DOES work on my 'QSI CDRW/DVD
SBW-241' (finally!) woot!

Of course, I tested it 4x to be sure before I replied. Please submit this
temporary fix before all owners of 'QSI' CD drive lose their hairs! :-)

Hi,

unless this problem can be repeated with Solaris, the bug
should be assigned to the Linux kernel......

For a simple test, just boot SchilliX, the OpenSolaris Live CD.

http://schillix.berlios.de/

Jörg

--
 EMail:<email address hidden> (home) Jörg Schilling D-13353 Berlin
       <email address hidden> (uni)
       <email address hidden> (work) Blog: http://schily.blogspot.com/
 URL: http://cdrecord.berlios.de/old/private/ ftp://ftp.berlios.de/pub/schily

Moin Joerg!
Joerg Schilling schrieb am Dienstag, den 21. Juni 2005:

> unless this problem can be repeated with Solaris, the bug
> should be assigned to the Linux kernel......
>
> For a simple test, just boot SchilliX, the OpenSolaris Live CD.
>
> http://schillix.berlios.de/

"Unless the problem XYZ can be reproduced with Microsoft Windows XP the
problem Foo Bar Baz should be assigned to the Solaris Kernel."

Can't you find a better playground for that sloppy adverts?

Regards,
Eduard.

--
[Surveying a scene in a bar below] Sebastian: Nothing changes: Decadence,
immorality, chaos.
                                                 -- Quotes from Babylon 5 --

Eduard Bloch <email address hidden> wrote:

> Moin Joerg!
> Joerg Schilling schrieb am Dienstag, den 21. Juni 2005:
>
> > unless this problem can be repeated with Solaris, the bug
> > should be assigned to the Linux kernel......
> >
> > For a simple test, just boot SchilliX, the OpenSolaris Live CD.
> >
> > http://schillix.berlios.de/
>
> "Unless the problem XYZ can be reproduced with Microsoft Windows XP the
> problem Foo Bar Baz should be assigned to the Solaris Kernel."
>
> Can't you find a better playground for that sloppy adverts?

Could you please stop your useless and childish rants?

If you are unwilling to remove a non cdrecord related bug from the list
or if you unable to understand the background, you should ask for help
or leave the cdrecord project.

For the other people who are still interested in cdrecord, here is the
background:

I have been able to prove once that the Linux Kernel sometimes bastardizes
SCSI commands that are send to ATAPI drives. This has been done by
booting a different OS on the same hardware and the problem disappeared.
The Bug #186099 shows constraints that are similar to my observations
and the _only_ way to find out where the problem is located is to boot
a different OS.

In former times this was hard to do, but now SchilliX exists and allows
you to do the test within less than 2 minutes without modifying the
PC. If the problems does not go away with OpenSolaris (SchilliX), then
the bug is in the drive's firmware and cannot be fixed. If the problem
does not occur with Solaris, then the bug is in the Linux kernel.

Jörg

--
 EMail:<email address hidden> (home) Jörg Schilling D-13353 Berlin
       <email address hidden> (uni)
       <email address hidden> (work) Blog: http://schily.blogspot.com/
 URL: http://cdrecord.berlios.de/old/private/ ftp://ftp.berlios.de/pub/schily

Jörg didn't mention that libscg is also involved involved in this setup,
and the libscg code for Linux is different from the libscg code path for
other operating systems such as Solaris.

If SchilliX works, the bug might as still be in libscg, and booting
other operating systems cannot distinguish this from a kernel bug.

--
Matthias Andree

Still no erasing in dapper, updated as of April, 5.

Sebastien Bacher (seb128) wrote :

Seems there is no real package maintainer for cdrecord at the moment, the bug should probably be taken upstream to get some action

Changed in cdrtools:
assignee: seb128 → nobody

This is also a bug in Fedora and SuSE. I think we can consider it confirmed.

Changed in cdrtools:
status: Unconfirmed → Confirmed

Hi!

This is a general ping to all cdrkit (former cdrtools) related bugs. Please
test if your reported bug still applies with the new wodim burning program
and/or newest mkisofs/cdda2wav/...

If there is no response in 4 weeks, the bug reports will be closed.

/Sune
--
Man, do you know how to overclock the BIOS?

You should never open the forward of a LCD hardware, this way from Netscape or
from DOS 5.9 you neither should unlink the URL, nor can ever digit from a
serial utility in order to reset the IRC mail over a memory.

Version 5:1.0~pre4

Old cdrecord bugs will now be versioned closed.
This means that this bug will be marked 'closed' in the versions larger than
5:1.0~pre4, but still present in earlier versions.

/Sune

--
Do you know how to digit from the fan to the terminale?

From Windows you either must receive a digital AGP connection, or should
remove the fan.

Changed in cdrtools:
status: Confirmed → Fix Released

I have a QSI CD-RW/DVD-ROM SBW242B and it works 'fine'.

In Dapper everything worked and the disks were erased just fine using nautilus. Now on Edgy the erasing still works, but I can't copy an audio cd anymore. I have tried with several disks and with different write speeds, but all of the tries have failed so far. I can burn data disks, but audio disks fail every time.

I open another bug for this copy problem, but just wanted to say that erasing seems to work for me.

Schily (schilling-fokus) wrote :

This is a problem in the Linux kernel that is present for a while.

It seems that the Linux kernel under some unknown conditions
bastardizes the SCSI command on it's way from the user space
to the drive while talking to ATAPI drives.

I have been able to verify a similar problem (in my case with
cdd2wav and the READ FULL TOC command).

In all cases, the drives will return a "illegal field in CDB" error
and booting the same hardware with Solaris let's the problem
disappear.

Schily (schilling-fokus) on 2007-09-15
description: updated

Same problem with brasero.

Schily (schilling-fokus) wrote :

As it seems that you are able to repeat the problem, I first like to see the output of a recent original cdrecord
when calling:

cdrecod -v blank=all

If this really causes a problem, I need a report from you run under Solaris.

This may be done by e.g. booting a schilllix CD and running the same command from Solaris.

Jonay (jonay-santana) wrote :

Having the same kind of problems here with brasero. Andrea Corbellini asked me to put the output of "dvd+rw-format -blank /dev/dvd", but I think that is useless:
* BD/DVD±RW/-RAM format utility by <email address hidden>, version 7.0.
:-( unable to open("/dev/dvd"): No such file or directory
Once the erasing process fails, my DVD+-RW drive becomes useless (with the disc spinning in it) until I reboot.
If there is any info or file I can add, please, ask me to.

Changed in cdrtools:
status: Confirmed → Triaged
Changed in cdrtools:
status: Confirmed → Incomplete
Changed in cdrtools:
status: Incomplete → In Progress
Changed in brasero:
status: New → Invalid
Changed in cdrtools:
status: In Progress → Won't Fix
Changed in nautilus-cd-burner:
importance: Unknown → Medium
status: Invalid → Unknown

Has this situation changed in the meantime? I read that it was first reported in Debian in the year 2003!

Changed in cdrtools (Ubuntu):
status: Triaged → Incomplete
Rafał Próchniak (burlap) wrote :

My QSi drive died years ago... It might be safe to assume this bug's expired.

Changed in cdrtools (Ubuntu):
status: Incomplete → Invalid
Changed in cdrtools (Fedora):
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.