Export to odg not work in 0.91 and 0.92

Bug #1654034 reported by Thierry on 2017-01-04
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Patrick Storz

Bug Description

Inscape 0.91 et 0.92 version en langue française

Sorry for my english

When I save as odg, I have an error message 'the xxx file could not be saved'.

su_v (suv-lp) wrote :

Please add information about OS/platform to the bug description, and attach a test case (Inkscape SVG file) to the bug report which exposes the reported issue to allow further investigation on other systems, thank you.

Changed in inkscape:
status: New → Incomplete
tags: added: exporting odg
Thierry (boulestin) wrote :

Windows 10 Pro French, 16 Go RAM, Core I7, SSD samsung 256 Go, Hard Drive 2 To.

I create a square, like on the screenshot and menu File / Save as ...

Error message : The 'filename.odg' file could not be saved

jazzynico (jazzynico) wrote :

Not reproduced on Xubuntu 16.04, Inkscape 0.91 and 0.92. The SVG drawing is correctly exported to ODG.

Changed in inkscape:
status: Incomplete → New
importance: Undecided → Medium
su_v (suv-lp) wrote :

Not reproduced with Inkscape 0.48.5 r10043, 0.91 r13725 and 0.92 r15299 on OS X 10.7.5: export succeeds with all tested versions, ODG file opens in LO ok.

<off-topic>
JazzyNico wrote:
> The SVG drawing is correctly exported to ODG.

Minor detail here: the exact position of the rectangle on the page in LibreOffice does not fully match how it is displayed in Inkscape (the objects (a rect with rounded corners centered on the page, lines connecting the rect geometric bbox corners to the page corners) scale larger in LibreOffice relative to the page size than in Inkscape). Could be due to outdated version of LO available for this OS though. Not related to recent unit changes in Inkscape (reproduces with 0.48.x too).
</off-topic>

su_v (suv-lp) wrote :

Reproduced with Inkscape 0.92 r15299 on Windows 10: same error message in dialog as reported, no console message(s).

Changed in inkscape:
status: New → Confirmed
tags: added: win64
su_v (suv-lp) wrote :

su_v wrote:
> Reproduced with Inkscape 0.92 r15299 on Windows 10

JFTR - this package was used for testing:
* Windows .msi installer for "Inkscape 0.92.0" (64-bit)
  file name of installer: Inkscape-0.92.0-x64.msi

Alvin Penner (apenner) wrote :
Download full text (4.8 KiB)

reproduced on Windows 10, Inkscape trunk, Inkscape 0.92+devel 15388

backtrace =

Program received signal SIGSEGV, Segmentation fault.
0x000000006e1a4499 in Inkscape::ObjectSet::clear() ()
   from C:\Users\penne_000\AppData\Roaming\InkscapeBZR\build\inkscape\libinkscape_base.dll
(gdb) bt
#0 0x000000006e1a4499 in Inkscape::ObjectSet::clear() ()
   from C:\Users\penne_000\AppData\Roaming\InkscapeBZR\build\inkscape\libinkscape_base.dll
#1 0x000000006e191b08 in Inkscape::Application::remove_desktop(SPDesktop*) ()
   from C:\Users\penne_000\AppData\Roaming\InkscapeBZR\build\inkscape\libinkscape_base.dll
#2 0x000000006e09cbc6 in sp_desktop_widget_dispose(_GObject*) ()
   from C:\Users\penne_000\AppData\Roaming\InkscapeBZR\build\inkscape\libinkscape_base.dll
#3 0x0000000063a4e526 in g_object_run_dispose (object=0x9a94490)
    at gobject.c:1082
#4 0x000000000198ea89 in gtk_window_forall ()
   from C:\Users\penne_000\AppData\Roaming\InkscapeBZR\build\inkscape\libgtk-3-0.dll
#5 0x000000000166cc1d in gtk_container_destroy ()
   from C:\Users\penne_000\AppData\Roaming\InkscapeBZR\build\inkscape\libgtk-3-0.dll
#6 0x0000000063a4732c in g_closure_invoke (closure=closure@entry=0x665ce60,
    return_value=return_value@entry=0x0, n_param_values=1,
    param_values=param_values@entry=0x66f140,
    invocation_hint=invocation_hint@entry=0x66f0a0) at gclosure.c:804
#7 0x0000000063a5ab4e in signal_emit_unlocked_R (node=<optimized out>,
    node@entry=0x6666a30, detail=0, instance=instance@entry=0xd737940,
    emission_return=emission_return@entry=0x0,
    instance_and_params=instance_and_params@entry=0x66f140) at gsignal.c:3745
#8 0x0000000063a63f5d in g_signal_emit_valist (instance=<optimized out>,
    signal_id=<optimized out>, detail=6747968, var_args=<optimized out>)
    at gsignal.c:3385
#9 0x0000000063a64238 in g_signal_emit (instance=0xffffffff, signal_id=0,
    detail=217866224) at gsignal.c:3441
#10 0x0000000001978b9c in gtk_widget_dispose ()
   from C:\Users\penne_000\AppData\Roaming\InkscapeBZR\build\inkscape\libgtk-3-0.dll
#11 0x0000000001991ef6 in gtk_window_dispose ()
   from C:\Users\penne_000\AppData\Roaming\InkscapeBZR\build\inkscape\libgtk-3-0.dll
#12 0x0000000063a4e526 in g_object_run_dispose (object=0xd737940)
    at gobject.c:1082
#13 0x0000000063f3b888 in Gtk::Window::~Window() ()
   from C:\Users\penne_000\AppData\Roaming\InkscapeBZR\build\inkscape\libgtkmm-3.0-1.dll
#14 0x000000006e147331 in SPDesktop::onDeleteUI(_GdkEventAny*) ()
   from C:\Users\penne_000\AppData\Roaming\InkscapeBZR\build\inkscape\libinkscape_base.dll
#15 0x0000000063f3351f in (anonymous namespace)::Widget_signal_delete_event_callback(_GtkWidget*, _GdkEventAny*, void*) ()
   from C:\Users\penne_000\AppData\Roaming\InkscapeBZR\build\inkscape\libgtkmm-3.0-1.dll
#16 0x000000000178e42b in _gtk_marshal_BOOLEAN__BOXED ()
   from C:\Users\penne_000\AppData\Roaming\InkscapeBZR\build\inkscape\libgtk-3----Type <return> to continue, or q <return> to quit---
0.dll
#17 0x0000000063a4732c in g_closure_invoke (closure=0xd229b50,
    return_value=return_value@entry=0x66f650, n_param_values=2,
    param_values=param_values@entry=0x66f740,
    invocation_hint=invocation_hint@entr...

Read more...

Alvin Penner (apenner) wrote :

on second thought, I am not sure that this backtrace is helpful. I get exactly the same backtrace if I just draw an object and close Inkscape normally without any crash.

but the failure to save is definitely real on the trunk build

Alvin Penner (apenner) wrote :

gdb backtrace reported separately, as
https://bugs.launchpad.net/inkscape/+bug/1654560

Rb-henschel (rb-henschel) wrote :

I get this error with the portable versions 0.91 and 0.92 on Windows 7, 32bit. In portable version 0.48.5 the export to odg works on the same PC.

Paul Figueiredo (ghona76) wrote :

I can confirm this bug on 0.92 on KDE Neon/Ubuntu 16.04. Have the same distro installed on a workstation desktop and on a cheaper laptop and in both cases, I get the same error message as the original bug description when trying to save as an .odg file.

I've tried both "Save as" and "Save a copy" and have tried, in both, typing the extension while selecting "Guess from extension" and choosing the actual extension from the drop down list.

Alvin Penner (apenner) wrote :

reproduced on Windows 10, Inkscape 0.92.2pre0 (973e216, 2017-07-25)
using the install file inkscape-0.92.2pre0-x86.exe

Felipe Marschall (marschall) wrote :

Reproduced on KDE Neon 16.04 with 0.91 r13725

Patrick Storz (ede123) wrote :

Fix pushed to master in
  https://gitlab.com/inkscape/inkscape/commit/d61e166a900e32e6f1640c7c26b1a8a66826e51d

It seems .odg export was broken completely on Windows due to file name handling of linked raster images (even of no images were included in the file)

Should any issues persist please report back (preferably in a new bug report with detailed steps on how reproduce the issue).

Changed in inkscape:
assignee: nobody → Eduard Braun (eduard-braun2)
milestone: none → 0.93
tags: added: backport-proposed
removed: odg
Patrick Storz (ede123) wrote :
Changed in inkscape:
milestone: 0.93 → 0.92.3
tags: removed: backport-proposed
Changed in inkscape:
status: Confirmed → Fix Committed
Bryce Harrington (bryce) on 2018-05-12
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers