Installscript does not work (multiple errors: broken autoinstall and problems with old config)

Reported by Albrecht Mühlenschulte on 2006-11-20
8
Affects Status Importance Assigned to Milestone
Jokosher
High
Stuart Langridge

Bug Description

Trying to run the installscript of Jokosher 0.2 gives me the following error. I had the edgy-package of 0.1 installed before and removed it now, but it did not make a difference.

Removing the old config file solved the problem partially, now the script stops with message 2). Then bison is not automatically installed 3). Then 4) flex, then 5) liboil-dev

After manually fixing these issues installing works fine (installing bison, flex liboil3-dev.

After all this I can't create a project - I will report further bugs, when I know I can get jokosher properly installed.

Never the less, great project - I was really waiting for someone to do this (it's like preschedueled chrismas :).

1)======================================================
$ ./Jokosher0.2runscript
E: Kann Quellpaket für gst-plugins-ugly0.10 nicht finden
Gtk-Message: Failed to load module "atk-bridge": libatk-bridge.so: cannot open shared object file: No such file or directory
GTK Accessibility Module initialized
Exception in thread Thread-1:
Traceback (most recent call last):
  File "threading.py", line 442, in __bootstrap
    self.run()
  File "./Jokosher0.2runscript", line 263, in run
    self.fetchthings()
  File "./Jokosher0.2runscript", line 205, in fetchthings
    self.installextensions()
  File "./Jokosher0.2runscript", line 182, in installextensions
    os.path.join(EXTDIR,f))
  File "shutil.py", line 48, in copyfile
    fdst = open(dst, 'wb')
IOError: [Errno 20] Not a directory: '/home/alp/.jokosher/extensions/GNOMEAudioProfiles.py'

2)======================================================
+ check for build tools
  checking for autoconf >= 2.52 ... found 2.60, ok.
  checking for automake >= 1.7 ... found 1.4-p6, not ok !
  checking for automake-1.9 >= 1.7 ... not found.
  checking for automake19 >= 1.7 ... not found.
  checking for automake-1.8 >= 1.7 ... not found.
  checking for automake18 >= 1.7 ... not found.
  checking for automake-1.7 >= 1.7 ... not found.
  checking for automake17 >= 1.7 ... not found.
  checking for automake-1.6 >= 1.7 ... not found.
  checking for automake16 >= 1.7 ... not found.
not found !
You must have automake installed to compile gstreamer.
Download the appropriate package for your distribution,
or get the source tarball at ftp://ftp.gnu.org/pub/gnu/automake/
  checking for autopoint >= 0.11.5 ... found 0.15, ok.
  checking for libtoolize >= 1.5.0 ... found 1.5.22, ok.
  checking for pkg-config >= 0.8.0 ... found 0.20, ok.

- Please get the right tools before proceeding.
- Alternatively, if you're sure we're wrong, run with --nocheck.

3)======================================================
.
.
.
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ISO C89... (cached) none needed
checking dependency style of gcc... (cached) gcc3
checking for perl... /usr/bin/perl
checking for bison... no
configure: error: Could not find bison

4)======================================================
.
.
.
checking for bison... /usr/bin/bison
checking bison version 2.3 >= 1.35... yes
checking for flex... no
configure: error: Could not find flex
  configure failed

5)======================================================
.
.
.
checking whether gcc implements __func__... yes
checking for GLIB... yes
checking for LIBOIL... configure: error: liboil-0.3.6 or later is required
  configure failed

description: updated

It requries quite some hands-on and is not at all as automatic as advertized. I had to use apt-get, add/remove and synaptics to find all packages that provides the missing tools. Automake for instance have another version (1.4) in Dapper but the repository containes newer versions also. Tricky! I'll get back with a report when the build has finished and I am able to try out the application.

It compiled finally after some hands-on package downloading. I didn't have to tweak any packages. I have now started to use it so will report new bugs when found. It looks like great fun! :-)

Stuart Langridge (sil) wrote :

Joakim: I would very much appreciate a list of the packages that you had to manually install; I can then make the script check for them. Do you have that list? (You might be able to retrieve your recent apt-get commands from your shell history by typing "history" in a terminal.)

Changed in jokosher:
assignee: nobody → sil-launchpad
importance: Undecided → High
status: Unconfirmed → Confirmed
John Green (john-thegreens) wrote :

The first reporter had this output in their console

$ ./Jokosher0.2runscript
E: Kann Quellpaket für gst-plugins-ugly0.10 nicht finden

This I think is the apt-get build-dep bowing out and none of the dependencies will get pulled in in this case. Don't know if something similar happened in the case of the second report. I also don't understand the message as the script is trying to find dependencies for gstreamer0.10-plugins-ugly in any case so where does this come from?

I am at work not having access to the computer but the tools I remember that
the install script stopped upon are

- make
- bison
- automake (Wrong version)
- gst-ugly0.10...

And possibly a few other, I will check my install history when I get back home
tonight. Finally the script identified some 143 packages that it asked me to
accept to install.

BR / Joakim

> ---- Original Message -----
> Date: 21-Nov-2006 09:15:10 +0100
> From: Stuart Langridge <email address hidden>
> To: <email address hidden>
> Subject: [Bug 72527] Re: Installscript does not work (multiple errors:
broken autoinst...
>
> Joakim: I would very much appreciate a list of the packages that you had
> to manually install; I can then make the script check for them. Do you
> have that list? (You might be able to retrieve your recent apt-get
> commands from your shell history by typing "history" in a terminal.)
>

----------------------------------------------------------------
 <email address hidden>
 http://www.bildrulle.nu/ - berättelser med bilder
----------------------------------------------------------------

In essence I found this in my history with history | grep apt-get

  484 sudo apt-get install alsa
  487 sudo apt-get install libtool
  488 sudo apt-get install pkg-config
  489 sudo apt-get install automake-1.9
  492 sudo apt-get install bison

In addition I used Synaptics and Application->Add/Remove for some other
packages than gst-ugly0.10... that I have forgot about. This is on Dapper BTW
----------------------------------------------------------------
 <email address hidden>
 http://www.bildrulle.nu/ - berättelser med bilder
----------------------------------------------------------------
> ---- Original Message -----
> Date: 21-Nov-2006 09:15:10 +0100
> From: Stuart Langridge <email address hidden>
> To: <email address hidden>
> Subject: [Bug 72527] Re: Installscript does not work (multiple errors:
broken autoinst...
>
> Joakim: I would very much appreciate a list of the packages that you had
> to manually install; I can then make the script check for them. Do you
> have that list? (You might be able to retrieve your recent apt-get
> commands from your shell history by typing "history" in a terminal.)
>

Gavin Luhrs (gavinluhrs) wrote :

I had a similar problem with the autoinstall script. I just needed to run

 sudo apt-get install automake1.9

'automake-1.9' didn't work

You are correct, I edited the history list removing some typos, and apparantly created some new ashwell...

Irene Gr (irenegr92) wrote :

After installing automake 1.4 the script works fine for me.

Will Thompson (wjt) wrote :

I've just been running the installscript on everyone's favourite Eft, as instructed by His Baconness. I had to manually install the following packages: bison, flex, liboil0.3-dev, python-gtk2-dev.

Hope this helps, Stuart.

sjsepp (sjsepp) wrote :

Install script in Ubuntu Edgy (6.10) failed with

checking for LIBOIL... configure: error: liboil-0.3.6 or later is required
  configure failed
/home/user/Jokosher0.2checkout/gst/gst-plugins-base

Installing liboil0.3-dev fixed this, of course.

Laszlo Pandy (laszlok) wrote :

Install script is really old and won't be used anymore. You should be able to get the proper gstreamer version from your distro's packages.

Changed in jokosher:
status: Confirmed → Rejected
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers