Suggest possible duplicate bugs based on keywords/strings

Reported by SVAKSHA on 2006-03-31
6
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Björn Tillenius

Bug Description

Can Malone have an automated feature programmed to compare each bug (after it has been filed) for similar keywords/strings. Sometimes people filing the bug provide this info, while some dont. Matching bug numbers could be displayed on LP to allow a volunteer-bug-squasher to
compare if it is indeed a duplicate bug and decide further action on case-to-case basis. This feature will help compare duplicate bugs filed by oversight and filter them making it easier to track duplicate bugs filed.

On Fri, 2006-03-31 at 07:53 +0000, Svaksha wrote:
> Public bug reported:
>
> Affects: malone (upstream)
> Severity: Wishlist
> Priority: (none set)
> Status: Unconfirmed
>
>
> Description:
> Can Malone have an automated feature programmed to compare each bug (after it has been filed) for similar keywords/strings. Sometimes people filing the bug provide this info, while some dont. Matching bug numbers could be displayed on LP to allow a volunteer-bug-squasher to
> compare if it is indeed a duplicate bug and decide further action on case-to-case basis. This feature will help compare duplicate bugs filed by oversight and filter them making it easier to track duplicate bugs filed.

I think this is a very interesting idea, and would be a very challenging
project. This is the kind of thing I'd imagine we'd consider thinking
more about several months or a year down the road, once things like a
guided filebug form are working smoothly.

Brad

Mandriva used to (and maybe still do) this. The problem was that it searched other bugs for words that I assume were in the title of the report you were submitting and returned a list asking you whether you were sure you wanted to file a report.

The problem I ran into was that this list was frequently quite long and rarely (if ever) contained my issue in it anyway. I guess the trick is you have to get good at returning as few reports as possible.

On a related note, I had an idea for a duplicate spotting system which is along these lines. I posted it on the launchpad mailing list but it was suggested that I'd be better off filing a report here and this is a pretty close match (as is Bug #996 ).

The idea is that when you go to file a new bug you are given the option to put in 3 or more tags to search for your bug in launchpad. If the tags are found in other bugs then they are shown as likely candidates and the user is given the option to view them.

If the user goes on to file a report those search tags are also saved with the report and the bug as a tag summary to aid in its discovery.

If a bug report is duplicated against another, a note is made and when searches are done its tags are "added" to the original report's tags to make the original more likely to be found.

The option to bypass the tag search is offered but is recorded into a bug report. This way at a later stage it can be determined whether tagging is an effective system by checking how many bugs which never had a search done ended up actually being dupes versus bugs that did have tag search done.

SVAKSHA (svaksha) wrote :

That would be very helpful. Also keywords by themselves render useless results sometimes. See bug # 37425 which Matthew filed a few minutes before I did. Although we are saying the same thing essentially, the confusion and difference in communication means a bug’s status as “open” is higher. This is the difficult part to bridge when using pure keywords to search duplicates IMHO.
Thanks!

Sitsofe Wheeler (sitsofe) wrote :

This behavior seems to have been recently implemented. Resolve Fixed?

Matthew Paul Thomas (mpt) wrote :

yes, Brad and Bjorn implemented this a few months ago.

Changed in malone:
assignee: nobody → bjornt
status: Unconfirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers