Rosetta reverts translation fixes to old faulty values

Bug #68014 reported by Jan Claeys on 2006-10-24
42
Affects Status Importance Assigned to Milestone
Launchpad itself
Critical
Carlos Perelló Marín
Ubuntu
Undecided
Pascal De Vuyst

Bug Description

Rosetta sometimes(?) sets (some?) translation values back to old (and faulty) values.

I mailed about this problem to the rosetta mailing list some time ago, and the developers thought it wasn't really a bug with rosetta, but now it has happened again, including with some strings that I fixed after the discussion on the list, e.g. in gnome-panel "Places" --> "Locaties" (correct) vs. "Lokaties" (incorrect).

The result of this is that edgy will be released with a Dutch translation that is unacceptable... :-(

I have checked the daily language pack builds, and for gnome-panel the change back to old faulty translations happened between version 1:6.10+20061018 and version 1:6.10+20061019 of 'language-pack-gnome-nl-base', so it happened just before or just after the LanguagePackTranslationDeadline...

Jan Claeys (janc) on 2006-10-24
Changed in rosetta:
status: Unconfirmed → Confirmed
Lasse Bang Mikkelsen (lbm) wrote :

I'm experiencing this with the Danish translations too.

Diogo Matsubara (matsubara) wrote :

I chatted with carlos on IRC and he'll take a closer look at this before confirming. Thanks for reporting

Changed in rosetta:
assignee: nobody → carlos
status: Confirmed → Unconfirmed
Erdal Ronahi (erdalronahi) wrote :

We're seeing this with gnome-panel in Kurdish at the moment.

Carlos Perelló Marín (carlos) wrote :

Please, would you add concrete links and references to concrete messages that got this behaviour so I can concentrate exactly with the broken messages?

I was planning to add some extra internal logging to track this kind of changes, in the mean time, I need to figure it based on what I see in our database so it's easy if I know exactly a set of messages that have this problem.

Changed in rosetta:
importance: Undecided → High
Jan Claeys (janc) wrote :

The most in-your-face bug in the Dutch translation is this string:

https://launchpad.net/distros/ubuntu/edgy/+source/gnome-panel/+pots/gnome-panel-2.0/nl/366/+translate

The "lokaties" there should be "locaties" (and I have fixed this on 2006-10-20, but my fix got lost...).

This translation error[*] was in upstream GNOME in the past, but was fixed upstream (probably by the same translator) and included correctly in at least dapper (and maybe also in breezy, but I would have to check that).

[*] well, older spelling rules allowed both "lokaties" and "locaties", so what's a spelling error...

Jan Claeys (janc) wrote :
Changed in rosetta:
status: Unconfirmed → In Progress
Christian Reis (kiko) wrote :

This has been brought to my attention and will be addressed ASAP.

Changed in rosetta:
importance: High → Critical
Igor Zubarev (igor.zubarev) wrote :

Confirm bug for russian. Soundjuicer is example.

Vladimer Sichinava (alinux) wrote :

confirm for Georgian translation, Edgy was realised with erroneous/old gnome-desktop translation, even if I've had corrected these strings before.

Please, for future confirmations of this bug, could you say whether the reverting problem happened after 1st November? It's not enough to say that you noticed it after that date, you must be sure it was correct around that date and, later, it was reverted.

We disabled the upload form around that date so, unless there is a pending import in the queue, if there are translation reversions, we have the problem somewhere else.

Thank you.

Raivis Dejus (orvils) wrote :

I am not sure when did latvian translations for nautilus got messed up, but "2006-08-03" is as last changes date and I am pretty sure that no one has updated it since so there is definetly a bug in Rosetta.

No one would translate those strings as they are so the wrong translations must be comming from the system. And we have a lot of wrongly translated / messed-up translations.

Raivis Dejus (orvils) wrote :

sorry for double comment but...

Those wrong translations I see in latvian files are not some older versions, they are simply wrong translations that come (or could come) from other strings, maybe similar. So the problem could be with rosetta guessing strings or something else, but not the old versions, because somew of wrongly translated strings before have never been translated this way.

Milo Casagrande (milo) wrote :

I've found a couple of reverted string for the italian translation of nautilus-cd-burner:

https://launchpad.net/distros/ubuntu/edgy/+source/nautilus-cd-burner/+pots/nautilus-cd-burner/it/+translate?start=97

They are #98 and #99, the suggestion is the correct translation.

I'm going to ask the italian translator if he remembers doing an import for that package.

Cheers!

Milo Casagrande (milo) wrote :

For the last message about the italian translation, it doesn't seem a regression. I've checked deeply and it's an upstream error for that translation.

Sorry!

Milo Casagrande (milo) wrote :

Ok, this time, the strings in here are really reverted:

https://launchpad.net/distros/ubuntu/edgy/+source/tomboy/+pots/tomboy/it/+translate?start=100

String 106 and 107. The correct translation is the segguestion and is the one in GNOME CVS.
I think the upload for tomboy has been done somewhere around october... but as I can see, after Edgy release.

I don't know if it could be of help: tomboy has been edited last time on 2006-11-01 by me (see strings 94 and 49), but in the translation template it says last edit was on 2006-09-22:

https://launchpad.net/distros/ubuntu/edgy/+source/tomboy/+translations

Another reverted is here, for nautilus-cd-burner:

https://launchpad.net/distros/ubuntu/edgy/+source/nautilus-cd-burner/+pots/nautilus-cd-burner/it/+translate?start=28

String 29. The po was imported on 2006-10-13 by me.

Hope this could help!
Thanks!

Amed Çeko Jiyan (amedcj) wrote :

it is since long time i am tyring to upload kopete but i cant. when will some one fix that?

Dave Neary (dneary) wrote :

The Wengophone project has also had this problem (in Spanish) as recently as last week.

Two weeks without an update - any news on this, guys?

Dave Neary.

Jan Claeys (janc) wrote :

Dave, if those changes really happened only a week ago, now that they have (more) logging in place, this might be just what they need to find the problem. At least, I hope so... :-)

Gustavo A. Díaz (gdiaz) wrote :

Yeah, I'm translating Spanish for WengoPhone, and when i try to download the .po file to check for changes, its send me and old version/changes of the translations...

Hmmm, does it mean that Rosetta has the right data in the UI, but the .po file export has old strings?

IMHO, that's a different issue, although would be possible that it increased the problem.

On Friday, I detected a problem that would be related with the exports you just commented. I'm finishing with the code for this bug before I can debug the export problem better. You can track that problem at https://launchpad.net/products/rosetta/+bug/73509

About the status of this bug, I'm working hard to get it on production this week.

Christian Reis (kiko) wrote :

Gus, Dave: can you confirm that the only case you have detected of reversing translations has been because of downloading out-of-date translation files, a.k.a. bug 73509? I'm asking because I want to be sure that we have all issue covered.

Arangel Angov (arangel) wrote :

Confirming for Macedonian also. This is the worst Ubuntu release ever when it comes to translations, I still have some strings with the same errors from Breezy. We (localization teams) are fighting with something that just keeps coming back all the time and it's really frustrating to have half of my Gaim in English when I've spend so much time to translate the whole thing in time for Edgy. I hope that you ll fix it soon.

Matic Zgur (mr-zgur) wrote :

Slovenian translation is also quite a mess due to this bug. There are some strings which really don't make any sense. Like the translation of gtk20 where "File name:" is translated as (in English) "Color name:", instead of "Today" there is "Modal" and so on. I hope, that this bug will be resolved soon. Good luck.

On Sun, Dec 03, 2006 at 12:27:48PM -0000, Matic Zgur wrote:
> Slovenian translation is also quite a mess due to this bug. There are
> some strings which really don't make any sense. Like the translation of
> gtk20 where "File name:" is translated as (in English) "Color name:",
> instead of "Today" there is "Modal" and so on. I hope, that this bug
> will be resolved soon. Good luck.

Matic, I don't see how the problems you report above are necessarily
related to reversal of translations. Do you have some evidence that
shows that these strings were wrong, fixed and then reverted?

Matic Zgur (mr-zgur) wrote :

I personally uploaded some of the po files (like gtk20, gnome-panel and others) to Rosetta during Knot3 era. And things were better then. Everything was translated OK. But soon after the release of Edgy (at least that's how I remember), there was a translation upgrade that broke the translations. I don't know what exactely happened but many strings are just wrong. Not badly translated, but so wrong that there must have been some kind of error when merging them or with translation memory. I don't know. I hope this was helpful.

No upload version for Occitan (all is done via Rosetta), I guess it would be difficult to allow Occitan translations to be uploaded?

Raivis Dejus (orvils) wrote :

Today with great sorrow I installed update of Latvian gnome language pack. With sorrow because it did not fixed any of all those faulty translations we have. And my sorrow is even grater because I know that I could have fixed these translations If only I could upload files...

This "critical" bug has been open for quire some time and all this time many translators are paralised to do anything.

Maybe you can enable file uploads and inform everyone by puting a notice or something that carefull testing and evidence gathering has to be done to help you identify the bug. As I can do nothing usefull as a translator I could help some other way. But so far I do not see what could I do.

Please do something (or say what can we do to help) as every day this bug is out there and we cannot fix those translations Ubuntu looks ridiculous to all those already skeptical.

sorry for spam, but I am fraustrated with doing nothing...

Christian Reis (kiko) wrote :

On Thu, Dec 07, 2006 at 07:53:34AM -0000, Raivis Dejus wrote:
> translations we have. And my sorrow is even grater because I know that I
> could have fixed these translations If only I could upload files...

Please send the files to be uploaded directly to me; I can have them
uploaded manually. Please also indicate whether they are to be uploaded
as official translations or as suggestions.

Right now, this bug is fixed, our QA review is done and should land in our source repository in next hours.

Next scheduled code update is next Friday so I hope it will be on production at that time. This means that you should be able to upload files again on Friday.

Anyway, I will confirm this tomorrow.

Changed in rosetta:
status: In Progress → Fix Committed

This is on production now and the upload form is enabled again.

Changed in rosetta:
status: Fix Committed → Fix Released

Sweet_Noosly, this doesn't look like a bug in an Ubuntu package.
Why did you add an Ubuntu task to this bug report?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers