Rapid Photo Downloader 0.9.25

Milestone information

Project:
Rapid Photo Downloader
Series:
pyqt
Version:
0.9.25
Released:
2020-12-16  
Registrant:
Damon Lynch
Release registered:
2020-12-16
Active:
No. Drivers cannot target bugs and blueprints to this milestone.  

Download RDF metadata

Activities

Assigned to you:
No blueprints or bugs assigned to you.
Assignees:
7 Damon Lynch
Blueprints:
No blueprints are targeted to this milestone.
Bugs:
2 Invalid, 5 Fix Released

Download files for this release

After you've downloaded a file, you can verify its authenticity using its MD5 sum or signature. (How do I verify a download?)

File Description Downloads
download icon install.py (md5, sig) Mandatory installer file 194
last downloaded 17 weeks ago
download icon rapid-photo-downloader-0.9.25.tar.gz (md5, sig) Code Release Tarball 347
last downloaded 7 weeks ago
download icon CHANGES.rst (md5) Change log 94
last downloaded 11 weeks ago
download icon README.rst (md5) Readme 8
last downloaded 3 weeks ago
download icon RELEASE_NOTES.rst (md5) Release notes 10
last downloaded 5 weeks ago
Total downloads: 653

Release notes 

Improve install.py script on old and new Linux distributions.
Improve creating new Job Codes before a download when no files are selected.
Fix several bugs.
Update Danish, Dutch, French, German, Hungarian, Russian, Serbian, and Spanish translations. Add partially translated Albanian translation.

Changelog 

View the full changelog

 - When a new Job Code is entered before a download and no files are selected,
   the Job Code is automatically saved. When entering a Job Code, "Remember this
   Choice" is now labelled as "Remember this Job Code".

 - Fix bug #1889770: Fails to run - Could not load the Qt platform plugin
   "xcb".

 - Fix bug #1906272: Exception while displaying tooltip for thumbnail of file
   downloaded from a removed device.

 - Fix bug #1891659: Exception when encountering invalid block device.

 - Fix bug #1881255: Unhandled exception when system file manager entry is
   malformed. The AppImages for RawTherapee and ART can have an unfortunate bug
   in which they wrongly sets themselves to be the path to the desktop's
   default file manger. Rapid Photo Downloader no longer crashes when trying to
   work with that incorrect setting.

 - Bump up minimum Python version supported to Python 3.5.

 - Don't install support library libunity on Fedora. Libunity has a serious
   bug on Fedora 33. Libunity provides emblems and progress bars on launchers on
   desktops like KDE and Ubuntu's flavor of Gnome.

 - Fedora 32 is now the minimum supported version of Fedora. Please note Fedora
   33 is not recommended for now, because of an issue with Python 3.9 and
   Python threads seen when running Rapid Photo Downloader in Fedora 33. In
   contrast to Fedora 33, Ubuntu 21.04 with Python 3.9 works as expected.

 - When installing on Debian using the install.py script, ignore any version
   number information (or lack thereof) in /etc/os-release.

 - When using the install.py script, don't install PyQt5 and python3-gphoto2
   from PyPi when the Linux distribution's package is relatively recent. Also:
   don't default to installing the PyPi Python tools pip, setuptools, and wheel
   using pip when the system packages are relatively recent, and don't install
   unsupported versions these same packages on Python 3.5.

 - Bump up minimum version of python package easygui to 0.98.1.

 - Bump up minimum version of python-dateutil to allow recent versions of
   arrow to function. When using the install.py script, don't install
   unsupported versions of arrow or pymediainfo on Python 3.5.

 - When using the install.py script, don't install the unmaintained python
   package rawkit on systems that do not contain libraw 0.16 or 0.17.

 - Update Danish, Dutch, French, German, Hungarian, Russian, Serbian, and
   Spanish translations. Add partially translated Albanian translation.

0 blueprints and 7 bugs targeted

Bug report Importance Assignee Status
1907943 #1907943 Device scan failed with pymediainfo 5.02 4 Medium Damon Lynch  3 Invalid
1890086 #1890086 'babel' has no attribute 'Locale' 1 Undecided Damon Lynch  3 Invalid
1889770 #1889770 Fails to run - Could not load the Qt platform plugin "xcb" 4 Medium Damon Lynch  10 Fix Released
1891659 #1891659 Exception when encountering invalid block device 4 Medium Damon Lynch  10 Fix Released
1904555 #1904555 Installer 'Detected Debian 0.0', fails 4 Medium Damon Lynch  10 Fix Released
1906272 #1906272 Exception while displaying tooltip for thumbnail from removed device 4 Medium Damon Lynch  10 Fix Released
1881255 #1881255 Unhandled exception when system file manager entry is malformed 5 Low Damon Lynch  10 Fix Released
This milestone contains Public information
Everyone can see this information.