Publishing details

Changelog

inkscape (0.48.2-0ubuntu1~lucid1) lucid-backports; urgency=low

  * Backport for Lucid (LP: #844697)
  * debian/control:
    - Drop build-dependency on specific libwpd/libwpg version.
    - Drop build-dependency on dh-translations.
  * debian/rules:
    - Drop use of dh_translations
    - Call intltool-update manually
  * 03-add-translation-domain.dpatch - New patch to add translation domain to
    desktop entry file, replacing functionality of unavailable dh_translations
    tool.

inkscape (0.48.2-0ubuntu1) oneiric; urgency=low

  * New upstream release (LP: #807912).  Fixes several Ubuntu bugs:
    - [SVG Font Editor] Crash when kerning an empty pair (LP: #706506)
    - Connector tool crash Inkscake (orthogonal mode) (LP: #771738)
    - Errors printed to console if openclipart search fails (LP: #638844)
    - pdf export with cairo 1.10 defaults to version PDF-1.5 (LP: #664335)
    - Cairo rendering broken for "use" elements when scaling or a viewBox
      (LP: #705345)
    - gimp_xcf.py crashed with TypeError in effect() (LP: #565296)
    - Enable build against libwpg-0.2 (LP: #778951)
    - Please add supported filetypes into MimeType line of inkscape.desktop
      (LP: #278307)
    - Inkscape fails to build with gcc 4.6 (LP: #707205)
  * Drop 01-libwpg0.2.dpatch - Applied upstream
  * Drop 03-add-missing-mimetypes.dpatch - Applied upstream
  * Drop 04-fix-build-with-gcc4.6.dpatch - Applied upstream
  * Drop 05-add-missing-includes.dpatch - Applied upstream
  * Drop fix-fontforge-glyph-template.dpatch - Applied upstream

inkscape (0.48.1-2.1ubuntu1) oneiric; urgency=low

  * Merge from Debian Unstable (LP: #791728).  Remaining changes:
    - debian/control:
      + Ubuntu maintainers
      + Promote python-lxml, python-numpy, python-uniconvertor to Recommends.
      + Demote pstoedit to Suggests (universe package).
      + Suggest transfig to allow import of xfig files (LP: #668300)
      + Drop unnecessary python and skencil suggestions (LP: #762541)
    - Handle translation tasks for Ubuntu main (LP: #726850):
      + debian/rules: Add dh_translations to binary-arch rule
      + debian/control: Build-Depends dh-translations
    - debian/patches/01_add_unity_quicklist_support.patch: add "New Drawing"
      to Unity quicklist (LP: #676886)
    - debian/patches/fix-fontforge-glyph-template.dpatch: Cherry-pick
      patch from uptream trunk to fix layer structure in template (LP: #565296)
    - debian/patches/02-add-shebangs-and-fix-permissions.dpatch: No longer mark
      JavaScript extension files as standalone executables (LP: #602005):
      + share/extensions/*.js: Revert addition of shebangs
      + share/extensions/Makefile.am: Install *.js using _DATA rule rather
        than _SCRIPTS rule to avoid giving executable permission
  * debian/patches/fix-datamatrix-ui.dpatch: Prevent invalid input in
    Datamatrix extension dialog (LP: #738108)

inkscape (0.48.1-2.1) unstable; urgency=high

  * Non-maintainer upload.
  * Fix FTBFS with gcc 4.6 (Closes: #624770), Thanks to Alex Valavanis
    for the patch.
    - added 04-fix-build-with-gcc4.6.dpatch
  * Fix build issues due to missing includes (Closes: #628226), patch
    taken from upstream.
    - added 05-add-missing-includes.dpatch

inkscape (0.48.1-2ubuntu5) oneiric; urgency=low

  * debian/rules: No need to manually call intltool-update on build.  This
    is now handled by dh_translations.
  * debian/control: No longer suggest python and skencil.  They do not
    offer any enhancement to Inkscape (LP: #762541)
  * debian/control: Suggest transfig to allow import of xfig files
    (LP: #668300)
  * debian/patches/02-add-shebangs-and-fix-permissions.dpatch:
    No longer mark JavaScript extension files as standalone executables
    (LP: #602005):
    - share/extensions/*.js: Revert addition of shebangs
    - share/extensions/Makefile.am: Install *.js using _DATA rule rather
      than _SCRIPTS rule to avoid giving executable permission
  * debian/patches/fix-fontforge-glyph-template.dpatch: Cherry-pick
    patch from uptream trunk to fix layer structure in template (LP: #565296)

inkscape (0.48.1-2ubuntu4) oneiric; urgency=low

  * debian/rules: Drop broken code to add translation domain to desktop files.
    Replace this with a call to dh_translations. Add dh-translations build
    dependency for this. Thanks to Alex Valavanis for pointing this out, and
    the original patch. (LP: #726850)

inkscape (0.48.1-2ubuntu3) oneiric; urgency=low

  * debian/patches/04-fix-gcc4.6-ftbfs.dpatch: Fix build failure with gcc 4.6
    - Backport upstream patch (lp:inkscape:r10071)
    - Add <cstddef> inclusion to src/2geom/utils.h

inkscape (0.48.1-2ubuntu2) natty; urgency=low

  * debian/patches/01_add_unity_quicklist_support.patch:
    - updated with latest specification

inkscape (0.48.1-2ubuntu1) natty; urgency=low

  * Merge with Debian unstable (LP: #719648, LP: #278307).  Remaining changes:
  * debian/control:
    - Ubuntu maintainers
    - Promote python-lxml, python-numpy, python-uniconvertor to Recommends.
    - Demote pstoedit to Suggests (universe package).
  * debian/rules:
    - Run intltool-update on build (Ubuntu-specific).
    - Add translation domain to .desktop files (Ubuntu-specific)
  * debian/patches/01_add_unity_quicklist_support.patch:
    - add unity quicklist support for a new entry to inkscape (LP: #676886)

inkscape (0.48.1-2) unstable; urgency=low

  * upload to unstable (closes: #611626)
  * [d364fdc] link against libwpg0.2/libwpd0.9 (closes: 604825)
    Thanks to Rene Engelhard <email address hidden> for his work and the patch!
  * upload sponsored by Guido Guenther <email address hidden>
    Thank you very much!

inkscape (0.48.1-1) experimental; urgency=low

  * [f6250fa] Imported Upstream version 0.48.1
  * [e5b9206] remove debian/patches/01-end-drag-fix.dpatch since applied
    upstream
  * [2b6fb5b] add patch to fix shebang lines in extensions scripts
  * [f38e3e1] drop dependency upon ttf-bitstream-vera (closes: #597503)
  * [0a91fb1] binary depends on ${misc:Depends} as indicated by lintian
  * [02b4953] depend on libmagick++-dev instead of libmagick++9-dev
  * [ea095c3] Add supported mime types (closes: #596982)

inkscape (0.48.1-0ubuntu2) natty; urgency=low

  * debian/patches/01_add_unity_quicklist_support.patch:
    - add unity quicklist support for a new entry to inkscape (LP: #676886)

inkscape (0.48.1-0ubuntu1) natty; urgency=low

  * New upstream version (LP: #710619).  Fixes several Ubuntu bugs:
    - Node editing causes segmentation fault (LP: #544599)
    - Cursor position markers are not cleared from rulers (LP: #627134)
    - Crashes when opening document properties (LP: #658055)
    - Export to XCF error with default template (LP: #485032)
    - Editing a connector in a transformed group returns it to original
      position (LP: #533897)
    - Ungrouping objects changes position of arrow lines (LP: #552289)
    - Will not save XCF file (LP: #642417)
    - XCF export fails when exporting from unsaved document (LP: #650890)
  * Drop all patches: Applied upstream
  * debian/rules: Disable chmod on debian/patches/* in clean rule (no patches used)

inkscape (0.48.0-1ubuntu3) natty; urgency=low

  * debian/patches/0001-Fix-build-with-Poppler-0.15.1.dpatch: Backport
    upstream patch to fix Poppler build issues in Natty (LP: #676271)

inkscape (0.48.0-1ubuntu2) natty; urgency=low

  * Bug-fix release (LP: #645888)
  * Added 02-fix-binutils-gold-build-failure.dpatch (LP: #662979)
  * debian/control: No longer suggest ttf-dejavu (LP: #643371)

inkscape (0.48.0-1ubuntu1) maverick; urgency=low

  * Merge with Debian unstable (LP: #628048, LP: #401567, LP: #456248,
    LP: #463602, LP: #591986)
  * debian/control:
    - Ubuntu maintainers
    - Promote python-lxml, python-numpy, python-uniconvertor to Recommends.
    - Demote pstoedit to Suggests (universe package).
    - Suggests ttf-dejavu instead of ttf-bitstream-vera (LP: #513319)
  * debian/rules:
    - Run intltool-update on build (Ubuntu-specific).
    - Add translation domain to .desktop files (Ubuntu-specific).
  * debian/dirs:
    - Add usr/share/pixmaps.  Allow inkscape.xpm installation
  * drop 50-poppler-API.dpatch (now upstream)
  * drop 51-paste-in-unwritable-directory.dpatch (now upstream)

inkscape (0.48.0-1) experimental; urgency=low

  * [cae07a3] New Upstream version 0.48.0
  * [309c498] add patch to fix crash in node tool
  * The highlights of this release are:
      - multipath editing
      - improved text tool: subscript, superscript, numerical input for text kerning, tracking and more
      - new Airbrush tool
      - LaTeX export with PDF/PS/EPS
      - JessyInk extension to create presentations
      - numerous bugfixes
  * [56702cf] don't build-depend on libssl-dev (closes: #573338)
  * [013b235] wrap lines in debian/control. patch by Benjamin Drung,
    many thanks to him (closes: #576357)
  * [747d3d1] add README.source adopted from nagios to make lintian a
    bit happier
  * [4df0df7] Remove all patches since they are applied upstream

inkscape (0.47.0-2ubuntu3) maverick; urgency=low

  * 51-paste-in-unwritable-directory.dpatch, debian/control: Allow paste
    from clipboard when in unwritable working directory (LP: #211607)
 -- Alex Valavanis <email address hidden>   Fri, 23 Sep 2011 23:46:04 +0100

Available diffs

Builds

Built packages

Package files