Publishing details

Changelog

ipsec-tools (1:0.8.0-9ubuntu1) precise; urgency=low

  * Merge from Debian unstable (LP: #881097). Remaining changes:
     - debian/control: Depend on lsb-base
     - debian/rules: switch -U_FORTIFY_SOURCE for -D_FORTIFY_SOURCE=0
  * Dropped changes:
     - Modify configure.ac to not convert -RXYZ to -Wl,-RXYZ, and regenerate
       configure (Applied in debian via configure-pass-Wl-with-R.patch)
     - debian/{racoon.init, ipsec-tools.setkey.init}: Re-write LSB init script
       (Fixed in Debian)

ipsec-tools (1:0.8.0-9) unstable; urgency=low

  * Apply new patchs which enable GNU/kfreebsd build.
    Thanks to Mats Erik Andersson. (Closes: #617859, #639970)
  * Put removing of config.log at end of dh_clean to stop file changed
    problems during git-buildpackage
  * Fix lots of minor lintian warnings.
  * LSB-fy init scripts. (Closes: #629828)
  * Fix spelling error in racoon.conf.5 manpage.
  * Fix typo in libipsec_strerror.h (Closes: #642926)
  * Updated racoon-tool.conf.5 manpage, minor regexps.
  * New racoon-tool, Multi relation SPD code.
  * debian/control: Add Vcs-* stanzas.

ipsec-tools (1:0.8.0-8) unstable; urgency=low

  * Revert racoon-tool default SPD level to unique for comaptibilty and
    individual VPN reload speed.

ipsec-tools (1:0.8.0-7) unstable; urgency=low

  * Temporarily fix gcc-4.6 build on most architectures. Need to contact
    upstream about proper use of autoconf and configure.ac for gcc-4.6 support
    as autoconf  for this package appears to be brittle.

ipsec-tools (1:0.8.0-6) unstable; urgency=low

  * Remove Requires-Stop $remotefs from init script. (Closes: #643006)

ipsec-tools (1:0.8.0-5.1) unstable; urgency=low

  * Minor version to kick over reprepro

ipsec-tools (1:0.8.0-5) unstable; urgency=low

  * Fix required-stop $remotefs with lintian override as otherwise causes
    dependency boot order loops sith sendsigs.
  * Add racoon-tool match code for udp port 500 traffic.

ipsec-tools (1:0.8.0-4.1) unstable; urgency=low

  * Update raccon-tool transport mode to ignore dup port 500 <-> 500 traffic.

ipsec-tools (1:0.8.0-4) unstable; urgency=low

  * New Maintainer.  Have conferred with Stefan Bauer.
  * Changed to gcc-4.5 only as 4.6 does not support -R flag that ipsec-tools
    requires. (Closes: #625184)
  * Marked automake, autoconf, and autoheader as Build-Conflicts.
  * Added updated racoon-tool.pl and associated manpages.
 -- Adam Gandelman <email address hidden>   Mon, 24 Oct 2011 12:08:24 -0700

Available diffs

Builds

Built packages

Package files