Publishing details

Changelog

bnd (3.5.0-1) unstable; urgency=medium

  * New upstream release
  * Drop obsolete patches:
    * disable-jpm-plugin.patch
    * gradle-compatibility.patch
    * no_ee_minimum.patch
    * no-ee.j2se.patch
    * no-osgi.r5.patch
    * remove-recursion-in-macro-warning.patch
  * New patches:
    * build-scripts.patch: Make the Build Scripts Buildable
    * ant-compatibility: Fix Ant compatibility
  * Use simpler "get-orig-source" approach
  * Update Standards-Version to 4.1.3
  * Remove Damien Raude-Morvan from Uploaders (Closes: 889406)
  * Add myself to Uploaders
  * Update to debhelper compat level 11
  * Modify (Build-)Depends:
    * Switch to default-jdk-headless
    * Switch from junit to junit4
    * Restrict libosgi-compendium-java to >= 6
    * Restrict gradle-debian-helper to >= 1.6~
    + libfelix-framework-java
    + libfelix-gogo-runtime-java
    + libfelix-resolver-java
    + libosgi-annotation-java
    + libslf4j-java
    + libxz-java
    + libyaml-snake-java
  * Install generated POMs instead of downloading them from internet
  * Rename JARs in "/usr/share/java" to comply with the policies
  * Re-enable parallel build
  * Build & install more artifacts:
    * bnd-libg
    * bnd-junit
    * bnd-launcher
    * bnd-remote-agent
    * bnd-remote-api
    * bnd-remote-gc
    * bnd-remote-launcher
    * bnd-remote-main
    * bnd-repository
    * bnd-resolve
    * bnd-tester
    * bnd-repoindex-api
    * bnd-repoindex-lib

 -- Kai-Chung Yan (殷啟聰) <email address hidden>  Fri, 16 Mar 2018 00:50:18 +0800

Available diffs

Builds

Built packages

Package files