Publishing details

Changelog

sagemath (8.3-2ubuntu1) cosmic; urgency=medium

  * Merge with Debian; remaining changes:
    - Use gdb instead of gdb-python2 as a build dependency.

sagemath (8.3-2) unstable; urgency=medium

  * Remove dependency on backports.ssl-match-hostname. (Closes: #909975)
  * Remove patches:
    - d1-test-optional.patch

sagemath (8.3-1) unstable; urgency=medium

  * Upload to unstable.

sagemath (8.3-1~exp2) experimental; urgency=medium

  [ Julian Rüth ]
  * New patches:
    - u0-fix-symlink-sage-kernel-spec.patch      #25722

  [ Ximin Luo ]
  * New patches:
    - u2-version-r-3.5.1-incomplete.patch        #26185

  [ Tobias Hansen ]
  * Depend on python-stemmer to fix docbuild (see #907381).

sagemath (8.3-1~exp1) experimental; urgency=medium

  [ Julian Rüth ]
  * New upstream version.
  * New (Build-)Depends:
    - libflint-arb-dev (>= 1:2.13)
    - libfplll-dev (>= 5.2.1)
    - libpynac-dev (>= 0.7.22)
    - ipython (>= 5.5.0)
    - maxima-sage (>= 5.41.0)
    - python-fpylll (>= 0.4.1)
    - python-packaging
  * Remove patches (applied upstream):
    - u0-version-pynac-0.7.19.patch              #24838
    - u0-version-sphinx-1.7.patch                #24935
    - u0-version-pbori-boost1.62-hashes.patch    #22243
    - u0-version-networkx-2.1.patch              #24374
    - u0-reproducible-docs.patch                 #25093
    - u0-better-sphinx-failure-modes.patch       #25160, 25161
    - u1-version-cddlib-094h.patch               #25341

  [ Tobias Hansen ]
  * New (Build-)Depends:
    - gfan (>= 0.6.2)
    - libgiac-dev (>= 1.4.9.69)
    - pari (>= 2.11.0)
    - python-cypari2 (>= 1.2.1),
  * New patches:
    - u0-version-cypari2-1.2.1.patch             #25813
    - u0-version-pari-2.11.patch                 #25567
    - u0-version-arb-2.14.patch                  #25966
  * Removed patches (aaplied upstream):
    - u2-pari-stackwarn.patch                    #23263
    - d0-pari-2.9-revert-24531.patch
    - d0-pari-2.9-revert-23544.patch
  * Use atlas instead of openblas to work around crashes with openblas 0.3.2.

sagemath (8.2-5) unstable; urgency=medium

  * New patch d1-remove-sage-python23.patch. (Closes: #902545)

sagemath (8.2-4) unstable; urgency=medium

  * Depend on libflint-arb-dev (>= 1:2.12).

sagemath (8.2-3) unstable; urgency=medium

  * Upload to unstable.
  * Update networkx patch.

sagemath (8.2-2) experimental; urgency=medium

  * New (Build-)Depends:
    - python-networkx (>= 2.1)
    - sympow (>= 1.023-9)
  * New patches:
    - u0-version-networkx-2.1.patch              #24374
      (Closes: #901532)

sagemath (8.2-1) experimental; urgency=medium

  * New upstream version.
  * New (Build-)Depends:
    - cython (>= 0.28.2)
    - fflas-ffpack (>= 2.3.2)
    - flint-arb (>= 2.12),
    - givaro (>= 4.0.4)
    - linbox (>= 1.5.2)
    - pynac (>= 0.7.19)
    - sphinx (>= 1.7)
    - python-numpy (>= 1:1.14)
    - python-sagenb (>= 1.0.1+ds1-5)
  * Version restrictions to use packages from unstable
    rather than experimental:
    - libec-dev (<< 20171219~)
    - libsingular4-dev (<< 1:4.1.1~)
  * Remove patches (applied upstream):
    - u0-version-matplotlib-2.1.0.patch          #23696
    - u0-version-mpfr-4.0.patch                  #24353
    - u1-version-ipython-5.4.patch               #24389
    - u1-version-giac-1.2.3.57.patch
  * New patches:
    - u0-version-numpy-1.14.3.patch              #25260
    - u0-version-pynac-0.7.19.patch              #24838
    - u0-version-sphinx-1.7.patch                #24935
    - d0-pari-2.9-revert-24531.patch
    - dt-version-ipywidgets-6-revert-23177.patch
  * Patches with non-trivial modifications:
    - d0-arb.patch
    - d0-pari-2.9-revert-23544.patch
    - d0-paths.patch
    - d1-sage-cli.patch
  * Increase the allowed test failures from 62 up to 70.

 -- Matthias Klose <email address hidden>  Tue, 02 Oct 2018 10:04:53 +0200

Available diffs

Builds

Built packages

Package files