CD detection failed on install.

Bug #55232 reported by tari
8
Affects Status Importance Assigned to Milestone
Ubuntu
New
Undecided
Unassigned

Bug Description

When booting from the Dapper CD to install on a Gigabyte GA-965P-DS3 motherboard with a Western Digital Caviar 200 GB SATA hard drive, it gets to the "mounting root file system" phase, waits for a little while, and reverts to the "uncompressing linux... booting the kernel" screen then hangs.
With the alternate CD for a text install, after booting the kernel, it says "ata2: disabling port","ata3: disabling port", and "ata4: disabling port". My hard drive is on ata1, and the board's only PATA port is ata5, where my CD drive is. After reaching the CD detection step of installation, it says "No common CD-ROM drive detected" and prompts to load a driver off a floppy. I have none, so say no, and none of the included drivers which can be chosen from work. This also happens with the Breezy Live CD, and appears to be a problem in the debian installer, because all debian-based systems I have tried this with have failed in the same way.

Revision history for this message
Doug (helltoad1969) wrote :

I have the same problem with the Dapper Live Cd. I'm running Athlon 64 2800+ on a MSI mobo and WD 400 GB sata drive with Plextor P916A DVDR sata drive. The bios and the drive firmware are uptodate.

It hangs for a long time on "mounting root file system", then eventually displays "booting the kernel". At this point the i386 Cd hangs forever.

The amd-64 Cd immediately bombs at this point and spews out a couple screens of erros that go by way too quick to read. I seem to recall something about "ata failed to respond" but it was way too quick. The XUbuntu amd-64 cd behaves the same.

The alternate amd-64 cd complains there is no valid cd-rom device.

Judging from the sheer volume of posts on the forums, Dapper has some serious problems with SATA.

Revision history for this message
tari (taricorp) wrote : Update: CD detection failed on install.

I can't speak for anyone else, but in my case, this actually appears to be a limitation of the kernel. I've found that it will only detect devices up to hdh (ata4,slave), and on my board, the PATA is on ata5. The SATA hard drive is mounted as hda, and the other three free SATA ports would be hdc,hde,and hdg. Every Linux distro I've tried has issues detecting this, but FreeBSD works fine. I'm going to buy a SATA to PATA adapter, attach it to ata2, and see if that allows it to detect the CD, because I don't like BSD. Otherwise, a USB boot allowed me to at least get a working system, but still no CD.
Doug: moving your DVD drive to one of the first four ports might fix the problem, if it isn't already.

Revision history for this message
Doug (helltoad1969) wrote :

FYI,

Tried installing the latest version (Edgy?) and it installed like a charm. Of course it is very rough around the edges (the time-set gui bombs etc), but no sata problems what-so-ever.

https://wiki.ubuntu.com/EdgyEft

Now if I could figure out how to install Dapper from within my running Edgy...

Revision history for this message
firefoxtester (gregpinero) wrote :

I think I'm having the same problem. I went ahead and made a new bug report though just to be sure:
https://launchpad.net/distros/ubuntu/+bug/58358

Also after doing research I'm thinking this is the same bug also:
https://launchpad.net/distros/ubuntu/+source/linux-source-2.6.17/+bug/57502

Here is a discussion on what may be the same issue:
http://www.suseforums.net/index.php?s=1776552b3af9bce7c0979825972c41f3&showtopic=22963&pid=126481&st=0&#entry126481

Doing a search in the forums for: GA-965P-DS3 also brings up a few people with the same problem.

How and when will this get fixed? Does anyone know? CAn I do anything to help??

Revision history for this message
firefoxtester (gregpinero) wrote :

I made a wiki page to put all of the information about this issue in one place:
https://wiki.ubuntu.com/Core_2_Duo_Support

As you can see it's a pretty major issue. There are already 3 bugs and at least 9 forum threads regarding this. Hopefully we can get this fixed for Edgy.

Revision history for this message
@rne (arne-muecke) wrote :

Hello, I have a Gigabyte 965P-DS4 and the same Problem as tari. Disable ATA1, 2 usw. No detection with may Nec 4550A at ATA1 -.-

Revision history for this message
Toni Helenius (toni-helenius) wrote :

I get this problem with every Edgy CD/DVD, as well as with Feistry Herd #1. Alternates tells me that it can't find DVD/CD drive. And desktop ones end up like: https://launchpad.net/distros/ubuntu/+bug/75135.

I have Intel DG965WH motherboard, Intel Core Duo processor and Nec's 18x Optriarc DVD-writer.

Please fix this! I can't install any Kubuntu :(

Revision history for this message
Toni Helenius (toni-helenius) wrote :

Ok, now the Live CD (Kubuntu Herd #2 AMD64) apparently works, except for the installer crashing on partitioning phase. But still the alternative CD fails to find the DVD-drive. This saddens me :(

Revision history for this message
Christoph Witzany (mail-doublemalt) wrote :

I have a Intel DQ965gf Mainboard and even with the newest Feisty version (Herd 5) I get this error.

Revision history for this message
Shriramana Sharma (jamadagni) wrote :

At https://launchpad.net/ubuntu/+bug/58358/comments/13 Ben said this bug was fixed and uploaded to dapper-proposed and edgy-proposed. Presumably it will be fixed for feisty. Even if it doesn't make its way out of the proposed repos, you can do a hd-install as said for edgy at http://ubuntuforums.org/showthread.php?t=316093

Make sure you get the initrd.gz and vmlinuz images for feisty from http://archive.ubuntu.com/ubuntu/dists/feisty/main/installer-i386/current/images/hd-media/
The edgy files may not work for feisty.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers