Please upgrade opera in dapper-commercial to 9.02

Bug #62405 reported by Conrad Knauer
280
Affects Status Importance Assigned to Milestone
Ubuntu
High
Tollef Fog Heen

Bug Description

The Ubuntu Dapper Commercial Repository hosts the Opera web browser. When it was introduced, dapper-commercial had the latest version, 9.00; since then version 9.01 was released as a DEB on the Opera site, but was not picked up in dapper commercial. Now version 9.02 is out (also as a DEB) and contains a fix for a "highly critical" security flaw:

http://www.opera.com/support/search/supsearch.dml?index=845

Please update the dapper-commercial version as it is a security risk!
---

BTW, when I tried to submit this bug, the package "opera" DOES appear when I searched for it with "Choose.." but when I pressed submit it said:

"opera" does not exist in Ubuntu. Please choose a different package. If you're unsure, please select "I don't know"

Revision history for this message
Dennis Kaarsemaker (dennis) wrote :

Tollef, I vaguely remember that you're the person with contacts at opera, so I subscribed you.

Revision history for this message
Louis (louisdk) wrote :

Please update Ubuntu.

Revision history for this message
Conrad Knauer (atheoi) wrote :

Louis: you can always add the official Opera repository to your sources.list file:

from Terminal run:

sudo gedit /etc/apt/sources.list

add these two lines:

## Opera
deb http://deb.opera.com/opera testing non-free

save the file and then add the Opera public key by running the following:

gpg --keyserver subkeys.pgp.net --recv 6A423791 && gpg --export --armor 6A423791 | sudo apt-key add -

Run Synaptic, press reload and apply and you should get the latest version of Opera if you already have the "opera" package installed.

Revision history for this message
Kai Kasurinen (kai-kasurinen) wrote :

opera (9.10-20061214.6ubuntu1) dapper-commercial; urgency=low

  * debian/control:
    - use ${shlibs:Depends} for the dependency generation
  * debian/rules:
    - uncomment dh_shlibdeps)
    - added dh_desktop
    - added dh_iconcache
  * Removed DH_COMPAT=1 in debian/rules and add debian/compat
  * Changed relative path for package in debian/rules to debian/opera
  * Added opera.desktop, commented out the the section of debian/rules that
    managed it, and adjust debian/dirs accordingly
  * Commented out the section of debian/rules that copied the icons around
    (not relevant to Ubuntu), and adjust debian/dirs and debian/rules
    accordingly
  * Removed leading "/" from debian/dirs
  * Removed debian/conffiles, conf files in /etc are taken care of by
    debhelpers

 -- Etienne Goyer <email address hidden> Mon, 8 Jan 2007 15:34:48 -0500

To post a comment you must log in.
This report contains Public Security information  Edit
Everyone can see this security related information.

Duplicates of this bug

Other bug subscribers