Change log for 7kaa package in Ubuntu

15 of 5 results
Published in bionic-release on 2017-10-24
Published in artful-release on 2017-07-27
Deleted in artful-proposed (Reason: moved to release)
7kaa (2.14.7+dfsg-1) unstable; urgency=medium

  * debian/rules:
    + remove override_dh_builddeb, xz is the default compression.
    + enable all hardening build flags, including bindnow.
  * debian/copyright:
    + update the exclude list according to upstream changes.
    + update years and Format: url.
  * New upstream version 2.14.7+dfsg.
  * Refresh patches.
  * Build-depend on libcurl4-gnutls-dev.
  * Standards-Version: 4.0.0.

 -- Bertrand Marc <email address hidden>  Wed, 26 Jul 2017 15:28:45 +0200

Available diffs

Superseded in artful-release on 2017-07-27
Published in zesty-release on 2016-11-02
Deleted in zesty-proposed (Reason: moved to release)
7kaa (2.14.6+dfsg-1) unstable; urgency=medium

  * Use my @debian.org address in the uploaders field and in debian/copyright.
  * Moved the package to Git.
  * Remove the fix_format_security patch, included upstream.
  * Migrate from a manual "-dbg" package to an automatic generated debug symbol
    package:
    + debian/control: remove 7kaa-dbg and remove it from 7kaa Suggests.
    + debian/rules: use --dbgsym-migration in override_dh_strip.
  * Use system libuiid:
    + Add a patch to replace every occurrence of guuid and misc.uuid.
    + Exclude src/common/misc_uuid.cpp,include/misc_uuid.h and COPYING.uuid in
      debian/copyright.
    + Build-depends on uuid-dev.
    + Add dversionmangle to debian/watch.
  * Update years and license text in debian/copyright.
  * New upstream version 2.14.6.
  * Remove debian/7kaa.menu, deprecated.
  * Standards-version 3.9.8.

 -- Bertrand Marc <email address hidden>  Tue, 20 Sep 2016 08:21:57 +0200

Available diffs

Superseded in zesty-release on 2016-11-02
Published in yakkety-release on 2016-04-22
Published in xenial-release on 2015-10-22
Published in wily-release on 2015-08-04
Deleted in wily-proposed (Reason: moved to release)
7kaa (2.14.5-1) unstable; urgency=medium

  * Update debian/watch.
  * New upstream release.
  * debian/control: update build dependencies according to README.
    + use libsdl2-dev instead of libsdl1.2-dev.
    + use libenet-dev instead of libsdl-net1.2-dev.
  * Refresh the only patch.
  * Add a patch picked upstream to fix build with -Werror=format-security.
  * Update debian/copyright.
  * Standards-version 3.9.6: no changes needed.
  * debian/rules: pass dpkg-buildflags to configure.

 -- Bertrand Marc <email address hidden>  Wed, 29 Jul 2015 18:23:06 +0200

Available diffs

Superseded in wily-release on 2015-08-04
Published in vivid-release on 2014-10-23
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2013-10-18
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed (Reason: moved to release)
7kaa (2.14.4-1) unstable; urgency=low


  * New upstream release.
  * Add myself to uploaders.
  * Remove quilt build-dep as package is format 3.0 (quilt).
  * Add build-arch and build-indep targets in rules.
  * Manually add relro to LDLFAGS in rules for now.
  * Create data packages since data is in single tarball now.
  * Fix watch file.
  * Bump Standards Version to 3.9.4.

  [ Markus Koschany ]
  * Bump compat level to 9 and require debhelper >= 9.
  * 7kaa.desktop: Add keywords.
  * 7kaa.menu: Use an absolute icon path.
  * debian/control:
    - Remove dh-buildinfo from build-dep, not needed.
    - Add dh-autoreconf to Build-Depends.
    - Remove superfluous ${shlibs:Depends} substvar from 7kaa-dbg.
  * debian/rules:
    - Simplify debian/rules by using dh sequencer.
    - Build with --parallel and --autoreconf.
    - Use xz compression.
  * Update debian/copyright top copyright format 1.0.

 -- Barry deFreese <email address hidden>  Sun, 16 Jun 2013 10:33:37 -0400

Available diffs

Superseded in saucy-release on 2013-06-25
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
Published in precise-release on 2011-10-13
Obsolete in oneiric-release on 2015-04-24
7kaa (2.14.3-1) unstable; urgency=low

  [ Bertrand Marc ]
  * Initial release (Closes: #591302).
  * Use dh_autotools-dev to update and restore config.*.

  [ Miriam Ruiz ]
  * New upstream release
 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  04 May 2011 09:04:28 +0000
15 of 5 results