everything loads fine, but no sound, only 1 channel in alsamixer

Bug #33719 reported by Ariel Vardi on 2006-03-04
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Medium
Daniel T Chen

Bug Description

Hi,

I've just installed Ubuntu Dapper on my new Vaio SZ110.
I've seen similar bugs in the database but this one seems to apply to the SigmaTel codec.

Everything loads fine, all the modules seems to be installed successfully. Alsa mixer reports only one channel called PCM, nothing else. This channel is unmuted and the volume at its maximum. But still, there is no sound at all.
The gnome volume controller reports the same thing.

This laptop model came out very recently.

Here is all the information regarding my machine that i thought could be relevant to this bug.

----
root@haifa:/home/ariel# lsmod | grep hda_intel
snd_hda_intel 19056 2
snd_hda_codec 92576 1 snd_hda_intel
snd_pcm 96644 3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd 59972 10 snd_hda_intel,snd_hda_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
snd_page_alloc 11304 2 snd_hda_intel,snd_pcm
root@haifa:/home/ariel#

here's the line for the sound in lspci:
0000:00:1b.0 0403: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

here is the content of /proc/asound/cards:
0 [Intel ]: HDA-Intel - HDA Intel
                     HDA Intel at 0xdc340000 irq 74

root@haifa:/home/ariel# cat /proc/asound/card0/codec#0
Codec: SigmaTel ID 7661
Address: 0
Vendor Id: 0x83847661
Subsystem Id: 0x104d0700
Revision Id: 0x104201
Default PCM: rates 0x7e0, bits 0x0e, types 0x1
Default Amp-In caps: ofs=0x00, nsteps=0x0f, stepsize=0x05, mute=1
Default Amp-Out caps: ofs=0x7f, nsteps=0x7f, stepsize=0x02, mute=1
Node 0x02 [Audio Output] wcaps 0xd0c05: Stereo Amp-Out
  Amp-Out caps: N/A
  Amp-Out vals: [0xff 0xff]
  Power: 0x33
Node 0x03 [Audio Output] wcaps 0xd0c05: Stereo Amp-Out
  Amp-Out caps: N/A
  Amp-Out vals: [0xff 0xff]
  Power: 0x33
Node 0x04 [Audio Output] wcaps 0xd0c05: Stereo Amp-Out
  Amp-Out caps: N/A
  Amp-Out vals: [0xff 0xff]
  Power: 0x33
Node 0x05 [Audio Output] wcaps 0xd0c05: Stereo Amp-Out
  Amp-Out caps: N/A
  Amp-Out vals: [0xff 0xff]
  Power: 0x33
Node 0x06 [Audio Input] wcaps 0x1d0541: Stereo
  Power: 0x33
  Connection: 1
     0x07
Node 0x07 [Audio Selector] wcaps 0x300903: Stereo Amp-In
  Amp-In caps: N/A
  Amp-In vals: [0x80 0x80]
  Connection: 1
     0x0e
Node 0x08 [Audio Input] wcaps 0x1d0541: Stereo
  Power: 0x33
  Connection: 1
     0x09
Node 0x09 [Audio Selector] wcaps 0x300903: Stereo Amp-In
  Amp-In caps: N/A
  Amp-In vals: [0x80 0x80]
  Connection: 1
     0x15
Node 0x0a [Pin Complex] wcaps 0x400181: Stereo
  Pincap 0x08173c: IN OUT HP
  Pin Default 0x012110f0: [Jack] HP Out at Ext Rear
    Conn = 1/8, Color = Black
  Pin-ctls: 0x00:
  Connection: 1
     0x02
Node 0x0b [Pin Complex] wcaps 0x400181: Stereo
  Pincap 0x0814: OUT
  Pin Default 0x40f000fb: [N/A] Other at Ext N/A
    Conn = Unknown, Color = Unknown
  Pin-ctls: 0x00:
  Connection: 1
     0x04
Node 0x0c [Pin Complex] wcaps 0x400181: Stereo
  Pincap 0x0814: OUT
  Pin Default 0x40f000fc: [N/A] Other at Ext N/A
    Conn = Unknown, Color = Unknown
  Pin-ctls: 0x00:
  Connection: 1
     0x03
Node 0x0d [Pin Complex] wcaps 0x400181: Stereo
  Pincap 0x08173c: IN OUT HP
  Pin Default 0x41a15020: [N/A] Mic at Ext Rear
    Conn = 1/8, Color = Red
  Pin-ctls: 0x00:
  Connection: 1
     0x02
Node 0x0e [Pin Complex] wcaps 0x400081: Stereo
  Pincap 0x0824: IN
  Pin Default 0x90370060: [Fixed] CD at Int N/A
    Conn = Analog, Color = Unknown
  Pin-ctls: 0x00:
Node 0x0f [Pin Complex] wcaps 0x400181: Stereo
  Pincap 0x0814: OUT
  Pin Default 0x90170010: [Fixed] Speaker at Int N/A
    Conn = Analog, Color = Unknown
  Pin-ctls: 0x00:
  Connection: 1
     0x05
Node 0x10 [Audio Output] wcaps 0x40211: Stereo Digital
  PCM: rates 0x3e0, bits 0x0e, types 0x5
Node 0x11 [Pin Complex] wcaps 0x400301: Stereo Digital
  Pincap 0x0810: OUT
  Pin Default 0x40f000fd: [N/A] Other at Ext N/A
    Conn = Unknown, Color = Unknown
  Pin-ctls: 0x00:
  Connection: 2
     0x10* 0x09
Node 0x12 [Audio Input] wcaps 0x140311: Stereo Digital
  PCM: rates 0x160, bits 0x0e, types 0x5
  Connection: 1
     0x13
Node 0x13 [Pin Complex] wcaps 0x440381: Stereo Digital
  Pincap 0x0834: IN OUT
  Pin Default 0x40f000fe: [N/A] Other at Ext N/A
    Conn = Unknown, Color = Unknown
  Pin-ctls: 0x00:
  Connection: 1
     0x18
Node 0x14 [Pin Complex] wcaps 0x400001: Stereo
  Pincap 0x0820: IN
  Pin Default 0x90a7002e: [Fixed] Mic at Int N/A
    Conn = Analog, Color = Unknown
  Pin-ctls: 0x00:
Node 0x15 [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
  Amp-Out caps: ofs=0x00, nsteps=0x04, stepsize=0x27, mute=1
  Amp-Out vals: [0x00 0x00]
  Connection: 4
     0x0a* 0x0d 0x14 0x02
Node 0x16 [Beep Generator Widget] wcaps 0x70000c: Mono Amp-Out
  Amp-Out caps: ofs=0x03, nsteps=0x03, stepsize=0x17, mute=0
  Amp-Out vals: [0x00]
Node 0x17 [Volume Knob Widget] wcaps 0x600000: Mono
Node 0x18 [Audio Output] wcaps 0x40201: Stereo Digital

Daniel T Chen (crimsun) wrote :

There is current (low-priority) work to merge the necessary HDA changes for another codec from upstream, so the necessary bits to fiddle for your hardware may be updated coincidentally, but it looks like your hardware may be too new to support in time for Dapper. Dapper+1 is definite.

Ariel Vardi (ariel-vardi) wrote :

Thanks for the answer Chen. Is there any way to install the appropriate driver manually if it's not scheduled to be merged in the very near future? Is it supported by alsa in some way? I wasn't able to find any information about it. Do you have a url where I could find more information about this?

Thanks again,

Ariel

Daniel T Chen (crimsun) wrote :

Yes, you'll need current cvs snapshots (1.0.11rc3 is insufficient, as work was merged post-1.0.11rc3) of the alsa-driver and alsa-kernel modules. You'll need the build-essential, automake1.9, autoconf, and cvs packages installed. Instructions for generating the hda-intel driver from cvs are found in the INSTALL file (scroll halfway through the file and follow the cvs instructions section) of alsa-driver, which you'll checkout.

I am currently working to push the necessary changes into a git branch so they can be considered by the kernel team lead.

That's great news! I'll test these drivers and let you know how it went.
Thanks!

On Fri, 2006-03-10 at 07:22 +0000, Daniel T. Chen wrote:
> Public bug report changed:
> https://launchpad.net/malone/bugs/33719
>
> Comment:
> Yes, you'll need current cvs snapshots (1.0.11rc3 is insufficient, as
> work was merged post-1.0.11rc3) of the alsa-driver and alsa-kernel
> modules. You'll need the build-essential, automake1.9, autoconf, and cvs
> packages installed. Instructions for generating the hda-intel driver
> from cvs are found in the INSTALL file (scroll halfway through the file
> and follow the cvs instructions section) of alsa-driver, which you'll
> checkout.
>
> I am currently working to push the necessary changes into a git branch
> so they can be considered by the kernel team lead.

Ariel Vardi (ariel-vardi) wrote :

I tried the current cvs snapshot and it doesn't work either. It seems like this chipset is not yet supported.

apply this patch to the alsa cvs snapshot to enable support for the sigmatel codec. It works for the Vaio SZ and FE

Ariel Vardi (ariel-vardi) wrote :

type:
echo "options snd-hda-intel model=vaio" | sudo tee -a /etc/modprobe.d/snd-hda-intel

to create the /etc/modprobe.d/snd-hda-intel to load the module with the appropriate parameter.

reboot, and the sound should work

Daniel T Chen (crimsun) wrote :

Thanks, I'll apply this to my git branch and submit it.

Changed in alsa-driver:
assignee: nobody → crimsun
status: Unconfirmed → Confirmed
Daniel T Chen (crimsun) on 2006-03-16
Changed in alsa-driver:
status: Confirmed → Fix Committed

I backported the patch to the current Ubuntu Dapper kernel. The dependencies on the CVS alsa were easy to deal with. I've tested this with my VAIO SZ and it works fine.

Daniel T Chen (crimsun) wrote :

James, see the comment above yours. The changes were pushed to BenC two weeks ago.

Changed in alsa-driver:
status: Fix Committed → Fix Released

In case this patch is not accepted in time for Dapper, is there another temporary workaround for the problem that does not require rebuilding the kernel?

Daniel T Chen (crimsun) wrote :

Stefan, the changes are already in our current kernel (hence why it's marked 'Fix Released').

Hi Daniel

Thanks, I missed that. I upgraded my dapper two days ago and the bug
was still present, which is why I thought it hadn't been merged.
Maybe I am seeing another bug.

Thanks for clarifying.

Cheers
Stéfan

On Tue, Apr 25, 2006 at 11:28:11PM -0000, Daniel T. Chen wrote:
> Stefan, the changes are already in our current kernel (hence why it's
> marked 'Fix Released').
>
> --
> everything loads fine, but no sound, only 1 channel in alsamixer
> https://launchpad.net/bugs/33719

Franck (alci) wrote :

I am using Dapper with latest 686 packaged kernel (linux-image-2.6.15-25-686 2.6.15-25.43) on a Sony Vaio SZ1M.

Alsamixer sees a HDA Sigmatel STAC7661 chipset and shows two items : Master and PCM.

Sound is fine on internal speakers, but I have still one problem :

when I plug headphones, internal speakers are muted (fine) but there is no sound on the headphones...

I can confirm that after loading the module with the appropriate parameter as Ariel suggested in his post (posted at 2006-03-14 18:19:06 UTC) fixed the problem Franck is reporting. My setup is 2.6.15-25-686 kernel on a Sony Vaio SZ1HP (similar to SZ1M spec-wise).

Franck (alci) wrote :

A little bit late, but I also confirm adding the "options snd-hda-intel model=vaio" in modprobe.d works on my laptop (SZ1M). Both speakers and headphones work !! Great.

Thanks,
Franck

Douma Motors (agreatwhitebird) wrote :

I trouble with a fresh Gutsy install on my Toshiba a200 (with intel's IHC8 family soundcard).

my speakers worked but my headphone jack wasn't being detected or showing up in the alsa mixer, nor was it working. Speakers didn't mute when I plugged my phones in.

But this fixes a lot of problems with these sound cards, because it ends up hooking you up with the latest alsa drivers, which i found hard to install elsewhere...

THE LINK THAT FIXED MY SOUND:
http://linuxtechie.wordpress.com/2007/10/19/getting-intel-ich8-family-rev-3-sound-card-to-work-in-gutsy/

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers