Ubuntu

Change log for “amarok” package in Ubuntu

175 of 186 results
Published in trusty-release on 2013-10-18
Published in saucy-release on 2013-09-26
Deleted in saucy-proposed (Reason: moved to release)
amarok (2:2.8.0-0ubuntu3) saucy; urgency=low

  * Set amzdownloader to NoDisplay as the name is terrible and the UI
    also doesn't do much in terms of affordance.
    Using kubuntu_hide_amz.diff.
 -- Harald Sitter <email address hidden>   Wed, 25 Sep 2013 13:25:47 +0200
Superseded in saucy-release on 2013-09-26
Deleted in saucy-proposed on 2013-09-27 (Reason: moved to release)
amarok (2:2.8.0-0ubuntu2) saucy; urgency=low

  * Update debian/rules and debian/amarok.install and
    amarok-common.install to explicitly install
    context applet analyzer related files to
    non-arm architecture.
 -- Howard Chan <email address hidden>   Fri, 16 Aug 2013 21:27:23 +0800
Superseded in saucy-release on 2013-08-16
Deleted in saucy-proposed on 2013-08-17 (Reason: moved to release)
amarok (2:2.8.0-0ubuntu1) saucy; urgency=low

  [ Howard Chan ]
  * New upstream release (LP:#1212722)
  * Refresh debian_disable_qtscriptbindings_check_fix.diff due to
    fuzz.

  [ Philip Muškovac ]
  * Bump build-dep on libmygpo-qt to >= 1.0.7 to match cmake
  * Add link to stable release location to watch file
 -- Howard Chan <email address hidden>   Fri, 16 Aug 2013 00:09:34 +0800
Superseded in saucy-release on 2013-08-16
Deleted in saucy-proposed on 2013-08-17 (Reason: moved to release)
amarok (2:2.7.90-0ubuntu1) saucy; urgency=low

  * New upstream release
  * Update amarok.install and amarok-common.install
    for new files.
  * Update debian_find_mysql_fix.diff and
    debian_disable_qtscriptbindings_check_fix.diff.
  * Remove 0001-Remove-usage-of-fake-Amarok-Mockup-theme.patch
    since it is included in this upstream release.
 -- Howard Chan <email address hidden>   Thu, 04 Jul 2013 22:16:53 +0800
Superseded in saucy-release on 2013-08-02
Deleted in saucy-proposed on 2013-08-03 (Reason: moved to release)
amarok (2:2.7.1-0ubuntu3) saucy; urgency=low

  * Add 0001-Remove-usage-of-fake-Amarok-Mockup-theme.patch from upstream so
    amarok doesn't crash with KDE SC 4.11
 -- Philip Muskovac <email address hidden>   Mon, 24 Jun 2013 22:09:44 +0200
Superseded in saucy-release on 2013-06-25
Deleted in saucy-proposed on 2013-06-26 (Reason: moved to release)
amarok (2:2.7.1-0ubuntu2) saucy; urgency=low

  * Drop kubuntu_qtwebkit_crash.diff, applied upstream
 -- Rohan Garg <email address hidden>   Fri, 17 May 2013 22:49:23 +0100
Superseded in saucy-release on 2013-05-18
Deleted in saucy-proposed on 2013-05-19 (Reason: moved to release)
amarok (2:2.7.1-0ubuntu1) saucy; urgency=low

  * New upstream release
 -- <email address hidden> (Jessie A. Morris)   Wed, 15 May 2013 22:40:31 +0000
Published in raring-updates on 2013-05-16
Deleted in raring-proposed (Reason: moved to -updates)
amarok (2:2.7.0-0ubuntu2.1) raring-proposed; urgency=low

  * Backport fix to raring

Superseded in saucy-release on 2013-05-17
Deleted in saucy-proposed on 2013-05-18 (Reason: moved to release)
amarok (2:2.7.0-0ubuntu3) saucy; urgency=low

  * Add kubuntu_qtwebkit_crash.diff
    Fix crashes on track change in QtWebKit LP: #1177781
 -- Jonathan Riddell <email address hidden>   Wed, 08 May 2013 14:09:54 +0100
Superseded in saucy-release on 2013-05-08
Published in raring-release on 2013-02-17
Deleted in raring-proposed (Reason: moved to release)
amarok (2:2.7.0-0ubuntu2) raring; urgency=low

  * Add missing epoch to several breaks/replaces versions
 -- Philip Muskovac <email address hidden>   Sun, 17 Feb 2013 01:06:45 +0100
Superseded in raring-release on 2013-02-17
Deleted in raring-proposed on 2013-02-18 (Reason: moved to release)
amarok (2:2.7.0-0ubuntu1) raring; urgency=low

  * New upstream release
  * Remove spectrum analyzer file from debian/rules, no longer upstream
  * Add build-dep on libofa0-dev
 -- Jonathan Riddell <email address hidden>   Fri, 18 Jan 2013 15:06:21 +0000
Superseded in raring-release on 2013-01-18
Deleted in raring-proposed on 2013-01-20 (Reason: moved to release)
amarok (2:2.6.90-0ubuntu3) raring; urgency=low

  * remove spectrum analyzer files from amarok.install, already in debian/rules
 -- Jonathan Riddell <email address hidden>   Mon, 07 Jan 2013 10:46:42 +0000
Superseded in raring-proposed on 2013-01-07
amarok (2:2.6.90-0ubuntu2) raring; urgency=low

  * Install libamarok_service_lastfm_shared.so, required by
    the last.fm plugin
 -- Rohan Garg <email address hidden>   Sun, 16 Dec 2012 17:00:58 +0000
Superseded in raring-proposed on 2012-12-16
amarok (2:2.6.90-0ubuntu1) raring; urgency=low

  * New upstream release [LP: #1090689]
    - Drop 0001-port-to-liblastfm1-api.patch
    - Add nepomuk-core-dev, clamz as build-deps
    - Update install files
    - Update not-installed
    - Update watch file
 -- Rohan Garg <email address hidden>   Sat, 15 Dec 2012 15:24:07 +0000
Published in quantal-updates on 2012-11-26
Deleted in quantal-proposed (Reason: moved to -updates)
amarok (2:2.6.0-0ubuntu2.1) quantal-proposed; urgency=low

  * Fix typo ( media-player-infoxs => media-player-info ) (LP: #1078772)
 -- Rohan Garg <email address hidden>   Wed, 14 Nov 2012 16:05:45 +0000
Superseded in raring-release on 2013-01-07
Deleted in raring-proposed on 2013-01-08 (Reason: moved to release)
amarok (2:2.6.0-0ubuntu3) raring; urgency=low

  * Fix typo ( media-player-infoxs => media-player-info )
 -- Rohan Garg <email address hidden>   Wed, 14 Nov 2012 15:47:00 +0000
Superseded in raring-release on 2012-11-14
Published in quantal-release on 2012-08-21
amarok (2:2.6.0-0ubuntu2) quantal; urgency=low

  * Build-dep on libgpod-dev not libgpod-dev-nogtk as it
    no longer depends on gtk LP: #260091
 -- Jonathan Riddell <email address hidden>   Tue, 21 Aug 2012 11:20:49 +0100
Superseded in quantal-release on 2012-08-21
amarok (2:2.6.0-0ubuntu1) quantal; urgency=low

  * New upstream release
  * Recommend media-player-info
 -- Jonathan Riddell <email address hidden>   Tue, 14 Aug 2012 11:08:28 +0100
Superseded in quantal-release on 2012-08-14
amarok (2:2.6~rc1-0ubuntu2) quantal; urgency=low

  * remove spectrum analyzer files from amarok.install, already in debian/rules
 -- Jonathan Riddell <email address hidden>   Fri, 10 Aug 2012 15:15:44 +0100
Superseded in quantal-release on 2012-08-10
amarok (2:2.6~rc1-0ubuntu1) quantal; urgency=low

  * New RC release 2.5.96
 -- Jonathan Riddell <email address hidden>   Tue, 07 Aug 2012 10:36:40 +0100
Superseded in quantal-release on 2012-08-07
amarok (2:2.6~beta1-1ubuntu2) quantal; urgency=low

  * Add 0001-port-to-liblastfm1-api.patch from upstream (target 2.7) fixing
    compatibiity with liblastfm1, fairly trivial and simple patch (LP: #1015526)
  * Don't depend on now removed kdemultimedia-dev (is not used anymore anyway)
  * Bump liblastfm build dep to 1.0
 -- Harald Sitter <email address hidden>   Wed, 20 Jun 2012 14:04:18 +0200
Superseded in quantal-release on 2012-07-12
Superseded in quantal-release on 2012-06-15
amarok (2:2.6~beta1-1ubuntu1) quantal; urgency=low

  * Merge from Debian experimental, remaining changes: (LP: 1008645)
    - Don't build-depend on libavformat-dev and libofa0-dev as libavcodec*
      is not allowed on cd images.
    - Don't build-dep on libqt4-opengl-dev on armel and armhf and install
      file manually in debian/rules
    - build-dep on libmygpo
    - Add epoch "2:" to the version number.
    - More complete not-installed
    - Keep build-dep libmysqld-pic at 5.1.36-2 (new version not yet  in archive)
    - Do not manually compress with xz, we handle this in pkg-kde and explicitly
      doing it prevents global control
  * Do not suggest libxine1-ffmpeg as this should have been in the Phonon
    backend to begin with and phonon-xine is no longer used anyway.
  * amarok-common breaks amarok (<< 2.6~beta1-1ubuntu1~) due to wrongly
    packaged desktop files in a previous release
  * Drop patches applied upstream:
    - kubuntu_Make-OpenGl-a-soft-dependency.diff
    - kubuntu_CMake-Move-occurence-of-OPENGL_INCLUDE_DIR-var.diff
    - kubuntu_kdelibs4.8_context_view.diff
  * Refreshed patch kubuntu_mysql_pic_library_path.diff
  * amarok-doc to Break and Replace all previous amarok-help-* packages
    having one big package and keep the diff small was deemed more reasonable
    on IRC
 -- Harald Sitter <email address hidden>   Tue, 05 Jun 2012 15:43:51 +0200
Superseded in quantal-release on 2012-06-05
Published in precise-release on 2012-02-27
amarok (2:2.5.0-0ubuntu6) precise; urgency=low

  * Add package amarok-help-en to reduce the size of amarok-common
 -- Jonathan Riddell <email address hidden>   Mon, 27 Feb 2012 17:33:30 +0000
Superseded in precise-release on 2012-02-27
amarok (2:2.5.0-0ubuntu5) precise; urgency=low

  * Install the spectrum-analyzer context applet.
  * Don't export KUBUNTU_DESKTOP_POT anymore.
  * Move localized handbooks into own packages named amarok-help-$lang.
 -- Felix Geyer <email address hidden>   Sun, 12 Feb 2012 13:33:03 +0100
Superseded in precise-release on 2012-02-12
amarok (2:2.5.0-0ubuntu4) precise; urgency=low

  * Add kubuntu_kdelibs4.8_context_view.diff from upstream for
    https://bugs.kde.org/290123 'Broken context view'
 -- Jonathan Riddell <email address hidden>   Fri, 27 Jan 2012 10:52:46 +0000
Superseded in precise-release on 2012-01-27
amarok (2:2.5.0-0ubuntu3) precise; urgency=low

  * Fix typos in debian/rules
 -- Jonathan Riddell <email address hidden>   Sat, 14 Jan 2012 15:03:23 +0000
Superseded in precise-release on 2012-01-14
amarok (2:2.5.0-0ubuntu2) precise; urgency=low

  * Add patch kubuntu_Make-OpenGl-a-soft-dependency.diff and
    kubuntu_CMake-Move-occurence-of-OPENGL_INCLUDE_DIR-var.diff
    make OpenGL optional, thanks to Kevin Funk
  * Don't build-dep on libqt4-opengl-dev on armel and armhf and install
    file manually in debian/rules
 -- Jonathan Riddell <email address hidden>   Thu, 12 Jan 2012 18:06:50 +0000
Superseded in precise-release on 2012-01-12
amarok (2:2.5.0-0ubuntu1) precise; urgency=low

  * New upstream release
  * Use mysql 5.5 build-dep
  * Add kubuntu_mysql_pic_library_path.diff because mysql_config no longer
    reports mysql_pic library now that mysqlclient has moved
 -- Jonathan Riddell <email address hidden>   Wed, 21 Dec 2011 17:44:37 +0000
Published in oneiric-updates on 2011-12-13
Deleted in oneiric-proposed (Reason: moved to -updates)
amarok (2:2.4.3-1ubuntu2.1) oneiric-proposed; urgency=low

  * Fix infinite loop in context view eating CPU until main window is shown.
    (LP: #854030)
    - Add kubuntu_fix_contextview_loop.diff
 -- Felix Geyer <email address hidden>   Mon, 28 Nov 2011 20:17:29 +0100
Superseded in precise-release on 2011-12-22
amarok (2:2.4.3-1ubuntu3) precise; urgency=low

  * Fix kubuntu-devel address in maintainer field.
  * Fix infinite loop in context view eating CPU until main window is shown.
    (LP: #854030)
    - Add kubuntu_fix_contextview_loop.diff
  * Hardcode the libmysqld_pic dir as mysql_config doesn't emit it anymore.
    - Add kubuntu_mysqld_pic_libdir.diff
  * Update Build-Depends for mysql 5.5.
 -- Felix Geyer <email address hidden>   Mon, 28 Nov 2011 19:45:52 +0100
Superseded in precise-release on 2011-11-28
Published in oneiric-release on 2011-09-16
amarok (2:2.4.3-1ubuntu2) oneiric; urgency=low

  * Remove kubuntu_restricted_install.diff. Phonon-GStreamer (the default
    Phonon backend) handles plugin installation itself.
 -- Jonathan Thomas <email address hidden>   Fri, 16 Sep 2011 16:54:45 +0200
Superseded in oneiric-release on 2011-09-16
amarok (2:2.4.3-1ubuntu1) oneiric; urgency=low

  * Merge from Debian unstable, remaining changes:
    - Don't build-depend on libavformat-dev and libofa0-dev as libavcodec*
      is not allowed on cd images.
    - Don't compress amarok-dbg with bzip2 as pkg-kde-tools uses lzma for
      all packages.
    - Set KUBUNTU_DESKTOP_POT in debian/rules.
    - Add epoch "2:" to the version number.
    - Keep the following patches:
      + kubuntu/03_restricted_install.diff
      + kubuntu/07_dont_ask_music_dir.diff
  * Drop kubuntu/14_soundmenu_fix_desktop_file_path.diff and
    kubuntu/16_mpris2_update_metadata.diff, applied upstream.
  * Only install the documentation files that are actually used.

Obsolete in natty-updates on 2013-06-04
Deleted in natty-proposed on 2013-06-04 (Reason: moved to -updates)
amarok (2:2.4.0-0ubuntu5.1) natty-proposed; urgency=low

  * Don't run dh_scour as it causes rendering bugs. (LP: #786192)
 -- Felix Geyer <email address hidden>   Fri, 27 May 2011 11:26:33 +0200
Superseded in oneiric-release on 2011-08-01
amarok (2:2.4.1-1ubuntu2) oneiric; urgency=low

  * Rebuild with scour disabled in pkg-kde-tools as it caused rendering
    bugs. (LP: #786192)
 -- Felix Geyer <email address hidden>   Fri, 27 May 2011 10:17:43 +0200
Superseded in oneiric-release on 2011-05-27
amarok (2:2.4.1-1ubuntu1) oneiric; urgency=low

  [ Felix Geyer ]
  * Merge from Debian unstable, remaining changes:
    - Build-depend on GTK version of libgpod.
    - Don't build-depend on libavformat-dev and libofa0-dev as libavcodec*
      is not allowed on cd images.
    - Don't compress amarok-dbg with bzip2 as pkg-kde-tools uses lzma for
      all packages.
    - Set KUBUNTU_DESKTOP_POT in debian/rules.
    - Keep the following patches:
      + kubuntu/03_restricted_install.diff
      + kubuntu/07_dont_ask_music_dir.diff
      + kubuntu/14_soundmenu_fix_desktop_file_path.diff
      + kubuntu/16_mpris2_update_metadata.diff
  * Drop kubuntu/10_soundmenu_support.diff, not needed anymore.
    - Drop libindicate-qt-dev from build-deps.
  * Drop kubuntu/12_appmenu_fix.diff, merged upstream.
  * Drop kubuntu/15_mpris2_fix_wrong_status.diff, fixed upstream.
  * Move all patches from patches/kubuntu/ to patches/ and remove the numbers
    in the filenames.

  [ Tarun Kumar Mall ]
  * kubuntu_restricted_install.diff: adapt to new upstream version.

Superseded in oneiric-release on 2011-05-08
Obsolete in natty-release on 2013-06-04
amarok (2:2.4.0-0ubuntu5) natty; urgency=low

  * Add 15_mpris2_fix_wrong_status.diff from master, correctly update
    the playback status property
  * Add 16_mpris2_update_metadata.diff from Aurelien Gateau, notify the
    outside world of track changes
 -- Jonathan Riddell <email address hidden>   Mon, 04 Apr 2011 13:14:00 +0100
Published in lucid-backports on 2011-03-03
amarok (2:2.4.0-0ubuntu4~lucid1) lucid-backports; urgency=low

  * Source backport to lucid (LP: #728447)
    - Drop version requirement on libindicate-qt-dev build-dep
 -- Scott Kitterman <email address hidden>   Thu, 03 Mar 2011 10:27:39 -0500
Obsolete in maverick-backports on 2013-03-05
amarok (2:2.4.0-0ubuntu4~maverick1) maverick-backports; urgency=low

  * Source backprt to maverick (LP: #728447)
    - Drop version requirement on libindicate-qt-dev build-dep
 -- Scott Kitterman <email address hidden>   Thu, 03 Mar 2011 10:20:39 -0500
Superseded in natty-release on 2011-04-04
amarok (2:2.4.0-0ubuntu4) natty; urgency=low

  * Rebuild with libindicate-qt 0.2.5.91-0ubuntu2 to fix dependency
 -- Jonathan Riddell <email address hidden>   Wed, 09 Feb 2011 13:38:11 +0000
Superseded in natty-release on 2011-02-09
amarok (2:2.4.0-0ubuntu3) natty; urgency=low

  * Build against libindicate-qt 0.2.5.91 for soname transition
 -- Jonathan Riddell <email address hidden>   Mon, 07 Feb 2011 18:00:24 +0000
Superseded in natty-release on 2011-02-07
amarok (2:2.4.0-0ubuntu2) natty; urgency=low

  * Restore ampache support. (LP: #706055)
    - Install libampache_account_login.so
  * Don't depend on phonon-backend, the phonon package already takes
    care of this.
 -- Felix Geyer <email address hidden>   Sun, 23 Jan 2011 13:36:38 +0100
Superseded in natty-release on 2011-01-29
amarok (2:2.4.0-0ubuntu1) natty; urgency=low

  * New upstream release.
  * Adapt patches to new upstream version.
  * Reactivate mysqle_amarok_local_errmsg_feature.diff.
  * Drop kubuntu/11_soundmenu_mpris2.0.diff, merged upstream.
  * Drop kubuntu/13_arm_compile.diff, merged upstream.
  * Add kubuntu/14_soundmenu_fix_desktop_file_path.diff to fix Amarok not
    registering with the sound indicator menu. (LP: #693316)
 -- Felix Geyer <email address hidden>   Wed, 12 Jan 2011 01:10:22 +0100
Superseded in natty-release on 2011-01-15
amarok (2:2.3.90-0ubuntu2) natty; urgency=low

  * Add kubuntu/13_arm_compile.diff to fix compile on ARM
 -- Jonathan Riddell <email address hidden>   Thu, 09 Dec 2010 16:25:23 +0000
Superseded in natty-release on 2010-12-10
amarok (2:2.3.90-0ubuntu1) natty; urgency=low

  * New upstream beta release
  * Disable mysqle_amarok_local_errmsg_feature.diff, files gone
  * Disable kubuntu/11_soundmenu_mpris2.0.diff no longer applies
  * Remove kubuntu/13_validate_xml.diff now upstream
  * Remove kubuntu/14_initial_applet_size.diff upstream
  * No not add build-dep on libofa0-dev, this requires libavcodecs which
    can not go on the CD
 -- Jonathan Riddell <email address hidden>   Mon, 06 Dec 2010 18:04:33 +0000
Superseded in natty-release on 2010-12-06
amarok (2:2.3.2-0ubuntu6) natty; urgency=low

  * In 03_restricted_install.diff install gstreamer instead of xine
    plugin
 -- Jonathan Riddell <email address hidden>   Thu, 18 Nov 2010 16:53:57 +0000
Superseded in natty-release on 2010-11-18
amarok (2:2.3.2-0ubuntu5) natty; urgency=low

  * Rebuild against kdelibs5-dev 4.5.2a-0ubuntu2 for libkutils4 transition
 -- Alessandro Ghersi <email address hidden>   Fri, 22 Oct 2010 07:15:54 +0200
Superseded in natty-release on 2010-10-23
Obsolete in maverick-release on 2013-03-05
amarok (2:2.3.2-0ubuntu4) maverick; urgency=low

  * Add kubuntu/14_initial_applet_size.diff to fix incorrect applet size
    on startup.
 -- Felix Geyer <email address hidden>   Sat, 02 Oct 2010 11:45:27 +0200
Superseded in maverick-release on 2010-10-03
amarok (2:2.3.2-0ubuntu3) maverick; urgency=low

  * Make sure clicking on "Amarok" in the Sound Menu raises it, even if it
    has been minimized to tray, patch from Aurélien Gâteau.
    - update kubuntu/11_soundmenu_mpris2.0.diff
 -- Felix Geyer <email address hidden>   Thu, 30 Sep 2010 22:59:25 +0200
Superseded in maverick-release on 2010-10-01
amarok (2:2.3.2-0ubuntu2) maverick; urgency=low

  * Add kubuntu/13_validate_xml.diff recommended by upstream
 -- Jonathan Riddell <email address hidden>   Thu, 23 Sep 2010 17:02:29 +0100
Superseded in maverick-release on 2010-09-23
amarok (2:2.3.2-0ubuntu1) maverick; urgency=low

  * New upstream release.
  * Drop patches that are applied upstream:
    - debian/mysql_no_openssl_fix.diff
    - kubuntu/08_fix_ftbfs_glib_2.25.diff
    - kubuntu/09_fix_applet_destructor_crash.diff
  * Drop patch that is not needed anymore:
    - kubuntu/05_kstatusnotifieritem_gnome_support.diff
  * Adapt patch to new upstream version:
    - debian/mysqle_amarok_local_errmsg_feature.diff
    - kubuntu/10_soundmenu_support.diff
    - kubuntu/11_soundmenu_mpris2.0.diff
  * Update install files.
 -- Felix Geyer <email address hidden>   Thu, 16 Sep 2010 12:47:14 +0200
Superseded in maverick-release on 2010-09-16
amarok (2:2.3.1-1ubuntu8) maverick; urgency=low

  * Add 12_appmenu_fix.diff from Aurélien Gâteau:
    When running Amarok with the appmenu Plasma widget, make sure going to
    "Internet > Magnatune" or any other service does not replace the menubar
    with a weird one-entry menubar.
 -- Felix Geyer <email address hidden>   Wed, 15 Sep 2010 00:43:11 +0200
Superseded in maverick-release on 2010-09-14
amarok (2:2.3.1-1ubuntu7) maverick; urgency=low

  * Update 11_soundmenu_mpris2.0.diff to use correct mpris interface
 -- Jonathan Riddell <email address hidden>   Tue, 31 Aug 2010 10:59:34 +0100
Superseded in maverick-release on 2010-08-31
amarok (2:2.3.1-1ubuntu6) maverick; urgency=low

  * Add 11_soundmenu_mpris2.0.diff from Aurlien Gateau, adds mpris2
    support to Amarok, closes LP: #617367
 -- Jonathan Riddell <email address hidden>   Thu, 26 Aug 2010 15:46:10 +0100
Superseded in maverick-release on 2010-08-26
amarok (2:2.3.1-1ubuntu5) maverick; urgency=low

  * Add 09_fix_applet_destructor_crash.diff, backported from upstream to fix
    a crash when Amarok starts/quits.
 -- Felix Geyer <email address hidden>   Wed, 11 Aug 2010 11:33:17 +0200
Superseded in maverick-release on 2010-08-11
amarok (2:2.3.1-1ubuntu4) maverick; urgency=low

  * Add back 10_soundmenu_support.diff, refreshed
  * Add build-dep on libindicate-qt-dev
 -- Jonathan Riddell <email address hidden>   Wed, 11 Aug 2010 00:57:33 +0100
Superseded in maverick-release on 2010-08-11
amarok (2:2.3.1-1ubuntu3) maverick; urgency=low

  * Add export KUBUNTU_DESKTOP_POT=extragear-multimedia_amarok
 -- Jonathan Riddell <email address hidden>   Mon, 26 Jul 2010 17:48:46 +0100
Superseded in maverick-release on 2010-07-26
amarok (2:2.3.1-1ubuntu2) maverick; urgency=low

  * Rebuilt for qtwebkit transition
 -- Jonathan Riddell <email address hidden>   Wed, 21 Jul 2010 09:49:55 +0100
Superseded in maverick-release on 2010-07-21
amarok (2:2.3.1-1ubuntu1) maverick; urgency=low

  * Merge with Debian unstable, remaining changes:
    - Build-depend on GTK version of libgpod for coinstallability with
      kipi-plugins.
    - Move libqt4-sql-sqlite from Suggests to Recommends.
    - Don't compress amarok-dbg with bzip2 as pkg-kde-tools uses lzma for
      all packages.
    - Keep the following patches:
      + kubuntu/03_restricted_install.diff
      + kubuntu/05_kstatusnotifieritem_gnome_support.diff
      + kubuntu/07_dont_ask_music_dir.diff
  * Fix FTBFS with glib >= 2.25.
    - Add kubuntu/08_fix_ftbfs_glib_2.25.diff
  * Drop patches that are applied upstream:
    - kubuntu/05_kstatusnotifieritem.diff
    - kubuntu/06_mimetypes.diff
    - kubuntu/08_crash_fix_info_applet.diff

Superseded in maverick-release on 2010-05-31
Published in lucid-release on 2010-04-08
amarok (2:2.3.0-0ubuntu4) lucid; urgency=low

  [ Scott Kitterman ]
  * Add amarok replaces amarok-common (<< 2:2.0.2) for better upgrade support

  [ Alessandro Ghersi ]
  * amarok-utils replaces amarok (<= 2:2.2.0-0ubuntu2) (LP: #556535)

  [ Harald Sitter ]
  * In kubuntu/03_restricted_install.diff send the translated programName
    to the restrictedInstall interface instead of a hardcoded name
    + Get rid of unused var warning due to this patch
 -- Harald Sitter <email address hidden>   Thu, 08 Apr 2010 18:04:54 +0200
Superseded in lucid-release on 2010-04-08
amarok (2:2.3.0-0ubuntu3) lucid; urgency=low

  [ Christian Mangold ]
  * Add 08_crash_fix_info_applet.diff as suggested upstream. It fixes a
    crash on startup when info applet is enabled and can be removed
    after Qt 4.6.3 is in the archive.

  [ Jonathan Riddell ]
  * Remove debian-changes-2:2.3.0-0ubuntu2
 -- Christian Mangold <email address hidden>   Mon, 29 Mar 2010 19:34:02 +0200
Superseded in lucid-release on 2010-03-31
amarok (2:2.3.0-0ubuntu2) lucid; urgency=low

  * Update 05_kstatusnotifieritem.diff from Aurelien Gateau, allows icon
    overlay in systray
  * Add 05_kstatusnotifieritem_gnome_support.diff from Aurelien Gateau,
    workaround limited Gnome support in new systray
 -- Jonathan Riddell <email address hidden>   Mon, 29 Mar 2010 13:27:27 +0100
Superseded in lucid-release on 2010-03-29
amarok (2:2.3.0-0ubuntu1) lucid; urgency=low

  [ Mackenzie Morgan ]
  * New upstream release
    - LP: #395876, #438268, #447534, #456139, #466949, #343716, #521389, #540232
  * patches/kubuntu/06_mimetypes.diff: (LP: #191475)
    - Add x-content/audio-cdda and x-content/audio-player to src/amarok.desktop

  [ Jonathan Riddell ]
  * Update debian/patches/kubuntu/05_kstatusnotifieritem.diff from Aurelien Gateau

  [ Jonathan Thomas ]
  * Add kubuntu/07_dont_ask_music_dir.diff, since ~/Music is a sensible default
    that we set by, well, default (LP: #543463)
 -- Mackenzie Morgan <email address hidden>   Thu, 11 Mar 2010 20:05:30 -0500
Superseded in lucid-release on 2010-03-21
amarok (2:2.2.2.90-0ubuntu3) lucid; urgency=low

  * Rebuild to fix broken pot file (LP: #529483)
 -- Harald Sitter <email address hidden>   Tue, 02 Mar 2010 23:56:33 +0100
Superseded in lucid-release on 2010-03-03
amarok (2:2.2.2.90-0ubuntu2) lucid; urgency=low

  * Add kubuntu/05_kstatusnotifieritem.diff from Aurelien Gateau, ports
    systray icon to KStatusNotifierItem, upstream merge
    http://gitorious.org/amarok/amarok/merge_requests/130
 -- Jonathan Riddell <email address hidden>   Fri, 26 Feb 2010 12:13:58 +0000
Superseded in lucid-release on 2010-02-26
amarok (2:2.2.2.90-0ubuntu1) lucid; urgency=low

  * New upstream beta release
 -- Jonathan Riddell <email address hidden>   Mon, 15 Feb 2010 17:35:42 +0000
Superseded in lucid-release on 2010-02-15
amarok (2:2.2.2-0ubuntu1) lucid; urgency=low

  * New upstream release
  * Add patch kubuntu/04_scanning_crash.diff as advised by upstream
 -- Jonathan Riddell <email address hidden>   Mon, 11 Jan 2010 11:20:59 +0000
Superseded in lucid-release on 2010-01-11
amarok (2:2.2.2~beta1-1ubuntu2) lucid; urgency=low

  * Build against new liblastfm
 -- Jonathan Riddell <email address hidden>   Thu, 07 Jan 2010 19:25:59 +0000
Superseded in lucid-release on 2010-01-08
amarok (2:2.2.2~beta1-1ubuntu1) lucid; urgency=low

  * Merge with Debian Experimental, remaining changes:
    - Keep conflicts/replaces on amarok-kde4* packages
    - Build-depend on GTK version of libgpod for coinstallability with
      kipi-plugins
    - Move libqt4-sql-sqlite from Suggests to Recommends
    - Make amarok-common Replace amarok (<< 2:2.0.0) to make 1.4 -> 2.x upgrades
      work properly
    - Keep the following patches:
      + kubuntu_03_restricted_install.diff
      + kubuntu_04_fix_playlist_layout.diff
  * Include /usr/lib/kubuntu-desktop-i18n/debhelper/kubuntu.mk in debian/rules
    for translations support in Kubuntu
 -- Jonathan Thomas <email address hidden>   Sun, 03 Jan 2010 12:18:32 -0500
Superseded in lucid-release on 2010-01-03
amarok (2:2.2.1.90-0ubuntu1) lucid; urgency=low

  * New upstream beta release
  * Remove 04_fix_playlist_layout.diff, merged upstream
 -- Jonathan Riddell <email address hidden>   Mon, 14 Dec 2009 14:37:38 +0000
Superseded in lucid-release on 2009-12-16
amarok (2:2.2.1-0ubuntu2) lucid; urgency=low

  * Merge from Debian Unstable, remaining changes:
    - Build-depend on cdbs and libgtk-dev
    - Changed build-deps to depend on gtk version of libgpod so kpiti-plugins
      and other packages depending on the gtk version can co-exist
    - Keep conflicts/replaces on amarok-kde4* packages
    - Add 04_fix_playlist_layout.diff to fix playlist layout as
      per upstream request
    - Move libqt4-sql-sqlite from Suggests to Recommends (LP: #430105)
    - Make amarok-common Replace amarok (<< 2:2.0.0) to make 1.4 -> 2.x upgrades
      work properly (LP: #421389)
    - Bump amarok-util's replaces version on amarok to 0ubuntu3 (LP: #463426)
    - Keep the following patches:
      + kubuntu_03_restricted_install.diff
      + kubuntu_04_fix_playlist_layout.diff
   * amarok no longer replaces amarok-common (<< 2:2.1.1orig-0ubuntu2)
   * Don't use dpkg-source 3.0 format
 -- Christian Mangold <email address hidden>   Thu, 19 Nov 2009 19:47:03 +0100
Superseded in lucid-release on 2009-11-25
amarok (2:2.2.1-0ubuntu1) lucid; urgency=low

  [Harald Sitter]
  * New upstream release
  * Drop 04_lyrics_script.diff (originated from upstream)
  * Rename mysqle_linkage_fix.diff to mysql_linkage_fix.diff
    and sync with Debian
  * Add 04_fix_playlist_layout.diff to fix playlist layout as
    per upstream request

  [Christian Mangold]
  * Update amarok-common.install with
    usr/share/kde4/apps/amarok/amarok.notifyrc
 -- Christian Mangold <email address hidden>   Sun, 15 Nov 2009 22:07:55 +0100
Superseded in lucid-release on 2009-11-16
Obsolete in karmic-release on 2013-03-04
amarok (2:2.2.0-0ubuntu2) karmic; urgency=low

  * Add 04_lyrics_script.diff from upstream, remove adverts in lyrics

 -- Jonathan Riddell <email address hidden>   Thu, 08 Oct 2009 11:08:11 +0100
Superseded in karmic-release on 2009-10-08
amarok (2:2.2.0-0ubuntu1) karmic; urgency=low

  * New upstream release

 -- Christian Mangold <email address hidden>   Mon, 28 Sep 2009 20:43:54 +0200
Superseded in karmic-release on 2009-10-02
amarok (2:2.1.90-0ubuntu1) karmic; urgency=low

  * New upstream release candidate
  * Move libqt4-sql-sqlite from Suggests to Recommends (LP: #430105)
  * Remove 'override_dh_strip: true' from debian/rules (LP: #433325)
  * Update amarok.install and amarok-common.install
  * Bump version of build-deps, libtag1-dev to 1.6 and libtag-extras-dev
    to 1.0.1, new versions are required now

 -- Christian Mangold <email address hidden>   Tue, 22 Sep 2009 00:10:44 +0200
Superseded in karmic-release on 2009-09-23
amarok (2:2.1.85-0ubuntu1) karmic; urgency=low

  * New upstream beta release
    - Fixes cover download (LP: #335578)
  * Remove 05_fix_lyrics_script.diff, fixed upstream (LP: #409407)
  * Remove 04_gpod_compile.diff, fixed upstream

 -- Christian Mangold <email address hidden>   Mon, 14 Sep 2009 22:26:19 +0200
175 of 186 results