Change log for ant package in Ubuntu

163 of 63 results
Published in cosmic-release on 2018-08-28
Deleted in cosmic-proposed (Reason: moved to release)
ant (1.10.5-2) unstable; urgency=medium

  * Team upload.
  * Lower the minimum required source/target level to 1.6 again.
    This is acceptable for OpenJDK 11 but must be reverted for OpenJDK 12.
    Thanks to Bdale Garbee for the report and patch. (Closes: #906785)
  * Declare compliance with Debian Policy 4.2.1.

 -- Markus Koschany <email address hidden>  Mon, 27 Aug 2018 14:57:47 +0200

Available diffs

Published in trusty-updates on 2018-07-24
Published in trusty-security on 2018-07-24
ant (1.9.3-2ubuntu0.1) trusty-security; urgency=medium

  * SECURITY UPDATE: Fix ZipSlip vulnerability
    - debian/patches/CVE-2018-10886-1.patch: don't extract entires outside of
      the destination directory in
      src/main/org/apache/tools/ant/taskdefs/Expand.java,
      src/tests/antunit/taskdefs/unzip-test.xml
    - debian/patches/CVE-2018-10886-2.patch: Update the manual
      manual/Tasks/unzip.html
    - debian/patches/CVE-2018-10886-3.patch: Small update to the manual entry
      manual/Tasks/unzip.html
    - debian/patches/CVE-2018-10886-4.patch: Change stripAbsolutePathSpec's
      default value
      manual/Tasks/unzip.html
      src/main/org/apache/tools/ant/taskdefs/Expand.java
    - debian/patches/CVE-2018-10886-5.patch: add additional isLeadingPath
      method that resolves symlinks
      src/main/org/apache/tools/ant/util/FileUtils.java
      src/tests/junit/org/apache/tools/ant/util/FileUtilsTest.java
    - debian/patches/CVE-2018-10886-6.patch: take symlinks into account when
      expanding archives and checking entries
      src/main/org/apache/tools/ant/taskdefs/Expand.java
    - CVE-2018-10886

 -- Mike Salvatore <email address hidden>  Mon, 23 Jul 2018 09:07:56 -0400
Published in xenial-updates on 2018-07-24
Published in xenial-security on 2018-07-24
ant (1.9.6-1ubuntu1.1) xenial-security; urgency=medium

  * SECURITY UPDATE: Fix ZipSlip vulnerability
    - debian/patches/CVE-2018-10886-1.patch: don't extract entires outside of
      the destination directory in
      src/main/org/apache/tools/ant/taskdefs/Expand.java,
      src/tests/antunit/taskdefs/unzip-test.xml
    - debian/patches/CVE-2018-10886-2.patch: Update the manual
      manual/Tasks/unzip.html
    - debian/patches/CVE-2018-10886-3.patch: Small update to the manual entry
      manual/Tasks/unzip.html
    - debian/patches/CVE-2018-10886-4.patch: Change stripAbsolutePathSpec's
      default value
      manual/Tasks/unzip.html
      src/main/org/apache/tools/ant/taskdefs/Expand.java
    - debian/patches/CVE-2018-10886-5.patch: add additional isLeadingPath
      method that resolves symlinks
      src/main/org/apache/tools/ant/util/FileUtils.java
      src/tests/junit/org/apache/tools/ant/util/FileUtilsTest.java
    - debian/patches/CVE-2018-10886-6.patch: take symlinks into account when
      expanding archives and checking entries
      src/main/org/apache/tools/ant/taskdefs/Expand.java
    - CVE-2018-10886

 -- Mike Salvatore <email address hidden>  Fri, 20 Jul 2018 13:55:37 -0400
Published in bionic-updates on 2018-07-24
Published in bionic-security on 2018-07-24
ant (1.10.3-1ubuntu0.1) bionic-security; urgency=medium

  * SECURITY UPDATE: Fix ZipSlip vulnerability
    - debian/patches/CVE-2018-10886-1.patch: don't extract entires outside of
      the destination directory in
      src/main/org/apache/tools/ant/taskdefs/Expand.java,
      src/tests/antunit/taskdefs/unzip-test.xml
    - debian/patches/CVE-2018-10886-2.patch: Update the manual
      manual/Tasks/unzip.html
    - debian/patches/CVE-2018-10886-3.patch: Small update to the manual entry
      manual/Tasks/unzip.html
    - debian/patches/CVE-2018-10886-4.patch: Change stripAbsolutePathSpec's
      default value
      manual/Tasks/unzip.html
      src/main/org/apache/tools/ant/taskdefs/Expand.java
    - debian/patches/CVE-2018-10886-5.patch: add additional isLeadingPath
      method that resolves symlinks
      src/main/org/apache/tools/ant/util/FileUtils.java
      src/tests/junit/org/apache/tools/ant/util/FileUtilsTest.java
    - debian/patches/CVE-2018-10886-6.patch: take symlinks into account when
      expanding archives and checking entries
      src/main/org/apache/tools/ant/taskdefs/Expand.java
    - CVE-2018-10886

 -- Mike Salvatore <email address hidden>  Thu, 19 Jul 2018 14:24:04 -0400
Superseded in cosmic-release on 2018-08-28
Deleted in cosmic-proposed on 2018-08-29 (Reason: moved to release)
ant (1.10.5-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
  * Replaced debian/orig-tar.sh with the Files-Excluded mechanism
  * Standards-Version updated to 4.1.5

 -- Emmanuel Bourg <email address hidden>  Mon, 16 Jul 2018 15:14:01 +0200

Available diffs

Superseded in cosmic-release on 2018-08-24
Deleted in cosmic-proposed on 2018-08-26 (Reason: moved to release)
ant (1.10.4-2) unstable; urgency=medium

  * Team upload.
  * Reverted the modification setting the 'release' attribute automatically
    since this renders the internal JDK APIs unavailable at compile time.
    (Closes: #902895)

 -- Emmanuel Bourg <email address hidden>  Tue, 03 Jul 2018 10:53:12 +0200

Available diffs

Superseded in cosmic-release on 2018-07-03
Deleted in cosmic-proposed on 2018-07-05 (Reason: moved to release)
ant (1.10.4-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
    - Refreshed the patches
    - Compile with hamcrest-all on the classpath

 -- Emmanuel Bourg <email address hidden>  Mon, 25 Jun 2018 13:11:09 +0200

Available diffs

Superseded in cosmic-release on 2018-06-25
Deleted in cosmic-proposed on 2018-06-27 (Reason: moved to release)
ant (1.10.3-2) unstable; urgency=medium

  * Team upload.
  * Automatically set the value of the javac --release attribute to improve
    the backward compatibility of the code compiled with Java 9 or later.
  * Standards-Version updated to 4.1.4
  * Use salsa.debian.org Vcs-* URLs

 -- Emmanuel Bourg <email address hidden>  Wed, 13 Jun 2018 23:28:33 +0200

Available diffs

Superseded in cosmic-release on 2018-06-22
Published in bionic-release on 2018-04-01
Deleted in bionic-proposed (Reason: moved to release)
ant (1.10.3-1) unstable; urgency=medium

  * New upstream release
    - Refreshed the patches
    - Changed the source/target level to 1.8 when building Ant
    - Build the new optional ant-xz module
    - Require Java 8 or higher to run Ant
  * Don't use the javadoc --ignore-source-errors option when using
    a custom doclet (Closes: #893547)
  * Adjust the source/target level to 1.7 in anticipation of the 1.6 removal
    in Java 11
  * Added activation.jar to the build classpath to fix the empty ant-javamail
    jar with Java 9

 -- Emmanuel Bourg <email address hidden>  Thu, 29 Mar 2018 09:35:04 +0200

Available diffs

Superseded in bionic-release on 2018-04-01
Deleted in bionic-proposed on 2018-04-02 (Reason: moved to release)
ant (1.9.10-2) unstable; urgency=medium

  * Non maintainer upload.
  * Stop building the gcj packages.
  * Remove Ludovic and Werner as uploaders.

 -- Matthias Klose <email address hidden>  Mon, 19 Mar 2018 10:04:26 +0100

Available diffs

Superseded in bionic-release on 2018-03-20
Deleted in bionic-proposed on 2018-03-21 (Reason: moved to release)
ant (1.9.10-1) unstable; urgency=medium

  * New upstream release
    - Refreshed the patches
  * Standards-Version updated to 4.1.3
  * Switch to debhelper level 11
  * Use a secure URL in debian/watch

 -- Emmanuel Bourg <email address hidden>  Fri, 23 Feb 2018 15:12:23 +0100

Available diffs

Superseded in bionic-release on 2018-02-24
Deleted in bionic-proposed on 2018-02-25 (Reason: moved to release)
ant (1.9.9-6) unstable; urgency=medium

  * Team upload.
  * Standards-Version updated to 4.1.2
  * ignore-source-errors in javadoc invocations (Closes: #884187)

 -- Chris West <email address hidden>  Tue, 19 Dec 2017 14:58:13 +0000

Available diffs

Superseded in bionic-release on 2017-12-20
Deleted in bionic-proposed on 2017-12-21 (Reason: moved to release)
ant (1.9.9-5) unstable; urgency=medium

  [ Chris West (Faux) ]
  * Adjust source/target level in Debian builds in more cases:
    - when ant.build.javac.source is set (Closes: #873969)
    - for javadoc (Closes: #873977)

  [ Emmanuel Bourg ]
  * Standards-Version updated to 4.1.1

 -- Emmanuel Bourg <email address hidden>  Wed, 29 Nov 2017 00:09:31 +0100

Available diffs

Superseded in bionic-release on 2017-12-18
Published in artful-release on 2017-07-02
Deleted in artful-proposed (Reason: moved to release)
ant (1.9.9-4) unstable; urgency=medium

  * Team upload.
  * Adjust the source/target level automatically for Debian builds with Java 9
  * Removed the Breaks/Replaces/Conflicts with the long gone libant1.6-java
  * Standards-Version updated to 4.0.0

 -- Emmanuel Bourg <email address hidden>  Fri, 30 Jun 2017 01:01:54 +0200

Available diffs

Superseded in artful-release on 2017-07-02
Deleted in artful-proposed on 2017-07-03 (Reason: moved to release)
ant (1.9.9-3) unstable; urgency=medium

  * Team upload.
  * Restore the GCJ packages.

 -- Matthias Klose <email address hidden>  Thu, 29 Jun 2017 08:56:24 +0200

Available diffs

Superseded in artful-proposed on 2017-06-29
ant (1.9.9-2) unstable; urgency=medium

  * Team upload.
  * Removed the GCJ packages

 -- Emmanuel Bourg <email address hidden>  Sun, 18 Jun 2017 11:36:49 +0200

Available diffs

Superseded in artful-release on 2017-06-30
Deleted in artful-proposed on 2017-07-01 (Reason: moved to release)
ant (1.9.9-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
    - Removed 0012-BZ-60582.patch (fixed upstream)

 -- Emmanuel Bourg <email address hidden>  Wed, 01 Mar 2017 09:36:22 +0100

Available diffs

Superseded in artful-release on 2017-04-30
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
ant (1.9.8-3) unstable; urgency=medium

  * Removed the newly introduced final modifier on Path.systemClasspath
    to preserve the backward compatibility and fix build failures with Eclipse
    (Closes: #850553)
  * Use a versioned dependency for junit4 (>= 4.11)

 -- Emmanuel Bourg <email address hidden>  Thu, 19 Jan 2017 10:41:24 +0100

Available diffs

Superseded in zesty-proposed on 2017-01-19
ant (1.9.8-2) unstable; urgency=medium

  * Team upload.
  * Fixed a typo in the man pages
  * Removed 0006-fix-ANT_HOME-path.patch (not required)
  * Removed 0008-junit4-replace-assumeFalse.patch
  * debian/rules:
    - Build with the DH sequencer instead of CDBS
    - Removed activation.jar and inetlib.jar from the build classpath
    - Link the build dependencies to lib/optional as expected by the build
      and removed the classpath tweaks
    - Simplified the bootstrapping
    - Removed the unused PACKAGE variable
    - No longer set the TODAY parameter since the Tsamp task is reproducible
    - No longer set the pom version explicitly
  * Improved the package descriptions

 -- Emmanuel Bourg <email address hidden>  Thu, 12 Jan 2017 15:31:33 +0100

Available diffs

Deleted in zesty-proposed on 2017-02-20 (Reason: NBS)
ant (1.9.8-1) unstable; urgency=medium

  * New upstream release
    - Refreshed the patches
  * Reproducibility improvements:
    - The PropertyFile task now honors the SOURCE_DATE_EPOCH variable
      for the date in the header of the .properties file generated
  * Switch to debhelper level 10

 -- Emmanuel Bourg <email address hidden>  Fri, 06 Jan 2017 01:27:38 +0100
Superseded in zesty-release on 2017-03-30
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
ant (1.9.7-3) unstable; urgency=medium

  * Do not set the javadoc encoding/locale parameters if they were already
    set with a <arg/> element (Closes: #823773)

 -- Emmanuel Bourg <email address hidden>  Mon, 16 May 2016 15:14:43 +0200

Available diffs

Superseded in yakkety-release on 2016-05-18
Deleted in yakkety-proposed on 2016-05-20 (Reason: moved to release)
ant (1.9.7-2) unstable; urgency=medium

  * Do not set the javadoc encoding twice (Closes: #821065)

 -- Emmanuel Bourg <email address hidden>  Fri, 15 Apr 2016 09:49:01 +0200
Superseded in yakkety-release on 2016-05-07
Published in xenial-release on 2016-04-08
Superseded in xenial-release on 2016-04-08
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed (Reason: moved to release)
ant (1.9.6-1ubuntu1) wily; urgency=low

  * Merge from Debian unstable.  Remaining changes:
    - Revert back to using libgnumail-java to avoid inclusion of Maven
      in Ubuntu main.

Available diffs

Superseded in wily-release on 2015-07-08
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
ant (1.9.4-3ubuntu1) vivid; urgency=medium

  * Revert back to using libgnumail-java to avoid inclusion of Maven
    in Ubuntu main.
 -- James Page <email address hidden>   Tue, 27 Jan 2015 16:35:45 +0000
Superseded in vivid-proposed on 2015-01-27
ant (1.9.4-3) unstable; urgency=medium


  * Removed the patch adding Xerces to the Ant classpath
    (Closes: #552032, #764376, LP: #324899, LP: #490831, LP: #876091)
  * Removed the dependency on libxerces2-java and libjaxp1.3-java
  * debian/rules: Removed the unused compile.debug and compile.optimize
    properties
  * Refreshed the man page for build.xml

 -- Emmanuel Bourg <email address hidden>  Wed, 08 Oct 2014 00:06:55 +0200
Superseded in vivid-release on 2015-01-27
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to release)
ant (1.9.4-1) unstable; urgency=medium


  * New upstream release
    - Refreshed the patches
    - Removed the patch for #735786 (Fixed upstream)

 -- Emmanuel Bourg <email address hidden>  Fri, 09 May 2014 11:46:04 +0200
Superseded in utopic-release on 2014-05-10
Published in trusty-release on 2014-04-08
Deleted in trusty-proposed (Reason: moved to release)
ant (1.9.3-2build1) trusty; urgency=medium

  * No-change upload to build the ant-gcj package on ppc64el.
 -- Matthias Klose <email address hidden>   Tue, 08 Apr 2014 01:44:03 +0200
Superseded in trusty-release on 2014-04-08
Deleted in trusty-proposed on 2014-04-09 (Reason: moved to release)
ant (1.9.3-2) unstable; urgency=medium


  * Team upload
  * debian/patches
    - add 0009-fix-NullPointerException-when-no-destdir-was-set.patch:
      pick up upstream fix for FTBFS <Closes: #735786>

 -- Hideki Yamane <email address hidden>  Sun, 16 Feb 2014 21:59:46 +0900

Available diffs

Superseded in trusty-release on 2014-02-19
Deleted in trusty-proposed on 2014-02-20 (Reason: moved to release)
ant (1.9.3-1) unstable; urgency=medium


  * New upstream release
  * Standards-Version updated to 3.9.5 (no changes)
  * Switch to debhelper level 9
  * Updated the description of 0008-junit4-replace-assumeFalse.patch
  * debian/rules:
    - Improved the clean target to allow rebuilds
    - Remove the version's -SNAPSHOT suffix by setting the version explicitly
      when calling mh_installjar instead of altering the original pom files
  * Use XZ compression for the upstream tarball
  * Documented the -silent flag in the man page (new in Ant 1.9.0)
  * debian/copyright: Updated to the Copyright Format 1.0

 -- Emmanuel Bourg <email address hidden>  Mon, 06 Jan 2014 23:33:38 +0100

Available diffs

Superseded in trusty-release on 2014-01-07
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
ant (1.9.2-1) unstable; urgency=low


  * New upstream release
  * Use canonical URLs for the Vcs-* fields

 -- Emmanuel Bourg <email address hidden>  Sun, 14 Jul 2013 14:24:45 +0200

Available diffs

Superseded in saucy-release on 2013-07-14
Deleted in saucy-proposed on 2013-07-16 (Reason: moved to release)
ant (1.9.1-2) unstable; urgency=low


  * Team upload.
  * d/maven.rules: Ensure that junit4 dependencies are mapped to 4.x
    junit artefact (Closes: #713381).

 -- James Page <email address hidden>  Tue, 02 Jul 2013 12:03:48 +0100

Available diffs

Superseded in saucy-release on 2013-07-03
Deleted in saucy-proposed on 2013-07-04 (Reason: moved to release)
ant (1.9.1-1) unstable; urgency=low


  * New upstream release
    - Refreshed the patches
    - Removed patch 0001-detect-classpath-based-JVM (merged upstream)
  * Enabled hardening for the -gcj packages
  * Upload to unstable

 -- Emmanuel Bourg <email address hidden>  Wed, 15 May 2013 16:19:56 +0200
Superseded in saucy-release on 2013-05-24
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
ant (1.8.2-4build2) quantal; urgency=low

  * No-change rebuild with openjdk-7 as default-jdk.
 -- James Page <email address hidden>   Fri, 18 May 2012 11:32:43 +0100

Available diffs

Superseded in quantal-release on 2012-05-18
Published in precise-release on 2011-12-03
ant (1.8.2-4build1) precise; urgency=low

  * No-change rebuild to drop spurious libsfgcc1 dependency on armhf.
 -- Adam Conrad <email address hidden>   Fri, 02 Dec 2011 17:30:15 -0700

Available diffs

Superseded in precise-release on 2011-12-03
ant (1.8.2-4) unstable; urgency=low

  * Team upload.
  * Provide ant-junit4.jar.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  17 Oct 2011 09:09:37 +0000

Available diffs

Superseded in precise-release on 2011-10-17
Obsolete in oneiric-release on 2015-04-24
ant (1.8.2-3) unstable; urgency=low

  * Team upload.
  * Fix FTBFS due to changes in libxml-commons-resolver1.1-java 1.2.
    (Closes: #637592).
  * Provide ant-testutil.jar. (Closes: #637593).
 -- Matthias Klose <email address hidden>   Tue,  16 Aug 2011 13:25:38 +0000

Available diffs

Superseded in oneiric-release on 2011-08-16
ant (1.8.2-2) unstable; urgency=low

  * Team upload.
  * Skip javadoc building if we are not building architecture all
    packages.  (Closes: #627110)
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  20 May 2011 08:08:46 +0000

Available diffs

Superseded in oneiric-release on 2011-05-20
ant (1.8.2-1) unstable; urgency=low

  [ James Page ]
  * New upstream release (Closes: #613914).
    - Fix FTBFS for jug with ant 1.8.1 (Closes: #610320).
  * Bumped Standards-Version to 3.9.2, no changes.
  * Removed ant-nodeps.jar from install as now part of ant core. 
  * Added myself to Uploaders.

  [ Niels Thykier ]
  * Added missing mh_clean, thanks to Miguel Landaeta for spotting
    this.
  * Fixed a typo in the ant manpage.
  * Made short descriptions unique.
  * Bumped debhelper compat to 7.
  * Removed empty linda-override dir from ant-doc.
  * Removed redundant Priority fields in d/control.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sat,  07 May 2011 09:26:39 +0000

Available diffs

Superseded in oneiric-release on 2011-05-07
ant (1.8.1-2) unstable; urgency=low

  * Upload to unstable.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  03 May 2011 08:09:42 +0000

Available diffs

Superseded in oneiric-release on 2011-05-03
Obsolete in natty-release on 2013-06-04
ant (1.8.1-1) experimental; urgency=low

  [ Niels Thykier ]
  * Replaced B-D on default-jdk-builddep with gcj-native-helper
    and default-jdk.
  * Bumped Standards-Versions to 3.9.0.
    - Reduced a Conflicts to a Breaks.

  [ Torsten Werner ]
  * New upstream release
  * Update or remove our patches.
  * Do no longer install ant-stylebook.jar and ant-trax.jar because they are no
    longer built.
  * Remove Stefan from Uploaders list. Thanks to your contributions!
 -- Matthias Klose <email address hidden>   Wed,  13 Oct 2010 11:56:48 +0000

Available diffs

Obsolete in lucid-updates on 2016-10-26
Obsolete in lucid-security on 2016-10-26
ant (1.7.1-4ubuntu1.1) lucid-security; urgency=low

  * No change rebuild to pull previous fix into lucid-security. LP: #629742
 -- Steve Beattie <email address hidden>   Fri, 03 Sep 2010 11:20:48 -0700
Obsolete in jaunty-updates on 2013-02-28
Obsolete in jaunty-security on 2013-02-28
ant (1.7.1-0ubuntu2.2) jaunty-security; urgency=low

  * Upload to -security to allow openjdk to be built correctly in
    jaunty-security
 -- Chris Coulson <email address hidden>   Fri, 02 Jul 2010 13:24:27 +0100
Obsolete in karmic-updates on 2013-03-04
Obsolete in karmic-security on 2013-03-04
ant (1.7.1-4ubuntu0.2) karmic-security; urgency=low

  * Upload to -security to allow openjdk to be built correctly in
    karmic-security
 -- Chris Coulson <email address hidden>   Fri, 02 Jul 2010 13:20:23 +0100
Superseded in jaunty-updates on 2010-07-22
Deleted in jaunty-proposed on 2010-07-23 (Reason: moved to -updates)
ant (1.7.1-0ubuntu2.1) jaunty-proposed; urgency=low

  * Fix ant to correctly build JAX-WS. LP: #600272.
 -- Matthias Klose <email address hidden>   Wed, 30 Jun 2010 22:57:00 +0000
Superseded in karmic-updates on 2010-07-22
Deleted in karmic-proposed on 2013-02-27 (Reason: moved to -updates)
ant (1.7.1-4ubuntu0.1) karmic-proposed; urgency=low

  * Fix ant to correctly build JAX-WS. LP: #600272.
 -- Matthias Klose <email address hidden>   Wed, 30 Jun 2010 22:44:07 +0000

Available diffs

Superseded in lucid-updates on 2010-09-23
Deleted in lucid-proposed on 2010-09-24 (Reason: moved to -updates)
ant (1.7.1-4ubuntu1) lucid-proposed; urgency=low

  * Fix ant to correctly build JAX-WS. LP: #600272.
 -- Matthias Klose <email address hidden>   Wed, 30 Jun 2010 23:56:15 +0200
Superseded in natty-release on 2010-10-13
Obsolete in maverick-release on 2013-03-05
ant (1.8.0-4) unstable; urgency=low

  * Convert patches to dep3 format.
  * Add patch from Petr Salinger to fix the nasty bus error in gij. (Closes:
    #570886)
  * Build *-gcj packages again.
  * Add myself to Uploaders.
  * Switch to source format 3.0.

Superseded in maverick-release on 2010-05-09
Obsolete in lucid-release on 2016-10-26
ant (1.7.1-4build1) lucid; urgency=low

  * rebuild rest of main for armel armv7/thumb2 optimization;
    UbuntuSpec:mobile-lucid-arm-gcc-v7-thumb2
 -- Alexander Sack <email address hidden>   Fri, 05 Mar 2010 03:09:33 +0100
Superseded in lucid-release on 2010-03-06
Obsolete in karmic-release on 2013-03-04
ant (1.7.1-4) unstable; urgency=low

  * Fix link to /usr/share/doc/ant-doc/manual/api. You may
    have to uninstall ant-doc then install it again for this
    change to take effect (Closes: #541416)

Available diffs

Superseded in karmic-release on 2009-10-19
ant (1.7.1-0ubuntu3) karmic; urgency=low

  * Drop JDK recommendation to a Suggests to make it feasible to fit ant on
    the server CD (thanks, Thierry Carrez; LP: #389470).

 -- Colin Watson <email address hidden>   Wed, 24 Jun 2009 15:14:55 +0100

Available diffs

Superseded in karmic-release on 2009-06-24
Obsolete in jaunty-release on 2013-02-28
ant (1.7.1-0ubuntu2) jaunty; urgency=low

  * Added 11_ant_underscore_dash_fix.patch fixes - to _ conversion LP: #296409

 -- <email address hidden> (Richard A. Johnson)   Mon, 10 Nov 2008 11:53:55 -0600

Available diffs

Superseded in jaunty-release on 2008-11-10
Obsolete in intrepid-release on 2013-02-20
ant (1.7.1-0ubuntu1) intrepid; urgency=low

  * New upstream version (bug fix release).
    - mainly a bugfix release.
    - has extended support for Java6 features.
    - <script> now has support for JavaFX.
    - release notes: http://apache.linux-mirror.org/ant/README.html
  * Remove debian/patches/05_ant-bug433444.patch. Obsoleted.

 -- Matthias Klose <email address hidden>   Tue, 30 Sep 2008 14:47:45 +0200

Available diffs

Superseded in intrepid-release on 2008-10-03
ant (1.7.0-6ubuntu3) intrepid; urgency=low

  * Set java source and target version to 1.4. LP: #264808.

 -- Matthias Klose <email address hidden>   Mon, 29 Sep 2008 22:39:54 +0000

Available diffs

Superseded in intrepid-release on 2008-09-30
ant (1.7.0-6ubuntu2) intrepid; urgency=low

  * ant: Recommend default-jdk | java-compiler | java-sdk. LP: #205441.

 -- Matthias Klose <email address hidden>   Sat, 06 Sep 2008 17:47:44 +0000

Available diffs

Superseded in intrepid-release on 2008-09-06
ant (1.7.0-6ubuntu1) intrepid; urgency=low

  * ant: Depend on default-jre-headless.

 -- Matthias Klose <email address hidden>   Thu, 31 Jul 2008 09:39:46 +0000

Available diffs

Superseded in intrepid-release on 2008-07-31
ant (1.7.0-6) unstable; urgency=low

  * Moved ant-bootstrap.jar to /usr/share/ant/etc/. Closes: #353586
  * Build-Depends on default-jdk-builddep. Closes: #477844

Superseded in intrepid-release on 2008-05-03
Obsolete in hardy-release on 2015-04-24
Obsolete in gutsy-release on 2011-09-16
ant (1.7.0-3) unstable; urgency=low

  * Upgrade source and target version from 1.2 to 1.3.

Superseded in gutsy-release on 2007-08-29
ant (1.7.0-1) unstable; urgency=low

  * New upstream version. Closes: #412716.
  * Updated debian/patches/01_gjdoc_task.patch.
  * Removed debian/patches/03_SplashTaskPatch_b.patch. Obsoleted.
  * Removed debian/patches/03_SplashTaskPatch_c.patch. Obsoleted.
  * Removed debian/patches/04_UUMailerReflection.patch. Obsoleted.
  * Removed debian/patches/05_TaskAvailabilityFix_ANT_PR38260.patch.
    Obsoleted.

Superseded in gutsy-release on 2007-07-11
Obsolete in feisty-release on 2009-08-20
Obsolete in edgy-release on 2008-06-19
ant (1.6.5-6build1) edgy; urgency=low

  * Manual sync (orig.tar.gz doesn't match).

Superseded in edgy-release on 2006-07-05
Obsolete in dapper-release on 2011-09-06
Superseded in dapper-release on 2006-02-03
ant (1.6.5-3ubuntu1) dapper; urgency=low


  * Synchronise with Debian unstable.

 -- Matthias Klose <email address hidden>  Wed, 26 Oct 2005 20:10:48 +0000
Obsolete in breezy-release on 2008-03-25
ant (1.6.5-0ubuntu4) breezy; urgency=low


  * Make sure to build with the ecj compiler and give proper options to
    bootstrap.sh.  Ubuntu #14593.

 -- Tollef Fog Heen <email address hidden>  Wed, 14 Sep 2005 12:07:01 +0200
Obsolete in hoary-release on 2008-03-19
ant (1.6.2-2ubuntu2) hoary; urgency=low


  * Adjusted path of GCJ in response to a FTBFS.

 -- Jerry Haltom <email address hidden>  Wed, 30 Mar 2005 20:00:43 -0600
Obsolete in warty-release on 2008-01-09
ant (1.6.2-2) unstable; urgency=low


  * added commons-net to the path when building (closes: #272556).

 -- Arnaud Vandyck <email address hidden>  Tue, 28 Sep 2004 11:44:52 +0200
163 of 63 results