apr 1.4.2-7ubuntu2.1 source package in Ubuntu

Changelog

apr (1.4.2-7ubuntu2.1) natty-security; urgency=low

  * SECURITY UPDATE: denial of service in apr_fnmatch exploitable via
    apache's mod_index
    - debian/patches/029_fnmatch_CVE-2011-0419.dpatch: rewrite
      apr_fnmatch to have a better time bounds on execution.
    - CVE-2011-0419
    - debian/patches/030_fnmatch_CVE-2011-1928.dpatch: fix possible
      DoS introduced by patch for CVE-2011-0419.
    - CVE-2011-1928
 -- Steve Beattie <email address hidden>   Thu, 19 May 2011 17:28:01 -0700

Upload details

Uploaded by:
Steve Beattie on 2011-05-20
Uploaded to:
Natty
Original maintainer:
Ubuntu Developers
Architectures:
any
Section:
libs
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
apr_1.4.2.orig.tar.gz 927.7 KiB 6a0291d6f6a59d5eab5ae5441c37b78b17f7a1a2fa1478741b7178f5fbc33ebe
apr_1.4.2-7ubuntu2.1.diff.gz 26.8 KiB e9d064c83034b7e59d3593751eed0dc8881ce1c1be0f0b2a04227dcb90171762
apr_1.4.2-7ubuntu2.1.dsc 2.1 KiB 8f26d0a4bda46f05ddc9cc3ffcd44123488d05d8b06e626d5c268eb5d2cf0b1a

View changes file

Binary packages built by this source

libapr1: No summary available for libapr1 in ubuntu natty.

No description available for libapr1 in ubuntu natty.

libapr1-dbg: No summary available for libapr1-dbg in ubuntu natty.

No description available for libapr1-dbg in ubuntu natty.

libapr1-dev: No summary available for libapr1-dev in ubuntu natty.

No description available for libapr1-dev in ubuntu natty.