Ubuntu

Change log for “aspell” package in Ubuntu

120 of 20 results
Published in trusty-release on 2013-12-15
Deleted in trusty-proposed (Reason: moved to release)
aspell (0.60.7~20110707-1ubuntu1) trusty; urgency=medium

  * Build using dh-autoreconf.
 -- Matthias Klose <email address hidden>   Sun, 15 Dec 2013 11:49:31 +0100
Superseded in trusty-release on 2013-12-15
Published in saucy-release on 2013-04-25
Published in raring-release on 2012-10-18
Published in quantal-release on 2012-10-01
aspell (0.60.7~20110707-1build1) quantal; urgency=low

  * Rebuild for new armel compiler default of ARMv5t.
 -- Colin Watson <email address hidden>   Mon, 01 Oct 2012 16:43:24 +0100
Superseded in quantal-release on 2012-10-01
Published in precise-release on 2011-10-17
aspell (0.60.7~20110707-1) unstable; urgency=low

  * New upstream snapshot 0.60.7-20110707
    - Removed 06_null_input_segfault_fix and 11_special_chars patches as
      they've been applied upstream
    - Fixes unexpected Ctrl-C quits program (Closes: #600214)
    - Partial support for recognizing the Unicode apostrophe
      (Closes: #533378)
  * Updated policy to 3.9.2, no changes necessary
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  17 Oct 2011 09:10:04 +0000

Available diffs

Superseded in precise-release on 2011-10-17
Published in oneiric-release on 2011-04-28
Obsolete in natty-release on 2013-06-04
aspell (0.60.6-6) unstable; urgency=low

  * Removed the debian-changes-0.60.6-5 patch which was accidentally
    introduced.
  * Reverted the pkgdatadir change since it breaks filters.  The spell and
    ispell scripts will just be left in /usr/lib/aspell, which is a
    retarded place for them but, eh, it's just not worth fighting the
    aspell build system over it.  (Closes: #612051)

Available diffs

Superseded in natty-release on 2011-02-08
Obsolete in maverick-release on 2013-03-05
aspell (0.60.6-4ubuntu1) maverick; urgency=low

  * Merge from debian unstable(LP:#609646). Remaining changes:
    - Add CVS patch 11_special_chars.diff:
      - Closes LP: #77414
  * Set ubuntu maintainer

Superseded in maverick-release on 2010-07-27
Published in lucid-release on 2010-03-24
aspell (0.60.6-3ubuntu1) lucid; urgency=low

  * Added CVS patch 11_special_chars.diff:
    - Closes LP: #77414
 -- Anthony Mercatante <email address hidden>   Wed, 24 Mar 2010 16:45:08 +0100

Available diffs

Superseded in lucid-release on 2010-03-24
aspell (0.60.6-3) unstable; urgency=low

  * Switched to dpkg-source 3.0 (quilt) format

  * No longer use dpatch

  * Cleared the dependency_libs= lines in the .la files

  * Bumped Standards-Version to 3.8.3, no changes necessary

  * Added a debian/watch file
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  01 Feb 2010 23:57:07 +0000

Available diffs

Superseded in lucid-release on 2010-02-02
Obsolete in karmic-release on 2013-03-04
aspell (0.60.6-2) unstable; urgency=low

  * Applied a patch from Christer Andersson <email address hidden> to add a
    filter for DDTP emails. (Closes: #457274)

  * Increased debhelper compat to v7

  * debian/control: added ${misc:Depends} dependencies to each binary
    package

  * Bumped Standards-Version to 3.8.2, no changes necessary
 
  * Restored the html documenation to aspell-doc, which at some point had
    gotten accidentally dropped.

  * Made dh_makeshlibs ignore files in usr/lib/aspell to fix the
    unused-shlib-entry-in-control-file lintian warning

 -- Alessandro Ghersi <email address hidden>   Wed,  09 Sep 2009 14:07:34 +0100

Available diffs

Superseded in karmic-release on 2009-09-09
Obsolete in jaunty-release on 2013-02-28
Obsolete in intrepid-release on 2013-02-20
aspell (0.60.6-1) unstable; urgency=low

  * New upstream release
    - Removed the 03_extra_qualification_fix.dpatch,
      05_removedebug_munchlist.dpatch, and 06_add_oo-only_texi.dpatch,
      patches as they've been incorporated upstream
    - debian/patches/04_gcc43_build_fix.dpatch: updated for integrated
      fixes

  * Bumped Standards-Version to 3.8.0, no changes necessary

 -- Bhavani Shankar <email address hidden>   Wed,  20 Aug 2008 10:04:31 +0100

Available diffs

Superseded in intrepid-release on 2008-08-20
aspell (0.60.5-2.2ubuntu1) intrepid; urgency=low

  * Merge from debian unstable, remaining changes:
    - debian/rules:
      + Build with -fpermissive when building with g++-4.3.
        (LP: 138557, needs-to-goto-debian)
    - Set Ubuntu maintainer address.

Superseded in intrepid-release on 2008-06-20
Published in hardy-release on 2008-01-26
aspell (0.60.5-1ubuntu2) hardy; urgency=low

  * Fix build failures with g++-4.3.

 -- Matthias Klose <email address hidden>   Sat, 26 Jan 2008 21:57:21 +0100
Superseded in hardy-release on 2008-01-26
Obsolete in gutsy-release on 2011-09-16
aspell (0.60.5-1ubuntu1) gutsy; urgency=low

  * Build with -fpermissive when building with g++-4.3. LP: #138557.
  * Set Ubuntu maintainer address.

 -- Matthias Klose <email address hidden>   Thu, 13 Sep 2007 19:05:25 +0000
Superseded in gutsy-release on 2007-09-13
aspell (0.60.5-1) unstable; urgency=low

  * New upstream release
    - Buggy '-m' option fixed (Closes: #400878)
    - Core dump with when (r)eplacing with 00 fixed (Closes: #347191)
    - Improper Tex filter handling of escaped % fixed (Closes: #347589)
    - Affix compression bug fixed (Closes: #340958)
  
  * Removed debian/patches/03_extra_qualification_fix.dpatch, incorporated
    upstream

  * debian/patches/10_autotools.dpatch: regenerated

  * debian/control: dropped the libaspell15c2 dummy package, as nothing in
    the archive depends on it any more

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  26 Apr 2007 23:29:28 +0100
Superseded in gutsy-release on 2007-04-27
Obsolete in feisty-release on 2009-08-20
Obsolete in edgy-release on 2008-06-19
aspell (0.60.4-4) unstable; urgency=low

  * debian/patches/03_extra_qualification_fix.dpatch: new patch to fix a
    FTBFS with GCC 4.1.  Thanks to Martin Michlmayr <email address hidden> for
    the patch. (Closes: #356444)

  * Updated to standards version 3.7.2

Superseded in edgy-release on 2006-06-15
Obsolete in dapper-release on 2011-09-06
Superseded in dapper-release on 2006-02-03
aspell (0.60.4-2) unstable; urgency=low


  * Rebuilding, which should fix segfaults due to C++ ABI changes
    (Closes: #343060)

  * Renamed debian/aspell.overrides to debian/aspell.lintian, and modified
    debian/rules to install it

  * Updated FSF address in the copyright files

  * debian/aspell.lintian: added "aspell:
    package-has-a-duplicate-relation"

  * debian/patches/02_u-deva_common_data.dpatch: new patch to add
    u-deva.cset and u-deva.cmap data files, needed by aspell-hi and
    aspell-mr

  * debian/control: have aspell replace versions of aspell-hi and
    aspell-mr that contained the u-deva files

 -- Brian Nelson <email address hidden>  Mon,  2 Jan 2006 20:57:57 -0800
Superseded in dapper-release on 2006-01-31
aspell (0.60.4-1build1) dapper; urgency=low


  * Rebuild for libstdc++ allocator change

 -- Matthias Klose <email address hidden>  Sat, 24 Dec 2005 15:31:40 +0000
Superseded in dapper-release on 2006-01-31
aspell (0.60.4-1) unstable; urgency=low


  * New upstream release

  * debian/patches/10_autotools: regenerated

 -- Brian Nelson <email address hidden>  Tue, 25 Oct 2005 23:43:21 -0700
Obsolete in breezy-release on 2008-03-25
aspell (0.60.3-5) unstable; urgency=low


  * Moved the 01_autotools patch to 10_autotools

  * debian/patches/01_debctrl: wrote a patch for a Debian packaging
    control file filter (Closes: #111929)

  * debian/patches/10_autotools: reran autotools to update build system so
    that it builds the debctrl filter

  * Updated aspell.1 manual to document the new debctrl filter

 -- Brian Nelson <email address hidden>  Mon,  1 Aug 2005 23:56:49 -0700
Obsolete in hoary-release on 2008-03-19
aspell (0.50.5-5) unstable; urgency=low


  * Included the contents of the GFDL license in the copyright file of the
    aspell-doc package to conform with policy.  Removed the separate FDL
    document.
  * Updated the manpages with newer ones from Aspell 0.60.

 -- Brian Nelson <email address hidden>  Sat,  4 Dec 2004 13:14:38 -0800
Obsolete in warty-release on 2008-01-09
aspell (0.50.5-3) unstable; urgency=medium


  * Applied a patch from upstream to fix a buffer overflow in the
    word-list-compress utility.  This is a minor security hole, so bumped
    the urgency to medium.
  * debian/rules: Don't pass a version value with "dh_makeshlibs -V".  The default is
    fine.
  * debian/rules: Don't set CC=g++ when running configure.  This was a
    hack to work around an old broken libtool and is no longer necessary.

 -- Brian Nelson <email address hidden>  Fri, 25 Jun 2004 15:47:48 -0700
120 of 20 results