Change log for atomix package in Ubuntu

129 of 29 results
Published in focal-release on 2019-10-18
Published in eoan-release on 2019-09-29
Deleted in eoan-proposed (Reason: moved to Release)
atomix (3.34.0-1) unstable; urgency=medium

  * New upstream version 3.34.0. (Closes: #941315)
  * Update debian/watch and track download.gnome.org stable releases.
    (Closes: #941316)

 -- Markus Koschany <email address hidden>  Sat, 28 Sep 2019 21:07:54 +0200

Available diffs

Superseded in eoan-release on 2019-09-29
Deleted in eoan-proposed on 2019-09-30 (Reason: moved to release)
atomix (3.32.1-1) unstable; urgency=medium

  * New upstream version 3.32.1.
  * Declare compliance with Debian Policy 4.4.0.
  * Switch to debhelper 12.

 -- Markus Koschany <email address hidden>  Mon, 08 Jul 2019 00:34:36 +0200

Available diffs

Superseded in eoan-release on 2019-07-09
Published in disco-release on 2019-02-06
Deleted in disco-proposed (Reason: moved to release)
atomix (3.31.90-1) unstable; urgency=medium

  * New upstream version 3.31.90.

 -- Markus Koschany <email address hidden>  Wed, 06 Feb 2019 11:09:47 +0100

Available diffs

Superseded in disco-release on 2019-02-06
Published in cosmic-release on 2018-09-06
Deleted in cosmic-proposed (Reason: moved to release)
atomix (3.30.0.1-1) unstable; urgency=medium

  * New upstream version 3.30.0.1.
    - The appmenu is back!

 -- Markus Koschany <email address hidden>  Thu, 06 Sep 2018 20:20:27 +0200

Available diffs

Superseded in cosmic-release on 2018-09-06
Deleted in cosmic-proposed on 2018-09-08 (Reason: moved to release)
atomix (3.30.0-1) unstable; urgency=medium

  * New upstream version 3.30.0.
  * Declare compliance with Debian Policy 4.2.1.

 -- Markus Koschany <email address hidden>  Tue, 04 Sep 2018 14:38:26 +0200

Available diffs

Superseded in cosmic-release on 2018-09-04
Deleted in cosmic-proposed on 2018-09-05 (Reason: moved to release)
atomix (3.29.3-1) unstable; urgency=medium

  * New upstream version 3.29.3.
  * Switch to compat level 11.
  * Declare compliance with Debian Policy 4.1.4.
  * Switch to new meson build system. Build-Depend on
    libgnome-games-support-1-dev and meson. (Closes: #901272)
  * Remove dh_auto_configure override.
  * Drop debian/clean file.
  * Drop fix-locale-dir.patch
  * Build-depend on ccache to avoid a FTBFS.
  * Fix installation paths.

 -- Markus Koschany <email address hidden>  Tue, 19 Jun 2018 21:51:08 +0200

Available diffs

Superseded in cosmic-release on 2018-06-20
Published in bionic-release on 2017-11-23
Deleted in bionic-proposed (Reason: moved to release)
atomix (3.22.0-2) unstable; urgency=medium

  * Declare compliance with Debian Policy 4.1.1.
  * Use dh_missing override instead of dh_install.
  * d/copyright: Use https for Format field.
  * Drop deprecated menu file and xpm icon.
  * Install metainfo directory instead of appdata.
    This was apparently changed in appstream-glib 0.7.4-1.
    Thanks to Adrian Bunk for the report. (Closes: #882004)

 -- Markus Koschany <email address hidden>  Fri, 17 Nov 2017 15:28:42 +0100

Available diffs

Superseded in bionic-release on 2017-11-23
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed (Reason: moved to release)
atomix (3.22.0-1) unstable; urgency=medium

  * New upstream version 3.22.0.
  * Declare compliance with Debian Policy 3.9.8.
  * Switch to compat level 10.
  * Drop build-dependency on gnome-common and build-depend on autoconf-archive
    and intltool. (Closes: #829875)
  * debian/watch: Use version=4.
  * Rebase fix-locale-dir.patch.
  * Update debian/clean and ensure the package can be built twice in a row.
  * Drop dh-autoreconf from Build-Depends since we use compat 10 now.

 -- Markus Koschany <email address hidden>  Thu, 22 Sep 2016 17:48:59 +0200
Superseded in yakkety-release on 2016-09-26
Deleted in yakkety-proposed on 2016-09-28 (Reason: moved to release)
atomix (3.22.0-0ubuntu1) yakkety; urgency=medium

  * New upstream release

 -- Jeremy Bicha <email address hidden>  Wed, 21 Sep 2016 00:43:22 -0400
Superseded in yakkety-release on 2016-09-21
Deleted in yakkety-proposed on 2016-09-22 (Reason: moved to release)
atomix (3.21.91-0ubuntu1) yakkety; urgency=medium

  * New upstream release
  * debian/control:
    - Build-depend on autoconf-archive and intltool
    - Drop build-dependency on gnome-common

 -- Jeremy Bicha <email address hidden>  Mon, 29 Aug 2016 21:11:47 -0400
Superseded in yakkety-release on 2016-08-30
Deleted in yakkety-proposed on 2016-08-31 (Reason: moved to release)
atomix (3.21.90-0ubuntu1) yakkety; urgency=medium

  * New upstream release

 -- Jeremy Bicha <email address hidden>  Wed, 17 Aug 2016 22:27:26 -0400
Superseded in yakkety-release on 2016-08-18
Deleted in yakkety-proposed on 2016-08-19 (Reason: moved to release)
atomix (3.20.0-1) unstable; urgency=medium

  * Imported Upstream version 3.20.0.
  * atomix-data.install: Install all new png icons into hicolor directory.

 -- Markus Koschany <email address hidden>  Fri, 25 Mar 2016 00:34:38 +0100

Available diffs

Superseded in yakkety-release on 2016-05-05
Published in xenial-release on 2016-01-25
Deleted in xenial-proposed (Reason: moved to release)
atomix (3.19.4-1) unstable; urgency=medium

  * Imported Upstream version 3.19.4.
  * Vcs-Git: Use https.
  * Drop icon-path.patch. No longer needed because a new svg icon is provided
    now.

 -- Markus Koschany <email address hidden>  Sun, 24 Jan 2016 15:44:58 +0100

Available diffs

Superseded in xenial-release on 2016-01-25
Deleted in xenial-proposed on 2016-01-26 (Reason: moved to release)
atomix (3.19.3-1) unstable; urgency=medium

  * Imported Upstream version 3.19.3.

 -- Markus Koschany <email address hidden>  Sat, 19 Dec 2015 01:25:47 +0100

Available diffs

Superseded in xenial-release on 2015-12-19
Deleted in xenial-proposed on 2015-12-20 (Reason: moved to release)
atomix (3.19.2-1) unstable; urgency=medium

  * Imported Upstream version 3.19.2.
  * Update my e-mail address.

 -- Markus Koschany <email address hidden>  Tue, 08 Dec 2015 00:33:13 +0100

Available diffs

Superseded in xenial-release on 2015-12-08
Deleted in xenial-proposed on 2015-12-09 (Reason: moved to release)
atomix (3.18.0-1) unstable; urgency=medium

  * Imported Upstream version 3.18.0.
  * Drop fix-incorrect-arrow-click-sensitivity.patch. Fixed upstream.

 -- Markus Koschany <email address hidden>  Wed, 28 Oct 2015 18:34:10 +0100

Available diffs

Superseded in xenial-release on 2015-10-29
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
atomix (3.16.0-1) unstable; urgency=medium

  * Imported Upstream version 3.16.0. (Closes: #780714)
  * debian/control:
    - Use dh-autoreconf instead of autotools_dev.
    - Add gettext, appstream-util and libgtk-3-dev to Build-Depends.
    - Drop obsolete GNOME 2 build-dependencies.
    - Use cgit for Vcs-Browser field.
    - Update homepage field and use gnome.org address.
  * Declare compliance with Debian Policy 3.9.6.
  * Update debian/watch to detect newer upstream releases.
  * Drop all patches. They were merged or fixed upstream.
  * Add icon-path.patch.
    Since DATADIR is /usr/share/games in Debian this patch is necessary for
    finding atomix-icon.png. It can be dropped when upstream fixes the
    installation path and installs the icon to the hicolor directory.
  * atomix-data.install: Do not install obsolete gnome directory.
  * Drop atomix-data.links and install the data to
    /usr/share/games/atomix
  * debian/rules:
    - Remove dh_fixperms override.
    - Do not add -lm to LDFLAGS and build with autoreconf. This ensures that
      Atomix will not FTBFS on Ubuntu any more. (Closes: #773094)
    - Use dh_install --fail-missing.
    - Add datadir option to dh_auto_configure.
    - Add get-orig-source target.
  * atomix.install: Do not install non-existent /var/games directory.
  * atomix-data.install: Install /usr/share/locale directory
  * atomix-data.install: Install /usr/share/appdata directory.
  * Update debian/copyright for new release
  * Add clean file and ensure that Atomix can be built twice in a row.
  * Add fix-incorrect-arrow-click-sensitivity.patch
    Cherry-pick upstream commit f53a3905e790170b1ad5e7f9dcb0c78c7fe841f2
    to fix a bug with selecting nearby atoms.
  * Add fix-locale-dir.patch and fix incorrect directory of installed
    translation files due to Debian specific datadir.

 -- Markus Koschany <email address hidden>  Sun, 26 Apr 2015 21:15:24 +0200
Superseded in wily-release on 2015-05-06
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
atomix (2.14.0-5ubuntu1) vivid; urgency=medium

  * debian/patches/underlinking.diff: Restore Robie Basak's patch from
    2.14.0-2ubuntu2 to build with -lm to fix an underlinking FTBFS.
  * Use dh-autoreconf so that the patch is applied.
  * Remove unnecessary -lm addition in debian/rules for LDFLAGS.
 -- Logan Rosen <email address hidden>   Thu, 04 Dec 2014 23:47:09 -0500
Superseded in vivid-proposed on 2014-12-05
atomix (2.14.0-5) unstable; urgency=low


  * [9620aec] debian/rules: Add -lm to LDFLAGS.
    Thanks to David Suárez for the report. (Closes: #713464)

 -- Markus Koschany <email address hidden>  Sat, 22 Jun 2013 20:34:12 +0200
Superseded in vivid-release on 2014-12-06
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2013-10-18
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed (Reason: moved to release)
atomix (2.14.0-2ubuntu2) raring; urgency=low

  * d/p/underlinking.diff: build with -lm to fix FTBFS.
 -- Robie Basak <email address hidden>   Fri, 05 Apr 2013 15:34:34 +0000

Available diffs

Superseded in raring-release on 2013-04-05
Obsolete in quantal-release on 2015-04-24
atomix (2.14.0-2ubuntu1) quantal; urgency=low

  * Merge from Debian Unstable (LP: #1016608). Remaining Changes:
    - Explicitly add all the locales to the atomix package.
    - Call autoreconf and intltoolize to generate a working
      autotools setup that will generate the locales. (LP: #851928)

Superseded in quantal-release on 2012-06-26
Published in precise-release on 2011-10-13
Obsolete in oneiric-release on 2015-04-24
atomix (2.14.0-1.1ubuntu1) oneiric; urgency=low

  * Explicitly add all the locales to the atomix package.
  * Call autoreconf and intltoolize to generate a working
    autotools setup that will generate the locales. (LP: #851928)
 -- Marc Gariepy <email address hidden>   Wed, 28 Sep 2011 13:36:46 -0400

Available diffs

Superseded in oneiric-release on 2011-09-29
Obsolete in natty-release on 2013-06-04
Obsolete in maverick-release on 2013-03-05
atomix (2.14.0-1.1) unstable; urgency=low

  * Non-maintainer upload.
  * Improve long title in menu (Closes: #445127).  Thanks to Bill
    Allombert for the text proposal.
  * Fix close button in about dialog (Closes: #495714).  Thanks to
    Marshall Scorcio and Ubuntu for the patch.  Adjusted home page URL
    to a working one.
  * Make sure desktop file is in the atomix package next to the Debian
    menu file (Closes: #570526).
  * Add manual page (Closes: 490259).  Thanks to Mike Ayers for the content.
 -- Efrain Valles <email address hidden>   Tue,  08 Jun 2010 23:28:27 +0100

Available diffs

Superseded in maverick-release on 2010-06-09
Obsolete in lucid-release on 2016-10-26
Superseded in lucid-release on 2010-02-10
Obsolete in karmic-release on 2013-03-04
Obsolete in jaunty-release on 2013-02-28
Obsolete in intrepid-release on 2013-02-20
atomix (2.14.0-1ubuntu1) intrepid; urgency=low

  * Fixed about dialog close button (LP: #173772)

 -- Marshall Scorcio <email address hidden>   Mon, 28 Apr 2008 22:01:43 -0500

Available diffs

Superseded in intrepid-release on 2008-08-19
Obsolete in hardy-release on 2015-04-24
Obsolete in gutsy-release on 2011-09-16
Obsolete in feisty-release on 2009-08-20
Obsolete in edgy-release on 2008-06-19
atomix (2.14.0-1) unstable; urgency=low

  * New upstream release
  * debian/control: updated my e-mail address

 -- Michael Vogt <email address hidden>   Fri,  30 Jun 2006 13:01:56 +0100
Superseded in edgy-release on 2006-06-30
Obsolete in dapper-release on 2011-09-06
Superseded in dapper-release on 2006-02-03
atomix (2.13.4-0ubuntu2) dapper; urgency=low


  * Resynchronized with Debian. (Ubuntu: #21107)
  * debian/control:
    - adapted versioning of the 'Replaces'.

 -- Daniel Holbach <email address hidden>  Wed, 11 Jan 2006 19:46:42 +0100
Superseded in dapper-release on 2006-01-31
atomix (2.13.4-0ubuntu1) dapper; urgency=low


  * New upstream release:
    - Include formulas of all compounds in the interface
    - Actually install Finnish, Macedonian and Malayalam translations
    - Updated translations:
      - Brazilian Portuguese [Guilherme de S. Pastore]
      - Serbian [Slobodan D. Sredojevic]
      - Tradicional Chinese [Abel Cheung]
      - Vietnamese [Clytie Siddall]

 -- Daniel Holbach <email address hidden>  Thu,  5 Jan 2006 20:42:53 +0100
Superseded in dapper-release on 2006-01-31
atomix (2.13.3-0ubuntu1) dapper; urgency=low


  * New upstream release:
    - Updated translations:
      - Dutch [Vincent van Adrighem]
      - Gujarati [Ankit Patel]
      - Lithuanian [Žygimantas Beručka]
      - Norwegian bokmål [Kjartan Maraas]

 -- Daniel Holbach <email address hidden>  Mon, 12 Dec 2005 20:29:19 +0100
Obsolete in breezy-release on 2008-03-25
atomix (1.2.1-1) unstable; urgency=low


  * New upstream release

 -- Guilherme de S. Pastore <email address hidden>  Fri, 17 Jun 2005 14:56:36 -0300
129 of 29 results