Change log for bglibs package in Ubuntu

118 of 18 results
Published in eoan-release on 2019-04-18
Published in disco-release on 2018-11-29
Deleted in disco-proposed (Reason: moved to release)
bglibs (2.04+dfsg-2) unstable; urgency=medium

  * New maintainer (Closes: #544056)
  * Update Vcs-* fields in debian/control.
  * Update standards version to 4.2.1 (no changes needed)
  * Build-depend on `debhelper-compat' (obsoletes `debian/compat')
  * Update symbols file

 -- Dmitry Bogatov <email address hidden>  Wed, 28 Nov 2018 22:36:45 +0000

Available diffs

Superseded in disco-release on 2018-11-29
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2018-04-06
Deleted in bionic-proposed (Reason: moved to release)
bglibs (2.04+dfsg-1) unstable; urgency=medium

  * QA upload.
  * New upstream release
  * Fix watch file
  * Bump std-version to 4.1.4, no changes required.
  * Move the library to libs
  * Drop unused jquery override
  * Use DEB_BUILD_MAINT_OPTIONS to enable hardening

 -- Gianfranco Costamagna <email address hidden>  Fri, 06 Apr 2018 11:32:16 +0200

Available diffs

Superseded in bionic-release on 2018-04-06
Deleted in bionic-proposed on 2018-04-08 (Reason: moved to release)
bglibs (2.03+dfsg-4) unstable; urgency=medium

  * Upload to unstable
  * This one is for you Dmitry, thanks for your hard work,
    sorry for "stealing your transition!"

 -- Gianfranco Costamagna <email address hidden>  Tue, 12 Dec 2017 17:20:39 +0100
Superseded in bionic-release on 2017-12-13
Published in artful-release on 2017-06-02
Deleted in artful-proposed (Reason: moved to release)
bglibs (1.106-3ubuntu1) artful; urgency=medium

  * debian/control: Put the source in Section: devel, matching the archive.

 -- Adam Conrad <email address hidden>  Fri, 02 Jun 2017 14:02:29 -0600
Superseded in bionic-proposed on 2017-12-12
bglibs (2.03+dfsg-2) experimental; urgency=medium

  * QA upload
  * Remove Conflict field from libbg-dev.
  * Install build tools into libbg-dev package, since they are required
    for building other packages of same upstream.
  * Fix spelling error in cli-generate.1

 -- Dmitry Bogatov <email address hidden>  Sun, 05 Feb 2017 08:32:31 +0300
Superseded in artful-release on 2017-06-02
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
bglibs (1.106-3) unstable; urgency=medium

  * QA upload.
  * Do not add -fPIC to CFLAGS. This undoes the change in the previous
    upload as it was not really necessary. Thanks to Adrian Bunk for
    the report. Closes: #842109.

 -- Santiago Vila <email address hidden>  Wed, 26 Oct 2016 13:29:02 +0200

Available diffs

Superseded in zesty-release on 2016-11-02
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
bglibs (1.106-2) unstable; urgency=medium

  * QA upload.
  * Switch to "3.0 (quilt)" source format.
  * debian/rules: Drop patch target and related stuff.
  * debian/control: Package is orphaned (Bug #544056),
    set Maintainer field to "Debian QA Group".
  * debian/control: Drop Recommends of libbg1 on libbg1-doc.
  * debian/rules and debian/implicit: Use gzip -n to improve
    reproducibility. Closes: #776942. Thanks to Chris Lamb.
  * debian/rules: Allow build with umask 002 to improve reproducibility.
  * debian/rules: Do not save or restore conf-bin, conf-cc, conf-include,
    conf-lib or conf-man. Just remove them in the clean target.
  * debian/rules: Add conf-ld to the mix and use dpkg-buildflags for hardening.
  * debian/rules: Add build-arch and build-indep targets. Closes: #831918.
  * debian/rules: Do not pass -isp to dpkg-gencontrol, it does nothing.
  * debian/implicit: Sort output of find before calculating md5sums to
    improve reproducibility.
  * debian/implicit: Add support for triggers.
  * debian/libbg1.triggers: New file to do ldconfig stuff with triggers.
  * Drop postinst and postrm accordingly.
  * debian/control: Standards-Version: 3.9.8.

 -- Santiago Vila <email address hidden>  Sun, 07 Aug 2016 17:44:22 +0200
Superseded in yakkety-release on 2016-08-08
Deleted in yakkety-proposed on 2016-08-10 (Reason: moved to release)
bglibs (1.106-1.1ubuntu1) yakkety; urgency=medium

  * Add missing Section: field to debian/control.

 -- Steve Langasek <email address hidden>  Fri, 29 Apr 2016 01:01:16 -0700
Superseded in yakkety-release on 2016-04-29
Published in xenial-release on 2015-10-22
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed (Reason: moved to release)
bglibs (1.106-1.1) unstable; urgency=medium


  * Non-maintainer upload.
  * Build-depend on libtool-bin. Closes: #761734.

 -- Matthias Klose <email address hidden>  Thu, 09 Oct 2014 10:15:11 +0000

Available diffs

Superseded in vivid-release on 2014-10-24
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2013-10-18
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
Published in precise-release on 2011-10-13
Obsolete in oneiric-release on 2015-04-24
Obsolete in natty-release on 2013-06-04
Obsolete in maverick-release on 2013-03-05
bglibs (1.106-1) unstable; urgency=low

  * new upstream release.
  * debian/rules: package libbg-docs: properly install documentation
    into /usr/share/doc/libbg$(SO)-doc/.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sat,  05 Jun 2010 11:28:47 +0100

Available diffs

Superseded in maverick-release on 2010-06-05
Obsolete in lucid-release on 2016-10-26
Obsolete in karmic-release on 2013-03-04
Obsolete in jaunty-release on 2013-02-28
Obsolete in intrepid-release on 2013-02-20
bglibs (1.104-2) unstable; urgency=low

  * debian/rules: typo (fixes FTBFS on autobuilders).

Available diffs

Superseded in intrepid-release on 2008-05-30
Obsolete in hardy-release on 2015-04-24
bglibs (1.041-2ubuntu1) hardy; urgency=low

  * Fix FTBFS when linked with a dietlibc build with SSP (LP: #184625).
    + debian/diff/link-main.diff:
      Link explicitly with the object file containing main() so gcc doesn't
      complain during linking that it couldn't find main().
  * debian/control:
    + Modify Maintainer value to match DebianMaintainerField spec.
  * debian/rules:
    + On sparc and powerpc build with -fno-stack-protector
      (set DIETCC on those archs to "diet -v gcc" as otherwise diet eats the
       -fno-stack-protector).

 -- Michael Bienia <email address hidden>   Sat, 15 Mar 2008 00:01:54 +0100
Superseded in hardy-release on 2008-03-17
Obsolete in gutsy-release on 2011-09-16
Obsolete in feisty-release on 2009-08-20
Obsolete in edgy-release on 2008-06-19
bglibs (1.041-2) unstable; urgency=low

  * debian/diff/ibuf_openreadclose.diff: ibuf_openreadclose() returns 0 if
    it it fails to open the file (#376244).

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  12 Jul 2006 23:37:41 +0100
Superseded in edgy-release on 2006-07-12
bglibs (1.041-1) unstable; urgency=low

  * new upstream version.
  * debian/rules: remove workaround for #327229; strip binaries only; install
    man page into /usr/share/man/ hierarchy and gzip -9.
  * debian/diff/signed-char.diff: remove; applied upstream.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  15 Jun 2006 13:23:20 +0100
Superseded in edgy-release on 2006-06-15
Obsolete in dapper-release on 2011-09-06
Superseded in dapper-release on 2006-02-03
bglibs (1.031-1) unstable; urgency=low


  * new upstream version.
  * debian/diff/signed-char.diff: adapt.
  * debian/copyright: adapt; license now is LGPL-2.1.

 -- Gerrit Pape <email address hidden>  Tue,  6 Dec 2005 16:49:38 +0000
Obsolete in breezy-release on 2008-03-25
bglibs (1.022-1) unstable; urgency=low


  * new upstream version.
    - fixes build failure on amd64 (thx Kurt Roeckx, closes: #313064).
  * debian/control: Depends: ${shlibs:Depends}.
  * debian/rules: don't install target directories, make install now does;
    binary-arch: run dpkg-shlibdeps.
  * debian/copyright: 2005.

 -- Gerrit Pape <email address hidden>  Wed, 15 Jun 2005 18:45:19 +0000
Obsolete in hoary-release on 2008-03-19
bglibs (1.019-1) unstable; urgency=low


  * new upstream version.
  * debian/control: bglibs-dev package Recommends: bglibs-doc.

 -- Gerrit Pape <email address hidden>  Wed, 17 Nov 2004 13:16:14 +0000
Obsolete in warty-release on 2008-01-09
bglibs (1.017-3) unstable; urgency=low


  * debian/rules: use dietlibc-dev on amd64 (thx Andreas Jochens); minor.
  * debian/control: Build-Depends: dietlibc-dev +[amd64].

 -- Gerrit Pape <email address hidden>  Fri, 30 Apr 2004 19:26:56 +0000
118 of 18 results