binutils 2.26.1-1ubuntu1~16.04.3 source package in Ubuntu

Changelog

binutils (2.26.1-1ubuntu1~16.04.3) xenial-security; urgency=medium

  [ Matthias Klose ]
  * Fix PR ld/20428 (ppc64le), taken from the 2.26 branch.

  [ Marc Deslauriers ]
  * Rebuild for security pocket.

 -- Marc Deslauriers <email address hidden>  Sun, 07 Aug 2016 11:43:56 -0400

Upload details

Uploaded by:
Marc Deslauriers on 2016-08-07
Uploaded to:
Xenial
Original maintainer:
Ubuntu Developers
Architectures:
any all
Section:
devel
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Xenial security on 2016-08-09 main devel

Downloads

File Size SHA-256 Checksum
binutils_2.26.1.orig.tar.gz 33.3 MiB dd9c3e37c266e4fefba68e444e2a00538b3c902dd31bf4912d90dca6d830a2a1
binutils_2.26.1-1ubuntu1~16.04.3.diff.gz 221.0 KiB e789b7a18634a582895934ab2b6b08fc4b15294cef51541e4ba5c4fad1343154
binutils_2.26.1-1ubuntu1~16.04.3.dsc 3.9 KiB ea10459b50be0beb8d6f1957c269e8eafb88c293c91b7d53a3bdcc6f5ea7a749

View changes file

Binary packages built by this source

binutils: GNU assembler, linker and binary utilities

 The programs in this package are used to assemble, link and manipulate
 binary and object files. They may be used in conjunction with a compiler
 and various libraries to build programs.

binutils-aarch64-linux-gnu: GNU binary utilities, for aarch64-linux-gnu target

 This package provides GNU assembler, linker and binary utilities
 for aarch64-linux-gnu target, for use in a cross-compilation environment.
 .
 You don't need this package unless you plan to cross-compile programs
 for aarch64-linux-gnu.

binutils-alpha-linux-gnu: GNU binary utilities, for alpha-linux-gnu target

 This package provides GNU assembler, linker and binary utilities
 for alpha-linux-gnu target, for use in a cross-compilation environment.
 .
 You don't need this package unless you plan to cross-compile programs
 for alpha-linux-gnu.

binutils-arm-linux-gnueabi: GNU binary utilities, for arm-linux-gnueabi target

 This package provides GNU assembler, linker and binary utilities
 for arm-linux-gnueabi target, for use in a cross-compilation environment.
 .
 You don't need this package unless you plan to cross-compile programs
 for arm-linux-gnueabi.

binutils-arm-linux-gnueabihf: GNU binary utilities, for arm-linux-gnueabihf target

 This package provides GNU assembler, linker and binary utilities
 for arm-linux-gnueabihf target, for use in a cross-compilation environment.
 .
 You don't need this package unless you plan to cross-compile programs
 for arm-linux-gnueabihf.

binutils-dev: GNU binary utilities (BFD development files)

 This package includes header files and static libraries necessary to build
 programs which use the GNU BFD library, which is part of binutils. Note
 that building Debian packages which depend on the shared libbfd is Not
 Allowed.

binutils-doc: Documentation for the GNU assembler, linker and binary utilities

 This package consists of the documentation for the GNU assembler,
 linker and binary utilities in info format.

binutils-hppa-linux-gnu: GNU binary utilities, for hppa-linux-gnu target

 This package provides GNU assembler, linker and binary utilities
 for hppa-linux-gnu target, for use in a cross-compilation environment.
 .
 You don't need this package unless you plan to cross-compile programs
 for hppa-linux-gnu.

binutils-hppa64-linux-gnu: GNU assembler, linker and binary utilities targeted for hppa64-linux

 The programs in this package are used to assemble, link and manipulate
 binary and object files. They may be used in conjunction with a compiler
 and various libraries to build programs.
 .
 This package is needed to build an 64-bit kernel for 64-bit hppa machines.

binutils-m68k-linux-gnu: GNU binary utilities, for m68k-linux-gnu target

 This package provides GNU assembler, linker and binary utilities
 for m68k-linux-gnu target, for use in a cross-compilation environment.
 .
 You don't need this package unless you plan to cross-compile programs
 for m68k-linux-gnu.

binutils-mips-linux-gnu: GNU binary utilities, for mips-linux-gnu target

 This package provides GNU assembler, linker and binary utilities
 for mips-linux-gnu target, for use in a cross-compilation environment.
 .
 You don't need this package unless you plan to cross-compile programs
 for mips-linux-gnu.

binutils-mips64-linux-gnuabi64: GNU binary utilities, for mips64-linux-gnuabi64 target

 This package provides GNU assembler, linker and binary utilities
 for mips64-linux-gnuabi64 target, for use in a cross-compilation environment.
 .
 You don't need this package unless you plan to cross-compile programs
 for mips64-linux-gnuabi64.

binutils-mips64el-linux-gnuabi64: GNU binary utilities, for mips64el-linux-gnuabi64 target

 This package provides GNU assembler, linker and binary utilities
 for mips64el-linux-gnuabi64 target, for use in a cross-compilation environment.
 .
 You don't need this package unless you plan to cross-compile programs
 for mips64el-linux-gnuabi64.

binutils-mipsel-linux-gnu: GNU binary utilities, for mipsel-linux-gnu target

 This package provides GNU assembler, linker and binary utilities
 for mipsel-linux-gnu target, for use in a cross-compilation environment.
 .
 You don't need this package unless you plan to cross-compile programs
 for mipsel-linux-gnu.

binutils-multiarch: Binary utilities that support multi-arch targets

 The programs in this package are used to manipulate binary and object
 files that may have been created on other architectures. This package
 is primarily for multi-architecture developers and cross-compilers and
 is not needed by normal users or developers. Note that a cross-assembling
 version of gas is not included in this package, just the binary utilities.
 .
 NORMAL USERS SHOULD NOT INSTALL THIS PACKAGE. It's meant only for those
 requiring support for reading info from binaries from other architectures.

binutils-multiarch-dev: GNU binary utilities that support multi-arch targets (BFD development files)

 This package includes header files, static and shared libraries necessary
 to build programs which use the GNU BFD library for multi-arch targets,
 which is part of binutils. Note that building Debian packages which depend
 on the shared libbfd is Not Allowed.
 .
 NORMAL USERS SHOULD NOT INSTALL THIS PACKAGE. It's meant only for those
 requiring support for reading info from binaries from other architectures.

binutils-powerpc-linux-gnu: GNU binary utilities, for powerpc-linux-gnu target

 This package provides GNU assembler, linker and binary utilities
 for powerpc-linux-gnu target, for use in a cross-compilation environment.
 .
 You don't need this package unless you plan to cross-compile programs
 for powerpc-linux-gnu.

binutils-powerpc-linux-gnuspe: GNU binary utilities, for powerpc-linux-gnuspe target

 This package provides GNU assembler, linker and binary utilities
 for powerpc-linux-gnuspe target, for use in a cross-compilation environment.
 .
 You don't need this package unless you plan to cross-compile programs
 for powerpc-linux-gnuspe.

binutils-powerpc64-linux-gnu: GNU binary utilities, for powerpc64-linux-gnu target

 This package provides GNU assembler, linker and binary utilities
 for powerpc64-linux-gnu target, for use in a cross-compilation environment.
 .
 You don't need this package unless you plan to cross-compile programs
 for powerpc64-linux-gnu.

binutils-powerpc64le-linux-gnu: GNU binary utilities, for powerpc64le-linux-gnu target

 This package provides GNU assembler, linker and binary utilities
 for powerpc64le-linux-gnu target, for use in a cross-compilation environment.
 .
 You don't need this package unless you plan to cross-compile programs
 for powerpc64le-linux-gnu.

binutils-s390x-linux-gnu: GNU binary utilities, for s390x-linux-gnu target

 This package provides GNU assembler, linker and binary utilities
 for s390x-linux-gnu target, for use in a cross-compilation environment.
 .
 You don't need this package unless you plan to cross-compile programs
 for s390x-linux-gnu.

binutils-sh4-linux-gnu: GNU binary utilities, for sh4-linux-gnu target

 This package provides GNU assembler, linker and binary utilities
 for sh4-linux-gnu target, for use in a cross-compilation environment.
 .
 You don't need this package unless you plan to cross-compile programs
 for sh4-linux-gnu.

binutils-source: GNU assembler, linker and binary utilities (source)

 This package contains the sources and patches which are needed to
 build binutils.

binutils-sparc64-linux-gnu: GNU binary utilities, for sparc64-linux-gnu target

 This package provides GNU assembler, linker and binary utilities
 for sparc64-linux-gnu target, for use in a cross-compilation environment.
 .
 You don't need this package unless you plan to cross-compile programs
 for sparc64-linux-gnu.