Change log for bleachbit package in Ubuntu

145 of 45 results
Published in impish-release
Published in hirsute-release
Published in groovy-release
Published in focal-release
Deleted in focal-proposed (Reason: moved to Release)
bleachbit (3.9.0-1) unstable; urgency=medium

  * New upstream release
  * debian/copyright
    - update upstream copyright notice
  * Switch to python3; Closes: #936214

 -- Sandro Tosi <email address hidden>  Wed, 01 Apr 2020 00:08:31 -0400

Available diffs

Superseded in focal-release
Deleted in focal-proposed (Reason: moved to Release)
bleachbit (3.0-1) unstable; urgency=medium

  [ Ondřej Nový ]
  * Bump Standards-Version to 4.4.1.

  [ Hugo Lefeuvre ]
  * New upstream release.
  * Run wrap-and-sort -a.
  * Refresh manpage for new upstream release.
  * Refresh patches for new upstream release.
  * Remove debian/lintian-overrides: warning not present anymore.
  * debian/copyright: Add missing CC0-1.0 entry for bleachbit.appdata.xml.
  * debian/control:
    - Remove pygtk dependency, upstream moved to GTK 3 as part of the 3.0
      release (Closes: #885261).
    - Add missing python-chardet, python-gi, python-requests and python-scandir
      dependencies.
    - Bump Standards-Version to 4.4.1.
    - Move python-setuptools to Build-Depends-Indep.
  * debian/install: Add rule to install data/app-menu.ui.

 -- Hugo Lefeuvre <email address hidden>  Sun, 27 Oct 2019 10:33:08 +0100

Available diffs

Superseded in focal-release
Obsolete in eoan-release
Deleted in eoan-proposed (Reason: moved to release)
bleachbit (2.2-3) unstable; urgency=medium

  * Fix autopkgtests, broken since 2.2-1 (Closes: #932730).

 -- Hugo Lefeuvre <email address hidden>  Mon, 22 Jul 2019 11:21:14 -0300

Available diffs

Superseded in eoan-proposed
bleachbit (2.2-2) unstable; urgency=medium

  [ Ondřej Nový ]
  * Use debhelper-compat instead of debian/compat.

  [ Hugo Lefeuvre ]
  * Upload to unstable.
  * debian/control:
    - Bump Standards-Version to 4.4.0.

 -- Hugo Lefeuvre <email address hidden>  Sun, 21 Jul 2019 19:48:34 -0300
Superseded in eoan-release
Obsolete in disco-release
Deleted in disco-proposed (Reason: moved to release)
bleachbit (2.0-3) unstable; urgency=medium

  [ Ondřej Nový ]
  * d/control: Remove ancient X-Python-Version field
  * d/watch: Use https protocol

  [ Hugo Lefeuvre ]
  * debian/control:
    - Bump Standards-Version to 4.3.0.
  * debian/copyright:
    - Update copyright years.
  * debian/patches/fix-deep-scan-unidecode-error.patch:
    - fix UnicodeDecodeError while running deepscan (Closes: #895979).

 -- Hugo Lefeuvre <email address hidden>  Wed, 30 Jan 2019 19:57:28 +0100

Available diffs

Superseded in disco-release
Obsolete in cosmic-release
Published in bionic-release
Deleted in bionic-proposed (Reason: moved to release)
bleachbit (2.0-2) unstable; urgency=medium

  * Use policykit instead of su-to-root (Closes: #855462).
    - Add required policykit-1 dependency to debian/control.
    - No longer depend on menu (was used for su-to-root, no longer relevant).
    - Update root desktop file in debian/rules.
    - Install policykit rule.
  * Run wrap-and-sort -a.

 -- Hugo Lefeuvre <email address hidden>  Fri, 23 Mar 2018 09:25:35 +0100

Available diffs

Superseded in bionic-release
Deleted in bionic-proposed (Reason: moved to release)
bleachbit (2.0-1) unstable; urgency=medium

  * New upstream release.
  * Remove trailing whitespaces in various files (help from Ondrej, thanks!).
  * debian/control:
    - Bump Standards-Version to 4.1.3.
    - Update debhelper dependency from >= 10 to >= 11.
    - Add missing desktop-file-utils dependency.
  * debian/copyright:
    - Update copyright years.
  * Refresh patches for new upstream release.
  * Remove local_cleaners_dir.patch, not useful anymore.
  * Update debian/watch to version 4 and remove upstream keys: not providing
    signed releases in a compatible format anymore.

 -- Hugo Lefeuvre <email address hidden>  Thu, 15 Mar 2018 18:42:45 +0100

Available diffs

Superseded in bionic-release
Deleted in bionic-proposed (Reason: moved to release)
bleachbit (1.15-2) unstable; urgency=medium

  * Upload to unstable.
  * debian/control:
    - Bump Standards-Version to 4.0.0.
    - Update debhelper dependency from >= 9 to >= 10.
    - Update X-Python-Version field to >= 2.6. 
  * Bump compat level to 10.
  * Use https protocol in debian/copyright links.

 -- Hugo Lefeuvre <email address hidden>  Wed, 30 Aug 2017 10:08:24 +0200

Available diffs

Superseded in bionic-release
Obsolete in artful-release
Obsolete in zesty-release
Obsolete in yakkety-release
Deleted in yakkety-proposed (Reason: moved to release)
bleachbit (1.12-1) unstable; urgency=medium

  * Upload to unstable.
  * New upstream release.

 -- Hugo Lefeuvre <email address hidden>  Thu, 28 Jul 2016 23:04:58 +0200

Available diffs

Superseded in yakkety-release
Published in xenial-release
Deleted in xenial-proposed (Reason: moved to release)
bleachbit (1.10-1) unstable; urgency=low

  * Upload to unstable.
  * New upstream release.
  * Remove debian/menu to make the package CTTE #741573 compliant.
  * debian/control:
    - Bump Standards-Version to 3.9.7 (no changes needed).
  * debian/patches/*.patch:
    - Refresh for new upstream release.
  * debian/copyright:
    - Update copyright years.
  * debian/bleachbit.1:
    - Refresh manpage for new upstream release.

 -- Hugo Lefeuvre <email address hidden>  Thu, 24 Mar 2016 11:21:20 +0100

Available diffs

Superseded in xenial-release
Obsolete in wily-release
Deleted in wily-proposed (Reason: moved to release)
bleachbit (1.8-1) unstable; urgency=low

  * New upstream release. 
  * debian/copyright:
    - Update copyright years.
  * debian/patches/*.patch:
    - Refresh for new upstream release.

 -- Hugo Lefeuvre <email address hidden>  Thu, 25 Jun 2015 19:47:27 +0200

Available diffs

Superseded in wily-release
Obsolete in vivid-release
Deleted in vivid-proposed (Reason: moved to release)
bleachbit (1.6-1) unstable; urgency=low


  * Upload to unstable.
  * New upstream release.
  * debian/patches/*.patch:
    - Refresh for new upstream release.

 -- Hugo Lefeuvre <email address hidden>  Sat, 22 Nov 2014 11:51:23 +0100

Available diffs

Superseded in vivid-release
Deleted in vivid-proposed (Reason: moved to release)
bleachbit (1.4-1) unstable; urgency=low


  * New upstream release.
  * debian/control, debian/copyright:
    - New Maintainer (Closes: #755293).
  * debian/patches/series, debian/patches/firefox_profiles.patch:
    - Added firefox_profiles.patch (Closes: #752257). 

 -- Hugo Lefeuvre <email address hidden>  Sat, 13 Sep 2014 15:32:42 +0200

Available diffs

Superseded in vivid-release
Obsolete in utopic-release
Deleted in utopic-proposed (Reason: moved to release)
bleachbit (1.2-1) unstable; urgency=medium


  * New upstream release.
  * debian/patches/*.patch:
    - Refresh for new upstream release.
  * debian/copyright:
    - Update copyright years.
  * debian/tests/*:
    - Provide a simple test to check whether the package is functional
      as per DEP8 (autopkgtests).

 -- Luca Falavigna <email address hidden>  Wed, 11 Jun 2014 23:09:35 +0200

Available diffs

Superseded in utopic-release
Published in trusty-release
Deleted in trusty-proposed (Reason: moved to release)
bleachbit (1.0-1) unstable; urgency=low


  * New upstream release (Closes: #725789).
  * debian/patches/desktop_file.patch:
    - Refresh for new upstream release.
  * debian/bleachbit.1:
    - Refresh man page with the newly added options.
  * debian/control:
    - Bump Standards-Version to 3.9.5.

 -- Luca Falavigna <email address hidden>  Sun, 24 Nov 2013 17:41:12 +0100

Available diffs

Superseded in trusty-release
Obsolete in saucy-release
Deleted in saucy-proposed (Reason: moved to release)
bleachbit (0.9.6-1) unstable; urgency=low


  * New upstream release.

 -- Luca Falavigna <email address hidden>  Sat, 20 Jul 2013 10:57:57 +0200

Available diffs

Superseded in saucy-release
Deleted in saucy-proposed (Reason: moved to release)
bleachbit (0.9.5-2) unstable; urgency=low


  * Upload to unstable.

 -- Luca Falavigna <email address hidden>  Sun, 05 May 2013 14:34:45 +0200

Available diffs

Superseded in saucy-release
Obsolete in raring-release
Obsolete in quantal-release
bleachbit (0.9.3-1) experimental; urgency=low


  * New upstream release.
  * debian/patches/no_X.patch:
    - Removed, applied upstream.
  * debian/bleachbit.xpm:
    - Convert to the new icon.

 -- Luca Falavigna <email address hidden>  Mon, 20 Aug 2012 23:05:43 +0200

Available diffs

Superseded in quantal-release
bleachbit (0.9.2-2) unstable; urgency=low


  * debian/patches/no_X.patch:
    - Do not try to launch GUI if X is not available (Closes: #674485).
  * debian/compat:
    - Bump compatibility level to 9.
  * debian/rules:
    - Delete .mo files during clean phase (Closes: #671414).

 -- Luca Falavigna <email address hidden>  Sat, 26 May 2012 18:28:15 +0200

Available diffs

Superseded in quantal-release
bleachbit (0.9.2-1) unstable; urgency=low


  * New upstream release.
   * debian/control:
     - Bump Standards-Version to 3.9.3.
  * debian/copyright:
    - Adjust copyright years.
    - Format now points to copyright-format site.

 -- Luca Falavigna <email address hidden>  Fri, 16 Mar 2012 21:43:26 +0100

Available diffs

Superseded in quantal-release
Published in precise-release
bleachbit (0.9.1-1) unstable; urgency=low

  * New upstream release.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  24 Nov 2011 13:18:13 +0000

Available diffs

Superseded in precise-release
bleachbit (0.9.0-1) unstable; urgency=low

  * New upstream release.
    - Use word 'Clean' instead of 'Delete' (Closes: #626883).
  * debian/patches/desktop_file.patch, debian/patches/gnomevfs.patch:
    - Refresh for new upstream release.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  17 Oct 2011 09:10:52 +0000

Available diffs

Superseded in precise-release
Obsolete in oneiric-release
bleachbit (0.8.8-2) unstable; urgency=low

  * Install new loader (LP: #797328).
    + debian/bleachbit.1:
      - Reworked to include CLI parameters.
    + debian/bleachbit_cli.1:
      - Removed, no longer needed.
    + debian/install:
      - Install bleachbit.py file.
    + debian/links:
      - Adjust bleachbit link to the new loader.
      - No longer provide link to CLI interface.
    + debian/manpages:
      - No longer install bleachbit_cli.1, removed.
    + debian/rules:
      - Adjust permissions of bleachbit.py.
  * debian/copyright:
    - Convert to DEP5 format.
  * debian/rules:
    - Remove egg-info information from binary package.
 -- Luca Falavigna <email address hidden>   Thu,  07 Jul 2011 23:23:46 +0000

Available diffs

Superseded in oneiric-release
bleachbit (0.8.8-1) unstable; urgency=low

  * New upstream release.
    - Fix crash when changing options (LP: #715286).
  * debian/patches/gnomevfs.patch:
    - Refresh for new upstream release.
  * debian/control:
    - Depend on menu (Closes: #630899) (LP: #632989).
    - Bump Standards-Version to 3.9.2, no changes required.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sun,  19 Jun 2011 03:56:50 +0000

Available diffs

Superseded in oneiric-release
Obsolete in natty-release
bleachbit (0.8.7-1) unstable; urgency=low

  * New upstream release (LP: #713537).
  * Refresh patches for new upstream release.
  * Switch to dh_python2.
  * debian/patches/gnomevfs.patch:
    - Replace gnomevfs methods, now deprecated.
  * debian/bleachbit_cli.1:
    - Document latest option implemented upstream.
  * debian/control:
    - Depends on python (>= 2.6) | python-simplejson.
    - Drop python-glade2 dependency.
    - Drop python-gnome2 dependency (Closes: #605555).
    - No longer recommend menu.
    - Bump Standards-Version to 3.9.1, no changes required.
  * debian/copyright:
    - Update copyright years.
 -- Luca Falavigna <email address hidden>   Sun, 06 Feb 2011 18:39:49 +0100

Available diffs

Superseded in natty-release
Obsolete in maverick-release
bleachbit (0.8.0-1) unstable; urgency=low

  * New upstream release.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  07 Jun 2010 10:09:51 +0100

Available diffs

Superseded in maverick-release
bleachbit (0.7.4-1) unstable; urgency=low

  * New upstream release.
  * Refresh patches for new upstream release.
  * debian/install:
    - Also provide bleachbit.png file.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sun,  09 May 2010 14:13:32 +0100

Available diffs

Superseded in maverick-release
Obsolete in lucid-release
bleachbit (0.7.3-1) unstable; urgency=low

  * New upstream release.
  * debian/control:
    - Bump Standards-Version to 3.8.4, no changes required.
  * debian/copyright:
    - Update copyright years.
 -- Stefan Ebner <email address hidden>   Mon,  01 Mar 2010 15:34:15 +0000

Available diffs

Superseded in lucid-release
bleachbit (0.7.2-2) unstable; urgency=low

  * debian/patches/local_cleaners_dir.patch:
    - Point local_cleaners_dir to personal_cleaners_dir. The former is
      not useful when BleachBit is installed system-wide, this way users
      are not bothered for new cleaners each time (Closes: #565359).
  * Switch to format 3.0 (quilt).
 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  04 Feb 2010 17:25:11 +0000

Available diffs

Superseded in lucid-release
bleachbit (0.7.2-1) unstable; urgency=low

  * New upstream release.
  * debian/patches/GUI_relative_imports.patch:
    - Removed, applied upstream.
  * debian/install, debian/rules:
    - No longer generate bleachbit-root.desktop in build directory, this
      way build is automatically removed during clean. Generate .desktop
      file into the correct location directly.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  14 Dec 2009 18:46:03 +0000

Available diffs

Superseded in lucid-release
bleachbit (0.7.1-1) unstable; urgency=low

  * New upstream release.
  * Refresh patches for new upstream release.
  * Use debhelper buildsystem feature.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  23 Nov 2009 18:26:05 +0000

Available diffs

Superseded in lucid-release
bleachbit (0.7.0-1) unstable; urgency=low

  * New upstream release.
  * debian/patches/GUI_relative_imports.patch:
    - Refreshed for new upstream release.

Available diffs

Superseded in lucid-release
Obsolete in karmic-release
bleachbit (0.6.3-1) unstable; urgency=low

  * New upstream release.

 -- Luca Falavigna <email address hidden>   Mon,  31 Aug 2009 22:25:34 +0100

Available diffs

Superseded in karmic-release
bleachbit (0.6.2-1ubuntu1) karmic; urgency=low

  * debian/patches/uncommon_locale:
    - Fix crash on startup with uncommon locales.

Available diffs

Superseded in karmic-release
bleachbit (0.5.4-1) unstable; urgency=low

  * New upstream release.

 -- Luca Falavigna <email address hidden>   Fri,  24 Jul 2009 16:47:36 +0100

Available diffs

Superseded in karmic-release
bleachbit (0.5.3-1) unstable; urgency=low

  * New upstream release.
  * Refresh patches for new upstream release:
    - debian/patches/desktop_file
  * Adjust Homepage field and download location to match current ones.

 -- Luca Falavigna <email address hidden>   Mon,  13 Jul 2009 15:41:08 +0100

Available diffs

Superseded in karmic-release
bleachbit (0.5.2-1) unstable; urgency=low

  * New upstream release.
  * Refresh patches for new upstream release:
    - debian/patches/desktop_file
    - debian/patches/no_update
  * Do not install Windows-specific cleaners, (as seen in release notes).
  * Bump Standards-Version to 3.8.2, no changes required.

 -- Luca Falavigna <email address hidden>   Mon,  29 Jun 2009 22:54:07 +0100

Available diffs

Superseded in karmic-release
bleachbit (0.5.1-1ubuntu1) karmic; urgency=low

  * debian/patches/distutils_use_dict:
    - Use dictionaries when passing arguments to setup function.

 -- Luca Falavigna <email address hidden>   Tue, 16 Jun 2009 21:12:48 +0200

Available diffs

Superseded in karmic-release
bleachbit (0.5.1-1) unstable; urgency=low

  * New upstream release.
  * Refresh patches for new upstream release:
    - debian/patches/desktop_file
    - debian/patches/no_update
  * debian/patches/suppress_locales_warnings:
    - Removed, fixed upstream.
  * Bump debhelper minimum version to 7.0.50 for override_* support.
  * Install only *.xml files from cleaners directory.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  15 Jun 2009 11:17:31 +0100

Available diffs

Superseded in karmic-release
bleachbit (0.4.2-1) unstable; urgency=low

  * New upstream release.
  * Switch to debhelper 7.
  * debian/patches/launcher:
    - Remove it, no longer needed because launcher has been replaced by
      a symlink to usr/share/bleachbit/bleachbit/GUI.py file.
  * debian/rules:
    - Make /usr/share/bleachbit/bleachbit/GUI.py executable.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  14 May 2009 14:17:11 +0100

Available diffs

Superseded in karmic-release
bleachbit (0.4.1-1) unstable; urgency=low

  * New upstream release.
    - French translation improved (Closes: #518951).
  * Remove patches merged upstream:
    - debian/patches/LANG_env
    - debian/patches/no_X
  * Refresh patches for new upstream release:
    - debian/patches/launcher
  * Remove python-dev from Build-Depends-Indep, use python instead.

Available diffs

Superseded in karmic-release
Obsolete in jaunty-release
bleachbit (0.3.1-0ubuntu1) jaunty; urgency=low

  * New upstream release.
  * Refreshed patch for new upstream release:
    - debian/patches/desktop_file
    - debian/patches/launcher
  * Add locales support:
    - debian/rules: add command to create and install .mo files.
    - debian/control: add gettext build-dependency.

 -- Luca Falavigna <email address hidden>   Thu, 05 Feb 2009 22:16:06 +0100

Available diffs

Superseded in jaunty-release
bleachbit (0.3.0-0ubuntu1) jaunty; urgency=low

  * New upstream release.
  * Refreshed patch for new upstream release:
    - debian/patches/desktop_file
    - debian/patches/launcher
  * Provide a bleachbit-root.desktop file to enable root privileges:
    - debian/rules: create the new file on top of bleachbit.desktop.
    - debian/bleachbit.install: install new .desktop file.
    - debian/control: let bleachbit recommends menu package.

 -- Luca Falavigna <email address hidden>   Thu, 29 Jan 2009 22:25:44 +0100

Available diffs

Superseded in jaunty-release
bleachbit (0.2.1-0ubuntu1) jaunty; urgency=low

  * New upstream release.
  * Convert bleachbit.png to XPM and replace debian/bleachbit.png icon.
  * debian/patches/launcher:
    - Implement and install a launcher to start the GUI.
  * Refresh these patches to adhere to the new release:
    - debian/patches/desktop_file
    - debian/patches/no_update

 -- Luca Falavigna <email address hidden>   Thu, 08 Jan 2009 12:56:26 +0100

Available diffs

Superseded in jaunty-release
bleachbit (0.2.0-0ubuntu1) jaunty; urgency=low

  * Initial release (LP: #313193).

 -- Luca Falavigna <email address hidden>   Fri, 02 Jan 2009 12:39:35 +0100
145 of 45 results