Change log for bnd package in Ubuntu

126 of 26 results
Published in disco-release on 2018-12-20
Deleted in disco-proposed (Reason: moved to release)
bnd (3.5.0-4) unstable; urgency=medium

  * Fixed the build failure with Java 11 (Closes: #912231)
  * Fixed the build failure caused by gradle-debian-helper 2.0.1
  * Ignore the dependency on xml-apis
  * Use salsa.debian.org Vcs-* URLs

 -- Emmanuel Bourg <email address hidden>  Wed, 19 Dec 2018 22:48:21 +0100

Available diffs

Superseded in disco-release on 2018-12-20
Published in cosmic-release on 2018-09-19
Deleted in cosmic-proposed (Reason: moved to release)
bnd (3.5.0-3) unstable; urgency=medium

  * Team upload.
  * Fixed the build failure with Gradle 4.4
  * Standards-Version updated to 4.2.1

 -- Emmanuel Bourg <email address hidden>  Mon, 17 Sep 2018 21:52:41 +0200

Available diffs

Superseded in cosmic-release on 2018-09-19
Deleted in cosmic-proposed on 2018-09-20 (Reason: moved to release)
bnd (3.5.0-2) unstable; urgency=medium

  * Install the Gradle plugin
  * Standards-Version updated to 4.1.5

 -- Emmanuel Bourg <email address hidden>  Mon, 30 Jul 2018 14:10:27 +0200

Available diffs

Superseded in cosmic-release on 2018-07-30
Published in bionic-release on 2018-03-29
Deleted in bionic-proposed (Reason: moved to release)
bnd (3.5.0-1) unstable; urgency=medium

  * New upstream release
  * Drop obsolete patches:
    * disable-jpm-plugin.patch
    * gradle-compatibility.patch
    * no_ee_minimum.patch
    * no-ee.j2se.patch
    * no-osgi.r5.patch
    * remove-recursion-in-macro-warning.patch
  * New patches:
    * build-scripts.patch: Make the Build Scripts Buildable
    * ant-compatibility: Fix Ant compatibility
  * Use simpler "get-orig-source" approach
  * Update Standards-Version to 4.1.3
  * Remove Damien Raude-Morvan from Uploaders (Closes: 889406)
  * Add myself to Uploaders
  * Update to debhelper compat level 11
  * Modify (Build-)Depends:
    * Switch to default-jdk-headless
    * Switch from junit to junit4
    * Restrict libosgi-compendium-java to >= 6
    * Restrict gradle-debian-helper to >= 1.6~
    + libfelix-framework-java
    + libfelix-gogo-runtime-java
    + libfelix-resolver-java
    + libosgi-annotation-java
    + libslf4j-java
    + libxz-java
    + libyaml-snake-java
  * Install generated POMs instead of downloading them from internet
  * Rename JARs in "/usr/share/java" to comply with the policies
  * Re-enable parallel build
  * Build & install more artifacts:
    * bnd-libg
    * bnd-junit
    * bnd-launcher
    * bnd-remote-agent
    * bnd-remote-api
    * bnd-remote-gc
    * bnd-remote-launcher
    * bnd-remote-main
    * bnd-repository
    * bnd-resolve
    * bnd-tester
    * bnd-repoindex-api
    * bnd-repoindex-lib

 -- Kai-Chung Yan (殷啟聰) <email address hidden>  Fri, 16 Mar 2018 00:50:18 +0800

Available diffs

Superseded in bionic-release on 2018-03-29
Deleted in bionic-proposed on 2018-03-30 (Reason: moved to release)
bnd (2.4.1-7) unstable; urgency=medium

  * Team upload.
  * Switch to compat level 10.
  * Declare compliance with Debian Policy 4.1.1.
  * Remove eclipse-jdt and eclipse-rcp from Build-Depends and do not suggest
    them anymore.
  * Remove obsolete Eclipse plugin symlinks and don't create eclipse-jdt
    directories.
  * Use https for Format field.
  * Update Homepage URL. (Closes: #845168)
  * Do not mention the Eclipse plugin in the package description anymore.
  * Build with --no-parallel option to avoid a race condition.

 -- Markus Koschany <email address hidden>  Thu, 02 Nov 2017 13:18:39 +0100

Available diffs

Superseded in bionic-release on 2017-11-03
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed (Reason: moved to release)
bnd (2.4.1-6) unstable; urgency=medium

  * Team upload
  * New transition_Gradle_3.1.patch
  * d/control:
    * Build-Depends on default-jdk-headless | default-jdk
    * Build-Depends on libfindbugs-ant-java instead of findbugs

 -- Kai-Chung Yan <email address hidden>  Mon, 14 Nov 2016 17:49:12 +0800

Available diffs

Superseded in zesty-release on 2016-11-14
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
bnd (2.4.1-5) unstable; urgency=medium

  * Team upload.
  * Removed the build dependency on libswt-gtk-3-java
  * Reproducibility improvements:
    - Sort the package lists generated by bnd (as in the Export-Package field)

 -- Emmanuel Bourg <email address hidden>  Tue, 30 Aug 2016 15:38:17 +0200

Available diffs

Superseded in yakkety-release on 2016-09-02
Deleted in yakkety-proposed on 2016-09-04 (Reason: moved to release)
bnd (2.4.1-4) unstable; urgency=medium

  * Team upload.
  * Fixed the build failure caused by the swicth from groovy2 to groovy
  * Standards-Version updated to 3.9.8 (no changes)
  * Use a secure Vcs-Git URL
  * Reproducibility improvements:
    - The value of the ${tstamp} and ${now} macros is now derived
      from SOURCE_DATE_EPOCH
    - Use SOURCE_DATE_EPOCH for the Bnd-LastModified field
    - Use SOURCE_DATE_EPOCH as the modification time of the entries
      in the jar files created by bnd

 -- Emmanuel Bourg <email address hidden>  Tue, 10 May 2016 18:34:32 +0200

Available diffs

Superseded in yakkety-release on 2016-07-10
Published in xenial-release on 2016-02-10
Deleted in xenial-proposed (Reason: moved to release)
bnd (2.4.1-3) unstable; urgency=medium

  * Team upload.
  * Enabled the Java 8 compatibility patch
  * Standards-Version updated to 3.9.7 (no changes)

 -- Emmanuel Bourg <email address hidden>  Wed, 10 Feb 2016 01:33:26 +0100

Available diffs

Superseded in xenial-release on 2016-02-10
Deleted in xenial-proposed on 2016-02-11 (Reason: moved to release)
bnd (2.4.1-2) unstable; urgency=medium

  * Team upload.
  * Removed the recursion in macro warnings causing out of memory errors.

 -- Emmanuel Bourg <email address hidden>  Sat, 02 Jan 2016 12:12:44 +0100

Available diffs

Superseded in xenial-proposed on 2016-01-02
bnd (2.4.1-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
    - Refreshed the patches
    - Updated the Maven poms
    - Build with Gradle instead of Ant
    - Refreshed debian/copyright
    - Require Java 6 or higher
    - Build the Gradle plugin during the bootstrap phase
    - Require libosgi-compendium-java >= 5.0.0-3 for the new OSGi types
    - Updated the linked jars and the ignored modules in debian/rules
    - Backported a fix to build with Gradle >= 2.3

 -- Emmanuel Bourg <email address hidden>  Thu, 17 Dec 2015 11:01:39 +0100

Available diffs

Superseded in xenial-release on 2016-01-31
Deleted in xenial-proposed on 2016-02-01 (Reason: moved to release)
bnd (2.2.0-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
    - Refreshed the patches
    - Updated the Maven poms
    - Added the missing resources to the bootstrap jar
    - Updated the linked jars in debian/rules
  * Restored the Java 8 compatibility patch
  * Use XZ compression for the upstream tarball
  * Build with the DH sequencer instead of CDBS

 -- Emmanuel Bourg <email address hidden>  Wed, 16 Dec 2015 11:55:37 +0100

Available diffs

Superseded in xenial-release on 2015-12-16
Deleted in xenial-proposed on 2015-12-18 (Reason: moved to release)
bnd (2.1.0-2) unstable; urgency=medium

  * Team upload.
  * Upload to unstable.
  * Vcs-Browser: Use https.
  * Update my e-mail address.

 -- Markus Koschany <email address hidden>  Mon, 16 Nov 2015 17:00:56 +0100

Available diffs

Superseded in xenial-release on 2015-11-17
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
bnd (1.50.0-9) unstable; urgency=medium

  * Team upload.
  * Add OSGi-6-methods.patch.
    - Fix FTBFS due to OSGi 5/6 transition.
  * Declare compliance with Debian Policy 3.9.6.
  * Move packaging to Git.
  * Tighten build-dependency and dependency on osgi-core and osgi-compendium.

 -- Markus Koschany <email address hidden>  Fri, 05 Jun 2015 23:55:15 +0200

Available diffs

Superseded in wily-release on 2015-06-06
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2018-01-19 (Reason: moved to release)
bnd (1.50.0-8) unstable; urgency=medium


  * Added a patch to fix the compilation errors with Java 8
  * debian/control:
    - Removed the dependency on openjdk-6-jdk
    - Standards-Version updated to 3.9.5 (no changes)
  * Switch to debhelper level 9

 -- Emmanuel Bourg <email address hidden>  Tue, 29 Apr 2014 14:05:29 +0200

Available diffs

Superseded in utopic-release on 2014-04-30
Published in trusty-release on 2013-10-21
Deleted in trusty-proposed (Reason: moved to release)
bnd (1.50.0-7) unstable; urgency=low


  * Install the Maven artifacts biz.aQute:annotation and biz.aQute:bnd

 -- Emmanuel Bourg <email address hidden>  Thu, 17 Oct 2013 22:15:13 +0200

Available diffs

Superseded in trusty-release on 2013-10-21
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
bnd (1.50.0-6) unstable; urgency=low


  [ Emmanuel Bourg ]
  * Added a patch to compile with Ant 1.9 (Closes: #712343)
  * Fixed the unmappable character errors during the compilation
  * debian/watch: Updated to catch the recent releases on Github
  * debian/control:
    - Updated Standards-Version to 3.9.4 (no changes)
    - Use canonical URLs for the Vcs-* fields
  * debian/rules: Improved the clean target
  * Updated the Maven pom

  [ Damien Raude-Morvan ]
  * d/rules: Don't fail clean target if there is no things to delete.
  * Upload to unstable.

 -- Emmanuel Bourg <email address hidden>  Fri, 26 Jul 2013 11:28:27 +0200

Available diffs

Superseded in saucy-release on 2013-09-02
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
bnd (1.50.0-5) unstable; urgency=low


  * d/rules: Fix FTBFS after update to eclipse 3.8.0~rc4-1 (Closes: #682647).
  * d/copyright: Update to copyright format 1.0.

 -- Damien Raude-Morvan <email address hidden>  Wed, 25 Jul 2012 00:34:41 +0200

Available diffs

Superseded in quantal-release on 2012-08-20
bnd (1.50.0-4) unstable; urgency=low


  * Fix FTBFS after update to eclipse 3.7.2-1 (Closes: #669533).
  * Add Jakub Adam to Uploaders.
  * Bump Standards-Version to 3.9.3: no changes needed.

 -- Jakub Adam <email address hidden>  Mon, 30 Apr 2012 22:44:59 +0200

Available diffs

Superseded in quantal-release on 2012-05-11
Published in precise-release on 2012-02-06
bnd (1.50.0-3) unstable; urgency=low


  * d/rules: Fix broken link with Eclipse JDT during build. (Closes: #655548).
  * d/patches/display_bsn_on_missing_bundle.diff: Improve error message when
    some bundle is missing.

 -- Damien Raude-Morvan <email address hidden>  Tue, 17 Jan 2012 23:16:19 +0100

Available diffs

Superseded in precise-release on 2012-02-06
bnd (1.50.0-2) unstable; urgency=low

  [ Miguel Landaeta ]
  * Team upload.

  [ James Page ]
  * Fix FTBFS with OpenJDK 7 (LP: #888926) (Closes: #651389):
    - d/ant.properties: Set default source/target to 1.5 to ensure
      backwards compatibility and avoid Java 7 encoding errors.
 -- Bhavani Shankar <email address hidden>   Thu, 08 Dec 2011 21:41:18 -0430

Available diffs

Superseded in precise-release on 2011-12-25
bnd (1.50.0-1ubuntu1) precise; urgency=low

  * Fix FTBFS with OpenJDK 7 (LP: #888926):
    - d/ant.properties: Set default source/target to 1.5 to ensure
      backwards compatibility and avoid Java 7 encoding errors.
 -- James Page <email address hidden>   Thu, 08 Dec 2011 09:25:02 +0000

Available diffs

Superseded in precise-release on 2011-12-08
bnd (1.50.0-1) unstable; urgency=low

  * New upstream release.
  * d/control: Add Build-Depends on libbindex-java.
  * d/{bootstrap,rules}: Add bindex.jar to classpath.
  * d/patches/no_git_during_build.diff: Don't try to use GIT during build.
  * d/patches/osgi43_fixes.diff: Some fixes for libosgi-core-java >= 4.3.
  * d/patches/no_felix.diff: Drop dependency on felix-framework (to remove
    dependency cycle).
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sun,  20 Nov 2011 12:04:58 +0000

Available diffs

Superseded in precise-release on 2011-11-20
bnd (1.44.0-1) unstable; urgency=low

  * New upstream version.
  * Bump Standards-Version to 3.9.2: no changes needed.
  * d/copyright: Upgrade to latest DEP-5 version.
  * Use upstream build system:
    - d/orig-tar.sh: Rework to use github (Closes: #640839).
    - d/build.xml, d/build.properties: Drop.
    - d/bootstrap.xml: Build a small bnd.jar just for its own bootstrap.
    - Rename d/svn-transform.sh to d/git-transform.sh and remove unneeded bits.
  * Enable full OSGi and Eclipse modules (Closes: #565749) :
    - d/control: Add Build-Depends on libswt-gtk-3-java, eclipse-rcp,
      eclipse-jdt and libosgi-core-java
    - d/control: Only Suggests: eclipse-rcp, eclipse-jdt
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  07 Nov 2011 10:02:06 +0000

Available diffs

Superseded in precise-release on 2011-11-07
bnd (0.0.384-2) unstable; urgency=low

  * Team upload.
  * Switch to source format 3.0.
  * Update Standards-Version: 3.9.1.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  17 Oct 2011 09:10:54 +0000

Available diffs

Superseded in precise-release on 2011-10-17
Obsolete in oneiric-release on 2015-04-24
Obsolete in natty-release on 2013-06-04
Obsolete in maverick-release on 2013-03-05
Obsolete in lucid-release on 2016-10-26
bnd (0.0.384-1) unstable; urgency=low

  * New upstream release
  * Exclude the Filter class from the distribution as it has
    some copyright issues and it is not used anymore in this
    new version of BND
  * Update copyright according to upstream changes, all
    contentious issues have been cleared.
  * Bump up Standards-Version to 3.8.3, no change

126 of 26 results