Change log for boa-constructor package in Ubuntu

123 of 23 results
Published in disco-release on 2018-10-30
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2017-10-24
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed (Reason: moved to release)
boa-constructor (0.6.1-16) unstable; urgency=low

  * QA upload.
  * Bump Standards-Version to 3.9.7.
  * Remove Vcs-* fields pointing to dead URLs.
  * Use SOURCE_DATE_EPOCH instead of BUILD_DATE, and depend on
    required debhelper version.
  * Sort files for boa.apphelp.htb archive.
  * Remove menu file.
  * Add Keywords to desktop file.
  * Don't install redundant license file.
  * Convert debian/copyright to DEP5.
  * Drop Python version restriction.

 -- Reiner Herrmann <email address hidden>  Fri, 25 Mar 2016 15:10:43 +0100

Available diffs

Superseded in yakkety-release on 2016-04-27
Published in xenial-release on 2015-10-24
Deleted in xenial-proposed (Reason: moved to release)
boa-constructor (0.6.1-15) unstable; urgency=medium

  * QA upload.
  * debian/rules: Add TZ=UTC. Now it should be reproducible.

 -- Santiago Vila <email address hidden>  Tue, 01 Sep 2015 17:44:32 +0200

Available diffs

Superseded in xenial-release on 2015-10-24
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2018-01-22 (Reason: moved to release)
boa-constructor (0.6.1-13) unstable; urgency=medium


  * QA upload.
  * Update to depend on python-wxgtk3.0 rather than python-wxgtk2.8:
    + New patch: wxpy3.0-compat.patch
    + Update/rename select_wxpython_2_8.patch to select_wxpython_3_0.patch.
  * Disable use of wx.media - this never worked in Debian, but now the
    module is gone too.
  * "Standards-Version: 3.9.5" - no changes required.
  * Update to debhelper compat level 9.
  * debian/README.source: Remove since it's obsolete with source format
    "3.0 (quilt)".

 -- Olly Betts <email address hidden>  Thu, 07 Aug 2014 23:55:41 +1200

Available diffs

Superseded in utopic-release on 2014-08-11
Published in trusty-release on 2013-10-18
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
Published in precise-release on 2011-11-20
boa-constructor (0.6.1-12) unstable; urgency=low

  * Orphaning package.
  * Update package to use wxwidgets2.8 (Closes: #645759).
  * Bump Standards-Version to 3.9.2, no changes required.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sun,  20 Nov 2011 12:05:04 +0000

Available diffs

Superseded in precise-release on 2011-11-20
Obsolete in oneiric-release on 2015-04-24
boa-constructor (0.6.1-11) unstable; urgency=low

  * debian/source:
    - switched to using source format 3.0 (quilt).
  * debian/control:
    - increase min python version to (>=2.6.6-11~).
    - after a discussion with Luca Falavigna I am taking over maintenance of 
      the package.  Added my info to Maintainers: field
    - bumped Standards-Version to 3.9.1, no changes needed.
    - removed dependency on quilt.
    - removed dependency on python-support.
    - use X-P-V instead of XS-P-V, increase version to 2.6
  * debian/rules:
    - removed "--with quilt", added "--with python2".
    - changed override to "dh_python2" and corrected syntax.
 -- Charlie_Smotherman (porthose) <email address hidden>   Thu,  16 Jun 2011 21:01:33 +0000

Available diffs

Superseded in oneiric-release on 2011-06-16
Obsolete in natty-release on 2013-06-04
boa-constructor (0.6.1-10ubuntu2) natty; urgency=low

  * Have package depend on pychecker.  Pychecker was never removed from the
    archives as stated in (lp: #527084).  This will eliminate the delta with
    debian, and the package can be synced next cycle.
 -- Charlie Smotherman <email address hidden>   Thur, 20 Jan 2010 09:57:12 -0500

Available diffs

Superseded in natty-release on 2011-02-07
Obsolete in maverick-release on 2013-03-05
boa-constructor (0.6.1-10ubuntu1) maverick; urgency=low

  * Merge from debian unstable (LP: #594178), remaining changes:
    - debian/control: Removed pychecker from depends. (lp: #527084)

Superseded in maverick-release on 2010-06-15
Obsolete in lucid-release on 2016-10-26
boa-constructor (0.6.1-9ubuntu1) lucid; urgency=low

  * debian/control:
    - Removed pychecker from depends. (lp: #527084)
 -- Nigel Babu <email address hidden>   Sat, 27 Feb 2010 19:40:14 +0530

Available diffs

Superseded in lucid-release on 2010-02-27
boa-constructor (0.6.1-9) unstable; urgency=low

  * Do not install embedded tarfile, zipfile and xmlrpclib modules, they
    are provided by stdlib (closes: #556355):
    + debian/patches/stdlib.patch:
      - Adjust files to load modules from stdlib.
    + debian/patches/no_maxint.patch:
      - Drop change on tarfile.py, it will not be installed anymore.
    + debian/rules:
      - Exclude affected files from the package.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  08 Dec 2009 08:14:55 +0000

Available diffs

Superseded in lucid-release on 2009-12-08
boa-constructor (0.6.1-8) unstable; urgency=low

  * Do not install embedded pyparsing module, suggest python-pyparsing
    instead, wx25upgrade.py needs it (Closes: #555367).
  * Do not install embedded ConfigParser module (Closes: #555426).
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  30 Nov 2009 19:05:22 +0000

Available diffs

Superseded in lucid-release on 2009-11-30
boa-constructor (0.6.1-7) unstable; urgency=low

  * Update my e-mail address.
  * Remove DM-Upload-Allowed field.
  * Switch to debhelper 7:
    - Bump compat level to 7.
    - Minimize debian/rules.
    - Build-Depend on debhelper (>= 7.0.50) and quilt (>= 0.46-7).
  * debian/patches/no_double_free.patch:
    - Do not attempt to free menu objects twice (Closes: #532988).
  * Depend on ${misc:Depends} to fix a lintian warning.
  * Bump Standards-Version to 3.8.3, no changes required.
  * Fix some wxWindows spelling errors in the description.
 -- Luca Falavigna <email address hidden>   Wed,  11 Nov 2009 12:29:14 +0000

Available diffs

Superseded in lucid-release on 2009-11-11
Obsolete in karmic-release on 2013-03-04
boa-constructor (0.6.1-6ubuntu1) karmic; urgency=low

  * debian/patches/no_double_free.patch:
    - Do not attempt to free menu objects twice (LP: #96012).

 -- Luca Falavigna <email address hidden>   Sun, 02 Aug 2009 22:09:51 +0200

Available diffs

Superseded in karmic-release on 2009-08-02
boa-constructor (0.6.1-6) unstable; urgency=low

  * Add Python Applications Packaging Team to Uploaders.
  * Add Vcs-* fields in source stanza.
  * debian/copyright:
    - Boa-Constructor is licensed under GPLv2, adjust link accordingly.
  * Switch to python-support:
    - Add python-support (>= 0.90.0) to Build-Depends-Indep.
    - Remove boa-constructor.postinst and boa-constructor.prerm files,
      skipping byte-compilation of ZopeLib/zoa/* files is handled using
      the appropriate dh_pysupport option.
    - Remove XB-Python-Version field boa-constructor binary stanza.
  * Switch to quilt:
    - Patches converted to new patch systems, descriptions updated.
    - README.source file adjusted to document quilt usage.
  * debian/patches/maxint:
    - Hardcode sys.maxint value to the one returned by 32-bit platforms,
      fix OverflowError on 64-bit machines (LP: #313952).
  * Adjust debian/rules:
    - Remove build target, useless.
    - Remove useless calls to some debhelper scripts.
  * Move boa-constructor.launcher to wrappers/boa-constructor, this way
    it can be installed directly by dh_install.
  * Bump Standards-Version to 3.8.1, no changes required.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  28 Apr 2009 22:59:23 +0100

Available diffs

Superseded in karmic-release on 2009-04-28
Obsolete in jaunty-release on 2013-02-28
boa-constructor (0.6.1-5) unstable; urgency=low

  * Install locales files (LP: #313955).
  * Bump to Standards-Version 3.8.0:
    - Add debian/README.source file for dpatch as per policy.
  * Remove some useless files:
    - debian/boa-constructor.dirs, not really needed.
    - debian/README.Debian, obsolete.
  * Add DM-Upload-Allowed field.

 -- Luca Falavigna <email address hidden>   Thu,  19 Feb 2009 18:12:59 +0000

Available diffs

Superseded in jaunty-release on 2009-02-19
Obsolete in intrepid-release on 2013-02-20
boa-constructor (0.6.1-4) unstable; urgency=high

  * Urgency high to fix RC bugs.
  * debian/control:
    - Move to XS-Python-Version: >= 2.4 (Closes: #476929, #477145).

 -- Ubuntu Archive Auto-Sync <email address hidden>   Sat,  03 May 2008 11:17:58 +0100
Superseded in intrepid-release on 2008-05-03
boa-constructor (0.6.1-3) unstable; urgency=low

  * Update to new policy (3.7.3)
  * Switch to new Homepage field

 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  02 May 2008 01:53:38 +0100
Superseded in intrepid-release on 2008-05-03
Obsolete in hardy-release on 2015-04-24
boa-constructor (0.6.1-2) unstable; urgency=low

  * Move to python-central
  * Do not byte-compile ZopeLib/zoa/* files (Closes: #399276)
    - Use dh_pycentral -n in debian rules
    - Install boa-constructor.postinst script
    - Install boa-constructor.prerm script
  * Do not call dh_desktop in debian/rules, no MIME types provided
  * Remove boa-constructor.preinst, now useless
  * Use Applications in menu file to fix menu-item-uses-apps-section
    lintian warning
  * Remove XS-Vcs-Bzr field in debian/control, not really useful for now
  * Add watch file

Superseded in hardy-release on 2007-10-23
Obsolete in gutsy-release on 2011-09-16
Obsolete in feisty-release on 2009-08-20
boa-constructor (0.4.4cvs20050714-4) unstable; urgency=low

  * Add a .desktop file (Closes: #349081)

Superseded in feisty-release on 2007-02-07
boa-constructor (0.4.4cvs20050714-2ubuntu2) feisty; urgency=low

  * Rebuild for python2.5 as the default python version.

 -- Matthias Klose <email address hidden>   Fri, 12 Jan 2007 13:19:31 +0000
Superseded in feisty-release on 2007-01-12
Obsolete in edgy-release on 2008-06-19
Obsolete in dapper-release on 2011-09-06
Superseded in dapper-release on 2006-02-03
boa-constructor (0.4.4cvs20050714-2ubuntu1) dapper; urgency=low


  * Resynchronise with Debian. (closes Malone bug #700)
  * Updated FSF address.
  * Updated Standards-Version to 3.6.2.1

 -- Zak B. Elep <email address hidden>  Mon, 14 Nov 2005 22:48:50 +0800
Obsolete in breezy-release on 2008-03-25
boa-constructor (0.4.4cvs20050714-1ubuntu2) breezy; urgency=low


  * Changed Depends from wxpython2.6-0 to python-wxgtk2.6

 -- Sebastian Dröge <email address hidden>  Wed, 24 Aug 2005 18:34:24 +0200
Obsolete in hoary-release on 2008-03-19
boa-constructor (0.3.0-3ubuntu1) hoary; urgency=low


  * Rebuild for python 2.4

 -- Andrew Mitchell <email address hidden>  Thu, 10 Feb 2005 01:09:18 +1300
Obsolete in warty-release on 2008-01-09
boa-constructor (0.2.8-2) unstable; urgency=low


  * Add "Examples" directory. Now examples can be opened (closes: Bug#235535)
  * Fix 2 typos in documentation (closes: Bug#228193, Bug#228194)
  
 -- Cédric Delfosse <email address hidden>  Sun, 23 May 2004 22:58:29 +0200
123 of 23 results