Change log for boinc-app-seti package in Ubuntu

137 of 37 results
Published in cosmic-release on 2018-06-06
Deleted in cosmic-proposed (Reason: moved to release)
boinc-app-seti (8.00~svn3725-3) unstable; urgency=medium

  * Switch export script to salsa.d.o
  * Update std-version to 4.1.4.1
  * Update Homepage to https mode
  * Update VCS fields to salsa.d.o

 -- Gianfranco Costamagna <email address hidden>  Wed, 06 Jun 2018 00:03:28 +0200

Available diffs

Superseded in cosmic-release on 2018-06-06
Deleted in cosmic-proposed on 2018-06-07 (Reason: moved to release)
boinc-app-seti (8.00~svn3725-2) unstable; urgency=medium

  * Fix arm64 build (add again the arm64 patch).

 -- Gianfranco Costamagna <email address hidden>  Thu, 17 May 2018 10:09:59 +0200
Superseded in cosmic-proposed on 2018-05-17
boinc-app-seti (8.00~svn3725-1) unstable; urgency=medium

  * Upload to unstable
  * Fix build failure due to missing stdio.h include

 -- Gianfranco Costamagna <email address hidden>  Wed, 16 May 2018 20:26:24 +0200
Superseded in cosmic-release on 2018-05-18
Published in bionic-release on 2017-10-24
Published in artful-release on 2017-09-12
Deleted in artful-proposed (Reason: moved to release)
boinc-app-seti (8.00~svn3701-1) unstable; urgency=medium

  * Upload to unstable

 -- Gianfranco Costamagna <email address hidden>  Mon, 11 Sep 2017 19:33:46 +0200

Available diffs

Superseded in artful-release on 2017-09-12
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
boinc-app-seti (8.00~svn3363-4) unstable; urgency=medium

  * Fix broken symlink (thanks Andreas Beckmann!)
    Closes: #857517

 -- Gianfranco Costamagna <email address hidden>  Wed, 15 Mar 2017 16:29:18 +0100

Available diffs

Superseded in zesty-release on 2017-03-16
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
boinc-app-seti (8.00~svn3363-3) unstable; urgency=medium

  [ Steffen Moeller ]
  * Transition to auto-dbg packages
  * Removed dependency on unused libgsl (Closes: #823878), thanks for spotting
    and suggesting so go to James Cowgill.
  * Bumped standard to 3.9.8.
  * Demand at least i686 architecture for x86.
  * Introduce -march=native for local builds and added respective instructions
    to debian/README.Debian

  [ Gianfranco Costamagna ]
  * Fix VCS fields.
  * Remove build fix for arm, preferring upstream fix.
  * Fix build with gcc-6 and glib-2.23 (Closes: #831186)

 -- Gianfranco Costamagna <email address hidden>  Thu, 14 Jul 2016 11:40:51 +0200

Available diffs

Superseded in yakkety-release on 2016-07-15
Published in xenial-release on 2016-02-02
Deleted in xenial-proposed (Reason: moved to release)
boinc-app-seti (8.00~svn3363-2) unstable; urgency=medium

  * Fix an armhf build failure by reverting the pld removal.

 -- Gianfranco Costamagna <email address hidden>  Tue, 02 Feb 2016 09:15:18 +0100
Superseded in xenial-proposed on 2016-02-02
boinc-app-seti (8.00~svn3363-1) unstable; urgency=medium

  * New upstream release (Closes: #813326).

 -- Gianfranco Costamagna <email address hidden>  Thu, 21 Jan 2016 10:01:38 +0100

Available diffs

Superseded in xenial-release on 2016-02-02
Deleted in xenial-proposed on 2016-02-04 (Reason: moved to release)
boinc-app-seti (7.28~svn3106-1) unstable; urgency=medium

  * New upstream release.
  * Update my uid.
  * Set priority optional
  * Drop useless build-dependencies (autoconf, automake, libtool)
    useless with dh-autoreconf

 -- Gianfranco Costamagna <email address hidden>  Fri, 11 Sep 2015 09:41:54 +0200

Available diffs

Superseded in xenial-release on 2015-10-29
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
boinc-app-seti (7.28~svn3013-1) unstable; urgency=medium

  * New upstream release.
  * d/p/216-fix-build.patch fix build error

 -- Gianfranco Costamagna <email address hidden>  Mon, 23 Feb 2015 14:49:35 +0100

Available diffs

Superseded in wily-release on 2015-08-11
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
boinc-app-seti (7.28~svn2633-3) unstable; urgency=medium


  * Bump std-version to 3.9.6, no changes required.
  * Stop depending on old boinc-dev.
  * Update copyright, now in machine readable format.
  * Add description to patches, reorder them,
    use patch name as written in README.patches.

 -- Gianfranco Costamagna <email address hidden>  Tue, 30 Sep 2014 14:49:40 +0200

Available diffs

Superseded in vivid-release on 2014-10-24
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to release)
boinc-app-seti (7.28~svn2408-1) unstable; urgency=medium


  * Updated Guo's uid in debian/control.
  * New upstream release, build against boinc 7.4.8.

 -- Gianfranco Costamagna <email address hidden>  Sun, 08 Jun 2014 10:26:17 +0200

Available diffs

Superseded in utopic-release on 2014-07-02
Deleted in utopic-proposed on 2014-07-03 (Reason: moved to release)
boinc-app-seti (7.28~svn2385-1) unstable; urgency=medium


  * New upstream release, build against new boinc 7.3.19.

 -- Gianfranco Costamagna <email address hidden>  Thu, 05 Jun 2014 19:19:23 +0200

Available diffs

Superseded in utopic-release on 2014-06-06
Deleted in utopic-proposed on 2014-06-07 (Reason: moved to release)
boinc-app-seti (7.28~svn2203-1) unstable; urgency=medium


  * New upstream release, patch refresh.
  * Drop fix-armel.patch and fix-ftbfs-arm64.patch, addressed
    upstream.

 -- Gianfranco Costamagna <email address hidden>  Mon, 14 Apr 2014 00:10:11 +0200

Available diffs

Superseded in utopic-release on 2014-04-26
Published in trusty-release on 2014-03-09
Deleted in trusty-proposed (Reason: moved to release)
boinc-app-seti (7.19~svn2051-2) unstable; urgency=medium


  * Upload to unstable.
  * Switch to dh-autoreconf.
  * Tweak app-info.xml file after upstream suggestion,
    thanks Claggy!
  * Moved app name from setiathome_enhanced to setiathome_v7
    for upstream suggestion.

 -- Gianfranco Costamagna <email address hidden>  Wed, 05 Mar 2014 09:40:55 +0100
Superseded in trusty-release on 2014-03-09
Deleted in trusty-proposed on 2014-03-10 (Reason: moved to release)
boinc-app-seti (7.19~svn2050-2.is.7.00~svn1933-2) unstable; urgency=low


  * Re added autotools-dev as build-dep, fixing arm64 ftbfs

 -- Gianfranco Costamagna <email address hidden>  Mon, 30 Dec 2013 23:04:20 +0100
Superseded in trusty-proposed on 2013-12-31
boinc-app-seti (7.19~svn2050-2.is.7.00~svn1933-1) unstable; urgency=low


  * Tweak debian/rules, forcing 7.00 as version
  * Rebuild 1933 against new boinc_7.2.33+dfsg-1 (Closes: #733204)

 -- Gianfranco Costamagna <email address hidden>  Sun, 29 Dec 2013 17:09:45 +0100
Superseded in trusty-proposed on 2013-12-29
boinc-app-seti (7.19~svn2050-1) unstable; urgency=low


  * New upstream snapshot.
  * Fixed a ftbfs on ubuntu arm64.

 -- Gianfranco Costamagna <email address hidden>  Fri, 22 Nov 2013 13:34:26 +0100

Available diffs

Superseded in trusty-proposed on 2013-11-27
boinc-app-seti (7.19~svn2022-1) unstable; urgency=low


  * Upload to unstable
  * New upstream release, addressing some autosetup warnings
  * Added autotools-dev as build-dep (Closes: #727333)

 -- Gianfranco Costamagna <email address hidden>  Fri, 11 Oct 2013 18:22:23 +0200

Available diffs

Superseded in trusty-proposed on 2013-10-25
boinc-app-seti (7.07~svn1976-1) unstable; urgency=low


  * New upstream release, patch refresh.
  * Tweaked debian/rules, now uses _autosetup script.
  * Added libtool as build-dep.

 -- Gianfranco Costamagna <email address hidden>  Wed, 04 Sep 2013 18:43:28 +0200
Superseded in trusty-release on 2013-12-31
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
boinc-app-seti (7.00~svn1933-1) unstable; urgency=low


  * New upstream release.
  * Removed win_build, mac_build, vector_lib, jpeglib
    not used in building and not completely listed in copyright file.
  * debian/copyright and README.sources have been updated.
  * dropping 101_freebsd_build.patch and separate_build_dir.patch,
    accepted upstream.
  * Removed debian/watch, unused.
  * Little changes in debian/README.source files.

 -- Gianfranco Costamagna <email address hidden>  Thu, 25 Jul 2013 09:38:04 +0200

Available diffs

Superseded in saucy-release on 2013-07-27
Deleted in saucy-proposed on 2013-07-28 (Reason: moved to release)
boinc-app-seti (7.00~svn1883-2) unstable; urgency=low


  [ Gianfranco Costamagna ]
  * Added libxmu-dev, libxi-dev as build-depends
  * Added boinc-manager as boinc-app-seti suggests fields
  * Tweaked some version checks in control file
  * Rebuild against boinc 7.1.21+dfsg-1
    to fix a FTBFS in ubuntu saucy.

  [ Guo Yixuan ]
  * Added a new package: boinc-app-seti-graphics, which provide
    a visualizer for seti.

 -- Gianfranco Costamagna <email address hidden>  Thu, 27 Jun 2013 13:13:29 +0200

Available diffs

Superseded in saucy-release on 2013-07-15
Deleted in saucy-proposed on 2013-07-16 (Reason: moved to release)
boinc-app-seti (7.00~svn1883-1) unstable; urgency=low


  * New upstream release.
  * New app_info.xml file (Closes: 711734)

 -- Gianfranco Costamagna <email address hidden>  Tue, 18 Jun 2013 11:23:57 +0200

Available diffs

Superseded in saucy-release on 2013-06-25
Deleted in saucy-proposed on 2013-06-26 (Reason: moved to release)
boinc-app-seti (7.00~svn1854-1) unstable; urgency=low


  * New upstream release.
    - Makefiles bugs fixed.
  * Added libgsl0-dev as build-dep.

 -- Gianfranco Costamagna <email address hidden>  Fri, 24 May 2013 11:33:48 +0200

Available diffs

Superseded in saucy-release on 2013-06-18
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
boinc-app-seti (6.97~svn1409-1) unstable; urgency=low


  [Eric J. Korpela]
  * app_info.xml: setiathome_enhanced replies to version 6 and 7 jobs

  [Guo Yixuan]
  * Removed Windows binaries in source tree, and some other files, see
    README.source.
  * New upstream version:
    - sah_v7 branch becomes trunk.
    - new feature: autocorrelation.
    - re-enabled 003_dont_use_own_jpeglib.patch, and refreshed some patches.

  [Steffen Moeller]
  * debian/control: boinc-app-seti suggests boinc-manager

 -- Guo Yixuan <email address hidden>  Tue, 28 Aug 2012 11:05:07 +0800
Superseded in raring-release on 2012-11-08
Obsolete in quantal-release on 2015-04-24
boinc-app-seti (6.12~svn1305-2ubuntu1) quantal; urgency=low

  * debian/patches/004_disable_altivec_on_ppc_linux.patch: Disable use of
    altivec on PPC in the case of LINUX. Fixes FTBFS.
 -- Ben Collins <email address hidden>   Tue, 12 Jun 2012 22:28:38 -0400
Superseded in quantal-release on 2012-06-13
boinc-app-seti (6.12~svn1305-2) unstable; urgency=low


  * debian/control:
    - remove quilt from build-depends.
    - add myself in Uploaders.
  * debian/rules:
    - add dh_install in override target to install app_info.xml and seti.cfg.
    - use dpkg-buildflags to add -g and default hardening options.

 -- Guo Yixuan <email address hidden>  Thu, 24 May 2012 23:16:40 +0800

Available diffs

Superseded in quantal-release on 2012-05-28
boinc-app-seti (6.12~svn1305-1) unstable; urgency=low


  * New upstream version.
    - Removed all patches
    - Adjusted debian/rules for dynamic linking
  * Updated debian/control
    - Steffen's uploader's email address, removed Martin
    - Set priority to extra (from optional)
  * Bumped policy compliance to 3.9.3
    - Source format 3.0
    - Adjusted clean target to allow repeated builds with git
    - added build-arch/-indep debian/rules targets
  * README.Debian and README.source get some extra wording

 -- Steffen Moeller <email address hidden>  Sat, 19 May 2012 15:17:06 +0200
Superseded in quantal-release on 2012-05-26
Published in precise-release on 2011-10-13
Obsolete in oneiric-release on 2015-04-24
boinc-app-seti (5.13+cvs20060510-7ubuntu1) oneiric; urgency=low

  * debian/rules: add include directories to fix FTBFS.
  * Rebuild gets rid of openssl0.9.8 binary dependency.
 -- Ilya Barygin <email address hidden>   Thu, 18 Aug 2011 23:15:11 +0400
Superseded in oneiric-release on 2011-08-18
Obsolete in natty-release on 2013-06-04
Obsolete in maverick-release on 2013-03-05
boinc-app-seti (5.13+cvs20060510-7) unstable; urgency=low

  * debian/control:
    - Add myself to uploaders
    - Use Standards-Version 3.8.4 (No changes needed)
    - Bump boinc-dev B-D to 6.10.17+dfsg-3 
  * Includes Ilya Barygin <email address hidden> patchs to fix a FTBFS
    coming since the last upgrade of boinc-dev, thanks for the 
    patches! (Closes: #556817) 
  * debian/rules: 
    - Delete configure to prevent ship the modified file
    - Use `clean' instead of `distclean', dist-clean fails to clean the package.
    - Remove some auto-generated files that are not cleaned on `clean' target
  * Switch to dpkg-source 3.0 (quilt) format
    - Remove quilt from debian/rules and from B-D
    - Remove README.source
 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  18 May 2010 15:26:07 +0100
Superseded in maverick-release on 2010-05-18
Obsolete in lucid-release on 2016-10-26
boinc-app-seti (5.13+cvs20060510-6ubuntu1) lucid; urgency=low

  * Fix FTBFS (debian/patches/20*.patch):
    - don't use std_fixes.h which is not provided by boinc-dev anymore
    - use new str_replace.h where necessary
    - declare some pointers as const char* to fix invalid conversion
 -- Ilya Barygin <email address hidden>   Tue, 26 Jan 2010 14:57:50 +0300
Superseded in lucid-release on 2010-01-26
Obsolete in karmic-release on 2013-03-04
boinc-app-seti (5.13+cvs20060510-6) unstable; urgency=low

  * debian/control:
    - Bumped Standards-Version from 3.8.0 to 3.8.1, no changes required.
    - Removed myself from Uploaders.

Superseded in karmic-release on 2009-04-28
Obsolete in jaunty-release on 2013-02-28
Obsolete in intrepid-release on 2013-02-20
boinc-app-seti (5.13+cvs20060510-4) unstable; urgency=low

  [ Steffen Moeller ]
  * debian/rules: Wrote get-orig-source target that downloads the latest
    nightly tarball.

  [ Frank S. Thomas ]
  * debian/control.in:
    - Bumped Standards-Version from 3.7.2 to 3.7.3, no changes required.
    - Changed my maintainer address to <email address hidden>.
  * debian/rules: Remove --disable-dependency-tracking from configure's
    arguments, because it breaks some handwritten rules in client/Makefile.am
    which require that $(DEPDIR) exists.
  * Bumped debhelper compat level from V5 to V6 since this is the current
    recommended level and raised the build dependency to "debhelper (>= 6)".
  * debian/patches/: Added 201_missing_header_for_gcc4.3.patch in order to
    fix a FTBFS with recent GCC 4.3 snapshots. Thanks to Martin Michlmayr
    <email address hidden> for the bug report. (closes: #462051)

 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  02 May 2008 01:53:39 +0100
Superseded in intrepid-release on 2008-05-03
Obsolete in hardy-release on 2015-04-24
boinc-app-seti (5.13+cvs20060510-3) unstable; urgency=low

  * debian/rules: Remove two binary files that are not removed by "make clean"
    and use clean instead of distclean as DEB_MAKE_CLEAN_TARGET, because
    distclean removes files that are needed to build this package. These
    changes fixes the FTBFS if build twice in a row. (closes: #442513)
  * debian/control.in:
    - Moved Homepage pseudo field in the long description to the source stanza
      because this is now a propper debian/control field supported by dpkg.
    - fftw3-dev was renamed to libfftw3-dev, adjusted Build-Depends
      accordingly.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  23 Oct 2007 15:32:30 +0100
Superseded in hardy-release on 2007-10-23
Obsolete in gutsy-release on 2011-09-16
boinc-app-seti (5.13+cvs20060510-2) unstable; urgency=low

  * debian/boinc-app-seti-prerm: Stop the BOINC core client before removing
    the SETI@home symlinks from the data directory to prevent the client from
    downloading new work units although no application to process these is
    present. (related to: #415765)
  * debian/control.in:
    - Added XS-Vcs fields to the source stanza.
    - Improved the description of the package and explicitly stated that this
      package is not needed on i386 and amd64 hosts since SETI@home supports
      those architectures officially.
  * debian/copyright: Added copyright information for glut/Roman.stroke and
    glut/stroke.h and added a copyright note about the Debian packaging.
  * Changed from dpatch to the quilt patch system.
  * debian/patches/:
    - 004_include_new_str_util.h.patch added. The strlcpy() and strlcat()
      functions that were previously declared in boinc-dev/lib/util.h have
      been moved in BOINC 5.10 to the new boinc-dev/lib/str_util.h header
      file, so we need to include this new header in some files. Bumped build
      dependency to "boinc-dev (>= 5.10.8-1)" accordingly. (closes: #433737)
    - 003_dont_use_own_jpeglib.patch modified to prevent that setiathome is
      linked against libjpeg. This ensures predictability of the dependecy
      list, see http://lists.debian.org/debian-devel/2007/07/msg00588.html for
      details.

 -- Andrew Mitchell <email address hidden>   Fri,  10 Aug 2007 10:29:58 +0100
Superseded in gutsy-release on 2007-08-10
Obsolete in feisty-release on 2009-08-20
boinc-app-seti (5.13+cvs20060510-1ubuntu1) feisty; urgency=low

  * Rebuild for ldbl128 change (powerpc, sparc).
  * Set Ubuntu maintainer address.

 -- Matthias Klose <email address hidden>   Thu,  1 Mar 2007 22:31:24 +0000
Superseded in feisty-release on 2007-03-02
Obsolete in edgy-release on 2008-06-19
boinc-app-seti (5.13+cvs20060510-1) unstable; urgency=low

  * Initial release based on Steffen Moeller's boinc-client-seti package.

 -- William Grant <email address hidden>   Thu,  28 Sep 2006 11:12:38 +0100
137 of 37 results