Seg fault when connecting

Bug #68074 reported by Ryan Kavanagh on 2006-10-24
Affects Status Importance Assigned to Milestone
bzflag (Ubuntu)
curl (Ubuntu)
Cody A.W. Somerville

Bug Description

Binary package hint: bzflag

Steps to reproduce:
 * Start bzflag
 * Join Game
 * Enter your username and password (for your callsign)
 * Select a sever from the list
 * Connect
 * Watch it crash :)

Please see the attached backtrace.

Ryan Kavanagh (ryanakca) wrote :

It seems to be something related to CURL...

Javier Jardón (jjardon) wrote :

In Kubuntu edgy

no crash for me (i have a ati FireGL8800i and I use opensource 3d ati drivers (r200))

nagy.pite (nagy.pite) wrote :

problem is the same.
ubuntu is edgy.
it happens about 4 times out of 5.

nagy.pite (nagy.pite) wrote :

sorry, forgot: it just appeared a few days before edgy became non-beta. (i used the beta one)
before it worked perfectly.

ville palo (vi64pa) wrote :

Happens on my edgy too, status changed to confirmed

Changed in bzflag:
status: Unconfirmed → Confirmed
ville palo (vi64pa) wrote :

Comments from upstream:

"This looks like a libcurl bug, please refer it to them.
As a workaround, use an older version of libcurl."

ville palo (vi64pa) wrote :

More info from upstream:

"It seems this issue has been raised with libcurl team before at
According to the thread it may have been fixed in cvs."

ville palo (vi64pa) on 2006-11-02
Changed in bzflag:
assignee: nobody → vi64pa
ville palo (vi64pa) on 2006-11-03
Changed in bzflag:
assignee: vi64pa → nobody
ville palo (vi64pa) wrote :

Changing curl bug status to fix committed, because fix is in curl CVS.

Changed in curl:
status: Unconfirmed → Fix Committed
ville palo (vi64pa) wrote :

Changing bzflag bug status to fix committed, because bug was in curl and fix is already in the CVS of curl

Changed in bzflag:
status: Confirmed → Fix Committed
Kolja Giedke (giedke) wrote :

Steps to reproduce:

 * Start bzflag -solo 5
 * start server
 * trying to connect
 * crashes....

Paul Zaremba (pez-launchpad) wrote :

This is still broken in Edgy and will be broken until Curl 7.15.5 is available for general use.

This bug *needs* to be reopened.

As a workaround (for people that find this bug) I downloaded the source and diff from the Feisty page for 7.15.5-1ubuntu1 and compiled the packages for edgy. bzflag doesn't crash anymore when I join games.

Changed in curl:
status: Fix Committed → Confirmed
Paul Zaremba (pez-launchpad) wrote :

curl still broken in edgy, re-opening

Changed in bzflag:
status: Fix Committed → Confirmed

Rejecting bzflag: This is a bug in curl, not bzflag.

Changed in bzflag:
status: Confirmed → Rejected
ville palo (vi64pa) wrote :

Curl will be broken in edgy forever without SRU request. For SRU request new bug report must be filled.
"Fix Committed: A fix has been included in the code, but this code is not necessarily available in a released version."

From: Jari Sundell <>
Date: 2006-07-16

On 7/16/06, Jari Sundell <email address hidden> wrote:
> On 7/16/06, Jari Sundell <email address hidden> wrote:
> >
> > Having looked at the splay code, I think the implementation could have
> > been cleaner and more robust.
> >
> The attached patch makes Curl_splayremovebyaddr properly handle double
> remove errors even if there's a node with the same key or the removed node
> was in the 'same' list.

The above changes got me closer to the point of failure. I found that
curl_multi_remove_handle sets easy->easy_handle->multi to NULL before
Curl_done is called, thus Curl_expire won't remove the timenode.



Attaching patch that was committed to SVN upstream. Maybe we can do a sru?

Cody A.W. Somerville

On Mon, 27 Nov 2006, Cody A.W. Somerville wrote:

Please remove me as CC for this "bug". This is not a bug in any recent curl,
but a bug in your version of curl and we (in the curl project) fixed it a long
time ago.

Fixed in Edgy. Please file new bug report for sru.

Daniel: This should be the last e-mail you get.

Changed in curl:
status: Confirmed → Fix Released

Correction. Meant to say fix fixed in Feisty. An SRU is in progress for edgy.

Changed in curl:
assignee: nobody → cody-somerville
Michael Vogt (mvo) wrote :

I'm unable to verifiy the crash on a stock edgy install. This is important for the sru-verificaton step. Do I need to connect to a special server?

Paul Zaremba (pez-launchpad) wrote :

It's random. Sometimes it would happen if I reconnected to a server, but try four or five times in the same session and it should eventually crash.

See bug #73447 for SRU request.

catay (mertens-steven) wrote :

To simulate it you have to be a registered bzflag user. If I remember correctly it doesn't
crash with a not-registered user.

Create an account on the official forum : .
You should use the callsign/password provided there in your bzflag client to connect
to a server.

Hope this helps.



Michael Vogt (mvo) wrote :

Thanks for this additional information. I was able to verify it now.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.