Change log for bzr package in Ubuntu

76150 of 193 results
Obsolete in natty-updates on 2013-06-04
Deleted in natty-proposed on 2013-06-04 (Reason: moved to -updates)
bzr (2.3.4-0ubuntu1) natty-proposed; urgency=low

  * New upstream release.
   + Fix bzr version number in deprecation warnings. LP: #794960
   + Prevent write attemps on remote branch during "bzr up". LP: #786980
   + Fix conflict handling when two trees involved in a merge have different
     root ids. LP: #805809

Available diffs

Superseded in oneiric-release on 2011-07-16
bzr (2.4.0~beta4-4ubuntu2) oneiric; urgency=low

  * Fix FTBFS: build without --parallel.
 -- Jelmer Vernooij <email address hidden>   Thu, 23 Jun 2011 11:45:29 +0200
Superseded in oneiric-release on 2011-06-23
bzr (2.4.0~beta4-4ubuntu1) oneiric; urgency=low

  * Merge from Debian. Remaining changes:
   + Drop build dependencies on python-{subunit,meliae,lzma,medusa}, which are
     not in main.
   + Disable support for running selftest in parallel (requires subunit).
 -- Jelmer Vernooij <email address hidden>   Thu, 23 Jun 2011 10:57:10 +0200
Superseded in oneiric-release on 2011-06-23
bzr (2.4.0~beta4-1ubuntu1) oneiric; urgency=low

  * Merge from Debian.

Superseded in natty-proposed on 2011-07-19
bzr (2.3.3-0ubuntu1) natty-proposed; urgency=low

  * New upstream release.
   + Fixes deprecation warning on newer versions of Python. LP: #760435
   + Stops 'bzr push' from copying entire repository if a .bzr directory is
     present without a branch. LP: #465517
   + Fixes undefined local variable error when waiting for lock. LP: #733136
   + Fixes lock contention issues pushing to a bound branch. LP: #733350
   + Transfers less data creating a new stacked branch. LP: #737234
   + Several fixes to the test suite, making it more robust. LP: #654733,
      LP: #751824
   + 'bzr merge --pull --preview' actually shows a preview rather than
     actually merging. LP: #760152
   + bzr smart server now supports UTF-8 user names. LP: #659763
   + user identity can now be set based on username and /etc/mailname, not
     requiring it to be set manually. LP: #616878
   + stacking is now fully transitive. LP: #715000
   + makes in-terminal crash report of plugins much shorter. LP: #716389
 -- Jelmer Vernooij <email address hidden>   Wed, 08 Jun 2011 13:58:00 +0100

Available diffs

Obsolete in lucid-updates on 2016-10-26
Deleted in lucid-proposed on 2016-11-01 (Reason: moved to -updates)
bzr (2.1.4-0ubuntu1) lucid-proposed; urgency=low

  * Update watch file to use 2.1 series.
  * New upstream release.
   + Fix file descriptors leaks in dirstate compiled extension. LP: #583486
   + Refuse to stack on repositories in incompatible formats. LP: #562380
   + Don't delete nested trees/repos. LP: #572098
   + Fix 'bzr switch' crash when a 'ConfigurableFileMerger' is used. LP: #559436
   + Fix compatibility with older smart servers. LP: #528041
   + Fix symlinks addition. LP: #192859
   + Properly unversion children of unversioned directories. LP: #494221
   + Lock configuration files in '~/.bazaar' for updates. LP: #525571
   + Fix 'bzr commit <symlink>'. LP: #128562
   + Fix `lp:` urls when behind an http proxy. LP: #558343
   + Stop using edge.launchpad.net. LP: #583667
 -- Max Bowsher <email address hidden>   Tue, 17 May 2011 09:54:17 +0100

Available diffs

Superseded in oneiric-release on 2011-06-17
bzr (2.4.0~beta2-2ubuntu1) oneiric; urgency=low

  * Merge from Debian experimental.
   + Remove build dependencies not present in main: python-medusa,
     python-subunit, python-meliae, python-lzma.
   + Disable parallel testing.
 -- Jelmer Vernooij <email address hidden>   Sat, 30 Apr 2011 16:20:58 +0200
Obsolete in maverick-updates on 2013-03-05
Deleted in maverick-proposed on 2013-03-05 (Reason: moved to -updates)
bzr (2.2.4-0ubuntu1) maverick-proposed; urgency=low

  [ Jelmer Vernooij ]
  * Update watch file to use 2.2 series.
  * New upstream release.
   + Fixes closing of leaked sockets to SSH subprocesses, which causes
     dput sftp uploads to hang. LP: #659590
   + Fixes the use of 'lp:' urls behind a http proxy. LP: #558343
   + Correctly sets the Content-Type header when http POSTing to comply
     with stricter web frameworks. LP: #665100
   + Fixes propagating tags to the master branch in a bound branch or
     heavyweight checkout. LP: #603395
   + Fixes the use of 'bzr resolve --take-other' if the file is
     involved in an unresolved text conflict. LP: #646961
   + Fixes https access with newer versions of python2.7. LP: #693880
   + Fixes crash during pack caused by a concurrent repository pack
     operation. LP: #701940
   + Fixes communication with the Launchpad web service when using
     launchpadlib >= 1.5.5. LP: #707075
   + Switches away from deprecated 'edge.launchpad.net' LP: #583667
   + Fixes resolving of content (and path) conflicts for files in subdirs.
     LP: #660935
   + Fixes nasty recursion loop while displaying branch opening error.
     LP: #687653

  [ Martin Pool ]
  * Propose for maverick SRU.
 -- Martin Pool <email address hidden>   Thu, 07 Apr 2011 15:30:17 +1000

Available diffs

Superseded in oneiric-release on 2011-04-30
Obsolete in natty-release on 2013-06-04
bzr (2.3.1-1ubuntu1) natty; urgency=low

  * Drop build dependency on python-subunit (universe). LP: #713038.
  * Disable parallel tests.
 -- Matthias Klose <email address hidden>   Sat, 26 Mar 2011 01:50:11 +0100

Available diffs

Superseded in natty-release on 2011-03-26
bzr (2.3.1-1) unstable; urgency=low

  * New upstream release.
   + Build depend on python-configobj >= 4.7.2+ds-2 which has a fix for bug
     #618349 which breaks the Bazaar testsuite.
  * Switch to dh_python2.
  * Switch to debhelper 7, drop cdbs.

Available diffs

Superseded in natty-release on 2011-03-22
bzr (2.3.0-2) unstable; urgency=low

  * Split python library into a separate package. Closes: #561647

Available diffs

Superseded in natty-release on 2011-02-08
bzr (2.3.0~beta5-1) unstable; urgency=medium

  [ Jelmer Vernooij ]
  * Cherrypick fix for compatibility with python2.7 >= 2.7.1-2.  LP: #693880
  * Switch to python-support. Closes: #568462
  * Add missing build dependency on python-configobj.
  * Make dependency on python-testtools versioned (>= 0.9.5).
  * Re-remove included elementtree and configobj. Closes: #555343, #555336

  [ Vincent Ladeuil ]
  * New upstream release.
   + Fix https python-2.7 compatibility. Closes: #608085
   + Follow the Freedesktop XDG Base Directory Specification. LP: #195397
  * Drop unnecessary dependency on graphviz.

  [ Max Bowsher ]
  * Run testsuite for bundled plugins too.

  [ Jelmer Vernooij ]
  * Cherrypick fix around default locales.
 -- Jelmer Vernooij <email address hidden>   Tue,  25 Jan 2011 18:25:51 +0000
Superseded in natty-release on 2011-01-25
bzr (2.3.0~beta3-1ubuntu3) natty; urgency=low

  * Revert back to 2.3.0~beta3-1ubuntu1 as it's not just the readline() issue
    causing problems, but bzr will corrupt .bzr dirs with python 2.7, see
    LP #654731.
  * Really use python2.6 by setting --executable to /usr/bin/python2.6 instead
    of /usr/bin/python in debian/rules; thanks Bilal Akhtar.
 -- Loic Minier <email address hidden>   Mon, 03 Jan 2011 18:54:29 +0100
Superseded in natty-release on 2011-01-03
bzr (2.3.0~beta3-1ubuntu2) natty; urgency=low

  * Revert changes from 2.3.0~beta3-1ubuntu1 as they don't fix the build.
  * New patch, fix-readline-python2.7, from
    https://code.launchpad.net/~vila/bzr/2.2-693880-ssl-readline; LP: #693880.
 -- Loic Minier <email address hidden>   Mon, 03 Jan 2011 18:43:13 +0100
Superseded in natty-release on 2011-01-03
bzr (2.3.0~beta3-1ubuntu1) natty; urgency=low

  * Force usage of python2.6 both while building and when the bzr command
    is executed. This is a temporary change to fix issues caused in bzr
    due to the python 2.7 transition. (LP: #693880)
 -- Bilal Akhtar <email address hidden>   Mon, 03 Jan 2011 18:10:35 +0300
Superseded in natty-release on 2011-01-03
bzr (2.3.0~beta3-1build1) natty; urgency=low

  * Rebuild to add support for python 2.7.
 -- Matthias Klose <email address hidden>   Thu, 02 Dec 2010 23:58:46 +0000
Superseded in natty-release on 2010-12-03
bzr (2.3.0~beta3-1) unstable; urgency=low

  [ Jelmer Vernooij ]
  * Add testtools to build dependencies.
  * Run tests by default again, unless "nocheck" is present in
    DEB_BUILD_OPTIONS. (per policy)

  [ Max Bowsher ]
  * Amend watch file to match current package version scheme.
  * New upstream release.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  09 Nov 2010 09:44:23 +0000

Available diffs

Superseded in natty-release on 2010-11-09
bzr (2.3.0~beta2-1) unstable; urgency=low

  * New upstream release.
  * Rebuild with python2.5 modules. Closes: #593409

Available diffs

Superseded in maverick-updates on 2011-04-26
Deleted in maverick-proposed on 2011-04-27 (Reason: moved to -updates)
bzr (2.2.1-0ubuntu1) maverick-proposed; urgency=low

  * New upstream release.
   + Fix regression with upgrading poor-root to rich-root formats. LP: #636930
   + Files in ~/.bazaar are now locked whilst being updated automatically.
     LP: #525571
 -- Max Bowsher <email address hidden>   Thu, 30 Sep 2010 09:57:15 +0100

Available diffs

Superseded in natty-release on 2010-10-15
Obsolete in maverick-release on 2013-03-05
bzr (2.2.0-1) unstable; urgency=low

  * New upstream release.
   + Adds support for setting timestamps to originating revisions.
     Closes: #473450
   + Removes remaining string exception. Closes: #585193, LP: #586926
   + Add C extension to work around Python issue 1628205. LP: #583941,
     Closes: #577110
   + Avoids showing progress bars when --quiet is used. Closes: #542105,
     LP: #320035
   + No longer creates ~/.bazaar as root when run under sudo. LP: #376388
   + 'bzr commit' now supports -p as alternative for --show-diff. LP: #571467
   + 'bzr add' no longer adds .THIS/.BASE/.THEIRS files unless
     explicitly requested. LP: #322767
   + When parsing patch files, Bazaar now supports diff lines before each
     patch. LP: #502076
   + WorkingTrees now no longer requires using signal.signal, so can
     be used in a threaded environment. LP: #521989
   + An assertion error is no longer triggered when pushing to a pre-1.6
     Bazaar server. LP: #528041
  * Bump standards version to 3.9.1.

Available diffs

Superseded in maverick-release on 2010-08-08
bzr (2.1.2-1) unstable; urgency=low

  * New upstream release.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  28 May 2010 11:22:38 +0100

Available diffs

Superseded in maverick-release on 2010-05-28
bzr (2.1.1-1.1) unstable; urgency=low

  * Non-maintainer upload with Jelmer's permission.
  * Backport fix from bzr 2.2 that makes bzr-git and bzr-svn operations
    work reliably again.  Closes: #582033
 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  18 May 2010 11:15:51 +0100

Available diffs

Superseded in maverick-release on 2010-05-18
Obsolete in lucid-release on 2016-10-26
bzr (2.1.1-1) unstable; urgency=low

  * Remove bob2 from uploaders. Closes: #573427
  * New upstream release.
 -- James Westby <email address hidden>   Fri,  26 Mar 2010 19:52:35 +0000

Available diffs

Superseded in lucid-release on 2010-03-26
bzr (2.1.0-1) unstable; urgency=low

  * New upstream release.
 -- Daniel Holbach <email address hidden>   Thu,  18 Feb 2010 08:38:52 +0000

Available diffs

Superseded in lucid-release on 2010-02-18
bzr (2.1.0~rc2-1) experimental; urgency=low

  * New upstream release.
  * Switch to dpkg-source 3.0 (quilt) format.
  * Bump standards version to 3.8.4.
  * Remove embedded copy of python-configobj. Closes: #555336
  * Remove embedded copy of python-elementtree. Closes: #555343
 -- Jelmer Vernooij <email address hidden>   Fri,  12 Feb 2010 22:33:45 +0000

Available diffs

Superseded in lucid-release on 2010-02-13
bzr (2.0.4-1) unstable; urgency=low

  [ Andrew Starr-Bochicchio ]
  * debian/control: Fix obsolete-relation-form-in-source
    lintian warning. 

  [ John Francesco Ferlito ]
  * New upstream release.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  08 Feb 2010 11:02:34 +0000

Available diffs

Superseded in lucid-release on 2010-02-08
bzr (2.0.3-1) unstable; urgency=low

  * New upstream release.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  01 Jan 2010 10:08:38 +0000

Available diffs

Obsolete in karmic-updates on 2013-03-04
Deleted in karmic-proposed on 2013-03-04 (Reason: moved to -updates)
bzr (2.0.2-0ubuntu1) karmic-proposed; urgency=low

  * Proposed SRU, taking all changes from Bazaar's 2.0.2 new bugfix-only
    upstream release.
  * Avoid "NoneType has no attribute st_mode" error when files disappear
    from a directory while it's being read. LP: #446033
  * Content filters are now applied correctly after revert.
  * Diff parsing handles "Binary files differ" hunks.  LP: #436325
  * Fetching from stacked pre-2a repository via a smart server no longer
    fails intermittently with "second push failed to complete".
    LP: #437626
  * Fix typos left after test_selftest refactoring.
    LP: #461149
  * Fixed ``ObjectNotLocked`` errors during ``bzr log -r NNN somefile``.
    LP: #445171
  * PreviewTree file names are not limited by the encoding of the temp
    directory's filesystem. LP: #436794
  * ``bzr log`` now read-locks branches exactly once, so makes better use of
    data caches.
  * Filtered views user documentation upgraded to refer to format 2a
    instead of pre-2.0 formats.
  * ``bzr add`` in a tree that has files with ``\r`` or ``\n`` in the
    filename will issue a warning and skip over those files.
    LP: #3918
  * bzr will attempt to authenticate with SSH servers that support
    ``keyboard-interactive`` auth but not ``password`` auth when using
    Paramiko.   LP: #433846
  * Fixed fetches from a stacked branch on a smart server that were failing
    with some combinations of remote and local formats.  This was causing
    "unknown object type identifier 60" errors.  LP: #427736
  * Fixed ``ObjectNotLocked`` errors when doing some log and diff operations
    on branches via a smart server.  LP: #389413
  * Handle things like ``bzr add foo`` and ``bzr rm foo`` when the tree is
    at the root of a drive. ``osutils._cicp_canonical_relpath`` always
    assumed that ``abspath()`` returned a path that did not have a trailing
    ``/``, but that is not true when working at the root of the filesystem.
    LP: #322807
  * Hide deprecation warnings for 'final' releases for python2.6.
    LP: #440062
  * Improve the time for ``bzr log DIR`` for 2a format repositories.
    We had been using the same code path as for <2a formats, which required
    iterating over all objects in all revisions.
    LP: #374730
  * Make sure that we unlock the tree if we fail to create a TreeTransform
    object when doing a merge, and there is limbo, or pending-deletions
    directory.  LP: #427773
  * Occasional IndexError on renamed files have been fixed. Operations that
    set a full inventory in the working tree will now go via the
    apply_inventory_delta code path which is simpler and easier to
    understand than dirstates set_state_from_inventory method. This may
    have a small performance impact on operations built on _write_inventory,
    but such operations are already doing full tree scans, so no radical
    performance change should be observed. LP: #403322
  * Retrieving file text or mtime from a _PreviewTree has good performance when
    there are many changes.
  * The CHK index pages now use an unlimited cache size. With a limited
    cache and a large project, the random access of chk pages could cause us
    to download the entire cix file many times.
    LP: #402623
  * When a file kind becomes unversionable after being added, a sensible
    error will be shown instead of a traceback. LP: #438569
  * Improved README.
  * Improved upgrade documentation for Launchpad branches.
 -- Martin Pool <email address hidden>   Mon, 14 Dec 2009 19:17:08 +1100

Available diffs

Superseded in lucid-release on 2010-01-01
bzr (2.0.2-1) unstable; urgency=low

  * New upstream release.

Available diffs

Superseded in lucid-release on 2009-12-07
Obsolete in karmic-release on 2013-03-04
bzr (2.0.0-0ubuntu1) karmic; urgency=low

  * New upstream release. (LP: #430467)
  * debian/bzr.install: Update path to files.

Available diffs

Superseded in karmic-release on 2009-09-22
bzr (1.18-0ubuntu1) karmic; urgency=low

  * New upstream release.
  * Take from Debian bzr in to karmic.

 -- James Westby <email address hidden>   Wed, 26 Aug 2009 13:04:49 +0100

Available diffs

Superseded in karmic-release on 2009-08-26
bzr (1.17-1) unstable; urgency=low

  * New upstream release.
   + Fixes compatibility with Python 2.4. Closes: #537708

 -- James Westby <email address hidden>   Fri,  24 Jul 2009 10:06:29 +0100

Available diffs

Superseded in karmic-release on 2009-07-24
bzr (1.17~rc1-1) unstable; urgency=low

  * New upstream version.
  * Bump standards version to 3.8.2.

 -- James Westby <email address hidden>   Mon,  20 Jul 2009 19:15:56 +0100

Available diffs

Superseded in karmic-release on 2009-07-20
bzr (1.16.1-1) unstable; urgency=low

  * New upstream release.
  * Bump standards version to 3.8.2.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  29 Jun 2009 21:36:07 +0100

Available diffs

Superseded in karmic-release on 2009-06-29
bzr (1.16-1) unstable; urgency=low

  * New upstream release.
  * Add python-pyrex to build-deps to ensure C extensions are always build.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  22 Jun 2009 15:34:28 +0100

Available diffs

Superseded in karmic-release on 2009-06-22
bzr (1.15-1) unstable; urgency=low

  * New upstream release.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  04 Jun 2009 05:47:24 +0100

Available diffs

Superseded in karmic-release on 2009-06-04
bzr (1.15~rc1-1) unstable; urgency=low

  * New upstream release.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  01 Jun 2009 10:41:34 +0100

Available diffs

Superseded in karmic-release on 2009-06-01
bzr (1.14-2) unstable; urgency=low

  * Fix API compatibility version. (Closes: #526233)

 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  01 May 2009 20:30:26 +0100

Available diffs

Superseded in karmic-release on 2009-05-01
bzr (1.14-1) unstable; urgency=low

  * New upstream release.
    + Fixes default format for upgrade command. (Closes: #464688)

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  30 Apr 2009 08:51:19 +0100

Available diffs

Superseded in karmic-release on 2009-04-30
bzr (1.14~rc1-2) unstable; urgency=low

  * Add missing dependency on zlib development library. (Closes:
    #523595)

Available diffs

Superseded in karmic-release on 2009-04-28
Obsolete in jaunty-release on 2013-02-28
bzr (1.13.1-1) unstable; urgency=low

  * New upstream release.
  * Move to section vcs.
  * Bump standards version to 3.8.1.

 -- Max Bowsher <email address hidden>   Fri,  03 Apr 2009 20:40:24 +0100

Available diffs

Superseded in jaunty-release on 2009-04-03
bzr (1.13~rc1-1build1) jaunty; urgency=low

  * No-change rebuild to fix lpia shared library dependencies.

 -- Colin Watson <email address hidden>   Thu, 19 Mar 2009 12:24:32 +0000

Available diffs

Superseded in jaunty-release on 2009-03-19
bzr (1.13~rc1-1) unstable; urgency=low

  * New upstream release.

 -- James Westby <email address hidden>   Mon,  16 Mar 2009 08:43:12 +0000

Available diffs

Superseded in jaunty-release on 2009-03-16
bzr (1.12-1build1) jaunty; urgency=low

  * Rebuild for python2.6.

 -- Matthias Klose <email address hidden>   Sun, 22 Feb 2009 00:41:08 +0000

Available diffs

Superseded in jaunty-release on 2009-02-22
bzr (1.12-1) experimental; urgency=low

  * New upstream release.

Available diffs

Superseded in jaunty-release on 2009-02-17
bzr (1.11-1) experimental; urgency=low

  * New upstream release.

Available diffs

Superseded in jaunty-release on 2009-02-09
bzr (1.9-1) experimental; urgency=low

  * New upstream release.

Available diffs

Superseded in jaunty-release on 2008-11-10
Obsolete in intrepid-release on 2013-02-20
bzr (1.6.1-1) experimental; urgency=low

  * New upstream release.

Available diffs

Superseded in intrepid-release on 2008-09-24
bzr (1.6-1) experimental; urgency=low

  * New upstream release.

Available diffs

Obsolete in hardy-updates on 2015-04-24
Deleted in hardy-proposed on 2015-04-30 (Reason: moved to -updates)
bzr (1.3.1-1ubuntu0.1) hardy-proposed; urgency=low

  * Fix a bug when checking out some branches over bzr+ssh://.
    This fix is cherrypicked from upstream 1.4. (LP: #230294)
  * Modify Maintainer value to match the DebianMaintainerField
    specification.

 -- James Westby <email address hidden>   Thu, 29 May 2008 22:34:44 +0100

Available diffs

Superseded in intrepid-release on 2008-08-28
bzr (1.5-1) unstable; urgency=low

  * Final 1.5 release.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  19 May 2008 07:39:40 +0100
Superseded in intrepid-release on 2008-05-19
bzr (1.5~rc1-1) unstable; urgency=low

  * New upstream release.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  15 May 2008 07:37:50 +0100
Superseded in intrepid-release on 2008-05-15
bzr (1.4-1) unstable; urgency=low

  [ Jelmer Vernooij ]
  * New upstream release.
  * Add myself as a co-maintainer.

  [ Adeodato Simó ]
  * Add a Dm-Upload-Allowed: yes header.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  05 May 2008 10:16:54 +0100
Superseded in intrepid-release on 2008-05-05
Obsolete in hardy-release on 2015-04-24
bzr (1.3.1-1) unstable; urgency=low

  * New upstream bugfix release.

 -- LaMont Jones <email address hidden>   Fri,  18 Apr 2008 17:19:06 +0100
Obsolete in gutsy-backports on 2011-09-16
bzr (1.3.1~rc1-0ubuntu1~gutsy1) gutsy-backports; urgency=low

  * Automated backport upload; no source changes.

Superseded in hardy-release on 2008-04-18
bzr (1.3.1~rc1-0ubuntu1) hardy; urgency=low

  * New upstream bug fix release:
    - Fix a bug causing a ValueError crash in ``parse_line_delta_iter`` when
      fetching revisions from a knit to pack repository or vice versa using
      bzr:// (including over http or ssh). (LP: #208418)
    - No other changes.

 -- Martin Pitt <email address hidden>   Fri, 04 Apr 2008 15:47:27 +0200
Superseded in hardy-release on 2008-04-04
bzr (1.3-1) unstable; urgency=low

  * Final 1.3 release.

Superseded in hardy-release on 2008-04-01
bzr (1.2~rc1-1build2) hardy; urgency=low

  * Rebuild with python-central (>= 0.5.60).

 -- Matthias Klose <email address hidden>   Sun, 02 Mar 2008 18:49:00 +0000
Superseded in hardy-release on 2008-03-02
bzr (1.2~rc1-1build1) hardy; urgency=low

  * rebuild due to python-central issues

 -- Sebastien Bacher <email address hidden>   Tue, 19 Feb 2008 19:45:51 +0100
Superseded in hardy-release on 2008-02-19
bzr (1.2~rc1-1) unstable; urgency=low

  * First release candidate of the upcoming 1.2 release.

    (NB: 1.1 final was never packaged because there were no code changes
    between 1.1~rc1 and 1.1 itself.)

 -- Martin Pitt <email address hidden>   Tue,  19 Feb 2008 07:39:24 +0000
Superseded in hardy-release on 2008-02-19
bzr (1.1~rc1-1) unstable; urgency=low

  * First release candidate of the upcoming 1.1 release.

  * Bump Standard-Versions to 3.7.3 (no changes required).

 -- Daniel Holbach <email address hidden>   Wed,  13 Feb 2008 18:26:54 +0000
Superseded in gutsy-backports on 2008-04-08
bzr (1.0-1~gutsy1) gutsy-backports; urgency=low

  * Automated backport upload; no source changes.

Superseded in hardy-release on 2008-02-13
bzr (1.0-1) unstable; urgency=low

  * Final 1.0 release.
    + Wrong download links in User Guide fixed. (Closes: #455592)
    + Drop now unneeded patch fix_version_strings.diff.

  * After some chat with upstream, recommend `bzr upgrade` and then `bzr
    reconcile` in NEWS.Debian, instead of reconcile before upgrade, since
    reconciling in the old format (knits) can be remarkably slower than in
    the new format (packs). (NB: this should only be done with 1.0~rc2 and
    later, due to LP #165290.)

 -- Ubuntu Archive Auto-Sync <email address hidden>   Sat,  15 Dec 2007 12:44:39 +0000
Superseded in hardy-release on 2007-12-15
bzr (1.0~rc2-2) unstable; urgency=low

  * Apply patch to fix wrong version numbers in bzr and bzrlib.
    (See https://bugs.launchpad.net/bzr/+bug/175171.)

Superseded in hardy-release on 2007-12-10
bzr (1.0~rc1-2) unstable; urgency=low

  * Install images that come with the documentation.

  * Remove unnecessary stuff from the clean target in debian/rules, and
    invoke $(MAKE) clean-docs from there so that building twice in a row
    works.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  03 Dec 2007 09:51:45 +0000
Superseded in hardy-release on 2007-12-03
bzr (1.0~rc1-1) unstable; urgency=low

  [ Adeodato Simó ]
  * First release candidate of the upcoming 1.0 release; see NEWS.Debian for
    more information.

  [ Arnaud Fontaine ]
  * Rename XS-Vcs-Bzr to Vcs-Bzr field (dpkg supports it now).
  * Add Homepage field.
  * Update GPL path to GPL-2 as GPL-3 is now the default.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Sat,  01 Dec 2007 13:18:45 +0000
Superseded in hardy-release on 2007-12-01
bzr (0.92-1) unstable; urgency=low

  * Final 0.92 release.
    - Introduction Packs as experimental format, which is expected to become
      the default format for the final release.            (Closes: #396227)

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  15 Nov 2007 10:38:06 +0000
Superseded in hardy-release on 2007-11-15
bzr (0.92~rc1-1) unstable; urgency=low

  * First release candidate for the upcoming 0.92 version.

  * Dropped Andres Salomon from the Uploaders field, at his request.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Sat,  03 Nov 2007 13:08:20 +0000
Superseded in hardy-release on 2007-11-03
bzr (0.91-2) unstable; urgency=low

  * remove python-celementree and python-paramiko from build-depends.
    rationale:
      - python-celementree is purely an optimisation for python2.4,
        and is already included in python2.5
      - python-paramiko is not used during build at all. However, the
        testsuite currently fails when paramiko is not installed
        (see also #59150 in launchpad.net for details). Since we
        currently don't run the testsuite by default on the buildds,
        it is safe to remove that dependency, at least for now.

Superseded in hardy-release on 2007-10-23
Obsolete in gutsy-release on 2011-09-16
bzr (0.90-1) unstable; urgency=low

  * Final 0.90 upstream release:
    + the doc/ directory has been re-organized in subdirectories, thus
      separating between *.txt and *.html cannot be easily done from
      bzr.install anymore. Do it from debian/rules instead.
    + update bzr.doc-base for this new layout as well.

  * Ship documents under doc/developers, following upstream wishes.

  * Use "/usr/bin/python" in the she-bang line instead of "/usr/bin/env
    python". Rationale in LP: #134046 is right.

Superseded in gutsy-release on 2007-09-11
bzr (0.18-1) unstable; urgency=low

  * New upstream version.

  * Drop version constraints in Build-Depends and Depends, all are satisfied
    in etch.

  * Add a patch to skip the generation of doc/developers/*.htm, since we don't
    ship those in the package.

  * debian/rules:
    + pass -r to xargs.
    + drop commented out install/bzr:: hunk.
    + don't abort the test suite on the first error.

  * Bits to help Ubuntu:

    + prefix dependency and build-dependency on python-celementtree with a
      "python (>> 2.5)" alternative, since Python 2.5 includes celementtree.

    + apply patch from Ubuntu to drop python2.4-specific shebang lines, and
      hence spurious dependency on python2.4 (submitted upstream).

    + drop build-dependency on python-medusa, only needed to exercise the FTP
      part of the test suite.

Superseded in gutsy-release on 2007-07-20
bzr (0.17-0ubuntu2) gutsy; urgency=low

  * Add debian/patches/no-python-2.4.patch: Remove hashbangs that are Python
    2.4 specific, so that we get rid of python2.4 from the CDs. (LP: #120659)

 -- Martin Pitt <email address hidden>   Mon, 25 Jun 2007 10:40:25 +0200
Superseded in gutsy-release on 2007-06-25
bzr (0.17-0ubuntu1) gutsy; urgency=low

  * New upstream release

 -- Etienne Goyer <email address hidden>   Mon, 18 Jun 2007 08:56:21 -0400
Superseded in gutsy-release on 2007-06-19
bzr (0.17~rc1-0ubuntu2) gutsy; urgency=low

  * Removed python-celementtree, python-medusa and python-paramiko from the
    Build-Depend-Indep

 -- Etienne Goyer <email address hidden>   Fri, 15 Jun 2007 08:41:47 -0400
Superseded in gutsy-release on 2007-06-15
bzr (0.17~rc1-0ubuntu1) gutsy; urgency=low

  * New upstream development release
  * debian/control: Setted Maintainer to ubuntu-dev, added Original-Maitainer
  * debian/rules: also remove man1/* and doc/developers/*.htm in the clean
    target

 -- Etienne Goyer <email address hidden>   Thu, 14 Jun 2007 16:20:21 -0400
76150 of 193 results