Accessibility options are not preserved on installs

Bug #50319 reported by Benjamin Mako Hill
8
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
Undecided
Colin Watson
ubiquity (Ubuntu)
Undecided
Colin Watson

Bug Description

If a users presses F5 and then selects an accessibility options (e.g., magnification) those options are not preserved and enabled by default if a user then installs Ubuntu on their system.

This issue was discussed in the "accessibility on the live CD" BOF at UDS Paris.

Revision history for this message
Colin Watson (cjwatson) wrote :

I reckon that this is because the casper's accessibility ubiquity hook wants to su to the newly-created user, but that user hasn't been created yet at that point in the proceedings. I'm not yet sure about where it would be best to fix this.

Revision history for this message
Henrik Nilsen Omma (henrik) wrote :

Subscribing Tollef as per Aug. 31. Dev meeting:

> 06:08 Mithrandir Kamion: I'll grab 50319

Thanks!

Tollef Fog Heen (tfheen)
Changed in casper:
assignee: nobody → tfheen
Revision history for this message
Colin Watson (cjwatson) wrote :

So, this turned out to be a bit of both casper and ubiquity. I've fixed a few minor bugs in casper which had to be dealt with, but the real structural fix was in ubiquity.

casper (1.66) edgy; urgency=low

  * Fix use of db_get in ubiquity accessibility hook.
  * Use sudo instead of su to get to the live session user from the
    initramfs or to the newly-installed user from ubiquity. su's argument
    handling has changed so that the previous code no longer worked, and su
    was never all that good for arguments containing spaces anyway.

 -- Colin Watson <email address hidden> Mon, 4 Sep 2006 15:46:55 +0100

Changed in casper:
assignee: tfheen → kamion
status: Unconfirmed → Fix Released
Revision history for this message
Colin Watson (cjwatson) wrote :

ubiquity (1.1.12) edgy; urgency=low

  * Install apt-setup cdrom generator.
  * Send all log messages to syslog rather than stderr. Use log-output from
    di-utils for external processes where necessary.
  * Remove several obsolete functions from ubiquity.misc.
  * Fix misc.ex to use subprocess.call properly rather than smashing
    arguments together and invoking them via the shell.
  * Remove duplicate logging from Install.chrex.
  * Remove /var/log/installer/syslog from all error messages etc., as
    everything goes to /var/log/syslog now. /var/log/syslog is now copied to
    /var/log/installer/syslog on the target system.
  * Automatically set UBIQUITY_NO_GTK or UBIQUITY_NO_KDE to disable building
    frontends as appropriate if tools are missing (pygtk-codegen-2.0 for the
    GTK frontend, kdepyuic for the KDE frontend). This should never happen
    in normal builds, but saves typing when building test versions.
  * Teach DebconfFilter to send escaped replies when CAPB escape is set.
  * Fix substitution variable for full name in ubiquity/summary.
  * I never really understood the whole control flow around the summary
    page, and I wrote it! Take advantage of the partman-commit script added
    in partman-base 90ubuntu4, so that instead we shut down partman, run the
    summary page, and then start it back up to commit changes. The
    PartmanCommit component is now used for both automatic and manual
    partitioning, and is simply called directly from progress_loop; and the
    Summary component no longer needs to be run with a temporary debconf
    database.
  * Configure locales and the user account before running target-config
    hooks (closes: Malone #50319).
  * GTK frontend: Put a button on the summary page to allow the user to
    install GRUB to somewhere other than the MBR of the first hard disk
    (closes: Malone #41579).
  * Install list-devices, since a fair bit of backend code now uses it.
  * Automatic update of included source packages: debian-installer-utils
    1.35ubuntu2, partman-base 90ubuntu5, partman-target 45ubuntu1.

 -- Colin Watson <email address hidden> Mon, 4 Sep 2006 22:54:02 +0100

Changed in ubiquity:
assignee: nobody → kamion
status: Unconfirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers