Ubuntu

No dialogue / status bar for progress of Audio disc image creation

Reported by Aaron Whitehouse on 2006-02-15
10
Affects Status Importance Assigned to Milestone
cdrdao
Unknown
Unknown
cdrdao (Ubuntu)
Low
Unassigned

Bug Description

When I put a CD into the computer, right-click the icon on the desktop and click "copy disc", it writes a disc image, asks me to swap the source disc for a blank disc and then writes the disc.

This works fine but, at the disc image creation stage (writing the disc image to my tmp directory), there is no change in the dialogue and the progress bar does not move. This is quite confusing as the only way to know that anything is happening is by watching the flashing drive and watching the size of the temporary iso image increase in size.

It would be excellent if the progress bar could move to indicate how long the writing of the image will take and that it is working.

Sebastien Bacher (seb128) wrote :

Thanks for your bug. What version of Ubuntu do you use? The creating image dialog has a progress bar and an estimation of the time required to create it on my dapper installation

Changed in nautilus-cd-burner:
assignee: nobody → desktop-bugs
status: Unconfirmed → Needs Info
Aaron Whitehouse (luna-tick) wrote :

Breezy Badger 5.10. The version of the package is:
nautilis-cd-burner 2.12.1-0ubuntu1

Daniel Holbach (dholbach) wrote :

Could you attach a screenshot of the dialog? As Sébastien said, it should have a time estimate.

This is a screenshot of the dialogue when creating a disc image.

It stays as in the above screenshot until it asks for a disc and then changes to the progress of writing the disc.

Sebastien Bacher (seb128) wrote :

Could you use gconf-editor to set /apps/nautilus-cd-burner/debug to true, then run from a command line:
- gnome-session-remove nautilus
- nautilus

then duplicate the CD from nautilus, wait for the copy to start and copy the command line log to a comment?

Aaron Whitehouse (luna-tick) wrote :
Download full text (3.9 KiB)

Thanks for the detailed instructions :). When copying an audio CD (the nearest CD I had on hand) the output is as follows:

When I first put in the CD there is a whole lot of:
(nautilus:9163): libgnomevfs-WARNING **: Cannot load module `/usr/lib/gnome-vfs-2.0/modules/libcdda.so' (/usr/lib/gnome-vfs-2.0/modules/libcdda.so: cannot open shared object file: No such file or directory)

When I right-click the "Audio Disc" and click Copy, I get:

cdrdao stderr: Cdrdao version 1.1.9 - (C) Andreas Mueller <email address hidden>
cdrdao stderr: SCSI interface library - (C) Joerg Schilling
cdrdao stderr: Paranoia DAE library - (C) Monty
cdrdao stderr:
cdrdao stderr: Check http://cdrdao.sourceforge.net/drives.html#dt for current driver tables.
cdrdao stderr:
cdrdao stderr: Using libscg version 'ubuntu-0.8ubuntu1'
cdrdao stderr:
cdrdao stderr: /dev/hdc: HL-DT-ST RW/DVD GCC-4243N Rev: A102
cdrdao stderr: Using driver: Generic SCSI-3/MMC - Version 2.0 (options 0x0000)
cdrdao stderr:
cdrdao stderr: Reading toc and track data...
cdrdao stderr:
cdrdao stderr: Track Mode Flags Start Length
cdrdao stderr: ------------------------------------------------------------
cdrdao stderr: 1 AUDIO 2 00:00:00( 0) 04:10:01( 18751)
cdrdao stderr: 2 AUDIO 2 04:10:01( 18751) 03:57:26( 17801)
cdrdao stderr: 3 AUDIO 2 08:07:27( 36552) 04:01:64( 18139)
cdrdao stderr: 4 AUDIO 2 12:09:16( 54691) 03:47:61( 17086)
cdrdao stderr: 5 AUDIO 2 15:57:02( 71777) 03:47:03( 17028)
cdrdao stderr: 6 AUDIO 2 19:44:05( 88805) 03:47:11( 17036)
cdrdao stderr: 7 AUDIO 2 23:31:16(105841) 03:55:11( 17636)
cdrdao stderr: 8 AUDIO 2 27:26:27(123477) 03:29:08( 15683)
cdrdao stderr: 9 AUDIO 2 30:55:35(139160) 03:55:61( 17686)
cdrdao stderr: 10 AUDIO 2 34:51:21(156846) 03:37:41( 16316)
cdrdao stderr: 11 AUDIO 2 38:28:62(173162) 03:46:71( 17021)
cdrdao stderr: 12 AUDIO 2 42:15:58(190183) 03:35:39( 16164)
cdrdao stderr: 13 AUDIO 2 45:51:22(206347) 03:47:43( 17068)
cdrdao stderr: 14 AUDIO 2 49:38:65(223415) 03:34:26( 16076)
cdrdao stderr: 15 AUDIO 2 53:13:16(239491) 03:47:46( 17071)
cdrdao stderr: Leadout AUDIO 2 57:00:62(256562)
cdrdao stderr:
cdrdao stderr: PQ sub-channel reading (audio track) is supported, data format is BCD.
cdrdao stderr: Copying audio tracks 1-15: start 00:00:00, length 57:00:62 to "/tmp/image.iso.cqKa5q"...
cdrdao stderr: Track 1...

----
It sits at this screen until the disc image is created (with no status indicated in the dialogue). When the image is complete, it echoes (after writing the image and before burning it):

cdrdao stderr: Found 269250 Q sub-channels with CRC errors.
cdrdao stderr: Reading of toc and track data finished successfully.
cdrdao stderr: HUP

(nautilus:9443): libgnomevfs-WARNING **: Cannot load module `/usr/lib/gnome-vfs-2.0/modules/libcdda.so' (/usr/lib/gnome-vfs-2.0/modules/libcdda.so: cannot open shared object file: No such file or directory)

(nautilus:9443): libgnomevfs-WARNING...

Read more...

Aaron Whitehouse (luna-tick) wrote :

With a data CD it has given me a progress bar with the two CDs that I just tried (the output is:

@Zyanya:~$ nautilus
seahorse nautilus module initialized
launching command: readcd -dev=/dev/hdc -f=/tmp/image.iso.d3Ja9U
readcd stderr: Read speed: 4234 kB/s (CD 24x, DVD 3x).
readcd stderr: Write speed: 4234 kB/s (CD 24x, DVD 3x).
readcd stderr: Capacity: 95433 Blocks = 190866 kBytes = 186 MBytes = 195 prMB
readcd stderr: Sectorsize: 2048 Bytes
readcd stderr: Copy from SCSI (1,0,0) disk to file '/tmp/image.iso.d3Ja9U'
readcd stderr: end: 95433
readcd stderr: ddr: 22912 cnt: 64

[The 22912 increments])

I don't remember if the first one that I tried was audio or data, but for now I'll change the bug title to just be audio CDs.

Sebastien Bacher (seb128) wrote :

nautilus-cd-burner update the bar according to the "%" which is usually written by cdrdao when it just sits without doing anything for you. Reassigning to bug to cdrdao

Changed in nautilus-cd-burner:
status: Needs Info → Unconfirmed
Aaron Whitehouse (luna-tick) wrote :

This still occurs on a fully updated Dapper Flight 6 install as at 9 April 2006.

Aaron Whitehouse (luna-tick) wrote :

There has been nearly two months of inaction on this - would you like me to forward the issue upstream for you?

Sebastien Bacher (seb128) wrote :

If you know cdrdao upstream and want to forward that you are welcome

Aaron Whitehouse (luna-tick) wrote :

Filed in Sourceforge bug tracker:
http://sourceforge.net/tracker/index.php?func=detail&aid=1466851&group_id=2171&atid=102171

It doesn't look as though that tracker is very active but I don't know where would be a better place to forward this.

Sebastien Bacher (seb128) wrote :

Thank you for forwarding it!

Changed in cdrdao:
assignee: desktop-bugs → nobody
status: Unconfirmed → Confirmed
Thomas Hotz (thotz) wrote :

Can you give us an update if this still happens on newer Ubuntu versions? Thank you!

Changed in cdrdao (Ubuntu):
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.