cglib 2.2+dfsg-1 source package in Ubuntu

Changelog

cglib (2.2+dfsg-1) unstable; urgency=low

  * New upstream release.
    - Rename source package to "cglib"
    - Drop unneeded Build-Depends on libaspectwerkz2-java
    - Build-Depends on libasm3-java instead of libasm-java
    - Drop uneeded debian/patches/01_build_classpath.patch 
  * Build-Depends on default-jdk instead of default-jdk-builddep
    because we don't build a native GCJ package.
  * Switch to debhelper 7
  * Use Quilt patch system:
    - refresh all debian/patches
    - Build-Depends on quilt
    - Update debian/README.source
  * Update my email address
  * Bump Standards-Version to 3.8.3: no changes needed
  * Fix debian/copyright to include BSD license of
    src/proxy/net/sf/cglib/core/LocalVariablesSorter.java

cglib2.1 (2.1.3.dfsg.2-2) unstable; urgency=low

  * Use default-java-builddep:
    - Remove B-D on java-gcj-compat-dev (Closes: #526274)
    - Add default-java-builddep to B-D
    - Use /usr/lib/jvm/default-java as JAVA_HOME
  * Move ant to B-D-I (needed for clean target)
  * Add myself as Uploaders
  * Add ${misc:Depends} as suggested by Lintian
  * Fix short-description of libcglib2.1-java-doc
    to include "documentation"
  * Fix Vcs-* fields to use "cglib2.1" instead of "cglib"
  * Bump Standards-Version to 3.8.2:
    - Move to "java" section
    - Rename README.Debian-source to README.source
    - Describe patch system usage in README.source

cglib2.1 (2.1.3.dfsg.2-1) unstable; urgency=low

  * Increase the upstream version number without changing the actual tarball
    to get the package uploaded to main.

cglib2.1 (2.1.3.dfsg.1-3) unstable; urgency=low

  [ Michael Koch ]
  * Use uscan sf.net helper for SourceForge. Fixes upstream checking.
  * Added myself to Uploaders.

  [ Torsten Werner ]
  * Move package to main.
  * Reformat debian/copyright for better readability.
  * Do not quote the full text of the Apache License in debian/copyright.
  * Fix doc-base file.

cglib2.1 (2.1.3.dfsg.1-2) unstable; urgency=low

  * Fix debian/watch.
  * Add myself to Uploaders.
  * Add Homepage and Vcs headers to debian/control.
  * Change Standards-Version: 3.7.3.
  * Switch to debhelper 5.

cglib2.1 (2.1.3.dfsg.1-1) unstable; urgency=low

  * Initial Release (closes: #386101).

 -- Matthias Klose <email address hidden>   Fri,  30 Oct 2009 08:23:05 +0000

Upload details

Uploaded by:
Matthias Klose on 2009-10-30
Uploaded to:
Lucid
Original maintainer:
Debian Java Maintainers
Architectures:
all
Section:
java
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Builds

Lucid: [FULLYBUILT] i386

Downloads

File Size SHA-256 Checksum
cglib_2.2+dfsg.orig.tar.gz 120.7 KiB 9c83361801c56c992438b50cd8bf4c91d86585135a72f3cf2ec1f43d3363f930
cglib_2.2+dfsg-1.diff.gz 4.7 KiB 561e227913119a201201bbc062e53fb1a54a9f6f3463c0d1db451bb065a862b8
cglib_2.2+dfsg-1.dsc 1.4 KiB 7fcc2835df2b5322e2d2206ab75f02f034c32cbab73feeaf18d5d2fbf8205375

View changes file

Binary packages built by this source

libcglib-java: No summary available for libcglib-java in ubuntu maverick.

No description available for libcglib-java in ubuntu maverick.

libcglib-java-doc: No summary available for libcglib-java-doc in ubuntu maverick.

No description available for libcglib-java-doc in ubuntu maverick.