Ubuntu

trac BROKEN on AMD64: "neo_cgi.so: undefined symbol: Py_InitModule4"

Reported by Bragi on 2007-02-21
134
This bug affects 7 people
Affects Status Importance Assigned to Milestone
The Trac Project
Fix Released
Unknown
clearsilver (Ubuntu)
Undecided
Unassigned
Nominated for Feisty by Stephan
Nominated for Jaunty by Chaim Krause
Hardy
Undecided
Unassigned
Intrepid
Undecided
Unassigned
trac (Ubuntu)
Undecided
Unassigned
Nominated for Feisty by Stephan
Nominated for Jaunty by Chaim Krause
Hardy
Undecided
Unassigned
Intrepid
Undecided
Unassigned

Bug Description

Old versions of python-clearsilver are broken on amd64 with python2.5 as the
default python.

The build system was broken such that it just built the extension for python2.4 and
copied it for python2.5. This was resolved in

    http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=452612

This makes python-clearsilver, and hence trac unusable for amd64 users on releases
where python2.5 is default.

It has been fixed in the development release by syncing that fix from Debian.

The patch attached cherry-picks the fix to the hardy package.

TEST CASE:
  * Install trac
  * Run "python -c 'import neo_cgi'"
Expected:
  * Exit code 0, no error messages
Currently:
  * "neo_cgi.so: undefined symbol: Py_InitModule4"
  * Non-zero exit code.

There should not be any regression as the module is completely broken for amd64 users,
and wrong for other architectures as well.

===
Original report:

Binary package hint: python-clearsilver

I created a new Trac environment and run tracd. After accessing it the first time I received following output on the console:

[bragi@ragnarson ogloszenia]$ tracd --port 8000 /home/bragi/projects/ogloszenia/trac
----------------------------------------
Exception happened during processing of request from ('127.0.0.1', 43756)
Traceback (most recent call last):
  File "SocketServer.py", line 463, in process_request_thread
    self.finish_request(request, client_address)
  File "SocketServer.py", line 254, in finish_request
    self.RequestHandlerClass(request, client_address, self)
  File "SocketServer.py", line 521, in __init__
    self.handle()
  File "BaseHTTPServer.py", line 316, in handle
    self.handle_one_request()
  File "/var/lib/python-support/python2.5/trac/web/wsgi.py", line 174, in handle_one_request
    gateway.run(self.server.application)
  File "/var/lib/python-support/python2.5/trac/web/wsgi.py", line 87, in run
    response = application(self.environ, self._start_response)
  File "/var/lib/python-support/python2.5/trac/web/standalone.py", line 88, in __call__
    return self.application(environ, start_response)
  File "/var/lib/python-support/python2.5/trac/web/main.py", line 352, in dispatch_request
    env_paths)
  File "/var/lib/python-support/python2.5/trac/web/main.py", line 436, in send_project_index
    req.hdf = HDFWrapper(loadpaths)
  File "/var/lib/python-support/python2.5/trac/web/clearsilver.py", line 135, in __init__
    raise TracError, "ClearSilver not installed (%s)" % e
TracError: ClearSilver not installed (/usr/lib/python2.5/site-packages/neo_cgi.so: undefined symbol: Py_InitModule4)
----------------------------------------

Tracd used Python 2.5 by default. When run against 2.4 there is no such error.

Ubuntu Feisty AMD64, python-clearsilver 0.10.3-4.1

Antonio Censi (accensi) wrote :

I can confirm the error too.

Py_InitModule4 in 64bit systems was renamed to Py_InitModule4_64 to allow addressing more than 4Gbytes. See http://www.python.org/dev/peps/pep-0353/.

In http://svn.python.org/projects/python/trunk/Include/modsupport.h
#if SIZEOF_SIZE_T != SIZEOF_INT
/* On a 64-bit system, rename the Py_InitModule4 so that 2.4
   modules cannot get loaded into a 2.5 interpreter */
#define Py_InitModule4 Py_InitModule4_64
#endif

So perhaps there was an configuration error when compiling the module.

I did the same installation of Trac 2 days ago in a x386 and it worked. Today when I tried in a amd64, I got the error.

Antonio Censi (accensi) wrote :

I have made a compile from source in Feisty environment with Python 2.5.

IMHO, the build process is buggy, just compiling and linking againt python2.4 libs and copying the .so file (just one file - neo_cgi.so) both to python2.5 and 2.5 SitePackages dirs. This can be confirmed by other short tests: all packages in python2.4 have just external references to Py_InitModule4, and in python2.5 there are only references to Py_InitModule4_64, except for the neo_cgi.so.

Perhaps the solution adopted has no side-effects in 32bit land, although it not correct too.

Build process result is attached. I think that the bug should be changed to confirmed, at least. I do not know if it affects upstream, as this solution of having python2.5 and python2.4 at the same time is a temporarily solution for Ubuntu, or it will be adopted by Debian too.

Antonio Censi (accensi) wrote :

I have checked clearsilver.net for python2.5 compatibility. Version 0.10.3 (last version in Debian and Ubuntu) has serious bugs in Python2.5.

These bugs, and some other minor ones, are solved in version 0.10.4.

To compile python-clearsilver version 0.10.3 with Python2.5 these bug corrections must be backported from version 0.10.4. So the correction of current bug is not so easy.

Antonio Censi (accensi) wrote :

Probably the text below would be better to be in Tutorials section in forums, but it could be helpful to have it here in case someone hits the same bug reported here.

In order to get Trac 0.10.3 running in amd64 Feisty, I have compiled , in the traditional way (./configure, make and make install) clearsilver-0.10.4, downloaded from its site.

To get it to compile with python2.5, i had to change 1 line in configure file and another in configure.in, to add version 2.5 to the allowed python versions:
configure:6560: python_versions="2.5 2.4 2.3 2.2 2.1 2.0 1.5 24 23 22 21 20 15"

and

configure.in:250: python_versions="2.5 2.4 2.3 2.2 2.1 2.0 1.5 24 23 22 21 20 15"

Original ones do not have the 2.5 I have added.

As I have ruby installed, it was necessary too install ruby1.8-dev, to get a required mkmf util for ruby interface build:
sudo apt-get install ruby1.8-dev

I tried to disable ruby and csharp compilations in configure, but it does not worked. If you have csharp (mono), probably it will be necessary to add other packages. I do not have it installed and so the build process skipped the csharp part.

Now Trac is running ok in x86_64 Feisty, with several plugins, like it is in another x86 Feisty I have installed before.

In addition to the comment from Antonio Censi, I had to:
sudo apt-get install zlib1g-dev
sudo apt-get install autoconf
sudo apt-get install python-dev

and edit Makefile lines 23,26 to read:
        ./configure --disable-perl --with-python=/usr/bin/python

Gustavo Carneiro (gjc) wrote :

Confirming; in feisty, module neo_cgi doesn't import on python2.5, only on python2.4.

KM (ubuntubug-acrasis) wrote :

I think I see the same bug here, following an upgrade from Edgy to Feisty. The trac home page consists of the following text:

Traceback (most recent call last):
  File "/var/lib/python-support/python2.5/trac/web/main.py", line 387, in dispatch_request
    dispatcher.dispatch(req)
  File "/var/lib/python-support/python2.5/trac/web/main.py", line 206, in dispatch
    req.hdf = HDFWrapper(loadpaths=chrome.get_all_templates_dirs())
  File "/var/lib/python-support/python2.5/trac/web/clearsilver.py", line 135, in __init__
    raise TracError, "ClearSilver not installed (%s)" % e
TracError: ClearSilver not installed (/usr/lib/python2.5/site-packages/neo_cgi.so: undefined symbol: Py_InitModule4)

GSMD (gsmdib) wrote :

replace neo_cgi.so with the one from clearsilver 0.10.4

Andras Szabo (andrei-hu) wrote :

I have tried to compile clearsilver-0.10.4 but in the end it doesn't created a neo_cgi.so file. However the make process (./configure && make && make install) was successful.

What can be wrong?

Kim Scheibel (kim-ubuntu) wrote :

Andras Szabo said on 2007-05-08:
> I have tried to compile clearsilver-0.10.4 but in the end it doesn't created
> a neo_cgi.so file. However the make process
> (./configure && make && make install) was successful.
Install python-dev and specify --with-python=/usr/bin/python2.5 to ./configure

Please find a diff.gz and .dsc for clearsilver-0.10.4 attached.

I've used these with sbuild in a feisty chroot to build amd64 debs and verified that this fixes the problem (at least when running with tracd).
Assuming you have the various Build-Depends installed you can of course also use dpkg-buildpackage.

Hope this helps,

Oops! I guess I should have put both files in a tarball. Oh well, here is the .dsc file.

Simon Wong (wongy) wrote :

I think there are enough people experiencing this problem!

Changed in clearsilver:
status: Unconfirmed → Confirmed

To summarise the work around:

Install the build dependencies
$ sudo apt-get build-dep python-clearsilver
$ sudo apt-get install python-dev

Download the 0.10.4 version (as it contains fixes for python2.5)
$ wget http://www.clearsilver.net/downloads/clearsilver-0.10.4.tar.gz
$ tar xzvf clearsilver-0.10.4.tar.gz

Edit the configure files as listed by Antonio Censi above

Build the new version
$ cd clearsilver-0.10.4
$ ./configure
$ make
$ sudo make install

Copy the new shared object over the packaged version
$ sudo cp -bi python/neo_cgi.so /usr/lib/python2.5/site-packages/neo_cgi.so

Enjoy!

I think the more proper way to get the python module to install to the correct site-packages directory is to do the following configure command instead of the one listed above:

./configure --with-python=/usr/bin/python2.5

This worked for me in such a way that I did not have to manually copy the neo_cgi.so file into place.

Thanks for all the info on the fix. Trac is vital to my organization.

huanix (huanix) wrote :

I'm experiencing this bug in AMD64 Gutsy (Beta). I installed trac from the repository, and after setting up my first repository, tried to access it.

I received this error:

Trac detected an internal error: 'NoneType' object has no attribute 'log'

Traceback (most recent call last):
  File "/var/www/trac/projects/trac.cgi", line 20, in <module>
    cgi_frontend.run()
  File "/var/lib/python-support/python2.5/trac/web/cgi_frontend.py", line 68, in run
    gateway.run(dispatch_request)
  File "/var/lib/python-support/python2.5/trac/web/wsgi.py", line 87, in run
    response = application(self.environ, self._start_response)
  File "/var/lib/python-support/python2.5/trac/web/main.py", line 430, in dispatch_request
    env.log.exception(e)
AttributeError: 'NoneType' object has no attribute 'log'

huanix (huanix) wrote :

The fix suggested by Simon Wong, with the modification by BramSwenson, was successful in AMD64 Gutsy (Beta).

GSMD (gsmdib) wrote :

Still here in Gutsy running on AMD64.

PM (launchpad-tempmail) wrote :

fixed source and amd64 packages for gutsy:
http://mathiasson.nu/debian/pool/main/c/clearsilver/

elsigh (lsimon) wrote :

The fix suggested by Simon Wong, with the modification by BramSwenson, was successful for me as well. Thanks - what a goofy fix ;)

elsigh (lsimon) wrote :

rather I mean what a goofy bug - trac should just work in a fresh install out of the box.. it's crucial.

KarlGoetz (kgoetz) wrote :

i'll look at the debs from above. rather an annoying bug to have sitting for two releases (especially when there was an updated to fix it available)

Matti Lindell (mlind) wrote :

Can anyone confirm this on Hardy? I couldn't reproduce the problem. clearsilver version is 0.10.4-1.

andrewEdwards (ae0000) wrote :

i've followed all the steps above and still cant get this to work. the last thing i have done is extract neo_cgi.so from the deb mentioned above and copied it to /usr/local/lib/python2.5/site-packages/neo_cgi.so

however I am still getting this error from Trac ::

Traceback (most recent call last):
  File "/var/lib/python-support/python2.5/trac/web/main.py", line 406, in dispatch_request
    dispatcher.dispatch(req)
  File "/var/lib/python-support/python2.5/trac/web/main.py", line 206, in dispatch
    req.hdf = HDFWrapper(loadpaths=chrome.get_all_templates_dirs())
  File "/var/lib/python-support/python2.5/trac/web/clearsilver.py", line 135, in __init__
    raise TracError, "ClearSilver not installed (%s)" % e
TracError: ClearSilver not installed (/usr/local/lib/python2.5/site-packages/neo_cgi.so: undefined symbol: Py_InitModule4)

Someone mentioned running ldconfig but that has made no difference either..... have i missed a step or is this another bug?

wizard (wizard2010) wrote :

I continue with the same problem:

Traceback (most recent call last):
  File "/var/lib/python-support/python2.5/trac/web/main.py", line 406, in dispatch_request
    dispatcher.dispatch(req)
  File "/var/lib/python-support/python2.5/trac/web/main.py", line 206, in dispatch
    req.hdf = HDFWrapper(loadpaths=chrome.get_all_templates_dirs())
  File "/var/lib/python-support/python2.5/trac/web/clearsilver.py", line 135, in __init__
    raise TracError, "ClearSilver not installed (%s)" % e
TracError: ClearSilver not installed (/usr/local/lib/python2.5/site-packages/neo_cgi.so: undefined symbol: Py_InitModule4)

I've followed all the steps and the problem continues. Any one have suggestion to fix this bug ????

Thanks of all of you.

KarlGoetz (kgoetz) wrote :

andrewedwards/ wizard,
what version of ubuntu, and what architecture (amd64?) are you running on?

William Lynch (wlynch) wrote :

Karl, I'm experiencing the same error as wizard. I'm running amd64 on Hardy.

elventear (elventear) wrote :

I have the same problem on Hardy (Beta) on x86_64:

Traceback (most recent call last):
  File "/var/lib/python-support/python2.5/trac/web/main.py", line 406, in dispatch_request
    dispatcher.dispatch(req)
  File "/var/lib/python-support/python2.5/trac/web/main.py", line 206, in dispatch
    req.hdf = HDFWrapper(loadpaths=chrome.get_all_templates_dirs())
  File "/var/lib/python-support/python2.5/trac/web/clearsilver.py", line 135, in __init__
    raise TracError, "ClearSilver not installed (%s)" % e
TracError: ClearSilver not installed (/usr/lib/python2.5/site-packages/neo_cgi.so: undefined symbol: Py_InitModule4)

Using the provided deb in the previous link, brought Trac back to life.

Matti Lindell (mlind) wrote :

Could someone try if the patch attached to Debian bug http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=452612 fixes this issue for amd64 users?

Not sure if configuring --with-python=/usr/bin/python2.5 will work for python2.4 users

Yes, I think it works for me.

I built those debian packages for debian version 0.10.4-1.2 as uploaded in the above bug. Downloaded from here:

http://packages.debian.org/sid/clearsilver-dev

(source package on the right)

I installed build dependencies ( apt-get build-dep python-clearsilver )

I installed the resulting packages and trac started working again, so I think this solves the problem.

My system: hardy - 2.6.24-16-generic #1 SMP Thu Apr 10 12:47:45 UTC 2008 x86_64 GNU/Linux

Eskil Heyn Olsen (eskil) wrote :

I can confirm the above mentioned debian package also works for Hardy on x86_64.

Upgraded from 7.04 to 8.04, and suddenly my trac no longer worked. Downloading the source package, applying the debian pacthes, build & install solved it.

Gabriel Dragffy (dragffy) wrote :

I can confirm this bug is present on Hardy Heron. I installed the debian from the link supplied by KarlGoetz and that's got it working! I have no idea what the difference is, but at least it works.

Bart Verwilst (verwilst) wrote :

I can confirm this being an issue on 64bit Hardy. Using the package above fixes it. Trac for example is broken because of this bug..

mog (launchpad-net-mog) wrote :

I can also confirm this on amd64 hardy. I just finished setting up trac an hour ago and trac was broken because of it.

Installing http://mathiasson.nu/debian/pool/main/c/clearsilver/python-clearsilver_0.10.4-1.0pm0_amd64.deb fixed it.

I found my way here through google & http://trac.edgewall.org/ticket/5387

I snagged the source with 'apt-get source clearsilver', but I found that adding the /usr/bin/python2.5 to the Makefile had no effect. This is probably because my rules.mk, which is generated by debian/rules, was still finding python2.4.

I added --with-python=/usr/bin/python2.5 to the rules file and all was good with my home built python-clearsilver_0.10.4-1ubuntu1_amd64.deb.

All the other tips on this page (except that prebuilt .deb) failed to work for me. Perhaps I'm not alone.

Guillaume Hain (zedtux) wrote :

For me, on Hardy Heron 64, I've install the deb package of Federico H, and now, trac work fine !!

janskey (janskey-boy) wrote :

Has anyone solved this problem: (just a fresh install of trac)

Traceback (most recent call last):
  File "/var/lib/python-support/python2.5/trac/web/main.py", line 406,
in dispatch_request
    dispatcher.dispatch(req)
  File "/var/lib/python-support/python2.5/trac/web/main.py", line 206,
in dispatch
    req.hdf = HDFWrapper(loadpaths=chrome.get_all_templates_dirs())
  File "/var/lib/python-support/python2.5/trac/web/clearsilver.py",
line 135, in __init__
    raise TracError, "ClearSilver not installed (%s)" % e
TracError: ClearSilver not installed (/usr/lib/python2.5/site-packages/
neo_cgi.so: undefined symbol: Py_InitModule4)

# ls -al /usr/lib/python2.5/site-packages/neo_cgi.so
-rw-r--r-- 1 root root 208960 Apr 8 15:52 /usr/lib/python2.5/site-packages/neo_cgi.so

# uname -a
Linux bo.test.com 2.6.18-xen #1 SMP Tue Feb 12 06:40:50 UTC 2008 x86_64 GNU/Linux

# dpkg -l | grep clearsilver
ii python-clearsilver 0.10.4-1ubuntu1 python bindings for clearsilver

I know that this bug is not in trac.
But it affects trac.

In fact, trac is BROKEN in Hardy AMD64 because of this bug.

Changed in trac:
status: New → Confirmed
KarlGoetz (kgoetz) wrote :

I'm now slightly confused:
I was under the impression the bug is caused because of using python <2.5 in -clearlooks, which caused trac to fail.
Is that the case?
If so, i'll go ahead and provide a debdiff to try and fix it

KarlGoetz (kgoetz) wrote :

This patch is everything i think that needs to change in this package for it to work (eg, a bump to python 2.5).
I need to sleep :0 night all, hope the patch helps you out.

Marius Gedminas (mgedmin) wrote :

The bug is that python-clearsilver is BROKEN on python2.5 on x86-64:

  mg@muskatas:~ $ python2.4 -c 'import neo_cgi'
  mg@muskatas:~ $ python -c 'import neo_cgi'
  Traceback (most recent call last):
    File "<string>", line 1, in <module>
  ImportError: /usr/lib/python2.5/site-packages/neo_cgi.so: undefined symbol: Py_InitModule4
  [exited with 1]

trac uses python2.5 and tries to import neo_cgi, so trac is broken.

huanix: your AttributeError: 'NoneType' object has no attribute 'log' problem is unrelated and is fixed by making sure the user that runs tracd owns the trac directory.

Marius Gedminas (mgedmin) wrote :

Another workaround, at least for those who're using tracd: run it under python2.4

  sudo -u www-data python2.4 /usr/bin/tracd -p 8080 /path/to/trac/instance

Bart Verwilst (verwilst) wrote :

Is this really still an issue in Hardy? This bug has been open for 1.5 years now??

Gabriel Bauman (gabrielbauman) wrote :

Yes, this is still broken and needs to be fixed in Hardy. See comment #45 (https://bugs.launchpad.net/ubuntu/+source/clearsilver/+bug/86685/comments/45) for a clear demonstration of the actual problem.

KarlGoetz (kgoetz) wrote :

Anyone tried this in 8.10?
If that works we could simply file a backport request for the clearlooks there.

KarlGoetz (kgoetz) wrote :

This is the 'force clearsilver to python2.5' debdiff
LP rejected my test build saying there was an -ubuntu2 version of the package already, so i'm not sure whats going on there yet.

KarlGoetz (kgoetz) wrote :

ubuntu-universe-sponsors subscribed.

(i think my test build issue was a ppa thing, not an archive one).

Kosh (kosh-linux) wrote :

I have the same problem, I think...

Traceback (most recent call last):
  File "/var/lib/python-support/python2.5/trac/web/main.py", line 406, in dispatch_request
    dispatcher.dispatch(req)
  File "/var/lib/python-support/python2.5/trac/web/main.py", line 191, in dispatch
    chosen_handler = self._pre_process_request(req, chosen_handler)
  File "/var/lib/python-support/python2.5/trac/web/main.py", line 263, in _pre_process_request
    chosen_handler = f.pre_process_request(req, chosen_handler)
  File "/var/lib/python-support/python2.5/trac/versioncontrol/api.py", line 73, in pre_process_request
    self.get_repository(req.authname).sync()
  File "/var/lib/python-support/python2.5/trac/versioncontrol/cache.py", line 97, in sync
    raise TracError('Missing "youngest_rev" in cache metadata')
TracError: Missing "youngest_rev" in cache metadata

My system is Ubuntu Server:

Linux mpserver 2.6.20-16-server #2 SMP Tue Feb 12 05:48:21 UTC 2008 i686 GNU/Linux

I follow this thread but wont work. How can I fix it?

Thanks

Changed in trac:
status: Unknown → Fix Released
reubenhwk (reubenhwk) wrote :

I'm also still having the same issue. Ubuntu v8.04 64-bit

KarlGoetz (kgoetz) wrote :

making python-clearsilver depend on python 2.5 doesnt fix this under hardy.
This is particularly annoying as python 2.5 and trac0.10.4 (main parts of previous 'fixes') are shipped by default.

KarlGoetz (kgoetz) wrote :

Hi all,
I think this patch will work.
The only change between this and what's in my PPA is that i changed the version number so its not a ppa build :)

Package in my ppa is here - incase someone wants to help test it out.:
https://launchpad.net/~kgoetz/+archive
to install from the ppa, use `sudo apt-get install python-clearsilver=0.10.4-1ubuntu1~rs0` (after adding the repository ...) or wget the deb directly.

James Westby (james-w) wrote :

Hi,

I believe this is fixed in Intrepid with the recent sync of the package
from Debian.

Thanks,

James

Changed in trac:
status: Confirmed → Invalid
Changed in clearsilver:
status: Confirmed → Fix Released
James Westby (james-w) wrote :

Hi,

I am preparing an SRU request and I need some help as I don't have
an amd64 box. How can this easily be reproduced to test the fix?
Is installing python-clearsilver and running "python -c 'import clearsilver'"
enough?

Thanks,

James

description: updated
Marius Gedminas (mgedmin) wrote :

James: install trac and run "python -c 'import neo_cgi'".

James Westby (james-w) wrote :

Thanks Marius. This will need testing if/when it hits -propsed.

motu-sru: does this qualify for an SRU?

Thanks,

James

description: updated

mathiasson.nu link is broken: 404

Chucky (michel-nolard) wrote :

The bug is still present in Hardy (8.04) completely up to date (on 23rd of march 2009).
Python 2.5.2-0ubuntu1
Trac 0.10.4-2
Python-clearsilver 0.10.4-1ubuntu1

This is flooding my apache2/error.log !
Is there a way to see the fix arrive in hardy-i386 ?

Note: the bug's been open on 2007-02-21 and we are 2009-02-23, which is 2 years 1 month 2 days later !

Thanks,

Michel Nolard

Phil M (unmobile+ubuntu) wrote :

I can confirm Chucky's statement that this bug is present in 8.04 x86_64, up to date as of today. My version of trac is 0.10.4-2. I was able to resolve it by installing python-clearsilver version 0.10.4-1.3 from Debian sid:
http://http.us.debian.org/debian/pool/main/c/clearsilver/python-clearsilver_0.10.4-1.3_amd64.deb

Maxim Doucet (maximdoucet) wrote :

This bug is still present on up to date Hardy 8.04.2 x86_64.

Looking at https://launchpad.net/ubuntu/intrepid/+source/clearsilver/0.10.4-1.3, it seems that the fix has only be released for Intrepid.

When will it be fixed for Hardy? This is a Long Term Support version: supported 3 years for desktop and *5* for servers! Clearsilver, hence Trac, should definitely be usable on this Ubuntu version.

Maxim Doucet (maximdoucet) wrote :

The bug is *still* present in Ubuntu Hardy 8.04.2. The fix is only available for Intrepid (see https://launchpad.net/ubuntu/intrepid/+source/clearsilver/0.10.4-1.3)

Changed in clearsilver (Ubuntu):
status: Fix Released → Confirmed
James Westby (james-w) wrote :

Hi,

That task is "Fix Released" as it is fixed in the latest release. We have to
have that otherwise we would go mad working out what bugs still need
a fix.

To record that this needs fixing in Hardy a task for that release needs to
be added, if you look at the page you can see "Nominated for Hardy..." which
means that someone has requested that this be added.

The documentation on getting a stable release update done is at

  https://wiki.ubuntu.com/StableReleaseUpdates

Thanks,

James

Changed in clearsilver (Ubuntu):
status: Confirmed → Fix Released
James Westby (james-w) wrote :

motu-sru, you apparently weren't subscribed when I asked you
if this was appropriate for an SRU, sorry about that. Could you
review it now please.

Thanks,

James

jmdugan (dugan-matsonsystems) wrote :

I an re- re-confirm this is still a bug, and trac does not work on AMD64+Hardy - exact same issue here.

Chaim Krause (tinjaw) wrote :

Why is this marked as fixed. I don't understand. It is still broken. I am running a fully up-to-date Jaunty 9.04 and it is still broken. What am I missing?

Chaim Krause (tinjaw) wrote :

My bad. Please disregard my previous comment.

This bug is still IN Hardy NOW!!!
It's exist for more than 2 years, but there's still NO FIX in Hardy till now, sadly.

 Traceback (most recent call last):
  File "/var/lib/python-support/python2.5/trac/web/main.py", line 406, in dispatch_request
    dispatcher.dispatch(req)
  File "/var/lib/python-support/python2.5/trac/web/main.py", line 206, in dispatch
    req.hdf = HDFWrapper(loadpaths=chrome.get_all_templates_dirs())
  File "/var/lib/python-support/python2.5/trac/web/clearsilver.py", line 135, in __init__
    raise TracError, "ClearSilver not installed (%s)" % e
TracError: ClearSilver not installed (/usr/lib/python2.5/site-packages/neo_cgi.so: undefined symbol: Py_InitModule4)

I'm promoting Ubuntu all the times, but how can I answer "No, Trac - one of the most popular software is still Broken in the Latest LTS version of Ubuntu"?
Wish we can see the fix in AMD64 Hardy.

Martin von Gagern (gagern) wrote :

As I need trac on a Hardy LTS server, I just uploaded a fixed version of the package to my PPA. I tried to use the Debian patch from comment 32, but had to adjust it to include the -I flag to the compiler, no just the include path without a flag. I attach the corresponding diff. It would be really good to see this officially fixed in Hardy. Until then, you may also get the version from my PPA: https://launchpad.net/~gagern/+archive/ppa

Martin Pitt (pitti) wrote :

I subscribed ubuntu-universe-sponsors for the hardy fix, thanks!

Changed in clearsilver (Ubuntu Hardy):
status: New → Invalid
Changed in trac (Ubuntu Hardy):
status: New → Fix Committed
Terence Simpson (tsimpson) wrote :

This is still an issue on Hardy, can someone look into this?

Zoltan Herpai (wigyori) wrote :

Guys, this is nuts, the bug is still present in 8.04.4. Could you change the status of this bug in Hardy/amd64 to "wontfix" please? I could compile myself a newer version, but then I'll be providing LTS to myself, and not the project.

Chucky (michel-nolard) wrote :

Dear James Westby,
Dear Ubuntu hacker,

I am sorry not to understand as well as you do the in's and out's of https://wiki.ubuntu.com/StableReleaseUpdates, so can I ask you to confirm, please, that I've understood things correctly ?

My understanding #1: Hardy won't receive any new "simple" patch if it is not related to a high impact bug.

My understanding #2: Same things stand for Intrepid, Jaunty and Karmic.

My understanding #3: Ubuntu hackers (like James Westby) have already a lot of work and cannot cope with supplementary tasks like doing more fixes than authorized by the policy pointed earlier (https://wiki.ubuntu.com/StableReleaseUpdates)

My understanding #4: This policy uses the safety standpoint as an official argument not to allow you to maintain a high quality level for a release version like the Hardy LTS one.

My understanding #5: Distributions like Debian have already managed to fix this bug (which is not related to a high impact flaw) because they do not have that policy.

My understanding #6: LTS means Long Term Support for High Impact Problems (HIPs) only, not Other Annoying Flaws (OAFs).

My understanding #7: This bug (#86685) is not a high impact bug.

I hope I expressed myself clearly enough not to prevent you from understanding my underlying ideas.

Thank you by advance to take the time required to explain me things clearly.

Michel Nolard

On Wed, 23 Jun 2010 08:18:09 -0000, Chucky <email address hidden> wrote:
> Dear James Westby,
> Dear Ubuntu hacker,
>
> I am sorry not to understand as well as you do the in's and out's of
> https://wiki.ubuntu.com/StableReleaseUpdates, so can I ask you to
> confirm, please, that I've understood things correctly ?
>
> My understanding #1: Hardy won't receive any new "simple" patch if it is
> not related to a high impact bug.

The impact of the bug is weighed against the potential for regression,
but generally only serious bugs will get fixed.

> My understanding #2: Same things stand for Intrepid, Jaunty and Karmic.
>
> My understanding #3: Ubuntu hackers (like James Westby) have already a
> lot of work and cannot cope with supplementary tasks like doing more
> fixes than authorized by the policy pointed earlier
> (https://wiki.ubuntu.com/StableReleaseUpdates)

Well, we can't fix anything that doesn't follow the policy, regardless
of how busy or not we are.

> My understanding #4: This policy uses the safety standpoint as an
> official argument not to allow you to maintain a high quality level for
> a release version like the Hardy LTS one.
>
> My understanding #5: Distributions like Debian have already managed to
> fix this bug (which is not related to a high impact flaw) because they
> do not have that policy.

Debian didn't fix it in any stable release, as it never affected their
stable release. Ubuntu did the same in fixing it in the development
release.

> My understanding #6: LTS means Long Term Support for High Impact
> Problems (HIPs) only, not Other Annoying Flaws (OAFs).

LTS means security updates for longer, as well as some fixing of bugs
for longer. I doesn't mean that every problem will be fixed, no.

> My understanding #7: This bug (#86685) is not a high impact bug.

I think it is worthy of a SRU.

Thanks,

James

jan grant (s5uxnp) wrote :

Still broken in Hardy LTS.

No regression is possible from fixing this - it doesn't and has never worked.

Please consider SRU to hardy LTS.

Changed in clearsilver (Ubuntu Hardy):
status: Invalid → Confirmed
Steve Langasek (vorlon) wrote :

It was marked invalid because the bug is not in the clearsilver package but in the trac package. Setting back to invalid.

Changed in clearsilver (Ubuntu Hardy):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.